Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Midi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 806
Location: Greece

PostPosted: Mon Sep 10, 2012 10:18 pm    Post subject: No Midi Reply with quote

Hi there,

I have followed this official guide to get my midi device to work in my machine, without sucess.
I have midi useflag enabled, and alsasound initi script works without a problem. However, timidity initscript is a bit more sneaky:
Code:
◢ perjanus ◣ ~ $  /etc/init.d/timidity -v stop
 * Stopping TiMidity++ ...                                                                                                         [ ok ]
◢ perjanus ◣ ~ $  /etc/init.d/timidity -v start
 * Starting TiMidity++ Virtual Midi Sequencer ...
 * Detaching to start `/usr/bin/timidity' ...                                                                                      [ ok ]
◢ perjanus ◣ ~ $  /etc/init.d/timidity -v status
 * status: crashed
◢ perjanus ◣ ~ $  /etc/init.d/timidity -v restart
 * Stopping TiMidity++ ...                                                                                                         [ ok ]
 * Starting TiMidity++ Virtual Midi Sequencer ...
 * Detaching to start `/usr/bin/timidity' ...                                                                                      [ ok ]
◢ perjanus ◣ ~ $ 

Since no error message is shown, I am not sure what is wrong. When I try to run aplaymidi or asfxload I get the following errors:
Code:
◢ perjanus ◣ ~ $  asfxload ~/CT4MGM.sf2
No Emux synth hwdep device is found
◢ perjanus ◣ ~ $  aplaymidi -l
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
Cannot open sequencer - No such file or directory
◢ perjanus ◣ ~ $ 


Some information that might be relevant:
Code:
◢ perjanus ◣ ~ $  uname -a
Linux perjanus 3.4.4-gentoo #6 SMP PREEMPT Mon Sep 10 23:14:52 CEST 2012 x86_64 Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz GenuineIntel GNU/Linux
◢ perjanus ◣ ~ $  lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
◢ perjanus ◣ ~ $  lsmod | grep snd
snd_hda_codec_hdmi     22546  4
snd_hda_codec_idt      53285  1
snd_hda_intel          22431  4
snd_hda_codec          78369  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep               5766  1 snd_hda_codec
snd_pcm                70580  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          6617  2 snd_pcm,snd_hda_intel
snd_timer              17801  2 snd_pcm
snd                    54368  13 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore               5041  1 snd
◢ perjanus ◣ ~ $  cat /usr/src/linux/.config | grep SND_
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_RAWMIDI=m
CONFIG_SND_JACK=y
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_HRTIMER=m
CONFIG_SND_SEQ_HRTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
# CONFIG_SND_VERBOSE_PRINTK is not set
# CONFIG_SND_DEBUG is not set
CONFIG_SND_VMASTER=y
CONFIG_SND_KCTL_JACK=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_RAWMIDI_SEQ=m
# CONFIG_SND_OPL3_LIB_SEQ is not set
# CONFIG_SND_OPL4_LIB_SEQ is not set
# CONFIG_SND_SBAWE_SEQ is not set
# CONFIG_SND_EMU10K1_SEQ is not set
CONFIG_SND_MPU401_UART=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
# CONFIG_SND_PCSP is not set
CONFIG_SND_DUMMY=m
CONFIG_SND_ALOOP=m
CONFIG_SND_VIRMIDI=m
CONFIG_SND_MTPAV=m
CONFIG_SND_SERIAL_U16550=m
CONFIG_SND_MPU401=m
# CONFIG_SND_AC97_POWER_SAVE is not set
CONFIG_SND_PCI=y
# CONFIG_SND_AD1889 is not set
# CONFIG_SND_ALS300 is not set
# CONFIG_SND_ALS4000 is not set
# CONFIG_SND_ALI5451 is not set
# CONFIG_SND_ASIHPI is not set
# CONFIG_SND_ATIIXP is not set
# CONFIG_SND_ATIIXP_MODEM is not set
# CONFIG_SND_AU8810 is not set
# CONFIG_SND_AU8820 is not set
# CONFIG_SND_AU8830 is not set
# CONFIG_SND_AW2 is not set
# CONFIG_SND_AZT3328 is not set
# CONFIG_SND_BT87X is not set
# CONFIG_SND_CA0106 is not set
# CONFIG_SND_CMIPCI is not set
# CONFIG_SND_OXYGEN is not set
# CONFIG_SND_CS4281 is not set
# CONFIG_SND_CS46XX is not set
# CONFIG_SND_CS5530 is not set
# CONFIG_SND_CS5535AUDIO is not set
# CONFIG_SND_CTXFI is not set
# CONFIG_SND_DARLA20 is not set
# CONFIG_SND_GINA20 is not set
# CONFIG_SND_LAYLA20 is not set
# CONFIG_SND_DARLA24 is not set
# CONFIG_SND_GINA24 is not set
# CONFIG_SND_LAYLA24 is not set
# CONFIG_SND_MONA is not set
# CONFIG_SND_MIA is not set
# CONFIG_SND_ECHO3G is not set
# CONFIG_SND_INDIGO is not set
# CONFIG_SND_INDIGOIO is not set
# CONFIG_SND_INDIGODJ is not set
# CONFIG_SND_INDIGOIOX is not set
# CONFIG_SND_INDIGODJX is not set
# CONFIG_SND_EMU10K1 is not set
# CONFIG_SND_EMU10K1X is not set
# CONFIG_SND_ENS1370 is not set
# CONFIG_SND_ENS1371 is not set
# CONFIG_SND_ES1938 is not set
# CONFIG_SND_ES1968 is not set
# CONFIG_SND_FM801 is not set
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=2
CONFIG_SND_HDA_INPUT_JACK=y
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_ENABLE_REALTEK_QUIRKS=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CA0132=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
# CONFIG_SND_HDA_POWER_SAVE is not set
# CONFIG_SND_HDSP is not set
# CONFIG_SND_HDSPM is not set
# CONFIG_SND_ICE1712 is not set
# CONFIG_SND_ICE1724 is not set
CONFIG_SND_INTEL8X0=m
# CONFIG_SND_INTEL8X0M is not set
# CONFIG_SND_KORG1212 is not set
# CONFIG_SND_LOLA is not set
# CONFIG_SND_LX6464ES is not set
# CONFIG_SND_MAESTRO3 is not set
# CONFIG_SND_MIXART is not set
# CONFIG_SND_NM256 is not set
# CONFIG_SND_PCXHR is not set
# CONFIG_SND_RIPTIDE is not set
# CONFIG_SND_RME32 is not set
# CONFIG_SND_RME96 is not set
# CONFIG_SND_RME9652 is not set
# CONFIG_SND_SONICVIBES is not set
# CONFIG_SND_TRIDENT is not set
# CONFIG_SND_VIA82XX is not set
# CONFIG_SND_VIA82XX_MODEM is not set
# CONFIG_SND_VIRTUOSO is not set
# CONFIG_SND_VX222 is not set
# CONFIG_SND_YMFPCI is not set
CONFIG_SND_SPI=y
CONFIG_SND_USB=y
CONFIG_SND_USB_AUDIO=m
CONFIG_SND_USB_UA101=m
CONFIG_SND_USB_USX2Y=m
CONFIG_SND_USB_CAIAQ=m
# CONFIG_SND_USB_CAIAQ_INPUT is not set
CONFIG_SND_USB_US122L=m
# CONFIG_SND_USB_6FIRE is not set
# CONFIG_SND_FIREWIRE is not set
# CONFIG_SND_SOC is not set
◢ perjanus ◣ ~ $ 


Thanks in advance!
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Tue Sep 11, 2012 7:42 am    Post subject: Re: No Midi Reply with quote

Holysword wrote:


Code:
◢ perjanus ◣ ~ $  aplaymidi -l
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
Cannot open sequencer - No such file or directory
◢ perjanus ◣ ~ $ 


Code:
◢ perjanus ◣ ~ $  lsmod | grep snd
snd_hda_codec_hdmi     22546  4
snd_hda_codec_idt      53285  1
snd_hda_intel          22431  4
snd_hda_codec          78369  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep               5766  1 snd_hda_codec
snd_pcm                70580  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          6617  2 snd_pcm,snd_hda_intel
snd_timer              17801  2 snd_pcm
snd                    54368  13 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore               5041  1 snd

At a very first quick glance and undestanding that you seem building most of your drivers as modules, the two above information seems coherent.
As a matter of fact, I cannot see any of the needed snd_seq_* modules loaded.
=> Load these modules or build them statically in-kernel.
_________________
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 806
Location: Greece

PostPosted: Tue Sep 11, 2012 8:45 am    Post subject: Re: No Midi Reply with quote

aCOSwt wrote:
At a very first quick glance and undestanding that you seem building most of your drivers as modules, the two above information seems coherent.
As a matter of fact, I cannot see any of the needed snd_seq_* modules loaded.
=> Load these modules or build them statically in-kernel.

Oh well, never had to initialize them before... because normally Timidity and/or ALSA init script would do that automagically.
Does that have anything to do with kmod substituting module-init-tools? (also the lack of modprobe -l is so tragic).
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Who will save us from pulseaudio and systemd?
Back to top
View user's profile Send private message
romek
n00b
n00b


Joined: 02 Oct 2012
Posts: 4

PostPosted: Tue Oct 02, 2012 7:40 pm    Post subject: Error usb+midi Reply with quote

Plug Kabel MIDI+USB CMD U2MIDI
aplaymidi -p 24:0 aaaa.mid

No signal for midi instruments

dmesg
"usb_submit_urb: -28"
"usb_submit_urb: -28"
"usb_submit_urb: -28"
"usb_submit_urb: -28"
"usb_submit_urb: -28"
etc.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4294

PostPosted: Tue Oct 02, 2012 8:36 pm    Post subject: Reply with quote

find out what port to use
Code:
timidity -iA
Requested buffer size 32768, fragment size 8192
ALSA pcm 'default' set buffer size 30104, period size 3760 bytes
TiMidity starting in ALSA server mode
Opening sequencer port: 128:0 128:1 128:2 128:3

copy the port range value (128 for me), for some reason without it, timidity status is crash else
Code:
nano /etc/conf.d/timidity

look out for TIMIDITY_OPTS
you should add the port there as first argument
Code:
TIMIDITY_OPTS="128 -B2,8 -Os -EFreverb=0"

then (for eawpatches, you have other choices, look in portage tree)
Code:
emerge timidity-eawpatches

then select patches you wish use
Code:
eselect timidity list
Available TiMidity++ patchsets:
  [1]   eawpatches *
  [2]   shompatches

Code:
eselect timidity set 1
/etc/init.d/timidity start
 * Starting TiMidity++ Virtual Midi Sequencer ...                         [ ok ]
/etc/init.d/timidity status
 * status: started


and finally :
Code:
aplaymidi -l
 Port    Client name                      Port name
128:0    TiMidity                         TiMidity port 0
128:1    TiMidity                         TiMidity port 1
128:2    TiMidity                         TiMidity port 2
128:3    TiMidity                         TiMidity port 3

no need to really gave the port, just aplaymidi myfile.mid


but this will never work as long as you don't have snd_seq
Code:
 lsmod | grep snd_seq
snd_seq                40879  0
snd_seq_device          3989  1 snd_seq
snd_timer              14751  3 snd_hrtimer,snd_pcm,snd_seq
snd                    41400  9 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_hda_codec,snd_hda_intel,snd_seq_device
Back to top
View user's profile Send private message
romek
n00b
n00b


Joined: 02 Oct 2012
Posts: 4

PostPosted: Thu Oct 04, 2012 9:34 pm    Post subject: Reply with quote

Oh, thanks for your interest. Currently, I have connected two wires usb-midi: one (no name )- the is silvery wire box with - one side usb, and two wires side midi i drugi - CME U2MIDI. And the first midi-wire works both ways tzn. from keyboard to computer i from komputera to keyboard (Yamacha) when np. play a midi-file --- aplaymidi - p 24:0 aaa.mid ---. The second (CME) does not work both ways: although the light in the plug USB ( tam jest cały układ) flashes when I press the keys a Sequencer(software) no record. Conversely, when you send a signal to the keyboards np. aplaymidi - p 20:0 aaa.mid, when dmesg sent of messages "usb_submit_urb: -28".

lsusb
Bus 006 Device 007: ID 1a86:752d QinHeng Electronics CH345 MIDI adapter
Bus 006 Device 006: ID 1346:2001
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

aplaymidi -l
Port Client name Port name
14:0 Midi Through Midi Through Port-0
20:0 CME U2MIDI CME U2MIDI MIDI 1
24:0 USB2.0-MIDI USB2.0-MIDI MIDI 1
24:1 USB2.0-MIDI USB2.0-MIDI MIDI 2

lsmod |grep snd
snd_usb_audio 82245 0
snd_usbmidi_lib 13026 1 snd_usb_audio
snd_rawmidi 14059 1 snd_usbmidi_lib
snd_hwdep 4542 2 snd_usb_audio,snd_hda_codec
snd_pcm 56407 3 snd_usb_audio,snd_hda_codec,snd_hda_intel
snd 46367 16 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
snd_usb_audio 82245 0
snd_usbmidi_lib 13026 1 snd_usb_audio
snd_rawmidi 14059 2 snd_usbmidi_lib,snd_seq_midi
snd_hwdep 4542 2 snd_usb_audio,snd_hda_codec
snd_pcm 56407 3 snd_usb_audio,snd_hda_codec,snd_hda_intel
snd 46367 17 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device

lsmod grep snd
snd_usb_audio 82245 0
snd_usbmidi_lib 13026 1 snd_usb_audio
snd_rawmidi 14059 1 snd_usbmidi_lib
snd_seq_device 4013 1 snd_rawmidi
snd_hda_codec_realtek 44032 1
snd_hda_intel 20888 3
snd_hda_codec 67503 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 4542 2 snd_usb_audio,snd_hda_codec
snd_pcm 56407 3 snd_usb_audio,snd_hda_codec,snd_hda_intel
snd_page_alloc 5925 2 snd_pcm,snd_hda_intel
snd_timer 14262 1 snd_pcm
snd 46367 16 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
snd_seq_midi 3888 0
snd_seq_midi_event 4111 1 snd_seq_midi
snd_seq_dummy 1144 0
snd_seq 39355 3 snd_seq_midi_event,snd_seq_dummy,snd_seq_midi
snd_usb_audio 82245 0
snd_usbmidi_lib 13026 1 snd_usb_audio
snd_rawmidi 14059 2 snd_usbmidi_lib,snd_seq_midi
snd_seq_device 4013 4 snd_seq,snd_rawmidi,snd_seq_dummy,snd_seq_midi
snd_hda_codec_realtek 44032 1
snd_hda_intel 20888 3
snd_hda_codec 67503 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 4542 2 snd_usb_audio,snd_hda_codec
snd_pcm 56407 3 snd_usb_audio,snd_hda_codec,snd_hda_intel
snd_page_alloc 5925 2 snd_pcm,snd_hda_intel
snd_timer 14262 2 snd_pcm,snd_seq
snd 46367 17 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
dmesg
[ 420.792027] usb 6-1: new full-speed USB device number 2 using uhci_hcd
[ 420.954042] usb 6-1: New USB device found, idVendor=1a86, idProduct=752d
[ 420.954047] usb 6-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 420.954050] usb 6-1: Product: USB2.0-MIDI
[ 424.570683] usbcore: registered new interface driver snd-usb-audio
[ 501.499032] usb 6-2: new low-speed USB device number 3 using uhci_hcd
[ 501.699072] usb 6-2: config 1 interface 1 altsetting 0 endpoint 0x81 is Bulk; changing to Interrupt
[ 501.699077] usb 6-2: config 1 interface 1 altsetting 0 endpoint 0x1 is Bulk; changing to Interrupt
[ 501.718069] usb 6-2: New USB device found, idVendor=1346, idProduct=2001
[ 501.718074] usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 501.718078] usb 6-2: Product: CME U2MIDI
[ 501.718081] usb 6-2: Manufacturer: CME
[ 576.204057] usb 6-2: USB disconnect, device number 3
[ 593.410037] usb 6-2: new low-speed USB device number 4 using uhci_hcd
[ 593.559088] usb 6-2: config 1 interface 1 altsetting 0 endpoint 0x81 is Bulk; changing to Interrupt
[ 593.559094] usb 6-2: config 1 interface 1 altsetting 0 endpoint 0x1 is Bulk; changing to Interrupt
[ 593.579086] usb 6-2: New USB device found, idVendor=1346, idProduct=2001
[ 593.579091] usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 593.579095] usb 6-2: Product: CME U2MIDI
[ 593.579098] usb 6-2: Manufacturer: CME
[ 594.454064] usb 6-1: USB disconnect, device number 2
[ 605.918031] usb 6-1: new full-speed USB device number 5 using uhci_hcd
[ 606.073089] usb 6-1: New USB device found, idVendor=1a86, idProduct=752d
[ 606.073094] usb 6-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 606.073098] usb 6-1: Product: USB2.0-MIDI

post aplaymidi - p 20:0 aaa.mid
dmesg wygląda tak
[ 660.087993] usb_submit_urb: -28
[ 662.394823] usb_submit_urb: -28
[ 663.983743] usb_submit_urb: -28
[ 664.004434] usb_submit_urb: -28
[ 664.947633] usb_submit_urb: -28
itd...
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4294

PostPosted: Fri Oct 05, 2012 2:03 pm    Post subject: Reply with quote

Honestly i didn't really understood everything, your english skills and my poor english understanding doesn't make a nice couple :)

To me everything looks ok.

Try plugin the cable alone on a free usb (usb ports came by two, pick one with the other one next to it remaining free) to try without.
Back to top
View user's profile Send private message
romek
n00b
n00b


Joined: 02 Oct 2012
Posts: 4

PostPosted: Tue Oct 09, 2012 7:43 am    Post subject: Reply with quote

OK. Thank you.
Back to top
View user's profile Send private message
romek
n00b
n00b


Joined: 02 Oct 2012
Posts: 4

PostPosted: Tue Oct 09, 2012 7:50 am    Post subject: Reply with quote

KONWERTER USB MIDI MODEL 2012 http://vegacom.eu/product-pol-58-KONWERTER-USB-MIDI-MODEL-2012-.html?utm_source=nokaut.pl&utm_medium=cpc&utm_campaign=2012-10&utm_content=58#nclid=1b1a1051d32047a4fa4000d646f5c2ee -works well :D
CME U2MIDI http://www.cme-pro.com/products-list/product-u2midi.html - does not work :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum