Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-wm/xmonad-0.9 fails build [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
sbdmmg
n00b
n00b


Joined: 01 Jul 2010
Posts: 32
Location: NJ, USA

PostPosted: Thu Oct 04, 2012 3:10 pm    Post subject: x11-wm/xmonad-0.9 fails build [solved] Reply with quote

Hello,

during one of my world updates, xmonad broke down. I believe that some haskell dependence got broken on my system, so I tried to run haskell-updater (and ghc-pkg), but I am no haskell expert, so I am at loss. I installed all of my haskell packages with emerge, so I don't quite understand the
Quote:
The following packages don't seem to have been installed by your package manager
reported from haskell-updater...
Could anyone please suggest how I could investigate and fix this?

Many thanks for any suggestion you might have.

Davide

--------------

This is the error from portage:
Code:
#  emerge -auvDN  xmonad-contrib

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] x11-wm/xmonad-0.9  USE="-doc -profile" 0 kB
[ebuild  N     ] x11-wm/xmonad-contrib-0.9  USE="-doc -profile" 0 k
...
>>> Failed to emerge x11-wm/xmonad-0.9, Log file:

>>>  '/var/tmp/portage/x11-wm/xmonad-0.9/temp/build.log'

 * Messages for package x11-wm/xmonad-0.9:

 * ERROR: x11-wm/xmonad-0.9 failed (compile phase):
 *   setup build failed
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 2602:  Called haskell-cabal_src_compile
 *   environment, line 1929:  Called cabal_src_compile
 *   environment, line  546:  Called cabal-build
 *   environment, line  404:  Called die
 * The specific snippet of code:
 *       ./setup "$@" || die "setup build failed"
 *
 * If you need support, post the output of `emerge --info '=x11-wm/xmonad-0.9'`,
 * the complete build log and the output of `emerge -pqv '=x11-wm/xmonad-0.9'`.
 * The complete build log is located at '/var/tmp/portage/x11-wm/xmonad-0.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-wm/xmonad-0.9/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-wm/xmonad-0.9/work/xmonad-0.9'
 * S: '/var/tmp/portage/x11-wm/xmonad-0.9/work/xmonad-0.9'


the output from haskell-updater
Code:
# haskell-updater
Running haskell-updater using GHC 6.12.3
  * Executable: /usr/bin/ghc
  * Library directory: /usr/lib/ghc-6.12.3
  * Package manager (PM): portage

Searching for packages installed with a different version of GHC.
No old packages found!

Searching for Haskell libraries with broken dependencies.

The following packages don't seem to have been installed by your package manager:
  * xmonad-0.9
  * xmonad-contrib-0.9
No broken packages found!


Nothing to build!


Code:
# ghc-pkg check
There are problems in package xmonad-0.9:
  dependency "mtl-1.1.1.1-57f2dda1d35dc730219caa06f16057c1" doesn't exist
  import-dirs: /usr/lib/xmonad-0.9/ghc-6.12.3 doesn't exist or isn't a directory
  library-dirs: /usr/lib/xmonad-0.9/ghc-6.12.3 doesn't exist or isn't a directory
  file XMonad.hi is missing
...
  cannot find libHSxmonad-contrib-0.9.a on library path

The following packages are broken, either because they have a problem
listed above, or because they depend on a broken package.
xmonad-0.9
xmonad-contrib-0.9


and the emerge --info output

Code:
# emerge --info '=x11-wm/xmonad-0.9'
Portage 2.1.11.9 (default/linux/x86/10.0, gcc-4.5.4, glibc-2.15-r2, 3.3.8-gentoo i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.8-gentoo-i686-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Thu, 04 Oct 2012 11:45:01 +0000
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo zugaina dev-zero science x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirror.mcs.anl.gov/pub/gentoo/ rsync://mirror.mcs.anl.gov/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/dev-zero /var/lib/layman/science /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bzip2 cdr cli consolekit cracklib crypt cups cxx dbus divx dri dvd flac fortran gdbm gif gpm iconv icu id3 ipv6 kde lame midi modules mp3 mp4 mplayer mudflap ncurses nls nptl ogg opengl openmp pam pcre policykit pppd qt3support qt4 readline realmedia session ssl svg tcpd udev unicode v4l v4l2 video webkit wmp x86 zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by sbdmmg on Fri Oct 05, 2012 1:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4606
Location: Saint Amant, Acadiana

PostPosted: Thu Oct 04, 2012 8:38 pm    Post subject: Reply with quote

Quote:
[ebuild N ] x11-wm/xmonad-contrib-0.9 USE="-doc -profile" 0 k
...
>>> Failed to emerge x11-wm/xmonad-0.9, Log file:

Are you really getting three dots or you just left out the information that would help us to help you? Put the whole log into pastebin if in doubt what's important.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4137

PostPosted: Thu Oct 04, 2012 8:41 pm    Post subject: Re: x11-wm/xmonad-0.9 fails build Reply with quote

sbdmmg wrote:
Quote:
The following packages don't seem to have been installed by your package manager
reported from haskell-updater...
Could anyone please suggest how I could investigate and fix this?

Well, considering portage also is telling you the package aren't install, i don't see anything illogic there

Quote:
Code:
#  emerge -auvDN  xmonad-contrib

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] x11-wm/xmonad-0.9  USE="-doc -profile" 0 kB
[ebuild  N     ] x11-wm/xmonad-contrib-0.9  USE="-doc -profile" 0 k


N - new == not install yet
Back to top
View user's profile Send private message
sbdmmg
n00b
n00b


Joined: 01 Jul 2010
Posts: 32
Location: NJ, USA

PostPosted: Thu Oct 04, 2012 8:52 pm    Post subject: Reply with quote

Hello,

Thanks for your messages.
Jaglover, I added the three dots because I stripped the long error message, leaving only the last part with the call stack. I pasted the complete error report here http://pastebin.com/8T4gYDMD .
Krinn, you are right, xmonad is not installed because I removed it while trying to see whether something was inconsistent with my installation.

Cheers,

Davide
Back to top
View user's profile Send private message
gienah
Developer
Developer


Joined: 24 Nov 2010
Posts: 118
Location: AU

PostPosted: Fri Oct 05, 2012 9:56 am    Post subject: Reply with quote

Please try unmasking:

x11-xm/xmonad-0.10
dev-haskell/mtl-2.1.2
dev-haskell/x11-1.5.0.1

then:

emerge -av --keep-going =dev-haskell/mtl-2.1.2 =dev-haskell/x11-1.5.0.1 =x11-xm/xmonad-0.10
haskell-updater

Its normal for upgrades of haskell packages to break other haskell installed packages,
which can be fixed by running:

haskell-updater

You can ask us on irc: #gentoo-haskell
Back to top
View user's profile Send private message
sbdmmg
n00b
n00b


Joined: 01 Jul 2010
Posts: 32
Location: NJ, USA

PostPosted: Fri Oct 05, 2012 1:36 pm    Post subject: Reply with quote

Thank you for your help, gienah!
With your suggestion, I was able to emerge again xmonad. The only thing I had to add was to unmask x11-wm/xmonad-contrib-0.10.
I have one last question: haskell-updater is still telling me that xmonad-0.9 and xmonad-contrib-0.9 were "not installed by my package manager", although they are not installed on my system (I did 'emerge -C xmonad xmonad-contrib' when trying to fix the xmonad issue...).
How can I get rid of those?

Many thanks,

davide

Code:

# haskell-updater     
Running haskell-updater using GHC 6.12.3
  * Executable: /usr/bin/ghc
  * Library directory: /usr/lib/ghc-6.12.3
  * Package manager (PM): portage

Searching for packages installed with a different version of GHC.
No old packages found!xmonad-contrib-0.9

Searching for Haskell libraries with broken dependencies.

The following packages don't seem to have been installed by your package manager:
  * xmonad-0.9
  * xmonad-contrib-0.9
No broken packages found!


Nothing to build!
Back to top
View user's profile Send private message
gienah
Developer
Developer


Joined: 24 Nov 2010
Posts: 118
Location: AU

PostPosted: Sat Oct 06, 2012 6:45 am    Post subject: Reply with quote

Hi Davide,

If:

Code:
ghc-pkg list xmonad
ghc-pkg list xmonad-contrib


shows there are 2 versions of each of these packages installed:

xmonad-0.9
xmonad-0.10
xmonad-contrib-0.9
xmonad-contrib-0.10

(normally haskell-updater --upgrade would have upgraded them, and normally the way to fix the above error is to run haskell-updater --upgrade, but you already did that, so for this situation only)

then you could remove the redundant old versions like:

Code:
ghc-pkg unregister xmonad-0.9
ghc-pkg unregister xmonad-contrib-0.9


Note: again for anyone else reading this, the normal solution is to run:

Code:
haskell-updater --upgrade


and using ghc-pkg unregister is dangerous (if you do something wrong then you may have to emerge -aC dev-haskell/pkg-name and the emerge it again, and then run haskell-updater to fix the broken packages).
Back to top
View user's profile Send private message
sbdmmg
n00b
n00b


Joined: 01 Jul 2010
Posts: 32
Location: NJ, USA

PostPosted: Sat Oct 06, 2012 3:11 pm    Post subject: Reply with quote

Thanks a lot, gienah!

Davide
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum