Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] eth0 interface does not exist
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
mattive
n00b
n00b


Joined: 03 Oct 2012
Posts: 6

PostPosted: Wed Oct 03, 2012 6:34 pm    Post subject: [SOLVED] eth0 interface does not exist Reply with quote

I'm trying to use an Intel 82566MM ethernet device (Lenovo Thinkpad T61p), but trying to start it up results in

Code:
ERROR: interface eth0 does not exist


Code:
lspci -k | grep -A3 net
gives

Quote:
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
Subsystem: Lenovo ThinkPad T61
00:1a.0 ..
(no driver or kernel module)

According to http://en.gentoo-wiki.com/wiki/Lenovo_Thinkpad_T61p I should use e1000e drivers, so I enabled this in kernel config (as built-in). However, according to
Code:
dmesg | grep e1000
it seems that e1000 is loaded, whereas there is no entry of e1000e. Why might this be? How might it be possible to fix my problem?

Code:
uname -r
3.4.9-gentoo


Thanks in advance!


Last edited by mattive on Wed Oct 03, 2012 9:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32018
Location: 56N 3W

PostPosted: Wed Oct 03, 2012 8:05 pm    Post subject: Reply with quote

mattive,

Welcome to Gentoo.

If you made e1000e built into your kernel, I suspect the issue is that you are not using the kernel you thing you are
Look at your uname -a output. here is mine as an example
Code:
$ uname -a
Linux NeddySeagoon 3.5.2-gentoo #1 SMP PREEMPT Sun Aug 19 12:15:45 BST 2012 x86_64 AMD Phenom(tm) II X6 1090T Processor AuthenticAMD GNU/Linux

The date and time here, Sun Aug 19 12:15:45 BST 2012, is the important information. Its the build time of the running kernel. From your memory, does that look right for your kernel.
Another indicator is the #1 in Linux NeddySeagoon 3.5.2-gentoo #1, which indicates the first build of this kernel version. I guess you rebuilt your 3.4.9-gentoo kernel, so you should have #2 or even later.

If it looks wrong, did yo remember to mount /boot before you copied the kernel to /boot?
Did you mistype the /boot/<filename>, so that grub does not seethe new kernel?

There are lots of ways to mess up the kernel install, if thats what your problem is.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mattive
n00b
n00b


Joined: 03 Oct 2012
Posts: 6

PostPosted: Wed Oct 03, 2012 8:17 pm    Post subject: Reply with quote

NeddySeagoon wrote:

If you made e1000e built into your kernel, I suspect the issue is that you are not using the kernel you thing you are
Look at your uname -a output.


This is in fact the case, mine also says #1, and I in fact forgot to mount the boot partition. Thank you for this advice! But now I run into a different problem: I can't mount /dev/sda1 (my boot partition), since my system won't recognise the ext2 filesystem.

Code:
mount: unknown filesystem type 'ext2'

Perhaps I forgot to include this in the kernel as well? Is it even possible that I managed to boot from an ext2 filesystem without ext2 filesystem support enabled in the kernel? Should I just use the LiveUSB to

1) Make sure the newly compiled kernel includes ext2 support
2) Mount the boot partition
3) Copy the new kernel binary
4) Reboot to new system

?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6593
Location: Goose Creek SC

PostPosted: Wed Oct 03, 2012 8:18 pm    Post subject: Reply with quote

redo your menuconfig ensuring that e1000e is the only possible choice as in:
Quote:
Device Drivers --->
[*] Ethernet driver support --->
[*] Intel devices
< > Intel(R) PRO/100+ support (NEW)
< > Intel(R) PRO/1000 Gigabit Ethernet support (NEW)
<M> Intel(R) PRO/1000 PCI-Express Gigabit Ethernet support
< > Intel(R) 82575/82576 PCI-Express Gigabit Ethernet support (NEW
< > Intel(R) 82576 Virtual Function Ethernet support (NEW)
< > Intel(R) PRO/10GbE support (NEW)
< > Intel(R) 10GbE PCI Express adapters support (NEW)
< > Intel(R) 82599 Virtual Function Ethernet support (NEW)
[ ] Intel (82586/82593/82596) devices
make e1000e as a module so you can use modprobe to examine behavior after recompiling, recopying, and rebooting, if needed.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
mattive
n00b
n00b


Joined: 03 Oct 2012
Posts: 6

PostPosted: Wed Oct 03, 2012 8:21 pm    Post subject: Reply with quote

DONAHUE: I already ensured that e1000e is the only Intel ethernet driver included in the config, which is why I wondered why the e1000 got loaded on boot anyways. Now it seems that I've been using the old, first compile kernel. I should see if getting the new one working fixes this, but I just need to get my boot partition mounted.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6593
Location: Goose Creek SC

PostPosted: Wed Oct 03, 2012 8:46 pm    Post subject: Reply with quote

Tell me if I understand the situation:
you have intsalled gentoo to your hard drive.
you can boot an old kernel successfully but it does not provide the e1000e driver.
you compiled a new kernel but cannot mount the boot partition to copy the new kernel to the boot partition.

is your boot partition /dev/sda1?

if so
Code:
nano /etc/fstab
should include
Quote:
/dev/sda1 /boot ext2 defaults,noatime 1 2
If your boot partition is not /dev/sda1 use your correct value
If your boot partition is not /dev/sda1 use your correct value, run:
Code:
mount /dev/sda1 /boot
If your boot partition is not /dev/sda1 use your correct value. post the result.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
mattive
n00b
n00b


Joined: 03 Oct 2012
Posts: 6

PostPosted: Wed Oct 03, 2012 8:51 pm    Post subject: Reply with quote

That is correct, my boot partition is /dev/sda1, and I have the same line in my /etc/fstab. When trying to

Code:
mount /dev/sda1 /boot


it gives me

Code:
mount: unknown filesystem type 'ext2'
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6593
Location: Goose Creek SC

PostPosted: Wed Oct 03, 2012 8:55 pm    Post subject: Reply with quote

the old kernel does not contain ext2 support.
are you using ext4 at all?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
mattive
n00b
n00b


Joined: 03 Oct 2012
Posts: 6

PostPosted: Wed Oct 03, 2012 8:59 pm    Post subject: Reply with quote

I have

/dev/sda1, which is ext2
/dev/sda2, swap and
/dev/sda3, ext3.

I don't use ext4. I've been following the Gentoo installation guide quite closely, since I'm a beginner. Should I now recompile the kernel to include ext2 support, and use the liveusb to mount&copy the new kernel to the boot partition?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6593
Location: Goose Creek SC

PostPosted: Wed Oct 03, 2012 9:06 pm    Post subject: Reply with quote

Quote:
and use the liveusb to mount&copy the new kernel to the boot partition?
this is the cleanest way include e1000e exclude e1000 while you're at it
older lineup, ok if ext4 not used on root
Quote:
<*> Second extended fs support
[*] Ext2 extended attributes
[ ] Ext2 POSIX Access Control Lists (NEW)
[ ] Ext2 Security Labels (NEW)
[ ] Ext2 execute in place support (NEW)
<*> Ext3 journalling file system support
[*] Default to 'data=ordered' in ext3 (NEW)
[*] Ext3 extended attributes (NEW)
[ ] Ext3 POSIX Access Control Lists (NEW)
[ ] Ext3 Security Labels (NEW)
< > The Extended 4 (ext4) filesystem

newer, better if ext4 used on root
Quote:
< > Second extended fs support
< > Ext3 journalling file system support
<*> The Extended 4 (ext4) filesystem
[*] Use ext4 for ext2/ext3 file systems (NEW)
[*] Ext4 extended attributes (NEW)
[ ] Ext4 POSIX Access Control Lists (NEW)
[ ] Ext4 Security Labels (NEW)
[ ] EXT4 debugging support (NEW)
[ ] JBD2 (ext4) debugging support (NEW)

_________________
Defund the FCC.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32018
Location: 56N 3W

PostPosted: Wed Oct 03, 2012 9:13 pm    Post subject: Reply with quote

mattive,

Boot into your system that can't mount /boot

In menuconfig set the ext2 filesystem option to <M>. Exit, saving the change.
Now do
Code:
make modules && make modules_install

Code:
modprobe ext2
should work and allow you to mount /boot

With /boot mounted go back into menuconfig and set ext2 to <*>
Do the whole kernel build and install.

Do not unmount boot until your new kernel build is installed.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mattive
n00b
n00b


Joined: 03 Oct 2012
Posts: 6

PostPosted: Wed Oct 03, 2012 9:34 pm    Post subject: Reply with quote

And I'm online!

Thank you both for your assistance and patience :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum