Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] nieprawidłowe wyświetlanie Xów
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
Robert W.
Guru
Guru


Joined: 13 Jul 2004
Posts: 364
Location: Kobyłka

PostPosted: Tue Oct 02, 2012 5:24 am    Post subject: [SOLVED] nieprawidłowe wyświetlanie Xów Reply with quote

Na screenshocie widać nieprawidłowe wyświetlanie się (brak ikon), Poprawia się to jak przeciągnę widok belką, kółko w myszy nie pomaga.
http://imageshack.us/a/img87/3606/20121002071351642x504sc.png
Karta graficzna to nvidia gforce 2mx 400.

wersja xorg: 1.13.0
wersja xorg-drivers: 1.13
wersja xf86-video-nouveau: 1.0.2

Xorg.0.log:http://ctrlv.it/text/MzExNzQ3

xorg.conf:http://ctrlv.it/xorg_conf/MzExNzQ2

Może jest ktoś będący w stanie pomóc w rozwiązaniu problemu?


Last edited by Robert W. on Thu Oct 04, 2012 7:13 am; edited 1 time in total
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2825

PostPosted: Tue Oct 02, 2012 9:41 am    Post subject: Reply with quote

manager okien ma wlaczone composite? Sprawdz z wylaczonym.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Robert W.
Guru
Guru


Joined: 13 Jul 2004
Posts: 364
Location: Kobyłka

PostPosted: Tue Oct 02, 2012 10:23 am    Post subject: Reply with quote

SlashBeast wrote:
manager okien ma wlaczone composite? Sprawdz z wylaczonym.

Używam LXDE z xcompmgr, ale to co widać na screenshocie jest z wyłączonym xcompmgr.
Back to top
View user's profile Send private message
joi_
Apprentice
Apprentice


Joined: 28 Mar 2005
Posts: 171

PostPosted: Tue Oct 02, 2012 5:43 pm    Post subject: Reply with quote

downgrade cairo do 1.10.* pomaga? jest coś "ciekawego" na temat nouveau w dmesgu (najlepiej załącz cały)?
Back to top
View user's profile Send private message
Robert W.
Guru
Guru


Joined: 13 Jul 2004
Posts: 364
Location: Kobyłka

PostPosted: Wed Oct 03, 2012 6:07 am    Post subject: Reply with quote

to co dmesg mówi niepokojącego o nouveau:
Code:
[  130.474670] firefox[2666]: segfault at 4 ip b398d532 sp bfe0a250 error 4 in nouveau_vieux_dri.so[b3986000+2d000]
Ale nie znalazłem w sieci nic sensownego na ten temat.
A tu całość dmesg: http://ctrlv.it/id/MzExODAz
Downgrade cairo do 1.10.* nie pomaga.
Back to top
View user's profile Send private message
joi_
Apprentice
Apprentice


Joined: 28 Mar 2005
Posts: 171

PostPosted: Wed Oct 03, 2012 11:36 am    Post subject: Reply with quote

Heh, nie ma punktu zaczepienia. Segfault firefoksa raczej nie ma związku - błąd prawdopodobnie jest po stronie xf86-video-nouveau, a crash jest po stronie mesy.
Jeżeli wyłączenie akceleracji pomoże (NoAccel w xorg.conf, zobacz man nouveau), to załóż buga wg instrukcji: http://nouveau.freedesktop.org/wiki/Bugs - może ktoś będzie miał pomysł (napisz też o cairo).
Back to top
View user's profile Send private message
Robert W.
Guru
Guru


Joined: 13 Jul 2004
Posts: 364
Location: Kobyłka

PostPosted: Thu Oct 04, 2012 7:13 am    Post subject: Reply with quote

NoAccel w xorg.conf rozwiązało problem. Dzięki.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum