Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update one specific package in gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
alex73782
n00b
n00b


Joined: 01 Oct 2012
Posts: 4

PostPosted: Mon Oct 01, 2012 4:37 pm    Post subject: Update one specific package in gentoo Reply with quote

Hi,

I can imagine this question has been asked before, but I did not find any results using the search function in this forum. I want to update only the package

cmake

in gentoo to a newer, the newest or a specific version number. How can I do this? I tried

emerge-webrsync
emerge cmake

but this only installed the version already on the system.


Thanks for any hints,

Alex
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2229
Location: Netherlands

PostPosted: Mon Oct 01, 2012 4:58 pm    Post subject: Reply with quote

Newest cmake version in portage is cmake-2.8.9.
If you want a newer one you'll have to find it in an overlay or compile it from newest available source.
Not recommended.
The command to emerge a specific version is
Code:

emerge =<packagename-version>.

Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
alex73782
n00b
n00b


Joined: 01 Oct 2012
Posts: 4

PostPosted: Tue Oct 02, 2012 5:38 am    Post subject: Reply with quote

Hi,

your suggestion does not seem to work. I tried the following
Code:

 emerge =cmake-2.8.9


and got an error
Code:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=dev-util/cmake-2.8.9".


Without the '='-sign it says that cmake-2.8.9 i not a valid package atom.

So again, how do I install cmake 2.8 or higher on gentoo; only cmake, only version 2.8 or higher.

Thanks
Alex
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1492

PostPosted: Tue Oct 02, 2012 5:54 am    Post subject: Reply with quote

I would argue that you should include the -1 option to avoid adding the file to your world file. That can cause complications.

The highest available in portage is 2.8.9. I can't find a higher version in the overlays either. A quick look at the home page makes me think it is the latest release.

You can see the available versions using emerge -s cmake and install your desired version using emerge -1 =cmake-<version> where <version> is the one you want.

Also I have found it better to search the forum using Google like this: site:http://forums.gentoo.org <search key>
Its a handy trick.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
alex73782
n00b
n00b


Joined: 01 Oct 2012
Posts: 4

PostPosted: Tue Oct 02, 2012 6:04 am    Post subject: Reply with quote

Hi,

thank you for your quick answer, but I get the same error as above when trying to do
Code:

emerge -1 =cmake-2.8.9


Anything missing?
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1492

PostPosted: Tue Oct 02, 2012 6:08 am    Post subject: Reply with quote

Its odd. cmake is stable and according to http://packages.gentoo.org only cmake 2.8.9 is available. What is the output of emerge -pv cmake? I would be interesting to see what you have installed. When was the last time you synced?
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
alex73782
n00b
n00b


Joined: 01 Oct 2012
Posts: 4

PostPosted: Tue Oct 02, 2012 6:14 am    Post subject: Reply with quote

Hi,

the output of

Code:

emerge -pv cmake


is

Code:

These are the packages that would be merged, in order:

Calculating dependencies |!!! Error loading '/var/cache/edb/vdb_blockers.pickle': Global and instance pickles are not supported.
... done!
[ebuild   R   ] dev-util/cmake-2.6.4-r2  USE="vim-syntax -emacs -python3 -qt4" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB



The used gentoo base might be an older one, but this is a stable version and NOTHING ELSE must be changed. ONLY cmake to a version>2.8 (does not need to be the latest and greatest, just better than 2.8).


Thanks
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1492

PostPosted: Tue Oct 02, 2012 6:25 am    Post subject: Reply with quote

Well, then we have a problem. dev-util/cmake-2.6.4-r2 is not in portage so I assume you have set this box up in the past and left it alone for a very long time. Don't worry about updating it. Even if you wanted to update it at this point, you can't do it easily. I am not saying there is anything wrong with that. I am sure you have your reasons.

A single package can be updated to the most recent version using the -u option like so: emerge -u cmake That should also pull in any deps if needed, but if you are really serous you can add the --no-deps option, although this could break your system.

What I don't get is that a recent --sync should have left cmake-2.8.9 as you only version available. Did your sync complete successfully? On a side not, which version of portage are you running?
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4337

PostPosted: Tue Oct 02, 2012 10:31 am    Post subject: Reply with quote

even it's not related to the problem now, the -1 suggest was a bad one

-1 won't prevent cmake-version from getting pickup by depclean
-1 won't tell emerge to not use other versions, upgrade or downgrade

So if you need a specific version of a package, make sure you don't use -1 and that version specific is added to your world file, else you'll get surprise soon or later.
Back to top
View user's profile Send private message
paulj
Guru
Guru


Joined: 30 Sep 2004
Posts: 342
Location: Wales, UK

PostPosted: Fri Oct 05, 2012 5:37 am    Post subject: Reply with quote

Have you sync-ed recently? cmake-2.8.9 was compiled on my system on 28/9/12, so would have been put in the tree recently. Your system is re-installing 2.6.4-r2, which is no longer in my tree.

Run
Code:
emerge --sync

then try again with
Code:
emerge -av -1 =cmake-2.8.9


Of course, with the tree synced, you don't need to specify the version number, as 2.8.9 is the current version. Out of interest, cmake is not a @selected dependency on my system, it is pulled in by a long list of packages (mostly kde based), so using the -1 option in this case is probably worthwhile (assuming it has already been installed as a dependency of something else) unless you want the system to remain at this version.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum