Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
求助:Xorg-server问题,startx失败 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese)
View previous topic :: View next topic  
Author Message
cj7kuangke
n00b
n00b


Joined: 12 Sep 2012
Posts: 12

PostPosted: Mon Sep 17, 2012 10:05 am    Post subject: 求助:Xorg-server问题,startx失败 [SOLVED] Reply with quote

如题,Xorg-server问题,startx失败,不知道是不是驱动问题,有两块显卡,一块是 集显AMD6520G,一块是 独显AMD6470M

Xorg.0.log文件如下:

Code:

[  3827.483]
X.Org X Server 1.12.2
Release Date: 2012-05-29
[  3827.483] X Protocol Version 11, Revision 0
[  3827.483] Build Operating System: Linux 3.4.9-gentoo x86_64 Gentoo
[  3827.483] Current Operating System: Linux localhost 3.4.9-gentoo #7 SMP Mon Sep 17 10:33:08 Local time zone must be set--see zic  x86_64
[  3827.483] Kernel command line: root=/dev/sda10
[  3827.484] Build Date: 17 September 2012  04:42:16PM
[  3827.484] 
[  3827.484] Current version of pixman: 0.26.0
[  3827.484]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  3827.484] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3827.485] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 17 16:53:03 2012
[  3827.485] (==) Using config file: "/etc/X11/xorg.conf"
[  3827.485] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3827.486] (==) ServerLayout "aticonfig Layout"
[  3827.486] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[  3827.486] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[  3827.486] (**) |   |-->Device "aticonfig-Device[0]-0"
[  3827.486] (==) Automatically adding devices
[  3827.486] (==) Automatically enabling devices
[  3827.494] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  3827.494]    Entry deleted from font path.
[  3827.494] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  3827.494]    Entry deleted from font path.
[  3827.494] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  3827.494]    Entry deleted from font path.
[  3827.494] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  3827.494]    Entry deleted from font path.
[  3827.494] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  3827.494]    Entry deleted from font path.
[  3827.494] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  3827.494]    Entry deleted from font path.
[  3827.494] (==) FontPath set to:
   
[  3827.494] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  3827.494] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  3827.494] (II) Loader magic: 0x7d5ac0
[  3827.494] (II) Module ABI versions:
[  3827.494]    X.Org ANSI C Emulation: 0.4
[  3827.494]    X.Org Video Driver: 12.0
[  3827.494]    X.Org XInput driver : 16.0
[  3827.494]    X.Org Server Extension : 6.0
[  3827.495] (--) PCI:*(0:0:1:0) 1002:9647:17aa:397b rev 0, Mem @ 0xd0000000/268435456, 0xf0300000/262144, I/O @ 0x00003000/256
[  3827.495] (--) PCI: (0:1:0:0) 1002:6760:17aa:397b rev 0, Mem @ 0xe0000000/268435456, 0xf0200000/131072, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
[  3827.495] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  3827.495] (II) "extmod" will be loaded by default.
[  3827.495] (II) "dbe" will be loaded by default.
[  3827.495] (II) "glx" will be loaded by default.
[  3827.495] (II) "record" will be loaded by default.
[  3827.495] (II) "dri" will be loaded by default.
[  3827.495] (II) "dri2" will be loaded by default.
[  3827.495] (II) LoadModule: "extmod"
[  3827.520] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[  3827.520] (II) Module extmod: vendor="X.Org Foundation"
[  3827.520]    compiled for 1.12.2, module version = 1.0.0
[  3827.520]    Module class: X.Org Server Extension
[  3827.520]    ABI class: X.Org Server Extension, version 6.0
[  3827.520] (II) Loading extension MIT-SCREEN-SAVER
[  3827.520] (II) Loading extension XFree86-VidModeExtension
[  3827.520] (II) Loading extension XFree86-DGA
[  3827.520] (II) Loading extension DPMS
[  3827.520] (II) Loading extension XVideo
[  3827.520] (II) Loading extension XVideo-MotionCompensation
[  3827.520] (II) Loading extension X-Resource
[  3827.520] (II) LoadModule: "dbe"
[  3827.520] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[  3827.520] (II) Module dbe: vendor="X.Org Foundation"
[  3827.520]    compiled for 1.12.2, module version = 1.0.0
[  3827.520]    Module class: X.Org Server Extension
[  3827.520]    ABI class: X.Org Server Extension, version 6.0
[  3827.520] (II) Loading extension DOUBLE-BUFFER
[  3827.520] (II) LoadModule: "glx"
[  3827.520] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  3827.520] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[  3827.520]    compiled for 6.9.0, module version = 1.0.0
[  3827.521] (II) Loading extension GLX
[  3827.521] (II) LoadModule: "record"
[  3827.521] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[  3827.521] (II) Module record: vendor="X.Org Foundation"
[  3827.521]    compiled for 1.12.2, module version = 1.13.0
[  3827.521]    Module class: X.Org Server Extension
[  3827.521]    ABI class: X.Org Server Extension, version 6.0
[  3827.521] (II) Loading extension RECORD
[  3827.521] (II) LoadModule: "dri"
[  3827.521] (WW) Warning, couldn't open module dri
[  3827.521] (II) UnloadModule: "dri"
[  3827.521] (II) Unloading dri
[  3827.521] (EE) Failed to load module "dri" (module does not exist, 0)
[  3827.521] (II) LoadModule: "dri2"
[  3827.521] (WW) Warning, couldn't open module dri2
[  3827.521] (II) UnloadModule: "dri2"
[  3827.521] (II) Unloading dri2
[  3827.521] (EE) Failed to load module "dri2" (module does not exist, 0)
[  3827.521] (II) LoadModule: "fglrx"
[  3827.521] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[  3827.541] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[  3827.541]    compiled for 1.4.99.906, module version = 8.98.2
[  3827.541]    Module class: X.Org Video Driver
[  3827.542] (II) Loading sub module "fglrxdrm"
[  3827.542] (II) LoadModule: "fglrxdrm"
[  3827.542] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[  3827.542] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[  3827.542]    compiled for 1.4.99.906, module version = 8.98.2
[  3827.542] (II) AMD Proprietary Linux Driver Version Identifier:8.98.2
[  3827.542] (II) AMD Proprietary Linux Driver Release Identifier: 8.98                                 
[  3827.542] (II) AMD Proprietary Linux Driver Build Date: Jun 11 2012 11:57:59
[  3827.542] (--) using VT number 7

[  3827.544] (WW) Falling back to old probe method for fglrx
[  3827.551] (II) Loading PCS database from /etc/ati/amdpcsdb
[  3827.551] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:0) found
[  3827.551] (--) Chipset Supported AMD Graphics Processor (0x6760) found
[  3827.552] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:1) found
[  3827.552] (**) ChipID override: 0x9647
[  3827.552] (**) Chipset Supported AMD Graphics Processor (0x9647) found
[  3827.554] ukiDynamicMajor: found major device number 250
[  3827.554] ukiDynamicMajor: found major device number 250
[  3827.554] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[  3827.554] ukiOpenDevice: node name is /dev/ati/card0
[  3827.554] ukiOpenDevice: open result is 7, (OK)
[  3827.554] ukiOpenByBusid: ukiOpenMinor returns 7
[  3827.554] ukiOpenByBusid: ukiGetBusid reports PCI:0:1:0
[  3827.554] ukiOpenDevice: node name is /dev/ati/card1
[  3827.554] ukiOpenDevice: open result is 7, (OK)
[  3827.554] ukiOpenByBusid: ukiOpenMinor returns 7
[  3827.554] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[  3827.556] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[  3827.556] (II) AMD Video driver is signed
[  3827.557] (II) fglrx(0): pEnt->device->identifier=0x1e1e890
[  3827.557] (II) fglrx(0): === [xdl_xs112_atiddxPreInit] === begin
[  3827.558] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[  3827.558] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[  3827.558] (==) fglrx(0): Default visual is TrueColor
[  3827.558] (**) fglrx(0): Option "DPMS" "true"
[  3827.558] (==) fglrx(0): RGB weight 888
[  3827.558] (II) fglrx(0): Using 8 bits per RGB
[  3827.558] (==) fglrx(0): Buffer Tiling is ON
[  3827.558] (II) Loading sub module "fglrxdrm"
[  3827.558] (II) LoadModule: "fglrxdrm"
[  3827.558] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[  3827.558] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[  3827.558]    compiled for 1.4.99.906, module version = 8.98.2
[  3827.560] ukiDynamicMajor: found major device number 250
[  3827.560] ukiDynamicMajor: found major device number 250
[  3827.560] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[  3827.560] ukiOpenDevice: node name is /dev/ati/card0
[  3827.560] ukiOpenDevice: open result is 11, (OK)
[  3827.560] ukiOpenByBusid: ukiOpenMinor returns 11
[  3827.560] ukiOpenByBusid: ukiGetBusid reports PCI:0:1:0
[  3827.560] ukiOpenDevice: node name is /dev/ati/card1
[  3827.560] ukiOpenDevice: open result is 11, (OK)
[  3827.560] ukiOpenByBusid: ukiOpenMinor returns 11
[  3827.560] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[  3827.560] (**) fglrx(0): NoAccel = NO
[  3827.561] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[  3827.561] (--) fglrx(0): Chipset: "AMD Radeon HD 6400M Series" (Chipset = 0x6760)
[  3827.561] (--) fglrx(0): (PciSubVendor = 0x17aa, PciSubDevice = 0x397b)
[  3827.561] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[  3827.561] (--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
[  3827.561] (--) fglrx(0): MMIO registers at 0xf0200000
[  3827.561] (--) fglrx(0): I/O port at 0x00002000
[  3827.561] (==) fglrx(0): ROM-BIOS at 0x000c0000
[  3827.563] (II) fglrx(0): ATIF platform detected
[  3827.564] (II) fglrx(0): AC Adapter is used
[  3829.740] (II) fglrx(0): AMD Video BIOS revision 9 or later detected
[  3829.740] (--) fglrx(0): Video RAM: 1048576 kByte, Type: DDR3
[  3829.740] (II) fglrx(0): PCIE card detected
[  3829.740] (--) fglrx(0): Using per-process page tables (PPPT) as GART.
[  3829.740] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[  3829.741]
[  3829.742] Backtrace:
[  3829.742] 0: /usr/bin/X (xorg_backtrace+0x36) [0x56d6d6]
[  3829.742] 1: /usr/bin/X (0x400000+0x171189) [0x571189]
[  3829.742] 2: /lib64/libpthread.so.0 (0x7ff113a17000+0x10420) [0x7ff113a27420]
[  3829.742] 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs112_atiddxPreInit+0x11fb) [0x7ff1109db42b]
[  3829.742] 4: /usr/bin/X (InitOutput+0x812) [0x476392]
[  3829.742] 5: /usr/bin/X (0x400000+0x24b83) [0x424b83]
[  3829.742] 6: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7ff11294b2ad]
[  3829.742] 7: /usr/bin/X (0x400000+0x248e9) [0x4248e9]
[  3829.742]
[  3829.742] Segmentation fault at address (nil)
[  3829.742]
Fatal server error:
[  3829.742] Caught signal 11 (Segmentation fault). Server aborting
[  3829.742]
[  3829.742]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  3829.742] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  3829.742]
[  3829.743] Server terminated with error (1). Closing log file.
[/gwn]



希望有高手指教!谢谢!


Last edited by cj7kuangke on Tue Sep 25, 2012 4:54 am; edited 1 time in total
Back to top
View user's profile Send private message
genio4urlife
n00b
n00b


Joined: 24 Sep 2012
Posts: 1

PostPosted: Mon Sep 24, 2012 7:35 am    Post subject: Reply with quote

Hybrid VGA Card请尝试使用VGA Switcheroo.

我的一些经验仅供参考:
(1)使用KMS.关闭所有frame buffer devices.正确选择Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) 中radeon相关项目.
(2)使用Open Source Driver. 开源的显卡驱动对3D的支持已经很稳定.
(3)安装radeon-ucode. (Radeon HD 6400-7600 aka. Northern Islands. 6470M需要的应该是BARTS_mc.bin BARTS_me.bin BARTS_pfp.bin BTC_rlc.bin)
(4)手动编辑内核配置文件(比如.config). 确认其中CONFIG_FIRMWARE_IN_KERNEL=y , 添加CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware" ,并指定radeon/BARTS_mc.bin radeon/BARTS_me.bin radeon/BARTS_pfp.bin radeon/BTC_rlc.bin . 重新编译内核
(5)正确配置/etc/portage/make.conf中的VIDEO_CARDS
(6)使用VGA Switcheroo进行非X环境下显卡切换.
Back to top
View user's profile Send private message
sumous
n00b
n00b


Joined: 13 Jul 2012
Posts: 6

PostPosted: Tue Oct 02, 2012 2:31 am    Post subject: Reply with quote

看起来像是你的显卡驱动跟你的显卡不兼容,确定这显卡驱动适合你的显卡吗?
Back to top
View user's profile Send private message
shanpo
n00b
n00b


Joined: 06 Oct 2012
Posts: 11

PostPosted: Sun Oct 07, 2012 5:27 pm    Post subject: Reply with quote

前段时间用debian时,安装amd显卡官方驱动遇到问题,原因是官方驱动不支持xorg1.12版本,降级后才能使用。不知道现在解决没有。
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 308
Location: Paris

PostPosted: Wed Oct 10, 2012 8:04 pm    Post subject: Reply with quote

genio4urlife wrote:
Hybrid VGA Card请尝试使用VGA Switcheroo.

我的一些经验仅供参考:
(1)使用KMS.关闭所有frame buffer devices.正确选择Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) 中radeon相关项目.
(2)使用Open Source Driver. 开源的显卡驱动对3D的支持已经很稳定.
(3)安装radeon-ucode. (Radeon HD 6400-7600 aka. Northern Islands. 6470M需要的应该是BARTS_mc.bin BARTS_me.bin BARTS_pfp.bin BTC_rlc.bin)
(4)手动编辑内核配置文件(比如.config). 确认其中CONFIG_FIRMWARE_IN_KERNEL=y , 添加CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware" ,并指定radeon/BARTS_mc.bin radeon/BARTS_me.bin radeon/BARTS_pfp.bin radeon/BTC_rlc.bin . 重新编译内核
(5)正确配置/etc/portage/make.conf中的VIDEO_CARDS
(6)使用VGA Switcheroo进行非X环境下显卡切换.


请问现在开源驱动的电源管理和温控方面做的怎么样?由于我的显卡最近被amd无情的抛弃了,考虑转到开源驱动上
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum