Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo prefix problem: Failed to emerge app-arch/tar-1.26-r
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
toby1234
n00b
n00b


Joined: 28 Mar 2012
Posts: 4

PostPosted: Thu Mar 29, 2012 4:15 am    Post subject: gentoo prefix problem: Failed to emerge app-arch/tar-1.26-r Reply with quote

Hi Every1,

I am trying to build a minimal gentoo stage 2 with gcc development libraries and auto-configuration tools on three supercompute clusters (in order to be able to build other software with non-root privileges). I do the following:

wget https://github.com/npinto/gentoo-prefix-bootstrap/tarball/master
mv master prefix.tgz
tar zxvf prefix.tgz

then issue the commands

cd npinto-gentoo-prefix-bootstrap-6d62ddc
make install/stage2-gcc

The build/compiling starts fine until the following error message (below).

On cluster 1 the command cat /etc/version gives:
Linux version 2.6.18-194.17.4.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Mon Oct 25 15:50:53 EDT 2010
On cluster 2 the command cat /etc/version gives:
Linux version 2.6.32.13-0.4-default (geeko@buildhost) (gcc version 4.3.4 [gcc-4_3-branch revision 152973] (SUSE Linux) ) #1 SMP 2010-06-15 12:47:25 +0200
On cluster 3 the command cat /etc/version gives:
Linux version 2.6.18-128.7.1.el5 (brewbuilder@norob.fnal.gov) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-44)) #1 SMP Mon Aug 24 08:12:52 EDT 2009

On all three clusters I get the same error message as follows: What to do? Any help appreciated?

>>> Emerging (1 of 1) app-arch/tar-1.26-r1
>>> Failed to emerge app-arch/tar-1.26-r1, Log file:
>>> '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/temp/build.log'
* Package: app-arch/tar-1.26-r1
* Repository: gentoo_prefix
* USE: amd64 bootstrap elibc_glibc kernel_linux prefix userland_GNU
* FEATURES: preserve-libs
* Applying tar-1.26-xattr.patch ...
[ ok ]
* Running eautoreconf in '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/work/tar-1.26' ...
* Running aclocal -I m4 ...
[ !! ]

* Failed Running aclocal !
*
* Include in your bugreport the contents of:
*
* /home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/temp/aclocal.out

* ERROR: app-arch/tar-1.26-r1 failed (prepare phase):
* Failed Running aclocal !
*
* Call stack:
* ebuild.sh, line 85: Called src_prepare
* environment, line 2842: Called eautoreconf
* environment, line 781: Called eaclocal
* environment, line 699: Called autotools_run_tool '--at-m4flags' 'aclocal' '-I' 'm4'
* environment, line 550: Called die
* The specific snippet of code:
* die "Failed Running $1 !";
*
* If you need support, post the output of 'emerge --info =app-arch/tar-1.26-r1',
* the complete build log and the output of 'emerge -pqv =app-arch/tar-1.26-r1'.
* The complete build log is located at '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/temp/build.log'.
* The ebuild environment file is located at '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/temp/environment'.
* S: '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/work/tar-1.26'

* Messages for package app-arch/tar-1.26-r1:

* Failed Running aclocal !
*
* Include in your bugreport the contents of:
*
* /home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/temp/aclocal.out
* ERROR: app-arch/tar-1.26-r1 failed (prepare phase):
* Failed Running aclocal !
*
* Call stack:
* ebuild.sh, line 85: Called src_prepare
* environment, line 2842: Called eautoreconf
* environment, line 781: Called eaclocal
* environment, line 699: Called autotools_run_tool '--at-m4flags' 'aclocal' '-I' 'm4'
* environment, line 550: Called die
* The specific snippet of code:
* die "Failed Running $1 !";
*
* If you need support, post the output of 'emerge --info =app-arch/tar-1.26-r1',
* the complete build log and the output of 'emerge -pqv =app-arch/tar-1.26-r1'.
* The complete build log is located at '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/temp/build.log'.
* The ebuild environment file is located at '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/temp/environment'.
* S: '/home/tobiash/gentoo/var/tmp/portage/app-arch/tar-1.26-r1/work/tar-1.26'
make: *** [install/stage2-up-to-bison] Error 1
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2546
Location: Richmond, BC, Canada

PostPosted: Thu Mar 29, 2012 7:34 am    Post subject: Reply with quote

Might I suggest you join #gentoo-prefix on the freenode irc network. Your likely to get prefix specific help there easier. Also, if you prefer the forums, possibly just use one thread for all your initial install problems, that way you won't have to keep repeating info about your system so people can figure out what you need to do. It helps us to know what step you are at, etc..
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2546
Location: Richmond, BC, Canada

PostPosted: Thu Mar 29, 2012 2:06 pm    Post subject: Reply with quote

Quote:
wget https://github.com/npinto/gentoo-prefix-bootstrap/tarball/master


I didn't see that last night. If you are using someone else's bootstrap script or tarball, you will need to get support from them.

I am not very familiar with doing prefix installs. I do know I had trouble with tar, but the info in the solaris guide had me try the different version which worked. Also as the tree evolves and different versions of apps are available there are some new problems that come up in a prefix install that do not normally come up.

Also I would stick with one system, get that one installed then use your new knowledge to get the next one installed.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
oclinux
n00b
n00b


Joined: 12 Jan 2011
Posts: 4

PostPosted: Mon Oct 01, 2012 6:56 pm    Post subject: Reply with quote

When running the prefix installer, change de MAKEOPTS to 1....the configuration and scripting in tar install have problems when MAKEOPTS>1.

hope taht helps
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum