Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compose Key problems [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Timmer
Guru
Guru


Joined: 24 Aug 2004
Posts: 328
Location: Bloomington, IN, USA

PostPosted: Tue Dec 28, 2010 12:36 am    Post subject: Compose Key problems [SOLVED] Reply with quote

I'm having some trouble with my compose key, and I'm hoping someone can help me.

It works for some key combinations in some programs, but not for the same key combinations in other programs.

compose+e+' produces é in KMail, but compose+"+> will not produce ”. (but it does in Chrome!)
Similarly, in KMail, compose+a+o produces å, but in Chrome, compose+a+o does nothing, I needed to do compose+o+a to get å. (In KMail, compose+o+a does nothing...)

Why is this? How can I make things work the same way across my entire X environment (which is where I thought this was controlled).


Last edited by Timmer on Sun Sep 30, 2012 7:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Timmer
Guru
Guru


Joined: 24 Aug 2004
Posts: 328
Location: Bloomington, IN, USA

PostPosted: Tue Dec 28, 2010 6:52 pm    Post subject: Reply with quote

I've determined that all KDE applications use one set of compose key combinations, while non-KDE programs use another set (which happens to be the one I'm used to). I find this strange, because, on my desktop (as opposed to the laptop I'm using currently), KDE uses the same compose combinations as non-KDE programs.

Does this help give anyone a clue? It's at least given me some Google terms, but I haven't turned anything up yet.
Back to top
View user's profile Send private message
Timmer
Guru
Guru


Joined: 24 Aug 2004
Posts: 328
Location: Bloomington, IN, USA

PostPosted: Sun Sep 30, 2012 5:49 am    Post subject: Reply with quote

It's been 2 years, and I mostly gave up, but this problem is bugging me again, so I'm giving it a bump, rather than posting it again.

Another example: <compose>.. in non-KDE programs gives me "…" but in KDE programs, it gives me "·".
Back to top
View user's profile Send private message
sno35
Guru
Guru


Joined: 15 May 2004
Posts: 332
Location: Paris, France

PostPosted: Sun Sep 30, 2012 9:52 am    Post subject: Reply with quote

Hi
May be this can lead to something ? Mostly non-utf8 vs utf8 ?

Code:
# pwd
/usr/share/X11/locale


Quote:
# grep '<a> <o>' */Compose
el_GR.UTF-8/Compose:<Multi_key> <a> <o> : "å" aring
iso8859-13/Compose:<Multi_key> <a> <o> : "\345" aring
iso8859-15/Compose:<Multi_key> <a> <o> : "\345" aring
iso8859-1/Compose:<Multi_key> <a> <o> : "\345" aring


Code:
# grep '<o> <a>' */Compose
en_US.UTF-8/Compose:<Multi_key> <o> <a>                 : "å"   aring # LATIN SMALL LETTER A WITH RING ABOVE
en_US.UTF-8/Compose:<dead_acute> <Multi_key> <o> <a>    : "ǻ"   U01FB # LATIN SMALL LETTER A WITH RING ABOVE AND ACUTE
pt_BR.UTF-8/Compose:<Multi_key> <o> <a> : "å" aring # LATIN SMALL LETTER A WITH RING ABOVE
pt_BR.UTF-8/Compose:<dead_acute> <Multi_key> <o> <a>    : "ǻ" U01FB # LATIN SMALL LETTER A WITH RING ABOVE AND ACUTE
pt_BR.UTF-8/Compose:# <Multi_key> <acute> <o> <a>       : "ǻ" U01FB # LATIN SMALL LETTER A WITH RING ABOVE AND ACUTE
pt_BR.UTF-8/Compose:# <Multi_key> <apostrophe> <o> <a>  : "ǻ" U01FB # LATIN SMALL LETTER A WITH RING ABOVE AND ACUTE


Hth
Back to top
View user's profile Send private message
Timmer
Guru
Guru


Joined: 24 Aug 2004
Posts: 328
Location: Bloomington, IN, USA

PostPosted: Sun Sep 30, 2012 7:54 pm    Post subject: Reply with quote

I was starting to get to the same place right before bed last night. It seemed like X is using utf-8 encoding, but KDE is over-ruling that to iso-8859-1. I was having trouble finding the setting for it though.

Since I'm using systemd, it seemed like the right place to set it would be in /etc/locale.conf, where it was in fact set correctly. However, when I ran the locale command, it appeared to be unset. I stumbled upon the Gentoo UTF-8 Guide, which gave me the instructions that worked: create /etc/env.d/02locale and set the locale in there.

Reboot, and my system is consistent!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum