Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema con libpng14-so.14 <SOLUCIONADO>
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Predatux
n00b
n00b


Joined: 14 Aug 2012
Posts: 19

PostPosted: Fri Sep 28, 2012 11:05 pm    Post subject: Problema con libpng14-so.14 <SOLUCIONADO> Reply with quote

Hola, estoy teniendo problemas con la librería libpng. Tengo instaladas las versiones:
libpng-1.2.49
libpng-1.5.10

y necesito tener instalada la versión:
libpng14.so.14

He intentado desinstalar la 1.5, y para poder hacerlo, debo desinstalar también el sistema operativo entero ;)

He intentado solucionarlo con el comando revdep-rebuild -i
obteniendo:

revdep-rebuild -i

* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 32% ] * broken /usr/lib32/libwx_gtk2u_core-2.8.so.0.7.0 (requires libpng14.so.14)
[ 100% ]
* Generated new 3_broken.rr
* Assigning files to packages
* /usr/lib32/libwx_gtk2u_core-2.8.so.0.7.0 -> app-emulation/emul-linux-x86-wxGTK
* Generated new 4_raw.rr and 4_owners.rr
* Cleaning list of packages to rebuild
* Generated new 4_pkgs.rr
* Assigning packages to ebuilds
* Generated new 4_ebuilds.rr
* Evaluating package order
* Generated new 5_order.rr
* All prepared. Starting rebuild
emerge --complete-graph=y --oneshot app-emulation/emul-linux-x86-wxGTK:0
..........

* IMPORTANT: 8 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-emulation/emul-linux-x86-wxGTK-1.0 from flora
* emul-linux-x86-wxGTK-1.0.tar.xz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking emul-linux-x86-wxGTK-1.0.tar.xz to /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work
>>> Source unpacked in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work
>>> Preparing source in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/emul-linux-x86-wxGTK-1.0

>>> Install emul-linux-x86-wxGTK-1.0 into /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/image/ category app-emulation
>>> Completed installing emul-linux-x86-wxGTK-1.0 into /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/image/


>>> Installing (1 of 1) app-emulation/emul-linux-x86-wxGTK-1.0
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.

* IMPORTANT: 8 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

* Build finished correctly. Removing temporary files...
* You can re-run revdep-rebuild to verify that all libraries and binaries
* are fixed. Possible reasons for remaining inconsistencies include:
* orphaned files
* deep dependencies
* packages installed outside of portage's control
* specially-evaluated libraries

Me instala siempre app-emulation/emul-linux-x86-wxGTK-1.0 sin dar problemas, pero si ejecuto de nuevo el comando, el error aparece de nuevo e instala otra vez emul-linux.


broken /usr/lib32/libwx_gtk2u_core-2.8.so.0.7.0 (requires libpng14.so.14)

He probado también a ejecutar:
revdep-rebuild -L libpng14.so.14 , obteniendo la salida:

revdep-rebuild -L libpng14.so.14
* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries using libpng14.so.14
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Checking dynamic linking
[ 32% ] * found /usr/lib32/libwx_gtk2u_core-2.8.so.0.7.0
[ 100% ]
* Generated new 3_broken.rr
* Assigning files to packages
* /usr/lib32/libwx_gtk2u_core-2.8.so.0.7.0 -> app-emulation/emul-linux-x86-wxGTK
* Generated new 4_raw.rr and 4_owners.rr
* Cleaning list of packages to rebuild
* Generated new 4_pkgs.rr
* Assigning packages to ebuilds
* Generated new 4_ebuilds.rr
* Evaluating package order
* Generated new 5_order.rr
* All prepared. Starting rebuild
emerge --complete-graph=y --oneshot app-emulation/emul-linux-x86-wxGTK:0
..........

* IMPORTANT: 8 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) app-emulation/emul-linux-x86-wxGTK-1.0 from flora
* emul-linux-x86-wxGTK-1.0.tar.xz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking emul-linux-x86-wxGTK-1.0.tar.xz to /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work
>>> Source unpacked in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work
>>> Preparing source in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/emul-linux-x86-wxGTK-1.0

>>> Install emul-linux-x86-wxGTK-1.0 into /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/image/ category app-emulation
>>> Completed installing emul-linux-x86-wxGTK-1.0 into /var/tmp/portage/app-emulation/emul-linux-x86-wxGTK-1.0/image/


>>> Installing (1 of 1) app-emulation/emul-linux-x86-wxGTK-1.0
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.

* IMPORTANT: 8 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

* Build finished correctly. Removing temporary files...
* You can re-run revdep-rebuild to verify that all libraries and binaries
* are fixed. Possible reasons for remaining inconsistencies include:
* orphaned files
* deep dependencies
* packages installed outside of portage's control
* specially-evaluated libraries


Ando un poco perdidillo, alguien puede arrojar un poco de luz al respecto?

Gracias de antemano.


Last edited by Predatux on Sun Sep 30, 2012 5:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1506

PostPosted: Sat Sep 29, 2012 10:17 am    Post subject: Reply with quote

Palos de ciego:
corre lafilefixer --justfixit
emerge python y selecciona el 2.7 nunca el 3.xx.
echa un vistazo a gdk-pixbuf.


Offtopic:
Por cierto llevo varios dias que sin saber por qué me desconecta el foro, el resto de internet me va bién, ¿sabeis si hay algun problema? www.gentoo.org funciona a la primera
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Predatux
n00b
n00b


Joined: 14 Aug 2012
Posts: 19

PostPosted: Sat Sep 29, 2012 11:11 am    Post subject: Reply with quote

Gracias por la respuesta.
El primer comando sin problemas.

Python instalado, pero según parece tengo la versión 3:
python-updater
* Starting Python Updater...
* Main active version of Python: 2.7
* Active version of Python 2: 2.7
* Active version of Python 3: 3.2

Como lo soluciono?
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Sat Sep 29, 2012 4:49 pm    Post subject: Reply with quote

Code:
eselect news list
Mira la entrada "Upgrade to libpng15" por si fuera tu caso.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3731

PostPosted: Sun Sep 30, 2012 9:03 am    Post subject: Reply with quote

lo primero asegúrate de que necesitas ese paquete, es decir, que hay algún paquete en tu sistema que requiere emul-linux-x86-wxGTK.
Si no es así, simplemente desinstálalo y problema resuelto.

Quote:
app-emulation/emul-linux-x86-wxGTK-1.0 from flora


es un paquete de binarios desde un overlay externo al árbol oficial de gentoo, que fueron compilados con una versión en concreto de lipng ( supongo que libpng-1.4-algo).
La única solución que le veo es que instales alguna de estas versiones de libpng juntamente con la versión 1.5 ( si es que se puede). Ya no están en el árbol oficial, pero puedes encontrar los ebuilds para esa version aqui :

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/libpng/?hideattic=0

mete el último ebuild disponible de libpng-1.4 en un overlay local y a ver si te los deja instalar en SLOT junto con la versión 1.5.
Si no te deja instalarlo junto con la versión 1.5 ( que es lo que me temo), lo único que quedaria es que el autor de ese Paquete haga un nuevo paquete que use la versión 1.5 o que hagas tu mismo un paquete nuevo :

http://www.gentoo.org/proj/en/base/amd64/emul/

suerte y saluetes
Back to top
View user's profile Send private message
Predatux
n00b
n00b


Joined: 14 Aug 2012
Posts: 19

PostPosted: Sun Sep 30, 2012 12:12 pm    Post subject: Reply with quote

Gracias por las respuestas. La librería app-emulation/emul-linux-x86-wxGTK-1.0 se ha instalado por motivo de algún emulador, posiblemente el pcsx.

Desinstalando y haciendo pruebas... luego os cuento.

Un saludo
Back to top
View user's profile Send private message
Predatux
n00b
n00b


Joined: 14 Aug 2012
Posts: 19

PostPosted: Sun Sep 30, 2012 5:30 pm    Post subject: Reply with quote

Solucionado el problema, muchas gracias.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum