Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Aufs doesn't work with my kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
laconism
n00b
n00b


Joined: 18 Jun 2012
Posts: 12
Location: Shanghai,China

PostPosted: Thu Sep 27, 2012 8:19 am    Post subject: Aufs doesn't work with my kernel Reply with quote

I'm making a my own livecd. I decide to use aufs to mount /.so i installed aufs3 in portage tree by
Code:
emerge aufs3


I uses gentoo-sources-3.5.2 and I have added "sys-fs/aufs3 kernel-patch" to package.use.

No errors and warnings are reported,but the kernel has nothing changed. I recompiled the kernel and found that no aufs modules.

How to install and use aufs correctly?
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1656
Location: Berlin, Germany

PostPosted: Fri Sep 28, 2012 12:28 am    Post subject: Reply with quote

The kernel-patch flag will modify your kernel so that it is able to load the aufs kernel module. It will not add support for aufs directly.

Verify that there is a match between:
Code:
# eselect kernel show
# uname -r
# find /lib/modules -name aufs.ko
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum