Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/etc/init.d/iptables save not working [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
njcwotx
Guru
Guru


Joined: 25 Feb 2005
Posts: 499
Location: Texas

PostPosted: Thu Sep 27, 2012 5:24 pm    Post subject: /etc/init.d/iptables save not working [SOLVED] Reply with quote

I can run iptables-save > iptables-saved and iptables-restore < iptables-saved and get the results expected.

However, when I reboot the configuration is not being rememberd.

I used /etc/init.d/iptables save and it appears to work but upon restore it is not there. the gentoo build is up to date as of 2 days ago.

Im looking at the init scripts trying to follow its logic, but I figured I would toss out the question while I inpsect.
_________________
Drinking from the fountain of knowldege.
Sometimes sipping.
Sometimes gulping.
Always thirsting.


Last edited by njcwotx on Thu Sep 27, 2012 5:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
njcwotx
Guru
Guru


Joined: 25 Feb 2005
Posts: 499
Location: Texas

PostPosted: Thu Sep 27, 2012 5:43 pm    Post subject: Reply with quote

Update...

I can run /etc/init.d/iptables save and the /var/lib/iptables/rules-save is there and correct.

iptables stop
iptables start

and rules are there.

iptables stop
rules still in /var/lib/iptables/rules-save
reboot
and the rules are back to default......but, /var/lib/iptables/rules-save is still correct
_________________
Drinking from the fountain of knowldege.
Sometimes sipping.
Sometimes gulping.
Always thirsting.
Back to top
View user's profile Send private message
njcwotx
Guru
Guru


Joined: 25 Feb 2005
Posts: 499
Location: Texas

PostPosted: Thu Sep 27, 2012 5:53 pm    Post subject: Reply with quote

I echoed the IPTABLES_SAVE value in the init script and the path/filename is correct.


still puzzled why it is doing this.
_________________
Drinking from the fountain of knowldege.
Sometimes sipping.
Sometimes gulping.
Always thirsting.
Back to top
View user's profile Send private message
njcwotx
Guru
Guru


Joined: 25 Feb 2005
Posts: 499
Location: Texas

PostPosted: Thu Sep 27, 2012 5:56 pm    Post subject: Reply with quote

SOLVED....

i forgot to add iptables to default run level :oops: :oops: :oops:

rc-update add iptables default :!:

reboot

and iptables is correct :D
_________________
Drinking from the fountain of knowldege.
Sometimes sipping.
Sometimes gulping.
Always thirsting.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum