Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[WORKAROUND] Battery Drains while Off
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
larophel
n00b
n00b


Joined: 19 Mar 2005
Posts: 46

PostPosted: Mon Sep 24, 2012 5:55 pm    Post subject: [WORKAROUND] Battery Drains while Off Reply with quote

I got a new laptop a while ago, and have been having the issue that the battery drains while the laptop is off.
By "off", I mean a full shutdown (e.g. shutdown -h now).
Over an eight hour off-period, the battery discharges around 15-20%.

This seems to be a Linux / ACPI-specific issue, because it does not happen if I shutdown the laptop from Windows.
It also does not happen if I boot Linux with the "acpi=off" kernel parameter, and then perform a shutdown.
I have tried various things to solve this, but have been unsuccessful:

1. Replace the battery.
2. Upgrade from kernel 3.2.12 gentoo sources to 3.4.9 vanilla sources.
3. Disable all power / wakeup related features in the laptop's BIOS.
4. Disable wake-on-lan using the command "ethtool -s eth0 wol d".
5. Disable all wake-up actions in /proc/acpi/wakeup.
6. Disable bluetooth using "echo 1 > /sys/devices/LNXSYSTM:00/device:00/TOS6208:00/rfkill/rfkill1/state".
7. Disable the wlan adapter using the FN+F8 hotkey.

I can't think of anything else to try, but I also want to avoid using the "acpi=off" parameter, because then various programs don't work.
I would appreciate any help / hints.


Last edited by larophel on Fri Nov 16, 2012 2:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
larophel
n00b
n00b


Joined: 19 Mar 2005
Posts: 46

PostPosted: Mon Sep 24, 2012 5:59 pm    Post subject: Reply with quote

Here's my kernel .config: http://pastebin.com/NRzK85bp
Here's my dmesg output: http://pastebin.com/BW4fE4tG
Back to top
View user's profile Send private message
larophel
n00b
n00b


Joined: 19 Mar 2005
Posts: 46

PostPosted: Tue Sep 25, 2012 2:00 pm    Post subject: Reply with quote

Another thing I tried: disabling the LAN driver completely in the kernel.
Didn't help either, unfortunately.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2681
Location: Hamburg/Germany

PostPosted: Tue Sep 25, 2012 3:36 pm    Post subject: Reply with quote

Bluetooth and wake-on-lan disabled (ethtool -s eth0 wol d) ?
Back to top
View user's profile Send private message
larophel
n00b
n00b


Joined: 19 Mar 2005
Posts: 46

PostPosted: Tue Sep 25, 2012 4:17 pm    Post subject: Reply with quote

I have tried to disable wake-on-lan just before shutdown, using "ethtool -s eth0 wol d", but it didn't help.
Wake-on-lan is already disabled in the laptop's BIOS, but "ethtool" always shows it as on after a restart.

To disable bluetooth, I tried the following: "echo 1 > /sys/devices/LNXSYSTM:00/device:00/TOS6208:00/rfkill/rfkill1/state"
Is there another way I could try?
Back to top
View user's profile Send private message
larophel
n00b
n00b


Joined: 19 Mar 2005
Posts: 46

PostPosted: Wed Sep 26, 2012 10:28 pm    Post subject: Reply with quote

I booted yesterday from an Ubuntu live-CD and shutdown my computer from there.
No battery drainage overnight.
Any idea what might be different between Gentoo and Ubuntu, which could cause this problem?
Back to top
View user's profile Send private message
larophel
n00b
n00b


Joined: 19 Mar 2005
Posts: 46

PostPosted: Tue Oct 09, 2012 12:23 am    Post subject: Reply with quote

The issue does not seem to be kernel-related, after all.
I installed Ubuntu on a different disk, and compiled the 3.4.9 kernel there, using the same kernel config as on Gentoo.
The battery still does not discharge over night.

Does anybody have any idea what else could cause this issue?
Back to top
View user's profile Send private message
larophel
n00b
n00b


Joined: 19 Mar 2005
Posts: 46

PostPosted: Fri Nov 16, 2012 2:10 pm    Post subject: Reply with quote

I finally found the cause of the issue: the command "hwclock --systohc --local" causes the battery to drain when the laptop is off.
This command is executed by the /etc/init.d/hwclock script.
If I set clock_hctosys="NO" in /etc/conf.d/hwclock, that command does not get executed anymore, and the battery does not drain.
Back to top
View user's profile Send private message
nlsa8z6zoz7lyih3ap
Guru
Guru


Joined: 25 Sep 2007
Posts: 331
Location: Canada

PostPosted: Fri Nov 16, 2012 5:07 pm    Post subject: Reply with quote

Thanks. This solves the same problem for me.
Back to top
View user's profile Send private message
gr650
n00b
n00b


Joined: 07 Jan 2005
Posts: 42
Location: Uzwil, Switzerland

PostPosted: Thu Feb 28, 2013 9:00 am    Post subject: usb sleep and charge? Reply with quote

I experienced the same problem with a Toshiba Satellite Z830: battery drains after shutdown at a rate of 25 percentage points per day, so that it was empty after around four days. The hwclock setting didn't change anything for me.

However, what did solve the problem was to disable the "USB sleep and charge" function in my laptop's BIOS. The thing's got one USB port that is permanently supplying power for USB devices even when the laptop's off. Even when there's nothing connected, the port (or that particular hardware function) seems to drain the battery. I disabled the function and there's almost no battery drain (maybe 1% per day) any longer. While you're at it, you may also disable the other Wake-On-X functions (where X is keyboard, LAN, etc.) if you don't need them.

Georg.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum