Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Solved)Perl gives (corei7-avx) bad value for -march=
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 158

PostPosted: Tue Sep 25, 2012 4:05 am    Post subject: (Solved)Perl gives (corei7-avx) bad value for -march= Reply with quote

trying to install gentoo on my desktop, and when doing "emerge gentoo-sources" at the first part while installing perl it gives me something that lloks like


...(corei7-avx) bad value for -march=...

I tried changing it to corei7 instead, but to no avail (same error)

I followed this: http://en.gentoo-wiki.com/wiki/Safe_Cflags/Intel#Core_i7_and_Core_i5.2C_Xeon_55xx

(gcc 4.6 part)
_________________
This picture is the only reason i ever installed this OS...


Last edited by rabcor on Mon Oct 01, 2012 11:13 am; edited 1 time in total
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Tue Sep 25, 2012 5:27 am    Post subject: Reply with quote

gcc-config -l; emerge --info please
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 158

PostPosted: Tue Sep 25, 2012 9:22 am    Post subject: Reply with quote

Veldrin wrote:
gcc-config -l; emerge --info please

gcc-config -l didn't seem to do me much good, or i may have typed it wrong...

either way, i decided it was in my best interest to be lazy and just use -march=native to bypass this. (i also found out later i needed gcc 4.6+ but gentoo only comes with 4.5.x as stable, thats why it wasn't working, it was my bad but i'll blame it on the fact that i was using links to read the options at the time. which isn't exactly very readable. or intended to use to read, i just had no other interface i could use at that time. but thanks to your input i realized that it had to do with my gcc version being outdated.)
_________________
This picture is the only reason i ever installed this OS...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum