Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemy z uruchamianiem wicid po aktualizacji pythona 2.7
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Fri Sep 21, 2012 10:03 am    Post subject: problemy z uruchamianiem wicid po aktualizacji pythona 2.7 Reply with quote

Witam kolegów. Po długiej nie obecności na forum znowu zostałem zmuszony odwiedzić stronkę, tym razem nie umiem poradzić sobie z problemem dbus.
Wczoraj postanowiłem uaktualnić pythona z 2.7 na 3.4/ Oczywiście jak to na forach i hanbook miałem tam info na temat jak to zrobić i pokierowałem się nimi. Wszystko szło jak z płatka aż po ponownym uruchomieniu kompa okazało się że Wicd nie chce sie uruchomić i większość programów związanych z dbus. Gdy w terminalu chce uruchomić wicd to wywala mi komunikat

Code:
Traceback (most recent call last):
 File "/usr/share/wicd/deamon/wicd-deamon.py", line 47, in <module> import dbus
 ........../dbus/_dbus.py", line 39 in <module> 
from.dbus import BusConection
...........

i tak dalej aż do ...

Code:
ImportError: No module named pyexpat


Już widziałem post na temat dbus i niemal identycznym problemem, i spróbowałem sposobu z dodaniem od nowa usera, ale to nie zadziałało, emergerowanie wicd też nie pomogło, oraz emergerowanie dbus. NIC.
Mój problem polega bardziej na zmianie pythona 3.4 Bo kolega z innego posta miał problem po aktualizacji systemu ze zmianą dbus.

Wybaczcie że nie wstawiłem pełnego opisu tego co mi wywaliło w terminalu, ale teraz jade na drógim lapku i nie mam jak skopiować tekstu, a pendriva nie mam przy sobie. Teraz jestem w pracy, a komputer jaki używam jest na potrzeby firmy, więc bardzo mi on jest potrzebny.

Gdy przestawiłem się spowrotem na starą wersje pythona 2.7 nic to nie zmieniło.

Wciąż się zmagam z kompem w pracy, na szczęście mam zapasowy (windows) :?
No gdzieś w postach znalazłem fajną opcje emerge -e wicd gdzie reinstaluje się razem z zależnościami. Wicd ma ich 256 8O
Mam nadzieje że może to pomoże. Jak ktoś ma prostrze pomysły to proszę o porady, bo teraz to się wszystkich sposobów chwytam jakie wyszukam na google.

Wiem!! Chyba mi brakuje pliku expat bo gdy tak sie bawiłem zależnościami i opcją emerge -e to znalazłem na samym początki plik z podobną nazwą do mojego problemu pyexpat i wydaje mi się że tego mi brakuje w systemie, niestety ten plik wymaga downloadu z neta expat a ja neta nie mam na kompie :(
No nic, będzie trzeba bawić się pendrivem :P
Back to top
View user's profile Send private message
lsdudi
Guru
Guru


Joined: 12 Nov 2006
Posts: 389
Location: Warsaw

PostPosted: Fri Sep 21, 2012 2:45 pm    Post subject: Reply with quote

hmm python 3.4 ? jestes pewien

wsparcie dla xml'a w pythonie masz?
_________________
RLU#416942
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Fri Sep 21, 2012 4:54 pm    Post subject: Reply with quote

A to tego nie wiem. Pomyślałem sobie że jak uaktualnie pythona to będę miał świeższy kod wynikowy.
Ale nie wiedziałem że z tym wiąże się aż tyle problemów. A teraz część oprogramowania mi się nie chce startować :(
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2831

PostPosted: Fri Sep 21, 2012 7:05 pm    Post subject: Reply with quote

A python-updater odpaliles? Wydaje mi sie, ze po instalacji pythona jest o tym wzmianka. On powinien przebudowac pakiety ktore daja moduly dla nowego pythona.

Podobnie jest z perlem, tam jest perl-cleaner.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
kamild
n00b
n00b


Joined: 24 Jan 2008
Posts: 56

PostPosted: Fri Sep 21, 2012 8:22 pm    Post subject: Reply with quote

Próbowałem kiedyś przesiadki na pythona 3.x - stwierdziłem że nie warto, bo część aplikacji wciąż wymaga wersji 2.7, a i dodatkowo można natknąć się na dość dziwne błędy.
Nie wiem co prawda czy wciąż tak wiele programów potrzebuje wersji 2.x, jednak polecałbym pozostać przy 2.7. Na aktualizację przyjdzie kiedyś czas, daj temu pythonowi dojrzeć nim zagości u Ciebie na dobre. ;)
Taka moja opinia. :)
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sat Sep 22, 2012 5:26 am    Post subject: Reply with quote

Właśnie w tym problem że zrobiłem wszystkie kroki potrzebne do aktualizacji w raz zpython-updater pythona. I właśnie w tym pies pogrzebany że nic to nie dało. Już wróciłem do starej wersji 2.7 i spróbowałem go też update'tować, ale problem pozostał. Dzwięku nie ma, porthol nie odpala, i wicid staje podczas próby ładowania "servisów" Na konsoli gdy startuje wicd pokazuje mi wciąż brak pyxpat mimo że zainstalowałem już expat.
Teraz męczę się nad wersją 2.7. Tą 3.2 już dawno wywaliłem.
Przebudowa całego systemu opcią emerge -e wicd lub python jest do bani. Bez neta jest do niczego, bo nic nie ściągnę. Próbowałem też poprzez usb dociągnąć brakujące paczki ale z jakiegoś powodu system nie widzi ich i podczas emergerowania pokazuje mi że musi ściągnąć z sieci.
Wydaje mi się że coś pominołem... Po za tym to strata czasu na słabym sprzęcie żeby wszystko kompilować za pomocą opcji -e
Sprawdziłem jeszcze raz czy na pewno mam usunięty 3.2, i odpaliłem python-updater, teraz mi rekompiluje 13 paczek.


Perl cleaner jeszcze nie próbowałem, jak to gościu za burtą chwycę się każdego spsosobu :P

Do Kamild: A Ty miałeś też taki problem po reinstalacji wersji 3.2? Jeśli tak to w jaki sposób sobie z tym poradziłeś?
Czy dodatkowo coś rekompilowałeś? I czy wracając do starej wersji 2.7 też robiłeś updete?

Po updacie nic się nie zmieniło, wciąż pokazuje mi problem z pyexpat.
W flagach mam włączone xml. Teraz spróbuje drógiej opcji. Z perlem.
Back to top
View user's profile Send private message
gexcite
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2005
Posts: 101

PostPosted: Sat Sep 22, 2012 7:12 am    Post subject: Reply with quote

Podnieś interfejs z palca. Wicd Ci do tego nie jest potrzebny.
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sat Sep 22, 2012 4:43 pm    Post subject: Reply with quote

No ale akurat tego nie umiem. :P A nie tylko wicid nie startuje ale też ważny dla mnie w pracy libreoffice.
Wiem trochę mi wstyd. 4 razy postawiłem system na 3 laptopach. A tu pierwszy raz mi się coś takiego zdażyło.


Był bym wdzięczny jak by ktoś napisał mi co mam robić. Jak naprawić ten feler aby znowu było tak jak dawniej.
Bo nie chce mi się instalować od nowa wszystkiego, i tak się napociłem by system wyglądał schludnie i chudo. :(
A jutro jak nie znajdę usterki to będę zmuszony od nowa wszystko zaczynać :(
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2831

PostPosted: Sat Sep 22, 2012 5:17 pm    Post subject: Reply with quote

odpal ponownie python-updater. Jezeli nadal masz probelmy sprawdz inny python, przez eselect, np
Code:
eselect python set python2.7

(przyjmuje, ze 2.7 tez masz w systemie).
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sat Sep 22, 2012 5:29 pm    Post subject: Reply with quote

Tak, teraz tylko go mam. W między czasie zamaskowałem nowsze wersje by mi nie kolidowały podczas reinstalacji, i zaczołem reinstalować jeszcze raz pythona 2.7.3-r2
A z tym updatem już pare razy próbowałem. Z curlem też chociaż on nic tam takiego nie znalazł.
Sprawdzę jeszcze raz jaką wersje mam w eselect, ale poprzednio już ją ustawiłem.
XML-expat też już reinstalowałem.
TAK, eselect jest ustawiony na 2.7
Tak ogulnie to jest teraz jedyna wersja jaką posiadam.

Niestety, po godzinie czekania i kompilowania przy pomocy python-update nie przyniosło to żadnego skutku.
Wciąż brakuje tam tego modułu... Może trzeba go doinstalować do pythona??
Nie jetstem w tym doświadczony i wolę się zapytać kogoś kto wie czy to jest bezpieczne? I czy jest to możliwe?
I jak to zrobić?

Bo naprawdę, nie chcę instalować wszystkiego od nowa, już się dosyć namęczyłem z tym by tego lapka doprowadzić do idealnego stanu, taki jaki dla mnie powinien być ideał.
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Sun Sep 23, 2012 3:16 pm    Post subject: Reply with quote

Podobny problem mnie spotkał na stacjionarnym komputerze, tym razem nie reinstalowałem pythona, został jaki jest. A wicd się nie załącza, co na poprzedniej instalce chodził świetnie.

Code:
localhost maxim # /etc/init.d/wicd start
 * Caching service dependencies ...                                       [ ok ]
 * Starting wicd daemon ...                                               [ !! ]
 * ERROR: wicd failed to start
localhost maxim #


Ale na tym kompie zainstalowałem setuptools z gałęzi pythona i python-wifi oraz dbus-python
Teraz jakoś działa wifi ale go w trayu nie widzę.

Code:
localhost maxim # wicd
It seems like the daemon is already running.
If it is not, please remove /var/run/wicd/wicd.pid and try again.
localhost maxim #


na laptopie dokładnie to samo robiłem ale wtedy nie było żadnej poprawy.

A laptopa instakuję jeszcze raz.
Ale chyba wypuścili nowy stage 3 bo zdumiało mnie że nie ma
Code:
make.conf

i mam teraz problem z z kompilacją kernela :(
Stacjionarny skompilował 3.5 a na laptopie potrzebuję 3.4. I właśnie ten 3.4 który wcześniej się ładnie kompilował, teraz sypie błędami. :|
Ale to inna historia. Nadal czekam na jakąś sugestie na temat tego problemu z wicd , dbus i pythonem.
Back to top
View user's profile Send private message
lsdudi
Guru
Guru


Joined: 12 Nov 2006
Posts: 389
Location: Warsaw

PostPosted: Mon Sep 24, 2012 7:18 am    Post subject: Reply with quote

flaga xml dla pythona

poka flagi use dla pytahona jakie posiadasz

pyexpat jest w pythonie to nie jest zaden zewnetrzny pakiet
_________________
RLU#416942
Back to top
View user's profile Send private message
maxim.251
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2012
Posts: 86

PostPosted: Mon Sep 24, 2012 9:44 am    Post subject: Reply with quote

Przepraszam, ale już usunołem ten system i instaluje wszystko od nowa.
Nie dałem rady wykombinować o co biegało z tym pyexpat
Na google było napisane że to jakiś zewnętrzny dodatek, który współpracuje z pythonem.
Na kompie stacjionarnym jak zrobiłem próbę rekompilacji tego samego pythona, to też zaczeły się pojawiać usterki w trakcie kompilacji innych programół tym pythonem, gdzie wcześniej na te same programy kompilowały się bez zażutu.
Sprawdziłem flagi, i do wszystkich wersji była ona włączona. Ta flaga była załączona w make.global
Nawet jak dopisałem linkijkę
Code:
USE="xml" emerge -av python

Po rekompilacji nic to nie dało. Wciąż najważniejsze dla mnie programy potrzebujące wtyczek pythona nie działały z powodu pyexpat.
Wydaje mi się że problem siedzi w ebuilidzie.
Bo gdy na stacjionarnym zrobiłem
Code:
emerge -eav world
to przekompiowało mi wszystko wraz z pythonem pod procesor ale python zaczoł nie działać jak powinien.
Mam pytanie, czy python powinien być kompilowany wraz z flagami "O2 i -pipe"?
Może z pythonem jest jak z javą? NIe można kompilować go z tymi flagami bo wtedy dzieją się dziwne żeczy?
A może python potrzebuje jakiś specjalnych ustawień do kompilowania?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum