Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201209-02 ] libTIFF: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1569

PostPosted: Sun Sep 23, 2012 7:26 pm    Post subject: [ GLSA 201209-02 ] libTIFF: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: libTIFF: Multiple vulnerabilities (GLSA 201209-02)
Severity: normal
Exploitable: remote
Date: September 23, 2012
Updated: June 02, 2014
Bug(s): #307001, #324885, #357271, #359871, #371308, #410931, #422673, #427166
ID: 201209-02

Synopsis

Multiple vulnerabilities in libTIFF could result in execution of
arbitrary code or Denial of Service.


Background

libTIFF provides support for reading and manipulating TIFF (Tagged Image
File Format) images.


Affected Packages

Package: media-libs/tiff
Vulnerable: < 4.0.2-r1
Unaffected: >= 4.0.2-r1
Unaffected: >= 3.9.5-r2 < 3.9.6
Unaffected: >= 3.9.7-r1 < 3.9.8
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in libTIFF. Please review
the CVE identifiers referenced below for details.


Impact

A remote attacker could entice a user to open a specially crafted TIFF
file with an application making use of libTIFF, possibly resulting in
execution of arbitrary code with the privileges of the user running the
application or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All libTIFF 4.0 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/tiff-4.0.2-r1"
   
All libTIFF 3.9 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/tiff-3.9.5-r2"
   


References

CVE-2009-2347
CVE-2009-5022
CVE-2010-1411
CVE-2010-2065
CVE-2010-2067
CVE-2010-2233
CVE-2010-2443
CVE-2010-2481
CVE-2010-2482
CVE-2010-2483
CVE-2010-2595
CVE-2010-2596
CVE-2010-2597
CVE-2010-2630
CVE-2010-2631
CVE-2010-3087
CVE-2010-4665
CVE-2011-0192
CVE-2011-0192
CVE-2011-1167
CVE-2011-1167
CVE-2012-1173
CVE-2012-2088
CVE-2012-2113
CVE-2012-3401


Last edited by GLSA on Tue Jun 03, 2014 4:31 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum