Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(solved) eth0 not found.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Sep 23, 2012 3:32 pm    Post subject: (solved) eth0 not found. Reply with quote

after installing my system it stopped detecting eth0. (livecd detected it fine)

ifconfig only gives me lo.

i'm guessing this is a kernel settings issue, however... i did not tamper with the default settings for anything related to networks in there.
_________________
This picture was my biggest reason for ever trying Gentoo <3


Last edited by rabcor on Sun Sep 23, 2012 6:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Sun Sep 23, 2012 3:41 pm    Post subject: Reply with quote

rabcor,

What does
Code:
ifconfig -a
show?
The -a is for all, including interfaces not started.

If eth0 is not there, its a kernel modules issue. You may need to modprobe your module, or if its not built, you will need to build it first.

IF eth0 is in ifconfig -a, the kernel is good, the module is loaded but the interface is not started.

What does
Code:
ls -l /etc/init.d/net.eth0
show?
Its a symlink to net.lo. Make the symlink if its missing.

With the kernel good, the symlink good,
Code:
/etc/init.d/net.eth0 start
should get eth0 up, provided you installed dhcpcd.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Sep 23, 2012 3:50 pm    Post subject: Reply with quote

ifconfig -a gives loo and sit0

ls -l... gives me
Code:
lrwxrwxrwx 1 root root 6 sep 23 1:51 /etc/init.d/net.eth0 -> net.lo



so it's the kernel then? it might just be, cus i did another install yesterday and had the same problem, however the first and second time i installed it (days before that)i did not have this issue, in fact i practically had no issue, but i noticed that the default .config after i download the sources was very much different from what it was when things were working properly.

they removed a lot of support in the default settings for a lot of things. which i liked, up until it started causing things like this.

i did install dhcpcd, thats also the function i first used when my internet wasn't working, to see if it was my network configurations.
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Sun Sep 23, 2012 3:55 pm    Post subject: Reply with quote

rabcor,

Yep, its the kernel. There is a shortcut you can make to avoid building the kernel and rebooting provided you only change kernel settings from < > to <M>

Tell us what lspci says about your ethernet card so we can identify the kernel module(s) you need.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Sep 23, 2012 5:16 pm    Post subject: Reply with quote

btw could sit0 be my wireless card? or is it maybe the bluetooth?
lspci?
-bash: lspci: command not found
Booting into livecd to see if that'll help..
lspci on livecd works...weird

but thats a nice command to know... i didn't know about it, so thanks for the command.
Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev06)

So i just add that as a module in driver devices in the /usr/src/linux/.config file and reboot the system? and i wont have to re-make the kernel? (altho it looks like i'm going to have to recompile it soon anyways because of another issue)
_________________
This picture was my biggest reason for ever trying Gentoo <3


Last edited by rabcor on Sun Sep 23, 2012 5:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Sun Sep 23, 2012 5:25 pm    Post subject: Reply with quote

rabcor,

sit0 is an IPv6 tunnel end point. You get it for free when you configure IPv6 in your kernel.

lspci is provided by pciutils. Its friend lsusb comes from usbutils.
Of course, its helps to have working internet to install those packages. You could use sneakernet but lets not go there unless we have to.

lspci has a -k option which shows the kernel module in use, which would be good on the liveCD as it will tell you which kernel module its using now.
In your own install, with kernel support missing, -k wouldn't help.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Sun Sep 23, 2012 5:27 pm    Post subject: Reply with quote

rabcor,

Its probably there but not loaded ...
What does
Code:
modprobe r8169
do?

As long as you don't get an error,
Code:
 ifconfig -a
should show eth0.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Sep 23, 2012 5:40 pm    Post subject: Reply with quote

naw its not found, you should seriously see their most recent default .config settings man, they've disabled like half the stuff in here...
including ALL wireless drivers.

and my CONFIG_TMPFS is not set which i think is also causing my sysfs not to start (we're checking that in another thread)

and well.. lets just say that with the default settings, changin only the things i really had to (like disabling support for intel/nvidia and enabling support for amd/ati where possible, enabling filesystems.... yes, they disabled support for nearly all filesystems on default except ext3)

and more, but many of the things they disabled/enabled i wanted to be changed that way like "Optimize for size" is now off by default... and real time clock is now on by default (i mean.. hwclock seems to need it...) and more...

but thanks, i didn't think they'd have disabled the support for my network card, but then again i didn't bother to check because... "nah it can't be they disabled the realtek drivers... those are too common" i thought, and same with my wireless broadcom drivers... both wrong.
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31835
Location: 56N 3W

PostPosted: Sun Sep 23, 2012 6:29 pm    Post subject: Reply with quote

rabcor,

It sounds like you have bigger problems than just your network card.
I never see the default .config file as I migrate from one kernel to the next by copying the old .config file to the new kernel then running
Code:
make oldconfig
in the new kernel.

Heres the shortcut for your r8169.

Get into make.conf, press / and enter 8169. It should tell you where the options you need for r8169 is.
Go there and set the driver to <M>, not to <*>.

Provided you only chnaged settings from < > to <M> (you can do more than one), exit menuconfig, saving the changed .config file.
Code:
make modules
make modules_install
modprobe r8169
/etc/init.d/net.eth0 start
will make your ethernet work.
Notice the absence of copying the kernel to /boot and rebooting. Loadable modules are stored in /lib/modules and by adding modules, the kernel binary, in /boot is unchanged.

To automate the module load, you need to add r8169 to /etc/conf.d/modules, as network modules are not normally autoloaded.
Its up to you how you start net.eth0. You may want to add it to the default runlevel.

DEVTMPFS only has a <*> or < > so thats a complete kernel reinstall and reboot.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Sun Sep 23, 2012 6:58 pm    Post subject: Reply with quote

thankfully genkernel --no-clean makes for a very fast kernel compilation. and since i'm recompiling it anyways i'll set my ethernet driver to <*>

many thanks good sir for all your help!
_________________
This picture was my biggest reason for ever trying Gentoo <3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum