Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge wpa_supplicant
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
leonixyz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2012
Posts: 76
Location: Italy

PostPosted: Tue Sep 18, 2012 6:51 pm    Post subject: emerge wpa_supplicant Reply with quote

Hello,
today I installed for the first time Gentoo on a Sony Vaio PCG-971M, by following this manual http://www.gentoo.org/doc/en/handbook/handbook-x86.xml: now I'm having some troubles.
While installing Gentoo from stage3 my connection was wired, and all worked fine[/url], but now I want to enable the wireless connection to stay physically in my bed and continue exploring this very interesting distribution.
I considered to use ssh to do that, and using Gentoo from another machine, but I want first try to enable my wireless connection.

Actually I only have eth0 and lo listed by ifconfig. By reading http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=4&chap=4 I thought maybe by installing wpa_supplicant the driver of wlan0 interface can be auto-installed and work out-of-the-box (but now I'm no more sure of that).

Unfortunately while doing that I was really tired (the installation/kernel-compilation/reading of the manual, takes me 7 hours!) and I only typed "emerge wpa_supplicant" and not "emerge net-wireless/wpa_supplicant" like stands in the manual.

Now this emerge script is working since hours, it will emerge and install 60 (!!!) items. How is this possible? Are all this 60 items needed? If not, how can I safe un-emerge this things? What is all this stuff?

During the installation I runned "net-setup eth0" and my wired connection was quickly and easily configured, now this command is no more available.
Is possible now to do something like this for wlan0?

Thanks
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6428
Location: Goose Creek SC

PostPosted: Tue Sep 18, 2012 7:49 pm    Post subject: Reply with quote

Quote:
Actually I only have eth0 and lo listed by ifconfig
means that no driver is installed for the wireless NIC.
Code:
emerge pciutils wgetpaste
lspci -k | wgetpaste
wgetpaste /usr/src/linux/.config
post the url's returned.

you will need wpa_supplicant although first you will need a driver for the wireless NIC.
the additional files being merged are required to support installing and running wpa_supplicant as determined by the use flags selected and the ebuild. parts 2,3,4 of the handbook may be of interest.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
leonixyz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2012
Posts: 76
Location: Italy

PostPosted: Thu Sep 20, 2012 10:44 am    Post subject: Reply with quote

I don't want to emerge wgetpaste now... is enough if I post the output of those two commands manually?
Thank you...

lspci -k
Code:
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: agpgart-via
   Kernel modules: via-agp
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
   Kernel modules: shpchp
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: parport_pc
   Kernel modules: parport_pc
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: pata_via
00:07.2 USB controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: uhci_hcd
   Kernel modules: uhci-hcd
00:07.3 USB controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: uhci_hcd
   Kernel modules: uhci-hcd
00:07.4 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
   Subsystem: Sony Corporation Device 80f6
   Kernel modules: via686a, i2c-viapro
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: snd_via82xx
   Kernel modules: snd-via82xx
00:07.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 30)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: snd_via82xx_modem
   Kernel modules: snd-via82xx-modem
00:0a.0 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: yenta_cardbus
   Kernel modules: yenta_socket
00:0a.1 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: yenta_cardbus
   Kernel modules: yenta_socket
00:0e.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)
   Subsystem: Sony Corporation Device 80f6
00:10.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
   Subsystem: Sony Corporation Device 80f6
   Kernel driver in use: 8139too
   Kernel modules: 8139too, 8139cp
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Rage Mobility P/M AGP 2x (rev 64)
   Subsystem: Sony Corporation Device 80f6



cat /usr/src/linux/.config
http://www.leonixyz.net/linux.config.txt
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6428
Location: Goose Creek SC

PostPosted: Thu Sep 20, 2012 12:53 pm    Post subject: Reply with quote

no wireless device appears in lspci or in the technical manual specifications for Sony Vaio PCG-971M. if you have usb wireless run
Code:
emerge usbutils
lsusb
and post the entry for your wireless.
if a pc card wireless that does not show in lspci find a label or technical manual and identify it.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
leonixyz
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2012
Posts: 76
Location: Italy

PostPosted: Fri Sep 21, 2012 3:46 pm    Post subject: Reply with quote

I'm very sorry, you're right, this notebook does not have a wireless device O_O

ftp://ftp.vaio-link.com/pub/manuals/Notebooks/FX/FX400/FX400_H_UK.pdf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum