Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(solved)Genkernel wont complete
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 158

PostPosted: Thu Sep 20, 2012 3:52 am    Post subject: (solved)Genkernel wont complete Reply with quote

cc1: warnings being treated as errors
drivers/scsi/lpfc.... (bunch of errors looking like that)
make[3] *** [drivers....] Error 1
make[2] *** [drivers....] Error 2
make[3] *** [drivers....] Error 2
--
CC [M] drivers/net/wireless.....
warning: unused variable 'img'
warning: unusde variable 'dev'
--
CC [M] drivers/net/wireless...
make: *** [drivers] Error 2
*running with options: --splash --no-install --no-clean --menuconfig all
ERROR: Failed to compile the "modules" target...

-- End log... --


The above is pretty much all i can see, then whats below end log.

i've pretty much done everything by the handbook so far, and through trial and error managed to reach the point where i need to compile the kernel... as a beginner i use genkernel.

I just ran "genkernel all" instead of that other thing, i get the same result. i'm giving up unless someone here knows how to do this. (giving up as in, giving up on trying to install gentoo on my laptop for now, i'd probably just switch to another distro)


Last edited by rabcor on Thu Sep 20, 2012 9:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jickler
n00b
n00b


Joined: 09 Sep 2011
Posts: 67

PostPosted: Thu Sep 20, 2012 4:22 am    Post subject: Reply with quote

Hey rabcor,

I'm pretty sure I ran into this problem the other day, the solution I used is at http://forums.gentoo.org/viewtopic-t-934434-start-0.html. You will have to append --menuconfig to your genkernel line and tick off one of the modules if I remember correctly.

--EDIT--
Sorry, I know you're new so here's a little more information. After you run genkernel --menuconfig all, a configuration menu will load as if you were manually configuring. You need to disable "Emulex LightPulse Fibre Channel Support," which you will find under:
-> Device Drivers │
│ -> SCSI device support │
│ -> SCSI low-level drivers

It's probably set to compile as a module now, you want to completely remove it.
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 158

PostPosted: Thu Sep 20, 2012 5:03 am    Post subject: Reply with quote

thanks a lot, it worked, altho now i'm getting
Code:

Required Kernel Parameters:
       real_root=/dev/$ROOT
       
       Where $ROOT is the device node for your root partition as the
       one specified in /etc/fstab

If you require Genkernel's hardware detection features; you MUST
tell your bootloader to use the provided INITRAMFS file. Otherwise;
substitute the root argument for the real_root argument if you are
not planning to use the initramfs...

WARNING... WARNING... WARNING...
Additional kernel cmdline arguments that *may* be required to boot properly...
add "vga=791 splash=silent, theme:default console=tty1 quiet" if you use a splash framebuffer ]
With support for several ext* filesystems around it may be needed to
add "rootfstype=ext3" or "rootfstype=ext4"


where am i meant to add this.. rootfstype=ext4 and... the vga thing? since i'm kindof worried abou this, i'll make a new thread for it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum