Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless notworking
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Tue Sep 18, 2012 5:00 pm    Post subject: Wireless notworking Reply with quote

Hello people,

I'm using a gentoo 64bits version. Since i installed it, i've been had a problem, when i run the command wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -B -Dwext, i got this message :

Quote:
ioctl[SIOCSIWMODE]: Operation not supported
ioctl[SIOCGIWRANGE]: Operation not supported
ioctl[SIOCGIWMODE]: Operation not supported
ioctl[SIOCSIWAP]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported


My driver is rtl8192se. I loaded it as a module in the kernel. Lsmod gives:
Quote:
Module Size Used by
rtl8192se 85147 0
rtlwifi 88236 1 rtl8192se
mac80211 215441 2 rtl8192se,rtlwifi
cfg80211 138603 2 rtlwifi,mac80211
snd_hda_codec_hdmi 23144 1
snd_hda_codec_conexant 44798 1
rtc_cmos 8396 0
snd_hda_intel 22387 0
snd_hda_codec 69869 3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 5949 1 snd_hda_codec
snd_pcm 64527 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer 18337 1 snd_pcm
snd 53624 7 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
atl1c 31402 0
snd_page_alloc 6809 2 snd_hda_intel,snd_pcm


i've done a ln -s /etc/init.d/net.lo /etc/init.d/net.wlan0 and ln -s /etc/init.d/net.lo /etc/init.d/wlan0
when i run : /etc/init.d/net.wlan0
Quote:
* Bringing up interface wlan0
* Starting wpa_supplicant on wlan0 ...
Unsupported driver 'rtl8192se'.
* start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant' [ !! ]
* ERROR: net.wlan0 failed to start


and when i run : /etc/init.d/wlan0
Quote:


Bringing down interface wlan0
* Removing addresses
* Bringing up interface wlan0
* Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWMODE]: Operation not supported
ioctl[SIOCGIWRANGE]: Operation not supported
ioctl[SIOCGIWMODE]: Operation not supported
ioctl[SIOCSIWAP]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Operation not supported [ ok ]
* Starting wpa_cli on wlan0 ... [ ok ]
* Backgrounding ... ...
* WARNING: wlan0 has started, but is inactive


I don't understant why the outpout of thistwo commands are differents.

Iwconfig :
Quote:


lo no wireless extensions.

wlan0 no wireless extensions.

eth0 no wireless extensions.


I got all the firmware.

I had already succed to connect with wpa_supplicant, but i had had used to use an another interface. Three months without my computer make me forget a lot of things like my english.

Thank for helping and sorry for my english i know it doesn't sound good enough.[/quote][/bug]
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 18, 2012 5:34 pm    Post subject: Reply with quote

bangerbros,

Can you paste back a couple of things :?:
Code:
rc-update|grep net

ls -l /etc/init.d|grep ^l

cat /etc/wpa_supplicant.conf

cat /etc/udev/rules.d/70-persistent-net.rules

_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
zappatized
n00b
n00b


Joined: 18 Aug 2012
Posts: 21

PostPosted: Tue Sep 18, 2012 5:38 pm    Post subject: Reply with quote

I'm not sure if this will help, but having at least one of these solved my wireless troubles.

Code:
$ eix -s crda
[I] net-wireless/crda
     Available versions:  1.0.1-r1 1.1.2-r3 (~)1.1.2-r4
     Installed versions:  1.1.2-r4(10:22:08 AM 08/15/2012)
     Homepage:            http://wireless.kernel.org/en/developers/Regulatory
     Description:         Central Regulatory Domain

$ zgrep -i regdb /proc/config.gz
# CONFIG_CFG80211_INTERNAL_REGDB is not set
Back to top
View user's profile Send private message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Tue Sep 18, 2012 5:55 pm    Post subject: Reply with quote

thank you all !!!

rc-update | grep net :
Quote:

net.lo | boot
net.wlan0 | default
netmount | default


ls -l /etc/init.d | grep ^l :
Quote:


lrwxrwxrwx 1 root root 25 2 juin 14:47 functions.sh -> /lib64/rc/sh/functions.sh
lrwxrwxrwx 1 root root 18 18 sept. 13:20 net.wlan0 -> /etc/init.d/net.lo
lrwxrwxrwx 1 root root 18 2 juin 22:36 wlan0 -> /etc/init.d/net.lo


my file /etc/wpa_supplicant.conf got no mistake, as i just said, i already succed to connect but with an wpa_supplicant command a litte bit different, but no way i can remember.

Quote:


cat /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x1969:0x1062 (atl1c)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="c8:0a:a9:98:eb:6c", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0x8172 (rtl8192se)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="70:f1:a1:a7:89:dc", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 18, 2012 6:24 pm    Post subject: Reply with quote

bangerbros.

You can get rid of this symlink: wlan0 -> /etc/init.d/net.lo

What does ifconfig return :?:

bangerbros wrote:
I had already succed to connect with wpa_supplicant, but i had had used to use an another interface. Three months without my computer make me forget a lot of things like my english.

Did you change anything in /etc/conf.d/net and/or make any kernel configuration changes for this :?:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Tue Sep 18, 2012 6:46 pm    Post subject: Reply with quote

no i make no change of this file. And about my system i just updated it right now. Before going in holiday i got still this error but i've found a way to avoid it.

ifconfig :
Quote:

eth0 Lien encap:Ethernet HWaddr c8:0a:a9:98:eb:6c
inet adr:192.168.0.11 Bcast:192.168.0.255 Masque:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:298594 errors:0 dropped:8 overruns:0 frame:0
TX packets:171052 errors:0 dropped:0 overruns:0 carrier:7
collisions:0 lg file transmission:1000
RX bytes:405622879 (386.8 MiB) TX bytes:18203692 (17.3 MiB)
Interruption:46

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:154 errors:0 dropped:0 overruns:0 frame:0
TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:11284 (11.0 KiB) TX bytes:11284 (11.0 KiB)

wlan0 Lien encap:Ethernet HWaddr 70:f1:a1:a7:89:dc
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Back to top
View user's profile Send private message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Tue Sep 18, 2012 10:06 pm    Post subject: Reply with quote

when i use the command wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf && dhcpc, the wifi works, but i can't figure myself, why it's with the driver nl80211.

Thank you for helping me !!!
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2641
Location: Slovenia

PostPosted: Tue Sep 18, 2012 11:31 pm    Post subject: Reply with quote

bangerbros wrote:
but i can't figure myself, why it's with the driver nl80211.

That's what you're supposed to use. Pretty much all wifi drivers nowadays are nl80211, the only still widely used wext driver is ipw2200.

nl80211 has a wext compatibility option that you probably didn't activate in your kernel, that's what iwconfig says "no wireless extensions" for wlan0. But there's nothing wrong with that. In fact, this wext compatibility option for nl80211 will disappear from the kernel at some point in the future. wireless-tools will stop working then, so you should get used to using net-wireless/iw instead.
Back to top
View user's profile Send private message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Wed Sep 19, 2012 5:10 pm    Post subject: Reply with quote

Ok, thank you for your explanation :)
Back to top
View user's profile Send private message
novinsh
n00b
n00b


Joined: 14 Nov 2013
Posts: 1

PostPosted: Thu Nov 14, 2013 2:02 pm    Post subject: using wpa_supplicant Reply with quote

I've had a same problem when I wanted to use wpa_supplicant and sort of ioctl operation failures showed up!
I've used this command "wpa_supplicant -Dnl80211 -iwlan0 -c/home/nao/Profiles/default" which bangerbros said it worked for him.
These were printed and no further message or returning to terminal command line occurred (just freezed!):
Code:
wlan0: SME: Trying to authenticate with 00:22:6b:68:16:d3 (SSID='MRL-SPL2' freq=2412 MHz)
wlan0: Trying to associate with 00:22:6b:68:16:d3 (SSID='MRL-SPL2' freq=2412 MHz)
wlan0: Associated with 00:22:6b:68:16:d3
wlan0: WPA: Key negotiation completed with 00:22:6b:68:16:d3 [PTK=CCMP GTK=TKIP]
wlan0: CTRL-EVENT-CONNECTED - Connection to 00:22:6b:68:16:d3 completed (auth) [id=0 id_str=]
Does it mean everything has just gone alright? then what's it that I can not ping other machines? Is there another way rather than pinging that could be proved everything's just fine?

It might be worthy to mention that I'm using gentoo on an embedded system and some modifications been done on the wireless drive and the default connection manager is connman.
I wondered if there's any configuration on gentoo that tells which driver to use because It seems that using nl80211 everything works fine with my adapter and the whole ioctl error was about loading the current driver.

actually I don't really want to execute the above command every time the system boots!

Thanks in advance for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum