Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Suspend to RAM broken with kernel > 3.3.x
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Wed Sep 19, 2012 10:30 am    Post subject: Suspend to RAM broken with kernel > 3.3.x Reply with quote

Hi,

I can't have a working suspend to ram on my system with kernels 3.4.x and 3.5.x, gentoo and vanilla sources tested
Suspend to disk (hibernate) is working
The suspend seems to work, but give a system freeze on resume : screen appears, but no reaction to mouse/keyboard...
Resume is working when xorg is stopped, but the system freeze in a same way when I try to restart it

My hardware :
ASROCK H61M/U3S3 - Chipset Intel H61 - Socket
1155
INTEL i3-2100 3.10GHz - 3Mo cache - Graphic HD
2000 - Socket LGA1155

lspci -v output :
http://shorttext.com/NXKmwx

Kernel config (all "not set" things filtered out : shorttext size limitation :
http://shorttext.com/LrSzLSO

Wonder if someone know the trick or have the same issue

Thanks in advance
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2096

PostPosted: Wed Sep 19, 2012 12:59 pm    Post subject: Reply with quote

How do you suspend? pm-utils, upower, `echo mem > ...`? Does it happen both from X11 and from VT?
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Wed Sep 19, 2012 9:26 pm    Post subject: Reply with quote

avx wrote:
How do you suspend? pm-utils, upower, `echo mem > ...`? Does it happen both from X11 and from VT?


pm-utils, but direct echo mem > /proc/... give the same issue
Freeze on resume from x11, ok from vt, but then freeze the same way when restarting x11
Thanks
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2096

PostPosted: Wed Sep 19, 2012 11:32 pm    Post subject: Reply with quote

What are you running, (un-)stable? I'm running ~amd64 and can't reproduce with my Intel systems, neither on 3.4 nor 3.5(didn't test 3.3).

Any errors in logfiles(X.org, suspend logs, dmesg, ...)?
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Thu Sep 20, 2012 1:23 pm    Post subject: Reply with quote

avx wrote:
What are you running, (un-)stable? I'm running ~amd64


The same here

avx wrote:
Any errors in logfiles(X.org, suspend logs, dmesg, ...)?


Don't have time to give any output (even with debug mode enabled in kernel), since it freeze before :/
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 524
Location: Coruña (Spain)

PostPosted: Thu Oct 11, 2012 5:47 pm    Post subject: Reply with quote

I have the exact same issue. Asus P5V-VM mobo, working as server (no X running). I suspend ok and after resume everything seems to have gone well: screen comes back, I see the VT prompt just as I left it... but everything is frozen.

In my case it doesn't happen all the times. Once every 3 or 4 suspend/resume cycles, more or less.

Nothing wrong in the logs.

I'll try with an older kernel (3.3) and see what happens.
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Thu Oct 11, 2012 6:42 pm    Post subject: Reply with quote

I have the similar issue, but not so bad.

after resuming, the laptop_mode stops working as welle as the keybinding Fn+F6 or F7 to control brightness, and so does the alt+Fx. Normally, in xfce (my desktop environment) alt+Fx have other functions such as, alt+F1 show menu, alt+F2 pop up the command windows, but after suspending and resuming, alt+F1 returns to the function of terminal switch.

When I suspend and resume in terminal (X is not running), it is black on the screen. but the keyboard still works, I could still make "reboot" to restart, and "startx" to enter my X window.

I would like to how to fix it. Thanks.
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Thu Oct 11, 2012 7:01 pm    Post subject: Reply with quote

I am sorry, this time, alt+Fx do what they should do. I don't know why
Back to top
View user's profile Send private message
nqzero
n00b
n00b


Joined: 01 Jan 2013
Posts: 1

PostPosted: Tue Jan 01, 2013 11:40 pm    Post subject: Re: Suspend to RAM broken with kernel > 3.3.x Reply with quote

just confirming razer's issue. i have exactly this issue - suspending with xorg running, or running xorg after suspend/resuming, results in a frozen system (no response to ping, blank screen of death)

foxconn h61s with a (sandy bridge) i3-2105
3.5.0 kernel (ubuntu 12.10 - apologies in advance)

.xsession-errors doesn't get updated. i haven't tried hibernate

razer wrote:


I can't have a working suspend to ram on my system with kernels 3.4.x and 3.5.x, gentoo and vanilla sources tested
Suspend to disk (hibernate) is working
The suspend seems to work, but give a system freeze on resume : screen appears, but no reaction to mouse/keyboard...
Resume is working when xorg is stopped, but the system freeze in a same way when I try to restart it

ASROCK H61M/U3S3 - Chipset Intel H61 - Socket 1155

[snip]

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum