Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
exFAT and FUSE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2099
Location: 127.0.0.1

PostPosted: Fri Sep 14, 2012 5:28 am    Post subject: exFAT and FUSE Reply with quote

I am trying t get exfat working on my Gentoo install.

I have enabled FUSE support in my kernel (not module, built in) and emerged fuse, fuse-exfat, exfat-utils.

I've loaded the new kernel by rebooting into it and I still cannot mount my exfat external drive:


Code:
# mount /dev/sde1 /mnt/usb/
mount: unknown filesystem type 'exfat'


Am I missing something else?
_________________
John5788
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2529

PostPosted: Fri Sep 14, 2012 1:11 pm    Post subject: Reply with quote

I've never fiddled with any of the exFAT stuff, but I have used the sshfs-fuse, mildly related, as it also works through FUSE. To use sshfs-fuse, after building the correct kernel and installing all of the correct packages, you still have to run some sort of command in order to make the new filesystem available, in my case the "sshfs" command.

I would look through any files your exFAT-related packages install for any commands, man pages, etc. I'm pretty sure the vanilla "mount" command won't do the job for you, and least until you run something else to make the system aware of the exFAT capabilities. I would guess that you either need to add some init script to your default runlevel, or may need to run a different "mount" command.

I've stuck to SDHC for my camera. One SD card lasts me a few months anyway, and I'd just as soon not collect more than that in-camera.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
morpheus2051
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 93

PostPosted: Sat Sep 15, 2012 10:41 am    Post subject: Reply with quote

Can you try mount -t <don't know how exfat is called here but insert correct name> /dev/sde1 /mnt/usb/. Or does the exfat-utils package contain a helper program like ntfs-3g? Then use that program. Hope this helps a bit.
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Sat Sep 15, 2012 4:31 pm    Post subject: Reply with quote

morpheus2051 wrote:
Can you try mount -t <don't know how exfat is called here but insert correct name> /dev/sde1 /mnt/usb/. Or does the exfat-utils package contain a helper program like ntfs-3g? Then use that program. Hope this helps a bit.


Based on the error

mount: unknown filesystem type 'exfat'

when mount is run without -t, I gather there is some entry in /etc/fstab. What does it read ?
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sat Sep 15, 2012 11:52 pm    Post subject: Reply with quote

John5788,

According to the web page you should use mount.exfat-fuse :?
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Sun Sep 16, 2012 5:03 am    Post subject: Reply with quote

BillWho wrote:
John5788,

According to the web page you should use mount.exfat-fuse :?

.
Actually that probably points to the solution - the filesystem is perhaps called exfat-fuse, not exfat

mount -t system calls mount.system, so my guess is mount -t exfat-fuse should work,
and so is setting filesystem to exfat-fuse in /etc/fstab


Last edited by dmpogo on Wed Sep 19, 2012 2:24 am; edited 1 time in total
Back to top
View user's profile Send private message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2099
Location: 127.0.0.1

PostPosted: Tue Sep 18, 2012 4:30 am    Post subject: Reply with quote

BillWho wrote:
John5788,

According to the web page you should use mount.exfat-fuse :?


That works from the command line. How would I go about integrating this into my file manager Thunar? When I click on the external drive in Thunar, it attempts to use the method of `mount -t exfat` instead of using the mount.exfat-fuse command.
_________________
John5788
Back to top
View user's profile Send private message
morpheus2051
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 93

PostPosted: Tue Sep 18, 2012 11:08 am    Post subject: Reply with quote

Try putting exfat_fuse in /etc/filesystems, presuming mount -t exfat_fuse does work.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2129
Location: Finland

PostPosted: Tue Sep 18, 2012 11:45 am    Post subject: Reply with quote

Might need an udev rules.d file like ntfs3g has

/etc/udev/rules.d/99-exfat.rules
Code:

ENV{ID_FS_TYPE}=="exfat", ENV{ID_FS_TYPE}="exfat_fuse"


(Or was it the otherway around?)
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2289
Location: Canada

PostPosted: Wed Sep 19, 2012 2:25 am    Post subject: Reply with quote

morpheus2051 wrote:
Try putting exfat_fuse in /etc/filesystems, presuming mount -t exfat_fuse does work.


I don't know, but is it underscore exfat_fuse or dash exfat-fuse ?
Back to top
View user's profile Send private message
s4e8
Apprentice
Apprentice


Joined: 29 Jul 2006
Posts: 210

PostPosted: Wed Sep 19, 2012 4:21 am    Post subject: Reply with quote

re-emerge util-linux and fuse-exfat.
fuse-exfat put mount helper mount.exfat symlink into /usr/sbin/, old util-linux may not search this directory.
Back to top
View user's profile Send private message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2099
Location: 127.0.0.1

PostPosted: Wed Sep 19, 2012 4:59 am    Post subject: Reply with quote

ssuominen wrote:
Might need an udev rules.d file like ntfs3g has

/etc/udev/rules.d/99-exfat.rules
Code:

ENV{ID_FS_TYPE}=="exfat", ENV{ID_FS_TYPE}="exfat_fuse"


(Or was it the otherway around?)


That worked for changing the the -t parameter to mount when I attempt to access in Thunar. However, the unfortunate bit is this:


Code:
# mount /dev/sde1 -t exfat-fuse /mnt/usb/
mount: unknown filesystem type 'exfat-fuse'

# mount.exfat /dev/sde1 /mnt/usb/
FUSE exfat 0.9.8


The first command using -t parameter does not work. calling mount.exfat or mount.exfat-fuse works (they are both symlinked together)

Why doesn't mount -t exfat or mount -t exfat-fuse work?
_________________
John5788
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2129
Location: Finland

PostPosted: Wed Sep 19, 2012 7:25 am    Post subject: Reply with quote

John5788 wrote:

The first command using -t parameter does not work. calling mount.exfat or mount.exfat-fuse works (they are both symlinked together)

Why doesn't mount -t exfat or mount -t exfat-fuse work?


I don't know of other than too old util-linux version doesn't have support for reading mount or umount helpers from /usr.
Back to top
View user's profile Send private message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2099
Location: 127.0.0.1

PostPosted: Wed Sep 19, 2012 7:34 am    Post subject: Reply with quote

ssuominen wrote:
John5788 wrote:

The first command using -t parameter does not work. calling mount.exfat or mount.exfat-fuse works (they are both symlinked together)

Why doesn't mount -t exfat or mount -t exfat-fuse work?


I don't know of other than too old util-linux version doesn't have support for reading mount or umount helpers from /usr.


I'm using 2.20.1-r2. Do you think this is too old? Should I update to 2.22 (latest)
_________________
John5788
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2129
Location: Finland

PostPosted: Wed Sep 19, 2012 11:19 am    Post subject: Reply with quote

John5788 wrote:
ssuominen wrote:
John5788 wrote:

The first command using -t parameter does not work. calling mount.exfat or mount.exfat-fuse works (they are both symlinked together)

Why doesn't mount -t exfat or mount -t exfat-fuse work?


I don't know of other than too old util-linux version doesn't have support for reading mount or umount helpers from /usr.


I'm using 2.20.1-r2. Do you think this is too old? Should I update to 2.22 (latest)


I think 2.20.1-r2 is the first one where umount wrappers were fixed and mount wrappers was already fixed prior to that. So 2.20.1-r2 should be good. You can try to upgrade. It is safe.

Furthermore you shouldn't really be using mount or umount at all for removable devices, just use `udisks --mount` or `udisks --unmount` with sys-fs/udisks:0 or `udisksctl mount` or `udisksctl unmount` with sys-fs/udisks:2.
Then you can even mount as a normal user as long as you are authorized by ConsoleKit to be 'active = TRUE' in the 'ck-list-sessions' output.
Back to top
View user's profile Send private message
benayed
n00b
n00b


Joined: 27 Mar 2009
Posts: 2

PostPosted: Tue Oct 09, 2012 5:40 pm    Post subject: Reply with quote

All you need to do is:

ln -s /usr/bin/mount.exfast-fuse /sbin/mount.exfat

fuse-exfat creates the symlink in /usr/bin which will not be picked up by mount.

This may be a defect against the fuse-exfaxt package. Once you do this, the exfat filesystem is reconized by Thunar, KDE, mount an others.

Thanks,

Karim Benayed
Back to top
View user's profile Send private message
ralpho
n00b
n00b


Joined: 17 Aug 2014
Posts: 3

PostPosted: Fri Sep 05, 2014 8:53 pm    Post subject: exfat Reply with quote

I think you guys missed the simple explanation.
The kernel needs fuse.
Back to top
View user's profile Send private message
fwong
n00b
n00b


Joined: 16 Sep 2014
Posts: 1
Location: France

PostPosted: Tue Sep 16, 2014 4:50 pm    Post subject: Reply with quote

avant tout, installer le paquet 'sys-fs/fuse-exfat' :
Code:
sudo equo install sys-fs/fuse-exfat

_________________
Francis Wong
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum