Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Darkplaces: missing/unlocatable data
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
jose.maria
n00b
n00b


Joined: 04 Sep 2012
Posts: 24
Location: In the garden

PostPosted: Tue Sep 18, 2012 6:33 pm    Post subject: Darkplaces: missing/unlocatable data Reply with quote

I just emerged Darkplaces. When I run it, it successfully opens in full screen. But an error message is displayed. It complains about not being able to find some data.

I have no idea of what to do. I tried to run it with the -basedir option pointing to the path of the game, but unsuccessfully.

Can anyone help me making it work?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7412
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Sep 18, 2012 6:38 pm    Post subject: Reply with quote

I'm probably not going to be able to help you, but most likely nobody will be able to unless you provide the exact messages that you're getting. :wink:

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
jose.maria
n00b
n00b


Joined: 04 Sep 2012
Posts: 24
Location: In the garden

PostPosted: Tue Sep 18, 2012 6:47 pm    Post subject: Reply with quote

Yes, that's true. I was asking for a miracle...

This is the message that Darkplaces displays when run:

Quote:
You have reached this menu due to missing or unlocatable content/data. You may consider adding -basedir /path/to/game to your launch commandline.


And it lets you open a Quake console or exit.

Perhaps I must have the original version of Quake in order to run Darkplaces. But I thought Darkplaces was by itself an engine.
Back to top
View user's profile Send private message
jose.maria
n00b
n00b


Joined: 04 Sep 2012
Posts: 24
Location: In the garden

PostPosted: Tue Sep 18, 2012 8:09 pm    Post subject: Reply with quote

I managed to solve the issue.

As explained in the Darkplaces website:

http://icculus.org/twilight/darkplaces/readme.html#HowToInstallQuake_Linux

all I had to do was to move the .pak files to the id1 directory of quake1. They were missing, in fact. But these files are from the original CD of Quake 1, perhaps they are available in some dark place in internet...
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7412
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Sep 18, 2012 8:41 pm    Post subject: Reply with quote

This might be worth a bug report, recommending that einfo or ewarn messages should be added to the ebuild notifying the user that the content must be installed separately, perhaps even referencing the tutorial you found.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
jose.maria
n00b
n00b


Joined: 04 Sep 2012
Posts: 24
Location: In the garden

PostPosted: Tue Sep 18, 2012 8:45 pm    Post subject: Reply with quote

I would gladly do as you suggest, although I never did such a thing. I will look in Gentoo's website to learn how to report a bug, although some help here would be appreciated.
Back to top
View user's profile Send private message
jose.maria
n00b
n00b


Joined: 04 Sep 2012
Posts: 24
Location: In the garden

PostPosted: Tue Sep 18, 2012 9:06 pm    Post subject: Reply with quote

OK, the bug was reported. Nice and easy!
Back to top
View user's profile Send private message
Crazy_Jerry
n00b
n00b


Joined: 08 May 2012
Posts: 44

PostPosted: Thu May 02, 2013 7:35 am    Post subject: Reply with quote

I had same problem .
And I unemerge it.

:D :D :D :D :D :D :D :D :D :D
_________________
God be with us !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum