Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error in all "patch"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8979

PostPosted: Sun Sep 16, 2012 4:37 pm    Post subject: Reply with quote

You have xattr support in your kernel. Are you mounting the filesystem with xattr enabled?
Back to top
View user's profile Send private message
dgiorgio
n00b
n00b


Joined: 24 Jun 2012
Posts: 58

PostPosted: Sun Sep 16, 2012 5:38 pm    Post subject: Reply with quote

how to enable?

my fstab
http://pastebin.com/RcsG9mYR
Back to top
View user's profile Send private message
dgiorgio
n00b
n00b


Joined: 24 Jun 2012
Posts: 58

PostPosted: Sun Sep 16, 2012 6:12 pm    Post subject: Reply with quote

I updated the acpid, gave no error, but does not need to patch.

always applying a patch, has an error.
Back to top
View user's profile Send private message
dgiorgio
n00b
n00b


Joined: 24 Jun 2012
Posts: 58

PostPosted: Sun Sep 16, 2012 6:18 pm    Post subject: Reply with quote

http://news.softpedia.com/news/Linux-Kernel-3-5-3-Is-Available-for-Download-288183.shtml

"Linux kernel 3.5.3 includes mostly updated drivers, especially for ATI Radeon and Intel i915 graphics cards, as well as some EXT4 filesystem changes."

Quote:
# uname -a
Linux DOUGLAS-NOTE 3.5.3-gentoo #4 SMP Sat Sep 15 23:58:39 BRT 2012 x86_64 Intel(R) Core(TM) i3 CPU M 350 @ 2.27GHz GenuineIntel GNU/Linux


ext4 upgraded? I need to reformat?
Back to top
View user's profile Send private message
dgiorgio
n00b
n00b


Joined: 24 Jun 2012
Posts: 58

PostPosted: Sun Sep 16, 2012 11:28 pm    Post subject: Reply with quote

http://imageshack.us/photo/my-images/26/imagem10k.png/

the root partition is not locked, but it is mounted.


Quote:

# revdep-rebuild --soname libncurses.so.5

Encountered deprecated option --soname.
Please use --library instead.
* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries using libncurses.so.5
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Checking dynamic linking
* found /bin/bash
* found /lib32/libgpm.so.1.20.0
[ 1% ] * found /lib32/libreadline.so.6.2
* found /lib64/libeinfo.so.1
* found /lib64/libgpm.so.1.20.0
[ 2% ] * found /lib64/libreadline.so.6.2
[ 3% ] * found /sbin/grub
[ 5% ] * found /usr/bin/ccmake
* found /usr/bin/conky
[ 10% ] * found /usr/bin/info
[ 13% ] * found /usr/bin/lame
[ 19% ] * found /usr/bin/pstree
[ 20% ] * found /usr/bin/resize
[ 22% ] * found /usr/bin/slabtop
[ 23% ] * found /usr/bin/top
[ 25% ] * found /usr/bin/xterm
[ 26% ] * found /usr/games/bin/gnugo
[ 31% ] * found /usr/lib32/libform.so.5.9
* found /usr/lib32/libgettextlib-0.18.1.so
* found /usr/lib32/libgettextsrc-0.18.1.so
[ 32% ] * found /usr/lib32/libmenu.so.5.9
[ 33% ] * found /usr/lib32/libpanel.so.5.9
[ 48% ] * found /usr/lib64/ggi/default/color.so
* found /usr/lib64/ggi/default/fbdev/fbdev_m2164w.so
* found /usr/lib64/ggi/default/fbdev/fbdev_mach64.so
* found /usr/lib64/ggi/default/fbdev/fbdev_mga_g400.so
* found /usr/lib64/ggi/default/ilbm.so
* found /usr/lib64/ggi/default/iplanar_2p.so
* found /usr/lib64/ggi/default/linear_16.so
* found /usr/lib64/ggi/default/linear_1_r.so
* found /usr/lib64/ggi/default/linear_1.so
* found /usr/lib64/ggi/default/linear_24.so
* found /usr/lib64/ggi/default/linear_2.so
* found /usr/lib64/ggi/default/linear_32.so
* found /usr/lib64/ggi/default/linear_4_r.so
* found /usr/lib64/ggi/default/linear_4.so
* found /usr/lib64/ggi/default/linear_8.so
* found /usr/lib64/ggi/default/planar.so
* found /usr/lib64/ggi/default/pseudo_stubs.so
* found /usr/lib64/ggi/default/stubs.so
* found /usr/lib64/ggi/default/text_16.so
* found /usr/lib64/ggi/default/text_32.so
* found /usr/lib64/ggi/display/aa.so
* found /usr/lib64/ggi/display/auto.so
* found /usr/lib64/ggi/display/fbdev.so
* found /usr/lib64/ggi/display/file.so
[ 49% ] * found /usr/lib64/ggi/display/ipc.so
* found /usr/lib64/ggi/display/linvtsw.so
* found /usr/lib64/ggi/display/mansync.so
* found /usr/lib64/ggi/display/memory.so
* found /usr/lib64/ggi/display/monotext.so
* found /usr/lib64/ggi/display/multi.so
* found /usr/lib64/ggi/display/palemu.so
* found /usr/lib64/ggi/display/sub.so
* found /usr/lib64/ggi/display/tele.so
* found /usr/lib64/ggi/display/terminfo.so
* found /usr/lib64/ggi/display/tile.so
* found /usr/lib64/ggi/display/trueemu.so
* found /usr/lib64/ggi/display/vcsa.so
* found /usr/lib64/ggi/display/X.so
* found /usr/lib64/ggi/helper/helper_x_dbe.so
* found /usr/lib64/ggi/helper/helper_x_dga.so
* found /usr/lib64/ggi/helper/helper_x_evi.so
* found /usr/lib64/ggi/helper/helper_x_shm.so
* found /usr/lib64/ggi/helper/helper_x_vidmode.so
[ 65% ] * found /usr/lib64/libaa.so.1.0.4
[ 67% ] * found /usr/lib64/libform.so.5.9
* found /usr/lib64/libgettextlib-0.18.1.so
* found /usr/lib64/libgettextsrc-0.18.1.so
* found /usr/lib64/libggi.so.2.0.2
[ 70% ] * found /usr/lib64/libmenu.so.5.9
[ 71% ] * found /usr/lib64/libpanel.so.5.9
[ 73% ] * found /usr/lib64/libvte.so.9.2800.2
[ 98% ] * found /usr/sbin/cgdisk
[ 99% ] * found /usr/sbin/parted
[ 100% ]
* Generated new 3_broken.rr
* Assigning files to packages
* /bin/bash -> app-shells/bash
* /lib32/libgpm.so.1.20.0 -> app-emulation/emul-linux-x86-baselibs
* /lib32/libreadline.so.6.2 -> app-emulation/emul-linux-x86-baselibs
* /lib64/libeinfo.so.1 -> sys-apps/openrc
* /lib64/libgpm.so.1.20.0 -> sys-libs/gpm
* /lib64/libreadline.so.6.2 -> sys-libs/readline
* /sbin/grub -> sys-boot/grub
* /usr/bin/ccmake -> dev-util/cmake
* /usr/bin/conky -> app-admin/conky
* /usr/bin/info -> sys-apps/texinfo
* /usr/bin/lame -> media-sound/lame
* /usr/bin/pstree -> sys-process/psmisc
* /usr/bin/resize -> x11-terms/xterm
* /usr/bin/slabtop -> sys-process/procps
* /usr/bin/top -> sys-process/procps
* /usr/bin/xterm -> x11-terms/xterm
* /usr/games/bin/gnugo -> games-board/gnugo
* /usr/lib32/libform.so.5.9 -> app-emulation/emul-linux-x86-baselibs
* /usr/lib32/libgettextlib-0.18.1.so -> app-emulation/emul-linux-x86-baselibs
* /usr/lib32/libgettextsrc-0.18.1.so -> app-emulation/emul-linux-x86-baselibs
* /usr/lib32/libmenu.so.5.9 -> app-emulation/emul-linux-x86-baselibs
* /usr/lib32/libpanel.so.5.9 -> app-emulation/emul-linux-x86-baselibs
* /usr/lib64/ggi/default/color.so -> media-libs/libggi
* /usr/lib64/ggi/default/fbdev/fbdev_m2164w.so -> media-libs/libggi
* /usr/lib64/ggi/default/fbdev/fbdev_mach64.so -> media-libs/libggi
* /usr/lib64/ggi/default/fbdev/fbdev_mga_g400.so -> media-libs/libggi
* /usr/lib64/ggi/default/ilbm.so -> media-libs/libggi
* /usr/lib64/ggi/default/iplanar_2p.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_16.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_1_r.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_1.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_24.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_2.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_32.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_4_r.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_4.so -> media-libs/libggi
* /usr/lib64/ggi/default/linear_8.so -> media-libs/libggi
* /usr/lib64/ggi/default/planar.so -> media-libs/libggi
* /usr/lib64/ggi/default/pseudo_stubs.so -> media-libs/libggi
* /usr/lib64/ggi/default/stubs.so -> media-libs/libggi
* /usr/lib64/ggi/default/text_16.so -> media-libs/libggi
* /usr/lib64/ggi/default/text_32.so -> media-libs/libggi
* /usr/lib64/ggi/display/aa.so -> media-libs/libggi
* /usr/lib64/ggi/display/auto.so -> media-libs/libggi
* /usr/lib64/ggi/display/fbdev.so -> media-libs/libggi
* /usr/lib64/ggi/display/file.so -> media-libs/libggi
* /usr/lib64/ggi/display/ipc.so -> media-libs/libggi
* /usr/lib64/ggi/display/linvtsw.so -> media-libs/libggi
* /usr/lib64/ggi/display/mansync.so -> media-libs/libggi
* /usr/lib64/ggi/display/memory.so -> media-libs/libggi
* /usr/lib64/ggi/display/monotext.so -> media-libs/libggi
* /usr/lib64/ggi/display/multi.so -> media-libs/libggi
* /usr/lib64/ggi/display/palemu.so -> media-libs/libggi
* /usr/lib64/ggi/display/sub.so -> media-libs/libggi
* /usr/lib64/ggi/display/tele.so -> media-libs/libggi
* /usr/lib64/ggi/display/terminfo.so -> media-libs/libggi
* /usr/lib64/ggi/display/tile.so -> media-libs/libggi
* /usr/lib64/ggi/display/trueemu.so -> media-libs/libggi
* /usr/lib64/ggi/display/vcsa.so -> media-libs/libggi
* /usr/lib64/ggi/display/X.so -> media-libs/libggi
* /usr/lib64/ggi/helper/helper_x_dbe.so -> media-libs/libggi
* /usr/lib64/ggi/helper/helper_x_dga.so -> media-libs/libggi
* /usr/lib64/ggi/helper/helper_x_evi.so -> media-libs/libggi
* /usr/lib64/ggi/helper/helper_x_shm.so -> media-libs/libggi
* /usr/lib64/ggi/helper/helper_x_vidmode.so -> media-libs/libggi
* /usr/lib64/libaa.so.1.0.4 -> media-libs/aalib
* /usr/lib64/libform.so.5.9 -> sys-libs/ncurses
* /usr/lib64/libgettextlib-0.18.1.so -> sys-devel/gettext
* /usr/lib64/libgettextsrc-0.18.1.so -> sys-devel/gettext
* /usr/lib64/libggi.so.2.0.2 -> media-libs/libggi
* /usr/lib64/libmenu.so.5.9 -> sys-libs/ncurses
* /usr/lib64/libpanel.so.5.9 -> sys-libs/ncurses
* /usr/lib64/libvte.so.9.2800.2 -> x11-libs/vte
* /usr/sbin/cgdisk -> sys-apps/gptfdisk
* /usr/sbin/parted -> sys-block/parted
* Generated new 4_raw.rr and 4_owners.rr
* Cleaning list of packages to rebuild
* Generated new 4_pkgs.rr
* Assigning packages to ebuilds
* Generated new 4_ebuilds.rr
* Evaluating package order
* Generated new 5_order.rr
* All prepared. Starting rebuild
emerge --complete-graph=y --oneshot --autounmask-write y app-admin/conky:0 app-emulation/emul-linux-x86-baselibs:0 app-shells/bash:0 dev-util/cmake:0 games-board/gnugo:0 media-libs/aalib:0 media-libs/libggi:0 media-sound/lame:0 sys-apps/gptfdisk:0 sys-apps/openrc:0 sys-apps/texinfo:0 sys-block/parted:0 sys-boot/grub:0 sys-devel/gettext:0 sys-libs/gpm:0 sys-libs/ncurses:5 sys-libs/readline:0 sys-process/procps:0 sys-process/psmisc:0 x11-libs/vte:0 x11-terms/xterm:0
..........
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 21) app-emulation/emul-linux-x86-baselibs-20120520
* Fetching files in the background. To view fetch progress, run
* `tail -f /var/log/emerge-fetch.log` in another terminal.
* emul-linux-x86-baselibs-20120520.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking emul-linux-x86-baselibs-20120520.tar.xz to /var/tmp/portage/app-emulation/emul-linux-x86-baselibs-20120520/work
>>> Source unpacked in /var/tmp/portage/app-emulation/emul-linux-x86-baselibs-20120520/work
>>> Preparing source in /var/tmp/portage/app-emulation/emul-linux-x86-baselibs-20120520/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/emul-linux-x86-baselibs-20120520/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-emulation/emul-linux-x86-baselibs-20120520/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-emulation/emul-linux-x86-baselibs-20120520

>>> Install emul-linux-x86-baselibs-20120520 into /var/tmp/portage/app-emulation/emul-linux-x86-baselibs-20120520/image/ category app-emulation
>>> Completed installing emul-linux-x86-baselibs-20120520 into /var/tmp/portage/app-emulation/emul-linux-x86-baselibs-20120520/image/

* QA Notice: Missing soname symlink(s):
*
* usr/lib32/libgnuintl.so.8 -> preloadable_libintl.so
*

>>> Installing (1 of 21) app-emulation/emul-linux-x86-baselibs-20120520

>>> Emerging (2 of 21) sys-libs/ncurses-5.9-r2
* ncurses-5.9.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking ncurses-5.9.tar.gz to /var/tmp/portage/sys-libs/ncurses-5.9-r2/work
* Applying ncurses-5.8-gfbsd.patch ...

* A dry-run of patch command succeeded, but actually
* applying the patch failed!

* Failed Patch: ncurses-5.8-gfbsd.patch !
* ( /usr/portage/sys-libs/ncurses/files/ncurses-5.8-gfbsd.patch )
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/sys-libs/ncurses-5.9-r2/temp/ncurses-5.8-gfbsd.patch.out

* ERROR: sys-libs/ncurses-5.9-r2 failed (unpack phase):
* Failed Patch: ncurses-5.8-gfbsd.patch!
*
* Call stack:
* ebuild.sh, line 85: Called src_unpack
* environment, line 2379: Called epatch '/usr/portage/sys-libs/ncurses/files/ncurses-5.8-gfbsd.patch'
* environment, line 1076: Called die
* The specific snippet of code:
* die "Failed Patch: ${patchname}!";
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-5.9-r2'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-5.9-r2'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-5.9-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-5.9-r2/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-5.9-r2/work/ncurses-5.9'
* S: '/var/tmp/portage/sys-libs/ncurses-5.9-r2/work/ncurses-5.9'

>>> Failed to emerge sys-libs/ncurses-5.9-r2, Log file:

>>> '/var/tmp/portage/sys-libs/ncurses-5.9-r2/temp/build.log'

* Messages for package sys-libs/ncurses-5.9-r2:

* A dry-run of patch command succeeded, but actually
* applying the patch failed!
* Failed Patch: ncurses-5.8-gfbsd.patch !
* ( /usr/portage/sys-libs/ncurses/files/ncurses-5.8-gfbsd.patch )
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/sys-libs/ncurses-5.9-r2/temp/ncurses-5.8-gfbsd.patch.out
* ERROR: sys-libs/ncurses-5.9-r2 failed (unpack phase):
* Failed Patch: ncurses-5.8-gfbsd.patch!
*
* Call stack:
* ebuild.sh, line 85: Called src_unpack
* environment, line 2379: Called epatch '/usr/portage/sys-libs/ncurses/files/ncurses-5.8-gfbsd.patch'
* environment, line 1076: Called die
* The specific snippet of code:
* die "Failed Patch: ${patchname}!";
*
* If you need support, post the output of `emerge --info '=sys-libs/ncurses-5.9-r2'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-5.9-r2'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-5.9-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-5.9-r2/temp/environment'.
* Working directory: '/var/tmp/portage/sys-libs/ncurses-5.9-r2/work/ncurses-5.9'
* S: '/var/tmp/portage/sys-libs/ncurses-5.9-r2/work/ncurses-5.9'

* GNU info directory index is up-to-date.
* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
* (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
* remove temporary files, and try again.
* (you can edit package/ebuild list first)
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr


'll run revdep-rebuild with the livecd.
Back to top
View user's profile Send private message
dgiorgio
n00b
n00b


Joined: 24 Jun 2012
Posts: 58

PostPosted: Mon Sep 17, 2012 1:18 am    Post subject: Reply with quote

I downgrade the kernel to version 3.5.2

and the problem continues.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Mon Sep 17, 2012 2:30 am    Post subject: Reply with quote

dgiorgio,

For lack of any brilliant ideas, give this a try:
Code:
mount -t tmpfs none /var/tmp/portage

then
Code:
ebuild $(equery w sys-apps/portage) configure

and let us know if it succeeded or not :roll:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
dgiorgio
n00b
n00b


Joined: 24 Jun 2012
Posts: 58

PostPosted: Mon Sep 17, 2012 2:45 am    Post subject: Reply with quote

could not stand the error and uninstalled gentoo.

needed to install some programs and was failing because of the error.

'm installing archlinux, if I have problem with archlinux (again), then I go back to gentoo.

thank you
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Mon Sep 17, 2012 2:47 am    Post subject: Reply with quote

dgiorgio,

OK, good luck with arch - it's a good distro :)
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
angry_vincent
n00b
n00b


Joined: 21 Feb 2010
Posts: 30

PostPosted: Mon Sep 17, 2012 3:47 am    Post subject: Reply with quote

this a =sys-devel/patch-2.7 problem, this on should be masked until resolved. anyone willing to file a bug? :)
_________________
http://www.funtoo.org
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Mon Sep 17, 2012 4:01 am    Post subject: Reply with quote

angry_vincent wrote:
this a =sys-devel/patch-2.7 problem, this on should be masked until resolved. anyone willing to file a bug? :)

It works here :?
Code:
root@gentoo-gateway portage # ebuild $(equery w sys-apps/portage) configure
 * portage-2.2.0_alpha124.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                           [ ok ]
 * portage-2.2.0_alpha128.patch.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                         [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                            [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                           [ ok ]
>>> Unpacking source...
>>> Unpacking portage-2.2.0_alpha124.tar.bz2 to /var/tmp/portage/sys-apps/portage-2.2.0_alpha128/work
>>> Unpacking portage-2.2.0_alpha128.patch.bz2 to /var/tmp/portage/sys-apps/portage-2.2.0_alpha128/work
>>> Source unpacked in /var/tmp/portage/sys-apps/portage-2.2.0_alpha128/work
>>> Preparing source in /var/tmp/portage/sys-apps/portage-2.2.0_alpha128/work/portage-2.2.0_alpha124 ...
 * Applying portage-2.2.0_alpha128.patch ...                                                                                                                     [ ok ]
 * Setting portage.VERSION to 2.2.0_alpha128 ...
patching file make.conf
Hunk #1 succeeded at 22 (offset -1 lines).
Hunk #2 succeeded at 44 with fuzz 2 (offset 6 lines).
Hunk #3 succeeded at 106 (offset 15 lines).
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-apps/portage-2.2.0_alpha128/work/portage-2.2.0_alpha124 ...
>>> Source configured.

Code:
root@gentoo-gateway portage # equery l sys-devel/patch
 * Searching for patch in sys-devel ...
[IP-] [  ] sys-devel/patch-2.7:0

_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
angry_vincent
n00b
n00b


Joined: 21 Feb 2010
Posts: 30

PostPosted: Mon Sep 17, 2012 5:18 am    Post subject: Reply with quote

"works for me" is not a solution, it keeps failing for others. downgrade to patch-2.6.1 resolving all above listed problems.
_________________
http://www.funtoo.org
Back to top
View user's profile Send private message
madman
Apprentice
Apprentice


Joined: 11 Mar 2004
Posts: 161
Location: Lodz, Poland

PostPosted: Mon Sep 17, 2012 12:15 pm    Post subject: Reply with quote

Downgrade patch to 2.6.1 worked for me too.
_________________
Kto jest twoim autorytetem moralnym i dlaczego jest nim JPII ?
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Mon Sep 17, 2012 3:27 pm    Post subject: Reply with quote

I've been trying to reproduce this with no luck. Have you guys ever had ACL's or extended attributes enabled when you mounted your ext4 filesystems? Can one of you with the broken patch-2.7 show the output of "tune2fs -l /dev/<yourrootdevice>"?
Back to top
View user's profile Send private message
TequilaTR
n00b
n00b


Joined: 01 Feb 2005
Posts: 58

PostPosted: Mon Sep 17, 2012 6:17 pm    Post subject: Reply with quote

Hi,

i also encounter the problem, and can definitely state, that it cannot be related to ext4, as i am using reiserfs (rw,noatime)

Downgrading to patch-2.6.1 seems to do the trick for me now...
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Mon Sep 17, 2012 7:21 pm    Post subject: Reply with quote

I wonder if this is related to the nanosecond timestamp support added to patch-2.7
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Tue Sep 18, 2012 4:12 am    Post subject: Reply with quote

So, it's not timestamp related. I reproduced this error in a VM and an strace on patch returns this:

Code:
rt_sigprocmask(SIG_BLOCK, [HUP INT PIPE TERM XCPU XFSZ], [], 8) = 0
geteuid32()                             = 0
getegid32()                             = 0
llistxattr("bar", NULL, 0)              = 17
llistxattr("bar", "security.selinux\0", 17) = 17
open("/etc/xattr.conf", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
lgetxattr("bar", "security.selinux"process_vm_readv: Bad address
, 0x0, 0) = 10
lgetxattr("bar", "security.selinux", "unlabeled", 10) = 10
lsetxattr("./bar.o84LKu5", "security.selinux", "unlabeled", 10, 0) = -1 EOPNOTSUPP (Operation not supported)
write(2, "patch: setting attributes for ./"..., 69patch: setting attributes for ./bar.o84LKu5: Operation not supported
) = 69
unlink("./bar.o84LKu5")                 = 0
exit_group(2)                           = ?
+++ exited with 2 +++
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Tue Sep 18, 2012 4:38 am    Post subject: Reply with quote

Looks like setting CONFIG_SECURITY_SELINUX=n in your kernel will fix this
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 18, 2012 4:48 am    Post subject: Reply with quote

iamben,

Are you using ext4 :?:

I didn't experience that error on ext3, but from the output of the trace you would think that all filesystems would exhibit the error :?
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Tue Sep 18, 2012 4:51 am    Post subject: Reply with quote

I have reproduced it on ext2 and ext4 so far
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 18, 2012 4:56 am    Post subject: Reply with quote

iamben.

Could you try this
Code:
mount -t tmpfs none /var/tmp/portage

and see if it still errors :?:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Tue Sep 18, 2012 5:23 am    Post subject: Reply with quote

Patching does succeed on tmpfs. BTW I'm now just testing patch outside portage, even a simple "patch -p0 < test.patch" from a terminal shows the failure.

I have traced the problem to this commit:
http://git.savannah.gnu.org/cgit/patch.git/commit/?id=76d0e43140e83602ecca0073f2ee5515c3a9613b

(edited because I linked the wrong commit first time)
Back to top
View user's profile Send private message
iamben
Apprentice
Apprentice


Joined: 10 May 2004
Posts: 258

PostPosted: Tue Sep 18, 2012 6:07 am    Post subject: Reply with quote

Reported here: https://bugs.gentoo.org/show_bug.cgi?id=435384
Back to top
View user's profile Send private message
TequilaTR
n00b
n00b


Joined: 01 Feb 2005
Posts: 58

PostPosted: Tue Sep 18, 2012 6:11 am    Post subject: Reply with quote

Thanks for the report.

I can now confirm, that disabling CONFIG_SECURITY_SELINUX does the trick for me as well and i can use patch-2.7.0 then. Seems like if you enabled the flag (i do not know why i had that in the first place) but do not use it on the filesystem/system patch seems to dislike it.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Sep 18, 2012 12:31 pm    Post subject: Reply with quote

iamben wrote:
Patching does succeed on tmpfs. BTW I'm now just testing patch outside portage, even a simple "patch -p0 < test.patch" from a terminal shows the failure.

I have traced the problem to this commit:
http://git.savannah.gnu.org/cgit/patch.git/commit/?id=76d0e43140e83602ecca0073f2ee5515c3a9613b

(edited because I linked the wrong commit first time)

iamben,

Thanks for taking the time to check the tmpfs mount. Too bad the OP didn't stick it out a few minutes longer.

Just to clarify. I usually mount /var/tmp/portage to tmpfs when emerging but I unmounted it to check for the error. As I stated in a prior post, the patch continued to work fine here.

Excellent job running-down the error :D

EDIT: I should have mentioned that CONFIG_SECURITY_SELINUX=y here and patch continued to work fine here.
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum