Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Johnny Who
n00b
n00b


Joined: 06 Aug 2012
Posts: 9
Location: Athens, Greece

PostPosted: Mon Sep 10, 2012 10:22 am    Post subject: Reply with quote

Perfect, I now only have to unmask the following packages:
Quote:
- gnome-extra/gnome-user-docs-3.4.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:

- gnome-base/gnome-desktop-3.4.2::gentoo (masked by: package.mask)
- media-libs/clutter-gst-1.5.6::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
# New clutter API breaks almost everything

- www-plugins/adobe-flash-11.2.202.238::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

- dev-libs/libgdata-0.12.0::gentoo (masked by: package.mask)
- app-crypt/seahorse-3.4.1::gentoo (masked by: package.mask)
- net-im/skype-4.0.0.8::gentoo (masked by: skype-4.0.0.7-copyright license(s))
A copy of the 'skype-4.0.0.7-copyright' license is located at '/usr/portage/licenses/skype-4.0.0.7-copyright'.

- net-im/empathy-3.4.2.1::gentoo (masked by: package.mask)
- gnome-extra/mousetweaks-3.4.2::gentoo (masked by: package.mask)
- app-cdr/nero-4.0.0.0b::gentoo (masked by: Nero-EULA-US license(s))
A copy of the 'Nero-EULA-US' license is located at '/usr/portage/licenses/Nero-EULA-US'.

- sci-geosciences/googleearth-6.2.1.6014-r1::gentoo (masked by: googleearth license(s))
A copy of the 'googleearth' license is located at '/usr/portage/licenses/googleearth'.

- app-accessibility/at-spi2-core-2.4.2::gentoo (masked by: package.mask)
- dev-libs/folks-0.6.9::gentoo (masked by: package.mask)
- gnome-extra/gnome-color-manager-3.4.2::gentoo (masked by: package.mask)
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- net-libs/telepathy-farstream-0.2.3::gentoo (masked by: package.mask)
- gnome-extra/gnome-contacts-3.4.1::gentoo (masked by: package.mask)
- gnome-extra/evolution-data-server-3.4.3::gentoo (masked by: package.mask)
- media-video/cheese-3.4.2::gentoo (masked by: package.mask)
- gnome-extra/sushi-0.4.1::gentoo (masked by: package.mask)
- x11-wm/mutter-3.4.1-r1::gentoo (masked by: package.mask)
- app-emulation/virtualbox-bin-4.1.18::gentoo (masked by: PUEL license(s))
A copy of the 'PUEL' license is located at '/usr/portage/licenses/PUEL'.

- media-video/totem-3.4.3::gentoo (masked by: package.mask)
- gnome-base/libgnomekbd-3.4.0.2::gentoo (masked by: package.mask)
- gnome-base/gnome-panel-3.4.1::gentoo (masked by: package.mask)
- app-crypt/gcr-3.4.1::gentoo (masked by: package.mask)
- app-accessibility/orca-3.4.2::gentoo (masked by: package.mask)

I will just temporarily rename package.mask, so that it cannot mask the packages.... :P
Back to top
View user's profile Send private message
Johnny Who
n00b
n00b


Joined: 06 Aug 2012
Posts: 9
Location: Athens, Greece

PostPosted: Mon Sep 10, 2012 10:38 am    Post subject: Reply with quote

Now I get
Quote:


--- Invalid atom in /etc/portage/package.keywords: The
--- Invalid atom in /etc/portage/package.unmask: gnome-extra/gnome-user-docs-3.4.1
--- Invalid atom in /etc/portage/package.unmask: gnome-base/gnome-desktop-3.4.2
--- Invalid atom in /etc/portage/package.unmask: media-libs/clutter-gst-1.5.6
--- Invalid atom in /etc/portage/package.unmask: www-plugins/adobe-flash-11.2.202.238
--- Invalid atom in /etc/portage/package.unmask: dev-libs/libgdata-0.12.
--- Invalid atom in /etc/portage/package.unmask: app-crypt/seahorse-3.4.1
--- Invalid atom in /etc/portage/package.unmask: net-im/skype-4.0.0.8
--- Invalid atom in /etc/portage/package.unmask: net-im/empathy-3.4.2.1
--- Invalid atom in /etc/portage/package.unmask: gnome-extra/mousetweaks-3.4.2)
--- Invalid atom in /etc/portage/package.unmask: app-cdr/nero-4.0.0.0b
--- Invalid atom in /etc/portage/package.unmask: sci-geosciences/googleearth-6.2.1.6014-r1
--- Invalid atom in /etc/portage/package.unmask: app-accessibility/at-spi2-core-2.4.2
--- Invalid atom in /etc/portage/package.unmask: dev-libs/folks-0.6.9
--- Invalid atom in /etc/portage/package.unmask: gnome-extra/gnome-color-manager-3.4.2
--- Invalid atom in /etc/portage/package.unmask: net-wireless/broadcom-sta-5.100.82.112-r2
--- Invalid atom in /etc/portage/package.unmask: net-libs/telepathy-farstream-0.2.
--- Invalid atom in /etc/portage/package.unmask: gnome-extra/gnome-contacts-3.4.1
--- Invalid atom in /etc/portage/package.unmask: gnome-extra/evolution-data-server-3.4.3
--- Invalid atom in /etc/portage/package.unmask: media-video/cheese-3.4.2
--- Invalid atom in /etc/portage/package.unmask: gnome-extra/sushi-0.4.1
--- Invalid atom in /etc/portage/package.unmask: x11-wm/mutter-3.4.1-r1
--- Invalid atom in /etc/portage/package.unmask: app-emulation/virtualbox-bin-4.1.18
--- Invalid atom in /etc/portage/package.unmask: media-video/totem-3.4.3
--- Invalid atom in /etc/portage/package.unmask: gnome-base/libgnomekbd-3.4.0.2
--- Invalid atom in /etc/portage/package.unmask: gnome-base/gnome-panel-3.4.1
--- Invalid atom in /etc/portage/package.unmask: app-crypt/gcr-3.4.1
--- Invalid atom in /etc/portage/package.unmask: app-accessibility/orca-3.4.2

* IMPORTANT: 6 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild N ~] dev-util/boost-build-1.49.0 USE="-examples -python"
[ebuild N ] gnome-base/gnome-common-3.1.0
[ebuild N ] dev-libs/xapian-1.2.8 USE="brass chert flint inmemory remote sse sse2 -doc -static-libs"
[ebuild N ] app-text/sgml-common-0.6.3-r5
[ebuild N ] app-text/docbook-dsssl-stylesheets-1.79
[ebuild N ] dev-util/gtk-doc-am-1.18
[ebuild U ~] x11-proto/fixesproto-5.0-r9999 [5.0]
[ebuild N ] x11-proto/trapproto-3.4.3
[ebuild N ] x11-proto/bigreqsproto-1.1.2 USE="-doc"
[ebuild N ] x11-proto/xf86driproto-2.1.1
[ebuild N ] x11-proto/xf86rushproto-1.1.2-r1
[ebuild N ] x11-proto/xcmiscproto-1.2.2 USE="-doc"
[ebuild N ] x11-apps/xvinfo-1.1.1
[ebuild N ] x11-misc/lndir-1.0.3
[ebuild U ~] x11-libs/libXfixes-5.0-r9999 [5.0]
[ebuild UD ] dev-libs/libxml2-2.8.0_rc1 [2.8.0-r1] USE="-icu*"
[ebuild N ] dev-python/oauth-1.0.1
[ebuild N ] dev-libs/xapian-bindings-1.2.8 USE="python -java -lua -mono -perl -php -ruby -tcl" PHP_TARGETS="php5-3"
[ebuild N ~] unity-base/utouch-evemu-1.0.9
[ebuild N ~] dev-python/configglue-1.0
[ebuild N ~] dev-python/dirspec-3.99.90
[ebuild N ] dev-python/pyrex-0.9.9 USE="-examples"
[ebuild N ~] dev-python/lazr-restfulclient-0.12.0
[ebuild N ] app-text/scrollkeeper-dtd-1.0
[ebuild NS ] dev-lang/vala-0.16.1-r1 [0.14.0] USE="vapigen -test"
[ebuild N ] app-text/opensp-1.5.2-r3 USE="nls -doc -static-libs -test"
[ebuild N ] app-text/rarian-0.8.1-r1 USE="-static-libs"
[ebuild NS ] dev-lang/vala-0.12.1 [0.14.0] USE="vapigen -test"
[ebuild U ~] dev-libs/glib-99.2.32.3 [2.32.1]
[ebuild N ] app-text/scrollkeeper-9999-r1
[ebuild N ] app-text/openjade-1.3.2-r3 USE="-static-libs"
[ebuild N ] x11-misc/icon-naming-utils-0.8.90
[ebuild U ~] x11-themes/gnome-icon-theme-3.4.0 [3.2.1.2] USE="branding*"
[ebuild N ~] x11-themes/ubuntu-mono-0.0.40
[ebuild N ~] x11-themes/unity-asset-pool-0.8.23 USE="-debug"
[ebuild U ~] dev-libs/atk-2.4.0 [2.2.0]
[ebuild N ~] dev-libs/libwacom-0.5 USE="-doc -static-libs"
[ebuild U ~] app-accessibility/at-spi2-atk-2.5.3 [2.4.0]
[ebuild N ] dev-python/imaging-1.1.7-r1 USE="X lcms -doc -examples -scanner -tk"
[ebuild U ~] x11-libs/gtk+-99.2.24.11-r1 [2.24.10-r1] USE="-xinerama*"
[ebuild N ] x11-themes/gtk-engines-murrine-0.98.2 USE="-animation-rtl -themes"
[ebuild U ~] gnome-base/gconf-99.3.2.5 [3.2.5]
[ebuild U ] gnome-extra/polkit-gnome-99.0.105 [0.105]
[ebuild N ] x11-themes/light-themes-0.1.8.29 USE="-gtk3"
[ebuild U ~] gnome-base/gsettings-desktop-schemas-99.3.5.91 [3.4.2]
[ebuild UD ] gnome-base/gnome-keyring-2.32.1-r1 [3.4.1]
[ebuild UD ] gnome-base/libgnome-keyring-2.32.0 [3.4.1]
[ebuild UD ] media-libs/cogl-1.8.2 [1.10.2]
[ebuild UD ] media-libs/clutter-1.8.4 [1.10.4]
[ebuild UD ] media-libs/clutter-gtk-1.0.4 [1.2.0]
[ebuild U ] app-admin/eselect-boost-0.4 [0.3]
[ebuild U ~] x11-base/xorg-server-1.12.3-r9999 [1.12.3]
[ebuild U ~] x11-libs/gtk+-99.3.4.2 [3.4.3-r1] USE="-xinerama*"
[ebuild U ~] gnome-base/gnome-settings-daemon-99.3.4.2-r1 [3.4.2]
[ebuild N ~] dev-libs/libdbusmenu-0.6.2 USE="gtk introspection -test"
[ebuild N ~] dev-libs/libunity-misc-4.0.4
[ebuild N ~] dev-libs/libindicator-99.12.10.0
[ebuild U ~] gnome-base/gnome-session-99.3.2.1 [3.4.2.1]
[ebuild NS ] dev-lang/python-3.2.3 [2.7.3-r2] USE="gdbm ipv6 ncurses readline sqlite ssl threads (wide-unicode) xml -build -doc -examples -tk -wininst"
[ebuild NS ~] dev-libs/boost-1.49.0-r1 [1.46.1-r1] USE="eselect python -debug -doc -icu -mpi -static-libs -test -tools"
[ebuild N ~] dev-util/gdbus-codegen-2.32.4 PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1"
[ebuild N ] dev-python/sip-4.13.3 USE="-debug -doc"
[ebuild N ] dev-python/cython-0.16 USE="-doc -examples -numpy"
[ebuild N ] dev-libs/protobuf-2.4.0a USE="python -emacs -examples -java -source -static-libs -vim-syntax"
[ebuild N ~] dev-python/python-geoclue-0.1.0 USE="-test"
[ebuild N ] dev-python/bsddb3-5.3.0 USE="-doc"
[ebuild N ~] dev-python/isodate-0.4.8
[ebuild N ~] dev-python/python-distutils-extra-2.35
[ebuild N ] net-zope/zope-fixers-1.0
[ebuild N ] app-text/docbook-sgml-dtd-3.0-r3
[ebuild NS ] app-text/docbook-xml-dtd-4.3-r1 [4.2-r2]
[ebuild NS ] app-text/docbook-xml-dtd-4.4-r2 [4.2-r2]
[ebuild N ~] dev-python/rdflib-3.2.1 USE="berkdb -examples -mysql -redland -sqlite -test"
[ebuild NS ] app-text/docbook-xml-dtd-4.1.2-r6 [4.2-r2]
[ebuild N #] net-zope/zope-interface-3.8.0
[ebuild N ] app-text/gnome-doc-utils-0.20.10
[ebuild U ~] gnome-base/gnome-menus-99.3.4.0 [3.4.2]
[ebuild N ] dev-python/twisted-11.0.0 USE="crypt gtk -serial"
[ebuild N ~] gnome-extra/zeitgeist-extensions-0.0.13-r1 USE="fts geolocation -memprofile -sqldebug -tracker"
[ebuild N ~] unity-base/utouch-frame-2.2.3
[ebuild N ] dev-python/gnome-python-desktop-base-2.32.0
[ebuild N ] dev-util/gtk-doc-1.18-r1 USE="-debug -doc -emacs -highlight -test -vim"
[ebuild N ~] dev-libs/libindicate-12.10.0 USE="gtk introspection"
[ebuild N ] dev-python/twisted-web-11.0.0 USE="-soap"
[ebuild N ] dev-python/gnome-keyring-python-2.32.0 USE="-examples"
[ebuild N ] dev-python/twisted-names-11.0.0
[ebuild N ] app-i18n/ibus-1.4.1 USE="X gconf gtk introspection nls python -dconf -doc -gtk3 -vala"
[ebuild N ~] unity-base/utouch-grail-3.0.5
[ebuild N ~] net-wireless/blueman-1.23-r2 USE="nls policykit -gconf -network -pulseaudio -sendto"
[ebuild N ~] unity-base/ubuntuone-storage-protocol-3.99.90
[ebuild U ~] net-wireless/gnome-bluetooth-99.3.4.2 [3.4.0]
[ebuild N ~] dev-libs/dee-1.0.12 USE="icu -debug -doc -examples -static-libs -test"
[ebuild N ~] dev-libs/libzeitgeist-0.3.18 USE="-static-libs"
[ebuild N ~] unity-base/unity-webapps-2.1
[ebuild N ~] unity-base/utouch-geis-2.2.9
[ebuild N ~] dev-libs/libunity-5.96.0
[ebuild N ~] unity-base/nux-2.14.0
[ebuild N ~] unity-base/bamf-0.3.0 USE="introspection"
[ebuild N ~] x11-libs/qt-webkit-99.4.8.2 USE="exceptions gstreamer jit (-aqua) -debug -icu -pch -qpa"
[ebuild N ~] x11-libs/qt-assistant-99.4.8.2 USE="compat exceptions glib qt3support (-aqua) -c++0x -debug -doc -pch -qpa -trace -webkit"
[ebuild N ~] x11-libs/qt-declarative-99.4.8.2 USE="accessibility exceptions qt3support webkit (-aqua) -c++0x -debug -pch -qpa"
[ebuild N ~] unity-base/compiz-0.9.7.8-r1 USE="-debug"
[ebuild N ~] dev-libs/libindicate-qt-0.2.5.91 USE="-test"
[ebuild N ~] dev-libs/libdbusmenu-qt-0.9.2 USE="-debug -doc -test"
[ebuild N ~] x11-libs/libcompizconfig-0.9.5.94 USE="-debug"
[ebuild N ~] dev-libs/libqtbamf-0.2.4 USE="-debug"
[ebuild N ~] dev-libs/libqtdee-0.2.4 USE="-debug"
[ebuild N ~] unity-base/dconf-qt-0.0.0.110722 USE="-debug"
[ebuild N ~] x11-plugins/compiz-plugins-main-0.9.7.0 USE="-debug"
[ebuild N ~] x11-misc/appmenu-qt-0.2.6
[ebuild N ~] dev-libs/libqtgconf-0.1 USE="-debug"
[ebuild N ] dev-python/PyQt4-4.9.4 USE="X assistant dbus declarative examples opengl sql svg webkit -debug -doc -kde -multimedia -phonon -xmlpatterns"
[ebuild N ~] unity-base/compizconfig-python-0.9.5.94
[ebuild N ~] unity-base/ubuntu-sso-client-3.99.90
[ebuild N ~] unity-base/compizconfig-backend-gconf-0.9.5.92
[ebuild N ~] unity-base/ccsm-0.9.5.92
[ebuild N ~] unity-base/ubuntuone-control-panel-3.99.90
[ebuild U ~] gnome-base/gnome-control-center-99.3.4.2 [3.4.2-r1]
[ebuild N ~] gnome-extra/zeitgeist-datasources-0.8.0.1 USE="telepathy -bzr -chromium -emacs -eog -geany -gedit -rhythmbox -static-libs -tomboy -totem -vim -xchat"
[ebuild N ~] gnome-extra/zeitgeist-datahub-0.8.2 USE="-download"
[ebuild N ~] gnome-extra/zeitgeist-0.9.5 USE="dbus extensions fts nls passiv plugins -icu -sql-debug"
[ebuild N ~] dev-libs/libappindicator-99.12.10.0 USE="-vala"
[ebuild N ~] unity-base/indicator-appmenu-12.10.0 USE="-debug"
[ebuild N ~] x11-misc/appmenu-gtk-12.10.0
[ebuild N ~] unity-base/unity-5.14.0 USE="-debug"
[blocks B ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.4.1)
[blocks B ] gnome-extra/zeitgeist[fts] ("gnome-extra/zeitgeist[fts]" is blocking gnome-extra/zeitgeist-extensions-0.0.13-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/gtk+:3

(x11-libs/gtk+-99.3.4.2::unity-gentoo, ebuild scheduled for merge) pulled in by
>=x11-libs/gtk+-99.3.4.2:3 required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)
(and 13 more with the same problem)

(x11-libs/gtk+-3.4.3-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

dev-libs/glib:2

(dev-libs/glib-99.2.32.3::unity-gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-99.2.32.3 required by (unity-base/dconf-qt-0.0.0.110722::unity-gentoo, ebuild scheduled for merge)
(and 4 more with the same problem)

(dev-libs/glib-2.32.1::sabayon-distro, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

media-libs/clutter:1.0

(media-libs/clutter-1.10.4::gentoo, installed) pulled in by
>=media-libs/clutter-1.10.0:1.0[introspection] required by (gnome-extra/sushi-0.4.1::gentoo, installed)
(and 4 more with the same problem)

(media-libs/clutter-1.8.4::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

media-libs/cogl:1.0

(media-libs/cogl-1.8.2::gentoo, ebuild scheduled for merge) pulled in by
<=media-libs/cogl-1.9.2:1.0 required by (media-libs/clutter-1.8.4::gentoo, ebuild scheduled for merge)

(media-libs/cogl-1.10.2::gentoo, installed) pulled in by
>=media-libs/cogl-1.9.6:1.0[introspection?,pango] required by (media-libs/clutter-1.10.4::gentoo, installed)
(and 1 more with the same problem)

media-libs/clutter-gtk:1.0

(media-libs/clutter-gtk-1.2.0::gentoo, installed) pulled in by
>=media-libs/clutter-gtk-1.1.2:1.0 required by (net-im/empathy-3.4.2.1::gentoo, installed)

(media-libs/clutter-gtk-1.0.4::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

gnome-base/gnome-keyring:0

(gnome-base/gnome-keyring-3.4.1::gentoo, installed) pulled in by
>=gnome-base/gnome-keyring-3.3.90 required by (gnome-base/gnome-shell-3.4.1::sabayon-distro, installed)
(and 4 more with the same problem)

(gnome-base/gnome-keyring-2.32.1-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

gnome-base/libgnome-keyring:0

(gnome-base/libgnome-keyring-3.4.1::gentoo, installed) pulled in by
>=gnome-base/libgnome-keyring-3.2 required by (gnome-base/gnome-core-apps-3.2.1::gentoo, installed)
(and 1 more with the same problem)

(gnome-base/libgnome-keyring-2.32.0::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- gnome-extra/gnome-user-docs-3.4.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:

- gnome-base/gnome-desktop-3.4.2::gentoo (masked by: package.mask)
- media-libs/clutter-gst-1.5.6::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
# New clutter API breaks almost everything

- www-plugins/adobe-flash-11.2.202.238::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

- dev-libs/libgdata-0.12.0::gentoo (masked by: package.mask)
- app-crypt/seahorse-3.4.1::gentoo (masked by: package.mask)
- net-im/skype-4.0.0.8::gentoo (masked by: skype-4.0.0.7-copyright license(s))
A copy of the 'skype-4.0.0.7-copyright' license is located at '/usr/portage/licenses/skype-4.0.0.7-copyright'.

- net-im/empathy-3.4.2.1::gentoo (masked by: package.mask)
- gnome-extra/mousetweaks-3.4.2::gentoo (masked by: package.mask)
- app-cdr/nero-4.0.0.0b::gentoo (masked by: Nero-EULA-US license(s))
A copy of the 'Nero-EULA-US' license is located at '/usr/portage/licenses/Nero-EULA-US'.

- sci-geosciences/googleearth-6.2.1.6014-r1::gentoo (masked by: googleearth license(s))
A copy of the 'googleearth' license is located at '/usr/portage/licenses/googleearth'.

- app-accessibility/at-spi2-core-2.4.2::gentoo (masked by: package.mask)
- dev-libs/folks-0.6.9::gentoo (masked by: package.mask)
- gnome-extra/gnome-color-manager-3.4.2::gentoo (masked by: package.mask)
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- net-libs/telepathy-farstream-0.2.3::gentoo (masked by: package.mask)
- gnome-extra/gnome-contacts-3.4.1::gentoo (masked by: package.mask)
- gnome-extra/evolution-data-server-3.4.3::gentoo (masked by: package.mask)
- media-video/cheese-3.4.2::gentoo (masked by: package.mask)
- gnome-extra/sushi-0.4.1::gentoo (masked by: package.mask)
- x11-wm/mutter-3.4.1-r1::gentoo (masked by: package.mask)
- app-emulation/virtualbox-bin-4.1.18::gentoo (masked by: PUEL license(s))
A copy of the 'PUEL' license is located at '/usr/portage/licenses/PUEL'.

- media-video/totem-3.4.3::gentoo (masked by: package.mask)
- gnome-base/libgnomekbd-3.4.0.2::gentoo (masked by: package.mask)
- gnome-base/gnome-panel-3.4.1::gentoo (masked by: package.mask)
- app-crypt/gcr-3.4.1::gentoo (masked by: package.mask)
- app-accessibility/orca-3.4.2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 4:44 am    Post subject: Reply with quote

Johnny Who wrote:
Now I get

--- Invalid atom in /etc/portage/package.keywords: The
--- Invalid atom in /etc/portage/package.unmask: gnome-extra/gnome-user-docs-3.4.1
--- Invalid atom in /etc/portage/package.unmask: gnome-base/gnome-desktop-3.4.2
--- Invalid atom in /etc/portage/package.unmask: media-libs/clutter-gst-1.5.6
(etc) ...



I guess it is much more simple to have a file inside /etc/portage/portage.keywords/ called gnome3

According to gentoo wiki, these packages should be added in this file:


Code:

app-accessibility/at-spi2-core
app-accessibility/caribou
app-arch/file-roller
app-cdr/brasero
app-crypt/p11-kit
app-crypt/seahorse
app-editors/gedit
app-misc/tracker
app-text/evince
app-text/yelp-tools
dev-cpp/glibmm
dev-cpp/gtkmm
dev-lang/spidermonkey
dev-libs/atk
dev-libs/folks
dev-libs/gjs
dev-libs/glib
dev-libs/gobject-introspection
dev-libs/gobject-introspection-common
dev-libs/libgdata
dev-libs/libgweather
dev-libs/libpeas
dev-python/pyatspi
dev-util/gtk-builder-convert
games-board/aisleriot
gnome-base/gdm
gnome-base/gnome
gnome-base/gnome-light
gnome-base/gnome-applets
gnome-base/gnome-control-center
gnome-base/gnome-core-apps
gnome-base/gnome-core-libs
gnome-base/gnome-desktop
gnome-base/gnome-extra-apps
gnome-base/gnome-fallback
gnome-base/gnome-keyring
gnome-base/gnome-menus
gnome-base/gnome-panel
gnome-base/gnome-session
gnome-base/gnome-settings-daemon
gnome-base/gnome-shell
gnome-base/gsettings-desktop-schemas
gnome-base/libgnomekbd
gnome-base/libgnome-keyring
#gnome-base/nautilus
gnome-base/librsvg
gnome-extra/evolution-data-server
gnome-extra/gcalctool
gnome-extra/gconf-editor
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
gnome-extra/gnome-games
gnome-extra/gnome-power-manager
gnome-extra/gnome-screensaver
gnome-extra/gnome-system-monitor
gnome-extra/gnome-tweak-tool
gnome-extra/gnome-user-docs
gnome-extra/gnome-utils
gnome-extra/gtkhtml
gnome-extra/gucharmap
gnome-extra/nautilus-tracker-tags
gnome-extra/nm-applet
gnome-extra/sushi
gnome-extra/yelp
gnome-extra/yelp-xsl
mail-client/evolution
media-gfx/eog
media-gfx/shotwell
media-libs/clutter
media-libs/cogl
media-libs/gexiv2
media-libs/libchamplain
media-libs/libgnome-media-profiles
media-libs/libraw
media-sound/sound-juicer
media-video/cheese
media-video/totem
net-analyzer/gnome-nettool
net-im/empathy
net-im/telepathy-logger
net-libs/gnome-online-accounts
net-libs/liboauth
net-libs/libsocialweb
net-libs/libsoup-gnome
net-libs/libsoup
net-libs/telepathy-glib
net-libs/webkit-gtk
net-misc/networkmanager
net-misc/vinagre
net-misc/vino
net-print/cups-pk-helper
net-wireless/gnome-bluetooth
sys-apps/accountsservice
www-client/epiphany
x11-libs/gdk-pixbuf
#x11-libs/gtk+
x11-libs/gtksourceview
x11-libs/libwnck
x11-libs/mx
x11-libs/pango
x11-libs/vte
x11-misc/notification-daemon
x11-terms/gnome-terminal
x11-themes/gnome-backgrounds
x11-themes/gnome-icon-theme-symbolic
x11-themes/gnome-themes-standard
#x11-wm/metacity
x11-wm/mutter



I commented metacity, gtk and nautilus because these packages we will get from unity-gentoo repo...

You should not add anything inside package.unmask. Here is my package.unmask, for example:

=gnome-base/gdm-3.4.1::gentoo
dev-java/oracle-jdk-bin

(only these 2 lines)

the other file inside portage.keywords folder should be a synlink to /var/lib/layman/unity-gentoo/PACKAGES, as shiznix told us..

with these two files (unity-gentoo (symlink to unity-gentoo/PACKAGES) and gnome3) we will be able to install a good set of unity and gnome3 packages without any mask problem.

In my case (but this might change according to your use flags) i had to put some extra packages (gnome3 deps) into package.accept_keywords (but only gdm into package.unmask).

So, do it (put unity packages and gnome3 packages inside portage.keywords file) and remove any gnome or unity lines in your package.accept_keywords file (or package.keywords), then told us what you got.


And would be nice if you post here or in pastebin all files inside your /etc/portage folder, so we would help you better.

And about this:

Invalid atom in /etc/portage/package.unmask: gnome-extra/gnome-user-docs-3.4.1

Is because the "=" is mandatory if we specific a package version (3.4.1), so you need to change gnome-extra/gnome-user-docs-3.4.1 to =gnome-extra/gnome-user-docs-3.4.1, but as i told you, you should not put anything inside package.unmask, it is generally no good and unnecessary, we seldom do it.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 5:59 pm    Post subject: Reply with quote

good / bad news:

Now there is a gnome 3.4 meta package in portage tree!!

gnome-base/gnome-3.4.1

Finally gnome 3.4 was marked for testing!!

But gnome 3.4 depends on unstable versions of various packages, such as udev, udisk, etc...

I will try to find an easier way to install gnome3.4, without put all theese lines in /etc/portage.

It is a bit off-topic, but unity depends on gnome3, so this information is relevant.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Thu Sep 13, 2012 5:58 am    Post subject: Reply with quote

I'm following tetromino's instructions to upgrade to a 100% gnome 3.4 ... Results soon.
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 647

PostPosted: Fri Sep 14, 2012 11:05 am    Post subject: Reply with quote

I don't know what I did but suddenly my Unity is broken:
  • it's forcing my monitor's refresh rate to 76 Hz instead of 60
  • there are no applications showing in the Dash launcher
  • unmaximized windows have their buttons misplaced: screenshot
Anyone know what's going on?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Fri Sep 14, 2012 12:51 pm    Post subject: Reply with quote

@ahgblopes
I reckon the gnome 3.4 installation should be relatively painless.
I've taken care not to break that with the Ubuntu patchset and I've been using the previously hard masked version of gnome-3.4 in conjunction with Unity without issue so far.
Look forward to reading what your experience is.

@Aquous
Are you able to link the breakage with some modification or action you have done around the same time as the breakage ?
A system update or depclean for example...

When you mention no applications showing in the launcher, do you mean the applications in the applications lens or applications shown in the sidebar ?
Not sure if it helps, but I can tell you that the applications/icons in the sidebar will break and disappear if >=media-libs/mesa-8.1 is installed.
Finally, if it's your user config that is broken you can reset that with the following commands:
Code:
rm -rf ~/.compiz/
rm -rf ~/.compiz-1/
rm -rf ~/.cache/compizconfig-1/
rm -rf ~/.config/compiz-1/
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Fri Sep 14, 2012 1:33 pm    Post subject: Reply with quote

So there's a few important updates been included over the past few days.

I haven't made any progress on the wrong window placement bug yet :(

Apart from the version bumps and bugfixes, Unity should now (mostly) install and work if your active python version is python-3.
Supporting both python2 and python3 as Unity is moving to python3 as default, we end up with a mix of python2 and python3 lens packages.

Gconf backend for compiz settings is stabilising ready for migration to dconf, which means you can change the side launcher bar icons size (unity 3d only) via 'System settings > Appearance'.
It's not enabled by default yet as setting the launcher to autohide doesn't enable it to be revealed again.
If you want to try it you can enable the gconf backend in 'ccsm' Preferences.

Unity-lens-radios package has been added to search for online radio stations and have them open in rhythmbox.
Appmenu-firefox has been updated to be compatible with firefox-15.0.1.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Sep 15, 2012 10:12 pm    Post subject: Reply with quote

After follow Alexandre' s instructions, i have a really nice, fast and smooth gnome 3.4 desktop!!

And a miracle: I don't know why, but decorated window buttons and OVERLAY SCROLLBAR works in unity2!!!! It is really amazing!!! Thank you again for bring us it!! I will stick with unity2d, because i' m really liking it, but i will now try to upgrade to python 3 and make unity (3d) works with it.
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 10:31 am    Post subject: Reply with quote

Hello, I have tried installing gentoo from scratch using this layman unity overlay and have encountered some of the same problems.

I have a few slot errors which I am struggling to solve:

Quote:

Total: 513 packages (4 upgrades, 1 downgrade, 503 new, 3 in new slots, 2 reinstalls), Size of downloads: 939,689 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libXfixes:0

(x11-libs/libXfixes-5.0::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
=x11-libs/libXfixes-5.0-r9999 required by (unity-base/bamf-0.3.0::unity-gentoo, ebuild scheduled for merge)
>=x11-libs/libXfixes-5.0-r9999 required by (dev-libs/libunity-misc-4.0.4::unity-gentoo, ebuild scheduled for merge)
(and 4 more with the same problems)

x11-proto/fixesproto:0

(x11-proto/fixesproto-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
=x11-proto/fixesproto-5.0-r9999 required by (x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge)

(x11-proto/fixesproto-5.0::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

net-libs/libsoup:2.4

(net-libs/libsoup-2.38.1::gentoo, ebuild scheduled for merge) pulled in by
>=net-libs/libsoup-2.37.91:2.4[introspection?] required by (dev-libs/libgdata-0.12.0::gentoo, ebuild scheduled for merge)

(net-libs/libsoup-2.36.1-r1::gentoo, ebuild scheduled for merge) pulled in by
~net-libs/libsoup-2.36.1 required by (net-libs/libsoup-gnome-2.36.1::gentoo, ebuild scheduled for merge)

media-libs/mesa:0

(media-libs/mesa-8.0.4-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(media-libs/mesa-8.0.3::gentoo, ebuild scheduled for merge) pulled in by
<=media-libs/mesa-8.0.4 required by (unity-base/compiz-0.9.7.8-r1::unity-gentoo, ebuild scheduled for merge)

sys-fs/udev:0

(sys-fs/udev-171-r6::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/udev-171[gudev] required by (media-video/cheese-3.4.2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (net-misc/networkmanager-0.9.4.0-r6::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (x11-misc/colord-0.1.18::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (dev-libs/libgusb-0.1.3::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r6[hwdb] required by (media-sound/pulseaudio-2.1-r1::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (dev-libs/libwacom-0.5::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (media-sound/rhythmbox-2.97::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (gnome-base/gvfs-1.10.1::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r5[gudev,hwdb] required by (sys-fs/udisks-1.0.4-r2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (app-admin/packagekit-base-0.7.4::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r5[gudev] required by (sys-power/upower-0.9.16::gentoo, ebuild scheduled for merge)

(sys-fs/udev-171-r6::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /etc/portage/package.mask:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29


I have also included this mask which will not go away:

Quote:

linux portage # cat package.mask
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29


Any ideas?
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Sep 17, 2012 10:53 am    Post subject: Reply with quote

Jono86 wrote:
Hello, I have tried installing gentoo from scratch using this layman unity overlay and have encountered some of the same problems.

I have a few slot errors which I am struggling to solve:

Quote:

Total: 513 packages (4 upgrades, 1 downgrade, 503 new, 3 in new slots, 2 reinstalls), Size of downloads: 939,689 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libXfixes:0

(x11-libs/libXfixes-5.0::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
=x11-libs/libXfixes-5.0-r9999 required by (unity-base/bamf-0.3.0::unity-gentoo, ebuild scheduled for merge)
>=x11-libs/libXfixes-5.0-r9999 required by (dev-libs/libunity-misc-4.0.4::unity-gentoo, ebuild scheduled for merge)
(and 4 more with the same problems)

x11-proto/fixesproto:0

(x11-proto/fixesproto-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
=x11-proto/fixesproto-5.0-r9999 required by (x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge)

(x11-proto/fixesproto-5.0::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

net-libs/libsoup:2.4

(net-libs/libsoup-2.38.1::gentoo, ebuild scheduled for merge) pulled in by
>=net-libs/libsoup-2.37.91:2.4[introspection?] required by (dev-libs/libgdata-0.12.0::gentoo, ebuild scheduled for merge)

(net-libs/libsoup-2.36.1-r1::gentoo, ebuild scheduled for merge) pulled in by
~net-libs/libsoup-2.36.1 required by (net-libs/libsoup-gnome-2.36.1::gentoo, ebuild scheduled for merge)

media-libs/mesa:0

(media-libs/mesa-8.0.4-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(media-libs/mesa-8.0.3::gentoo, ebuild scheduled for merge) pulled in by
<=media-libs/mesa-8.0.4 required by (unity-base/compiz-0.9.7.8-r1::unity-gentoo, ebuild scheduled for merge)

sys-fs/udev:0

(sys-fs/udev-171-r6::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/udev-171[gudev] required by (media-video/cheese-3.4.2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (net-misc/networkmanager-0.9.4.0-r6::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (x11-misc/colord-0.1.18::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (dev-libs/libgusb-0.1.3::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r6[hwdb] required by (media-sound/pulseaudio-2.1-r1::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (dev-libs/libwacom-0.5::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (media-sound/rhythmbox-2.97::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (gnome-base/gvfs-1.10.1::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r5[gudev,hwdb] required by (sys-fs/udisks-1.0.4-r2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (app-admin/packagekit-base-0.7.4::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r5[gudev] required by (sys-power/upower-0.9.16::gentoo, ebuild scheduled for merge)

(sys-fs/udev-171-r6::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /etc/portage/package.mask:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29


I have also included this mask which will not go away:

Quote:

linux portage # cat package.mask
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29


Any ideas?


Try this first:

in package.mask :

Code:

>media-libs/mesa-8.0.4
dev-libs/glib::gentoo
dev-libs/libappindicator::gentoo
dev-libs/libdbusmenu::gentoo
dev-libs/libindicator::gentoo
dev-libs/libqtbamf::gentoo
dev-libs/libqtdee::gentoo
dev-libs/libqtgconf::gentoo
dev-libs/libtimezonemap::gentoo
dev-libs/libubuntuone::gentoo
dev-libs/libunity::gentoo
dev-libs/libunity-misc::gentoo
dev-libs/libzeitgeist::gentoo
dev-python/configglue::gentoo
dev-python/dirspec::gentoo
dev-python/python-distutils-extra::gentoo
dev-python/lazr-restfulclient::gentoo
dev-python/pywapi::gentoo
dev-python/unity-singlet::gentoo
gnome-base/gconf::gentoo
gnome-base/gnome-control-center::gentoo
gnome-base/gnome-session::gentoo
gnome-base/gnome-settings-daemon::gentoo
gnome-base/nautilus::gentoo
gnome-extra/nm-applet::gentoo
gnome-extra/polkit-gnome::gentoo
gnome-extra/zeitgeist-datahub::gentoo
net-wireless/gnome-bluetooth::gentoo
x11-base/xorg-server::gentoo
x11-libs/gtk+::gentoo
x11-libs/libcompizconfig::gentoo
x11-libs/libXfixes::gentoo
x11-libs/qt-assistant::gentoo
x11-libs/qt-bearer::gentoo
x11-libs/qt-core::gentoo
x11-libs/qt-dbus::gentoo
x11-libs/qt-declarative::gentoo
x11-libs/qt-demo::gentoo
x11-libs/qt-gui::gentoo
x11-libs/qt-mobility::gentoo
x11-libs/qt-multimedia::gentoo
x11-libs/qt-opengl::gentoo
x11-libs/qt-openvg::gentoo
x11-libs/qt-phonon::gentoo
x11-libs/qt-qt3support::gentoo
x11-libs/qt-script::gentoo
x11-libs/qtscriptgenerator::gentoo
x11-libs/qt-sql::gentoo
x11-libs/qt-svg::gentoo
x11-libs/qt-test::gentoo
x11-libs/qt-webkit::gentoo
x11-libs/qt-xmlpatterns::gentoo
x11-misc/appmenu-firefox::gentoo
x11-misc/appmenu-gtk::gentoo
x11-plugins/compiz-plugins-main::gentoo
x11-proto/fixesproto::gentoo
x11-themes/ubuntu-mono::gentoo
x11-themes/unity-asset-pool::gentoo
x11-wm/metacity::gentoo


in package.accept_keywords :

=media-libs/mesa-8.0.3-r1 ~amd64

(or ~x86 if you are a 32bit user)

And make a "package.keywords" folder inside etc/portage and make a symlink to /var/lib/layman/unity-gentoo/PACKAGES inside it. Don't put anything inside package.unmask, this is unnecessary (i only have dev-java/oracle-jdk-bin on mine package.unmask file).

and about =sys-libs/db-5.1.29, i don't have it on any of my files, but i guess i accidentally removed it... Try first put it on package.accept_keywords, and if it doesn't work put it on package.unmask .
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 11:06 am    Post subject: Reply with quote

I had /etc/portage/package.keywords as a file contain various keywords, I have now deleted this and created a folder called package.keywords.

Quote:
And make a "package.keywords" folder inside etc/portage and make a symlink to /var/lib/layman/unity-gentoo/PACKAGES inside it. Don't put anything inside package.unmask, this is unnecessary (i only have dev-java/oracle-jdk-bin on mine package.unmask file).


What do I call the file inside the folder which needs symlinking to /var/lib/layman/unity-gentoo/PACKAGES?
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Sep 17, 2012 11:10 am    Post subject: Reply with quote

Jono86 wrote:
I had /etc/portage/package.keywords as a file contain various keywords, I have now deleted this and created a folder called package.keywords.

Quote:
And make a "package.keywords" folder inside etc/portage and make a symlink to /var/lib/layman/unity-gentoo/PACKAGES inside it. Don't put anything inside package.unmask, this is unnecessary (i only have dev-java/oracle-jdk-bin on mine package.unmask file).


What do I call the file inside the folder which needs symlinking to /var/lib/layman/unity-gentoo/PACKAGES?


Only for convenience "unity-gentoo", but it doesn't matter, you can put anything!
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 11:14 am    Post subject: Reply with quote

ok so now this brings the other keyword changes back:

Quote:
[blocks B ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-99.3.4.2)
[blocks B ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.4.1-r2)
[blocks B ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)

Total: 521 packages (4 upgrades, 1 downgrade, 511 new, 3 in new slots, 2 reinstalls), Size of downloads: 950,380 kB
Conflict: 3 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/gobject-introspection:0

(dev-libs/gobject-introspection-1.30.0-r2::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/gobject-introspection-1.32.1::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-99.3.4.2::unity-gentoo, ebuild scheduled for merge)
(and 2 more with the same problem)

x11-libs/gdk-pixbuf:2

(x11-libs/gdk-pixbuf-2.24.1-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(x11-libs/gdk-pixbuf-2.26.3::gentoo, ebuild scheduled for merge) pulled in by
>=x11-libs/gdk-pixbuf-2.26:2[introspection?,X?] required by (x11-libs/gtk+-99.3.4.2::unity-gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

net-libs/libsoup:2.4

(net-libs/libsoup-2.38.1::gentoo, ebuild scheduled for merge) pulled in by
>=net-libs/libsoup-2.37.91:2.4[introspection?] required by (dev-libs/libgdata-0.12.0::gentoo, ebuild scheduled for merge)

(net-libs/libsoup-2.36.1-r1::gentoo, ebuild scheduled for merge) pulled in by
~net-libs/libsoup-2.36.1 required by (net-libs/libsoup-gnome-2.36.1::gentoo, ebuild scheduled for merge)

gnome-base/gnome-keyring:0

(gnome-base/gnome-keyring-2.32.1-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(gnome-base/gnome-keyring-3.4.1::gentoo, ebuild scheduled for merge) pulled in by
>=gnome-base/gnome-keyring-3.3.90 required by (gnome-base/gnome-shell-3.4.2::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

net-libs/telepathy-glib:0

(net-libs/telepathy-glib-0.18.1::gentoo, ebuild scheduled for merge) pulled in by
>=net-libs/telepathy-glib-0.17.5 required by (dev-libs/folks-0.6.9::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

(net-libs/telepathy-glib-0.16.5::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

gnome-base/libgnome-keyring:0

(gnome-base/libgnome-keyring-3.4.1::gentoo, ebuild scheduled for merge) pulled in by
>=gnome-base/libgnome-keyring-3.1.92 required by (gnome-base/gnome-keyring-3.4.1::gentoo, ebuild scheduled for merge)

(gnome-base/libgnome-keyring-2.32.0::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

sys-fs/udev:0

(sys-fs/udev-171-r6::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/udev-171[gudev] required by (media-video/cheese-3.4.2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (net-misc/networkmanager-0.9.4.0-r6::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[hwdb] required by (media-sound/pulseaudio-1.1-r1::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (x11-misc/colord-0.1.18::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (dev-libs/libgusb-0.1.3::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r6[hwdb] required by (media-sound/pulseaudio-2.1-r1::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (dev-libs/libwacom-0.5::gentoo, ebuild scheduled for merge)
sys-fs/udev[gudev] required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (media-sound/rhythmbox-2.97::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (gnome-base/gvfs-1.10.1::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r5[gudev,hwdb] required by (sys-fs/udisks-1.0.4-r2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171[gudev] required by (app-admin/packagekit-base-0.7.4::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-171-r5[gudev] required by (sys-power/upower-0.9.16::gentoo, ebuild scheduled for merge)

(sys-fs/udev-171-r6::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

media-sound/pulseaudio:0

(media-sound/pulseaudio-1.1-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(media-sound/pulseaudio-2.1-r1::gentoo, ebuild scheduled for merge) pulled in by
>=media-sound/pulseaudio-2.0[glib] required by (gnome-base/gnome-control-center-99.3.4.2::unity-gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
#required by gnome-base/gnome-panel-3.4.2.1, required by unity-base/indicator-applet-12.10.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-desktop-3.4.2 ~amd64
#required by dev-libs/libgdata-0.12.0, required by gnome-extra/evolution-data-server-3.4.4, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-libs/liboauth-0.9.7 ~amd64
#required by gnome-base/gnome-panel-3.4.2.1, required by unity-base/indicator-applet-12.10.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libgweather-3.4.1 ~amd64
#required by gnome-base/gnome-keyring-3.4.1, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/libgnome-keyring-3.4.1 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-shell-3.4.2 ~amd64
#required by media-libs/cogl-1.10.4, required by x11-wm/mutter-3.4.1-r1, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/gdk-pixbuf-2.26.3 ~amd64
#required by media-video/cheese-3.4.2, required by gnome-base/gnome-control-center-99.3.4.2[cheese], required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-libs/clutter-1.10.8 ~amd64
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-menus-3.0.1-r1 ~amd64
#required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/gjs-1.32.0 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by gnome-base/gnome-session-99.3.2.1, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/atk-2.4.0 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/libgnomekbd-3.4.0.2 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by gnome-base/gnome-session-99.3.2.1, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/pango-1.30.1 ~amd64
#required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-wm/mutter-3.4.1-r1 ~amd64
#required by dev-python/pyatspi-2.4.0, required by app-accessibility/caribou-0.4.4, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-accessibility/at-spi2-core-2.4.2 ~amd64
#required by media-sound/rhythmbox-2.97, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libpeas-1.4.0-r1 ~amd64
#required by unity-base/indicator-applet-12.10.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-panel-3.4.2.1 ~amd64
#required by gnome-extra/evolution-data-server-3.4.4[gnome-online-accounts], required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-libs/gnome-online-accounts-3.4.2 ~amd64
#required by gnome-extra/evolution-data-server-3.4.4, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libgdata-0.12.0 ~amd64
#required by x11-wm/mutter-3.4.1-r1, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-libs/cogl-1.10.4 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2[colord], required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/gnome-color-manager-3.4.2 ~amd64
#required by unity-base/unity-lens-video-0.3.5, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/dee-99.1.0.14 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2[cheese], required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-video/cheese-3.4.2 ~amd64
#required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/evolution-data-server-3.4.4 ~amd64
#required by dev-libs/gjs-1.32.0, required by gnome-extra/sushi-0.4.1, required by gnome-base/nautilus-99.3.4.2[previewer], required by unity-base/ubuntuone-client-3.99.91, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-lang/spidermonkey-1.8.5-r1 ~amd64
#required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-keyring-3.4.1 ~amd64
#required by gnome-extra/evolution-data-server-3.4.4, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-util/fix-la-relink-command-0.1.1 ~amd64
#required by net-misc/networkmanager-0.9.4.0-r6, required by net-libs/libsocialweb-0.25.20[networkmanager], required by gnome-base/gnome-control-center-99.3.4.2[socialweb], required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-libs/libsoup-2.38.1 ~amd64
#required by app-accessibility/caribou-0.4.4, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/pyatspi-2.4.0 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by gnome-base/gnome-session-99.3.2.1, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-accessibility/at-spi2-atk-2.5.3 ~amd64
#required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-accessibility/caribou-0.4.4 ~amd64
#required by gnome-base/nautilus-99.3.4.2[previewer], required by unity-base/ubuntuone-client-3.99.91, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/sushi-0.4.1 ~amd64
#required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/folks-0.6.9 ~amd64
#required by gnome-extra/sushi-0.4.1, required by gnome-base/nautilus-99.3.4.2[previewer], required by unity-base/ubuntuone-client-3.99.91, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-text/evince-3.4.0 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-sound/pulseaudio-2.1-r1 ~amd64
#required by media-sound/pulseaudio-2.1-r1[webrtc-aec], required by gnome-base/gnome-control-center-99.3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-libs/webrtc-audio-processing-0.1 ~amd64
#required by x11-libs/gtk+-99.3.4.2[introspection], required by gnome-base/gnome-session-99.3.2.1, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/gobject-introspection-1.32.1 ~amd64
#required by gnome-base/gnome-control-center-99.3.4.2[cups], required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-print/cups-pk-helper-0.2.2 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/libgdu-3.0.2 ~amd64
#required by dev-libs/folks-0.6.9, required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-libs/telepathy-glib-0.18.1 ~amd64
#required by dev-libs/gobject-introspection-1.32.1, required by gnome-base/gsettings-desktop-schemas-99.3.5.91[introspection], required by app-text/evince-3.4.0, required by gnome-extra/sushi-0.4.1, required by gnome-base/nautilus-99.3.4.2[previewer], required by unity-base/ubuntuone-client-3.99.91, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/gobject-introspection-common-1.32.1 ~amd64
#required by media-video/cheese-3.4.2, required by gnome-base/gnome-control-center-99.3.4.2[cheese], required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/mx-1.4.2 ~amd64
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=sys-libs/db-5.1.29 ~amd64
#required by gnome-base/gnome-shell-3.4.2, required by unity-base/unity-5.14.0, required by unity-base/rhythmbox-ubuntuone-3.99.91, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-crypt/gcr-3.4.1-r2 ~amd64

The following mask changes are necessary to proceed:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29

NOTE: The --autounmask-keep-masks option will prevent emerge
from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).


I have created the symlink as followed:

Quote:
jwoodward-linux portage # ls -l *
-rw-r--r-- 1 root root 5093 Sep 17 11:06 package.accept_keywords
-rw-r--r-- 1 root root 1755 Sep 17 10:58 package.mask
-rw-r--r-- 1 root root 0 Sep 17 11:00 package.unmask
-rw-r--r-- 1 root root 3622 Sep 17 10:06 package.use

bin:
total 4
-rwxr-xr-x 1 root root 190 Sep 17 10:18 post_sync

package.keywords:
total 0
lrwxrwxrwx 1 root root 37 Sep 17 11:10 unity-gentoo -> /var/lib/layman/unity-gentoo/PACKAGES
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Sep 17, 2012 11:20 am    Post subject: Reply with quote

If you are making your files in etc/portage from scratch, after remove all of the lines in package.keywords and symlink /var/lib/layman/unity-gentoo/PACKAGES in /etc/portage/package.keywords/unity-gentoo, you will have to put a few packages inside package.accept_keywords (or package.keywords), but this is so easy (portage will tell you what to do). And if you want to have a nice, fast, smooth and stable gnome 3.4 (a entire gnome 3.4), simply entry these lines in a file called "gnome3" (make it) inside package.keywords file (and you will also have to put a few extra packages inside package.keywords file, but portage will tell you what to do)...
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Sep 17, 2012 11:23 am    Post subject: Reply with quote

Jono86 wrote:
ok so now this brings the other keyword changes back:

Quote:
[blocks B ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-99.3.4.2)
[blocks B ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.4.1-r2)
[blocks B ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)

Total: 521 packages (4 upgrades, 1 downgrade, 511 new, 3 in new slots, 2 reinstalls), Size of downloads: 950,380 kB
Conflict: 3 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/gobject-introspection:0

(dev-libs/gobject-introspection-1.30.0-r2::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/gobject- .... .... etc



This is easy to solve, try first full-upgrade to gnome3.4. Unfortunately i will have to sleep now... But we will try to help you soon, be patient.
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 11:31 am    Post subject: Reply with quote

The package.keywords.gnome3 worked well thanks, after deleting my package.use options and then adding the ones portage asked for.

The only problem I have left is the db one:

Code:

The following mask changes are necessary to proceed:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 11:40 am    Post subject: Reply with quote

It seems to be hardmasked:

Quote:


portage # eshowkw sys-libs/db
Keywords for sys-libs/db:
| | u |
| a a p s | n |
| l m h i m m p s p | u s | r
| p d a p a 6 i p c 3 a x | s l | e
| h 6 r p 6 8 p p 6 9 s r 8 | e o | p
| a 4 m a 4 k s c 4 0 h c 6 | d t | o
-------------+---------------------------+-------+-------
1.85-r3 | + + + + + + ~ + + + + + + | o 1 | gentoo
-------------+---------------------------+-------+-------
3.2.9_p2 | + + + + + + ~ + + + + + + | o 3 | gentoo
-------------+---------------------------+-------+-------
4.2.52_p5 | ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ | # 4.2 | gentoo
4.2.52_p5-r1 | + + + + + + ~ + + + + + + | o | gentoo
-------------+---------------------------+-------+-------
4.3.29_p1 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | # 4.3 | gentoo
4.3.29_p1-r1 | + + + + + + o + + + + + + | o | gentoo
-------------+---------------------------+-------+-------
4.4.20_p4 | o ~ ~ o ~ ~ o ~ ~ ~ ~ ~ ~ | # 4.4 | gentoo
4.4.20_p4-r1 | o ~ ~ o ~ ~ o ~ ~ ~ ~ ~ ~ | o | gentoo
-------------+---------------------------+-------+-------
4.5.20_p2 | + + + + + + ~ + + + + + + | # 4.5 | gentoo
4.5.20_p2-r1 | + + + + + + ~ + + + + + + | o | gentoo
-------------+---------------------------+-------+-------
4.6.21_p4 | + + + + + + ~ + + + + + + | o 4.6 | gentoo
-------------+---------------------------+-------+-------
4.7.25_p3 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | # 4.7 | gentoo
4.7.25_p4 | + + + + + + o + + + + + + | o | gentoo
-------------+---------------------------+-------+-------
4.8.24 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | # 4.8 | gentoo
4.8.26 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | # | gentoo
[I]4.8.30 | ~ + ~ ~ ~ ~ ~ + ~ ~ ~ ~ + | o | gentoo
-------------+---------------------------+-------+-------
[M]5.0.21-r1 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o 5.0 | gentoo
[M]5.0.26 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o | gentoo
[M]5.0.32 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o | gentoo
-------------+---------------------------+-------+-------
[M]5.1.19-r2 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o 5.1 | gentoo
[M]5.1.25 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o | gentoo
[M]5.1.29 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o | gentoo
-------------+---------------------------+-------+-------
[M]5.2.28 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o 5.2 | gentoo
[M]5.2.36 | ~ ~ ~ ~ ~ ~ o ~ ~ ~ ~ ~ ~ | o | gentoo
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 11:45 am    Post subject: Reply with quote

Adding it to package.unmask seems to get round it, 1 of 514 packages to install lol :lol:

Thanks for your help.
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 3:28 pm    Post subject: Reply with quote

Does anyone know when unity will be built into gentoo?
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Mon Sep 17, 2012 4:31 pm    Post subject: Reply with quote

Stuck again, will resume in the morning, if anyone has any ideas would be appreciated:

Code:


>>> Emerging (1 of 168) dev-python/python-geoclue-0.1.0
 * Fetching files in the background. To view fetch progress, run
 * `tail -f /var/log/emerge-fetch.log` in another terminal.
 * python-geoclue-0.1.0.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                        [ ok ]
>>> Unpacking source...
>>> Unpacking python-geoclue-0.1.0.tar.gz to /var/tmp/portage/dev-python/python-geoclue-0.1.0/work
>>> Source unpacked in /var/tmp/portage/dev-python/python-geoclue-0.1.0/work
>>> Preparing source in /var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue ...
 * Building of dev-python/python-geoclue-0.1.0 with CPython 2.7...
python2.7 setup.py build -b build-2.7
Traceback (most recent call last):
  File "setup.py", line 5, in <module>
    import Geoclue
  File "/var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue/Geoclue/__init__.py", line 17, in <module>
    from Base import *
  File "/var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue/Geoclue/Base.py", line 23, in <module>
    import gobject
ImportError: No module named gobject
 * ERROR: dev-python/python-geoclue-0.1.0 failed (compile phase):
 *   Building failed with CPython 2.7 in distutils_building() function
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 3704:  Called distutils_src_compile
 *   environment, line 1036:  Called python_execute_function 'distutils_building'
 *   environment, line 2088:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *
 * If you need support, post the output of `emerge --info '=dev-python/python-geoclue-0.1.0'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/python-geoclue-0.1.0'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/python-geoclue-0.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/python-geoclue-0.1.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue'
 * S: '/var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue'

>>> Failed to emerge dev-python/python-geoclue-0.1.0, Log file:

>>>  '/var/tmp/portage/dev-python/python-geoclue-0.1.0/temp/build.log'

 * Messages for package net-misc/networkmanager-0.9.4.0-r7:

 * Unable to find kernel sources at /usr/src/linux

 * Messages for package dev-python/python-geoclue-0.1.0:

 * ERROR: dev-python/python-geoclue-0.1.0 failed (compile phase):
 *   Building failed with CPython 2.7 in distutils_building() function
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
 *   environment, line 3704:  Called distutils_src_compile
 *   environment, line 1036:  Called python_execute_function 'distutils_building'
 *   environment, line 2088:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *
 * If you need support, post the output of `emerge --info '=dev-python/python-geoclue-0.1.0'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/python-geoclue-0.1.0'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/python-geoclue-0.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/python-geoclue-0.1.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue'
 * S: '/var/tmp/portage/dev-python/python-geoclue-0.1.0/work/python-geoclue'
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 647

PostPosted: Mon Sep 17, 2012 4:53 pm    Post subject: Reply with quote

Jono86 wrote:
Stuck again, will resume in the morning, if anyone has any ideas would be appreciated:
since a Python program is complaining about missing gobject...:
Code:
emerge pygobject
?
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Mon Sep 17, 2012 6:05 pm    Post subject: Reply with quote

Jono86 wrote:
Does anyone know when unity will be built into gentoo?

Me me me!
Never.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Sep 17, 2012 9:07 pm    Post subject: Reply with quote

^marcs wrote:
Jono86 wrote:
Does anyone know when unity will be built into gentoo?

Me me me!
Never.



:cry:
Back to top
View user's profile Send private message
Jono86
n00b
n00b


Joined: 10 Aug 2012
Posts: 28

PostPosted: Tue Sep 18, 2012 7:29 am    Post subject: Reply with quote

Yes I tried re-installing pygobject however it is marked for re-install and never does....

Code:

>>> Installing (1 of 1) dev-python/pygobject-3.2.2
 * checking 69 files for package collisions
>>> Merging dev-python/pygobject-3.2.2 to /
--- /usr/
--- /usr/share/
--- /usr/share/doc/
--- /usr/share/doc/pygobject-3.2.2/
>>> /usr/share/doc/pygobject-3.2.2/README.bz2
>>> /usr/share/doc/pygobject-3.2.2/ChangeLog.pre-2.18.bz2
>>> /usr/share/doc/pygobject-3.2.2/ChangeLog.bz2
>>> /usr/share/doc/pygobject-3.2.2/NEWS.bz2
>>> /usr/share/doc/pygobject-3.2.2/AUTHORS.bz2
--- /usr/lib64/
>>> /usr/lib64/libpyglib-gi-2.0-python3.2.so.0 -> libpyglib-gi-2.0-python3.2.so.0.0.0
>>> /usr/lib64/libpyglib-gi-2.0-python3.2.so.0.0.0
--- /usr/lib64/python3.2/
--- /usr/lib64/python3.2/site-packages/
--- /usr/lib64/python3.2/site-packages/gi/
>>> /usr/lib64/python3.2/site-packages/gi/_gi.so
>>> /usr/lib64/python3.2/site-packages/gi/__init__.py
>>> /usr/lib64/python3.2/site-packages/gi/_gi_cairo.so
--- /usr/lib64/python3.2/site-packages/gi/repository/
>>> /usr/lib64/python3.2/site-packages/gi/repository/__init__.py
--- /usr/lib64/python3.2/site-packages/gi/_glib/
>>> /usr/lib64/python3.2/site-packages/gi/_glib/__init__.py
>>> /usr/lib64/python3.2/site-packages/gi/_glib/_glib.so
>>> /usr/lib64/python3.2/site-packages/gi/_glib/option.py
>>> /usr/lib64/python3.2/site-packages/gi/module.py
>>> /usr/lib64/python3.2/site-packages/gi/importer.py
--- /usr/lib64/python3.2/site-packages/gi/overrides/
>>> /usr/lib64/python3.2/site-packages/gi/overrides/Gtk.py
>>> /usr/lib64/python3.2/site-packages/gi/overrides/__init__.py
>>> /usr/lib64/python3.2/site-packages/gi/overrides/Gdk.py
>>> /usr/lib64/python3.2/site-packages/gi/overrides/Gio.py
>>> /usr/lib64/python3.2/site-packages/gi/overrides/GIMarshallingTests.py
>>> /usr/lib64/python3.2/site-packages/gi/overrides/Pango.py
>>> /usr/lib64/python3.2/site-packages/gi/overrides/GLib.py
>>> /usr/lib64/python3.2/site-packages/gi/overrides/keysyms.py
>>> /usr/lib64/python3.2/site-packages/gi/types.py
>>> /usr/lib64/python3.2/site-packages/gi/pygtkcompat.py
--- /usr/lib64/python3.2/site-packages/gi/_gobject/
>>> /usr/lib64/python3.2/site-packages/gi/_gobject/__init__.py
>>> /usr/lib64/python3.2/site-packages/gi/_gobject/_gobject.so
>>> /usr/lib64/python3.2/site-packages/gi/_gobject/constants.py
>>> /usr/lib64/python3.2/site-packages/gi/_gobject/propertyhelper.py
>>> /usr/lib64/libpyglib-gi-2.0-python2.7.so.0.0.0
>>> /usr/lib64/libpyglib-gi-2.0-python2.7.so -> libpyglib-gi-2.0-python2.7.so.0.0.0
>>> /usr/lib64/libpyglib-gi-2.0-python2.7.so.0 -> libpyglib-gi-2.0-python2.7.so.0.0.0
>>> /usr/lib64/libpyglib-gi-2.0-python3.2.so -> libpyglib-gi-2.0-python3.2.so.0.0.0
--- /usr/lib64/python2.7/
--- /usr/lib64/python2.7/site-packages/
--- /usr/lib64/python2.7/site-packages/gi/
>>> /usr/lib64/python2.7/site-packages/gi/_gi.so
>>> /usr/lib64/python2.7/site-packages/gi/__init__.py
>>> /usr/lib64/python2.7/site-packages/gi/_gi_cairo.so
--- /usr/lib64/python2.7/site-packages/gi/repository/
>>> /usr/lib64/python2.7/site-packages/gi/repository/__init__.py
--- /usr/lib64/python2.7/site-packages/gi/_glib/
>>> /usr/lib64/python2.7/site-packages/gi/_glib/__init__.py
>>> /usr/lib64/python2.7/site-packages/gi/_glib/_glib.so
>>> /usr/lib64/python2.7/site-packages/gi/_glib/option.py
>>> /usr/lib64/python2.7/site-packages/gi/module.py
>>> /usr/lib64/python2.7/site-packages/gi/importer.py
--- /usr/lib64/python2.7/site-packages/gi/overrides/
>>> /usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py
>>> /usr/lib64/python2.7/site-packages/gi/overrides/__init__.py
>>> /usr/lib64/python2.7/site-packages/gi/overrides/Gdk.py
>>> /usr/lib64/python2.7/site-packages/gi/overrides/Gio.py
>>> /usr/lib64/python2.7/site-packages/gi/overrides/GIMarshallingTests.py
>>> /usr/lib64/python2.7/site-packages/gi/overrides/Pango.py
>>> /usr/lib64/python2.7/site-packages/gi/overrides/GLib.py
>>> /usr/lib64/python2.7/site-packages/gi/overrides/keysyms.py
>>> /usr/lib64/python2.7/site-packages/gi/types.py
>>> /usr/lib64/python2.7/site-packages/gi/pygtkcompat.py
--- /usr/lib64/python2.7/site-packages/gi/_gobject/
>>> /usr/lib64/python2.7/site-packages/gi/_gobject/__init__.py
>>> /usr/lib64/python2.7/site-packages/gi/_gobject/_gobject.so
>>> /usr/lib64/python2.7/site-packages/gi/_gobject/constants.py
>>> /usr/lib64/python2.7/site-packages/gi/_gobject/propertyhelper.py
--- /usr/lib64/pkgconfig/
>>> /usr/lib64/pkgconfig/pygobject-3.0.pc
--- /usr/lib/
--- /usr/lib/debug/
--- /usr/lib/debug/usr/
--- /usr/lib/debug/usr/lib64/
>>> /usr/lib/debug/usr/lib64/libpyglib-gi-2.0-python3.2.so.0.0.0.debug
--- /usr/lib/debug/usr/lib64/python3.2/
--- /usr/lib/debug/usr/lib64/python3.2/site-packages/
--- /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/
>>> /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gi.so.debug
--- /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_glib/
>>> /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_glib/_glib.so.debug
--- /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gobject/
>>> /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gobject/_gobject.so.debug
>>> /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gi_cairo.so.debug
>>> /usr/lib/debug/usr/lib64/libpyglib-gi-2.0-python2.7.so.0.0.0.debug
--- /usr/lib/debug/usr/lib64/python2.7/
--- /usr/lib/debug/usr/lib64/python2.7/site-packages/
--- /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/
>>> /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gi.so.debug
--- /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_glib/
>>> /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_glib/_glib.so.debug
--- /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gobject/
>>> /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gobject/_gobject.so.debug
>>> /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gi_cairo.so.debug
--- /usr/include/
--- /usr/include/pygobject-3.0/
>>> /usr/include/pygobject-3.0/pygobject.h
>>> Safely unmerging already-installed instance...
No package files given... Grabbing a set.
--- replaced obj /usr/share/doc/pygobject-3.2.2/README.bz2
--- replaced obj /usr/share/doc/pygobject-3.2.2/NEWS.bz2
--- replaced obj /usr/share/doc/pygobject-3.2.2/ChangeLog.pre-2.18.bz2
--- replaced obj /usr/share/doc/pygobject-3.2.2/ChangeLog.bz2
--- replaced obj /usr/share/doc/pygobject-3.2.2/AUTHORS.bz2
--- replaced dir /usr/share/doc/pygobject-3.2.2
--- replaced dir /usr/share/doc
--- replaced dir /usr/share
--- replaced obj /usr/lib64/python3.2/site-packages/gi/types.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/repository/__init__.py
--- replaced dir /usr/lib64/python3.2/site-packages/gi/repository
--- replaced obj /usr/lib64/python3.2/site-packages/gi/pygtkcompat.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/keysyms.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/__init__.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/Pango.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/Gtk.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/Gio.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/Gdk.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/GLib.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/overrides/GIMarshallingTests.py
--- replaced dir /usr/lib64/python3.2/site-packages/gi/overrides
--- replaced obj /usr/lib64/python3.2/site-packages/gi/module.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/importer.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_gobject/propertyhelper.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_gobject/constants.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_gobject/_gobject.so
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_gobject/__init__.py
--- replaced dir /usr/lib64/python3.2/site-packages/gi/_gobject
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_glib/option.py
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_glib/_glib.so
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_glib/__init__.py
--- replaced dir /usr/lib64/python3.2/site-packages/gi/_glib
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_gi_cairo.so
--- replaced obj /usr/lib64/python3.2/site-packages/gi/_gi.so
--- replaced obj /usr/lib64/python3.2/site-packages/gi/__init__.py
--- replaced dir /usr/lib64/python3.2/site-packages/gi
--- replaced dir /usr/lib64/python3.2/site-packages
--- replaced dir /usr/lib64/python3.2
--- replaced obj /usr/lib64/python2.7/site-packages/gi/types.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/repository/__init__.py
--- replaced dir /usr/lib64/python2.7/site-packages/gi/repository
--- replaced obj /usr/lib64/python2.7/site-packages/gi/pygtkcompat.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/keysyms.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/__init__.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/Pango.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/Gio.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/Gdk.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/GLib.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/overrides/GIMarshallingTests.py
--- replaced dir /usr/lib64/python2.7/site-packages/gi/overrides
--- replaced obj /usr/lib64/python2.7/site-packages/gi/module.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/importer.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_gobject/propertyhelper.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_gobject/constants.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_gobject/_gobject.so
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_gobject/__init__.py
--- replaced dir /usr/lib64/python2.7/site-packages/gi/_gobject
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_glib/option.py
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_glib/_glib.so
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_glib/__init__.py
--- replaced dir /usr/lib64/python2.7/site-packages/gi/_glib
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_gi_cairo.so
--- replaced obj /usr/lib64/python2.7/site-packages/gi/_gi.so
--- replaced obj /usr/lib64/python2.7/site-packages/gi/__init__.py
--- replaced dir /usr/lib64/python2.7/site-packages/gi
--- replaced dir /usr/lib64/python2.7/site-packages
--- replaced dir /usr/lib64/python2.7
--- replaced obj /usr/lib64/pkgconfig/pygobject-3.0.pc
--- replaced dir /usr/lib64/pkgconfig
--- replaced obj /usr/lib64/libpyglib-gi-2.0-python3.2.so.0.0.0
--- replaced sym /usr/lib64/libpyglib-gi-2.0-python3.2.so.0
--- replaced sym /usr/lib64/libpyglib-gi-2.0-python3.2.so
--- replaced obj /usr/lib64/libpyglib-gi-2.0-python2.7.so.0.0.0
--- replaced sym /usr/lib64/libpyglib-gi-2.0-python2.7.so.0
--- replaced sym /usr/lib64/libpyglib-gi-2.0-python2.7.so
--- replaced dir /usr/lib64
--- replaced obj /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gobject/_gobject.so.debug
--- replaced dir /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gobject
--- replaced obj /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_glib/_glib.so.debug
--- replaced dir /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_glib
--- replaced obj /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gi_cairo.so.debug
--- replaced obj /usr/lib/debug/usr/lib64/python3.2/site-packages/gi/_gi.so.debug
--- replaced dir /usr/lib/debug/usr/lib64/python3.2/site-packages/gi
--- replaced dir /usr/lib/debug/usr/lib64/python3.2/site-packages
--- replaced dir /usr/lib/debug/usr/lib64/python3.2
--- replaced obj /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gobject/_gobject.so.debug
--- replaced dir /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gobject
--- replaced obj /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_glib/_glib.so.debug
--- replaced dir /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_glib
--- replaced obj /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gi_cairo.so.debug
--- replaced obj /usr/lib/debug/usr/lib64/python2.7/site-packages/gi/_gi.so.debug
--- replaced dir /usr/lib/debug/usr/lib64/python2.7/site-packages/gi
--- replaced dir /usr/lib/debug/usr/lib64/python2.7/site-packages
--- replaced dir /usr/lib/debug/usr/lib64/python2.7
--- replaced obj /usr/lib/debug/usr/lib64/libpyglib-gi-2.0-python3.2.so.0.0.0.debug
--- replaced obj /usr/lib/debug/usr/lib64/libpyglib-gi-2.0-python2.7.so.0.0.0.debug
--- replaced dir /usr/lib/debug/usr/lib64
--- replaced dir /usr/lib/debug/usr
--- replaced dir /usr/lib/debug
--- cfgpro   dir /usr/lib
--- replaced obj /usr/include/pygobject-3.0/pygobject.h
--- replaced dir /usr/include/pygobject-3.0
--- replaced dir /usr/include
--- replaced dir /usr
>>> Regenerating /etc/ld.so.cache...
>>> Original instance of package unmerged safely.
 * Compilation and optimization of Python modules for CPython 2.7 ...                                                                      [ ok ]
 * Compilation and optimization of Python modules for CPython 3.2 ...                                                                      [ ok ]
>>> dev-python/pygobject-3.2.2 merged.
>>> Regenerating /etc/ld.so.cache...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: 3 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

jwoodward-linux ~ # emerge -av pygobject

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] dev-python/pygobject-3.2.2  USE="cairo threads -examples -test" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 24, 25, 26  Next
Page 6 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum