Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Don't update to qt 4.8.3 + portage hatethread
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
SeeksTheMoon
Apprentice
Apprentice


Joined: 24 Sep 2003
Posts: 158

PostPosted: Sun Sep 16, 2012 7:46 am    Post subject: Don't update to qt 4.8.3 + portage hatethread Reply with quote

I don't care if this is against the guidelines, I will not stfu and hit my wife instead. It is unacceptable that updates are put into portage that are labelled as minor ones, break the system and then prevent a downgrade to the previous version.
The best thing I had with gentoo was a "stable" mailman-$version-r1 some years ago that completely and in an incompatible way changed the program deployment and the cases where packages are marked as stable and then are reverted the next day. At least I was not prevented to do the downgrade in these cases, but gentoo reached a new state in userfriendlyness now:

Applications like ktorrent, kontact, vlc (try open the playlist window) segfault with qt-4.8.3 though they work fine with 4.8.2 (yes I revdepped and did not change anything else, everything is fine).
But if you try to downgrade to 4.8.2 by manually masking 4.8.3 because you NEED to, smartass portage says
Code:
 *     ***  Sanity check to keep you from breaking your system  ***
 * Downgrading Qt is completely unsupported and will break your system!

What the hell is this dumb shit? Except from breaking my system with a MINOR UPGRADE (thanks qt coders!), why the hell does portage patronize me when I want to force installing the working MINOR version again (thanks portage developers!)? Well, I guess I have to *unmerge* and then *emerge* qt, what are you going to do now? I am going to downgrade and you cannot stop me! Go sanitycheck yourself, portage.

Oh and yeah: "unsupported" ... as if I could call some paid developer in the middle of the night on his phone and ask for support. This is not RHEL, so just write "downgrading *should* not be done" instead of blubbering about some imaginary support, give 10s thinking time and then f*cking DO IT. I am ROOT, don't you think I KNOW what I want? This is why I use unix systems for years: programs don't shit themselves when I invoke them - except emerge now. What is this? Sissy-OS?
Yes, that's it:
Code:
~# alias sissy=emerge
~# sissy -C x11-libs/qt-core x11-libs/qt-dbus x11-libs/qt-declarative x11-libs/qt-gui x11-libs/qt-multimedia x11-libs/qt-opengl x11-libs/qt-qt3support x11-libs/qt-script x11-libs/qt-sql x11-libs/qt-svg x11-libs/qt-test x11-libs/qt-webkit x11-libs/qt-xmlpatterns
~# sissy x11-libs/qt-core x11-libs/qt-dbus x11-libs/qt-declarative x11-libs/qt-gui x11-libs/qt-multimedia x11-libs/qt-opengl x11-libs/qt-qt3support x11-libs/qt-script x11-libs/qt-sql x11-libs/qt-svg x11-libs/qt-test x11-libs/qt-webkit x11-libs/qt-xmlpatterns

Damn, I am so in rage right now, I could punch the developers in the face for 90 minutes (aka downgrade-while-having-a-useless-PC-time) :evil: :evil:
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2354
Location: Austria

PostPosted: Sun Sep 16, 2012 8:29 am    Post subject: Reply with quote

It would be interesting to know what actually broke your system because there is absolutely no problem at all for me with qt-4.8.3, and I was running 4.8.9999 for a long time already.

Now, qt-4.8.3 is not stable but ~arch keyworded so breakage, or even unbootable system could happen any time.

Since I basically also had to 'downgrade' from some older 4.8.9999 commit state to 4.8.3 I had to set I_KNOW_WHAT_I_AM_DOING=1 temporarily for emerge to proceed.

EDIT: I've just had vlc segfault _on close_ (never during usage, so that error could have gone by unnoticed well before qt-4.8.3), but no trouble with ktorrent and kontact so far - at what point did those crash for you? Also, what versions are you running?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2539
Location: In the city of dreaming spires

PostPosted: Sun Sep 16, 2012 2:35 pm    Post subject: Reply with quote

SeeksTheMoon, usually I'll ignore threads that try to get support by trolling, but since I have seen that portage behavior myself: What's stopping you from unmerging all qt packages, masking the offending version, and re-emerging them? (EDIT: Never mind, you already did that. So you're freaking out over two hours of downtime...? Dude, in that case, a source distro like Gentoo seems to be a poor choice for you, you might want to try RHEL instead...)

Last edited by Voltago on Sun Sep 16, 2012 3:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2354
Location: Austria

PostPosted: Sun Sep 16, 2012 2:55 pm    Post subject: Reply with quote

Probably the dependencies on the qt packages, but there's an easy way around as already provided above.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2539
Location: In the city of dreaming spires

PostPosted: Sun Sep 16, 2012 3:02 pm    Post subject: Reply with quote

genstorm wrote:
Probably the dependencies on the qt packages, but there's an easy way around as already provided above.

You know, some of these days I should start actually reading what other people write... the OP already had my 'solution' in his post even ;)

But no, portage will warn you, but you can still unmerge anything you like (except if the dependencies of the package itself are unmet, I seem to remember).
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2222
Location: UK

PostPosted: Sun Sep 16, 2012 5:10 pm    Post subject: Re: Don't update to qt 4.8.3 + portage hatethread Reply with quote

SeeksTheMoon wrote:
I am ROOT, don't you think I KNOW what I want?

Then why are you on here crying because you can't read simple instructions and use common sense? PEBKAC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum