Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cant seem to compile anything [closed]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
AliasXZ
l33t
l33t


Joined: 08 Feb 2005
Posts: 836
Location: England, Huddersfield

PostPosted: Fri Sep 14, 2012 3:40 pm    Post subject: Cant seem to compile anything [closed] Reply with quote

Hey all

I have tried searching, but I can't seem to find anything, when I try to compile anything, I always seem to get "Unable to determine byte order assuming big-endian" which throws an error and the compilation fails...

This is my emerge info:

Code:
Portage 2.1.11.9 (default/linux/x86/10.0, gcc-4.5.3, glibc-2.15-r2, 3.3.8-gentoo i686)
=================================================================
System uname: Linux-3.3.8-gentoo-i686-AMD_Athlon-tm-_XP_2700+-with-gentoo-2.1
Timestamp of tree: Fri, 14 Sep 2012 14:30:01 +0000
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo RichsEbuilds
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -pipe -O2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=athlon-xp -pipe -O2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB en"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl alsa apng berkdb bluetooth bzip2 cli cracklib crypt cups cxx dbus dri dvd dvdr dvdread encode faac fortran gdbm gif gpm gtk iconv ipv6 jpeg lm_sensors mmx modules mp3 mp540 mpg123 mudflap ncurses nls nptl nptlonly nss opengl openmp pam pcre png pppd python qt3support readline reiserfs session sse ssl tcpd unicode usb v4l v4l2 win32codecs x86 xulrunner xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


For example, this is from pkgconfig:

Code:
/usr/include/bits/endian.h:34:4: warning: #warning Cannot determine cu                                                                                                                                 
rrent byte order, assuming big-endian.
/bin/sh ./libtool  --tag=CC   --mode=link i686-pc-linux-gnu-gcc  -I/us                                                                                                                                 
r/include/glib-2.0 -I/usr/lib/glib-2.0/include   -march=athlon-xp -pip                                                                                                                                 
e -O2  -Wl,-O1 -Wl,--as-needed -o pkg-config pkg.o parse.o main.o -lgl                                                                                                                                 
ib-2.0   
libtool: link: i686-pc-linux-gnu-gcc -I/usr/include/glib-2.0 -I/usr/li                                                                                                                                 
b/glib-2.0/include -march=athlon-xp -pipe -O2 -Wl,-O1 -o pkg-config pk                                                                                                                                 
g.o parse.o main.o  -Wl,--as-needed -lglib-2.0
pkg.o: In function `packages_foreach':
pkg.c:(.text+0x1f42): undefined reference to `__nldbl___printf_chk'
main.o: In function `main':
main.c:(.text+0x60f): undefined reference to `__nldbl___fprintf_chk'
main.c:(.text+0x8c2): undefined reference to `__nldbl___fprintf_chk'
main.c:(.text+0xbfc): undefined reference to `__nldbl___printf_chk'
main.c:(.text+0xc9e): undefined reference to `__nldbl___fprintf_chk'
main.c:(.text+0xcfb): undefined reference to `__nldbl___printf_chk'
main.c:(.text+0xdb1): undefined reference to `__nldbl___printf_chk'
main.c:(.text+0xe39): undefined reference to `__nldbl___printf_chk'
main.c:(.text+0xe7a): undefined reference to `__nldbl___printf_chk'
main.c:(.text+0xebb): undefined reference to `__nldbl___printf_chk'
main.c:(.text+0xf7a): undefined reference to `__nldbl___fprintf_chk'
collect2: ld returned 1 exit status
make[2]: *** [pkg-config] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-util/pkgconfig-0.27.1                                                                                                                                 
/work/pkg-config-0.27.1'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-util/pkgconfig-0.27.1                                                                                                                                 
/work/pkg-config-0.27.1'
make: *** [all] Error 2
 * ERROR: dev-util/pkgconfig-0.27.1 failed (compile phase):
 *   emake failed


:(




Any help appreciated :)
_________________
Main:
Kernel: 3.12.13 amd64
RAM: 4GB
Lappy:
iBookG4 7447A @ 1.42G
------------------------------
Please add (solved) to your first post when your issue is resolved 8)


Last edited by AliasXZ on Sat Sep 15, 2012 9:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4006
Location: USA

PostPosted: Fri Sep 14, 2012 5:21 pm    Post subject: Reply with quote

/usr/include/bits/endian.h looks like
Code:
/* i386 is little-endian.  */

#ifndef _ENDIAN_H
# error "Never use <bits/endian.h> directly; include <endian.h> instead."
#endif

#define __BYTE_ORDER __LITTLE_ENDIAN

on my i686 machine, which does not have the #warning directive that your logs are hinting at.

Did you overwrite your /usr/include directory? This looks like the file should belong to glibc, but your glibc looks like it's up to date...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
AliasXZ
l33t
l33t


Joined: 08 Feb 2005
Posts: 836
Location: England, Huddersfield

PostPosted: Sat Sep 15, 2012 9:08 pm    Post subject: Reply with quote

Cheers for replies.

The only thing I can think that I have done, which may of done something to the /usr/include dir is cross compiling, but meh...

I ended up restoring a Clonezilla backup from June, so I'm just updating now.

Cheers :)
_________________
Main:
Kernel: 3.12.13 amd64
RAM: 4GB
Lappy:
iBookG4 7447A @ 1.42G
------------------------------
Please add (solved) to your first post when your issue is resolved 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum