Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]emerge has slot conflicts returns
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
uuhan
n00b
n00b


Joined: 26 Aug 2012
Posts: 20

PostPosted: Sat Sep 15, 2012 2:13 pm    Post subject: [solved]emerge has slot conflicts returns Reply with quote

I want to emerge a package named kalarm.I run emerge -pv kalarm ,there returns an error , followed:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

kde-base/kdelibs:4

(kde-base/kdelibs-4.9.1::gentoo, ebuild scheduled for merge) pulled in by
>=kde-base/kdelibs-4.9.1:4[aqua=] required by (kde-base/katepart-4.9.1::gentoo, ebuild scheduled for merge)
(and 3 more with the same problem)

(kde-base/kdelibs-4.8.5::gentoo, installed) pulled in by
>=kde-base/kdelibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/kdepimlibs-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/kdeplasma-addons-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[aqua=,opengl,semantic-desktop=] required by (kde-base/pykde4-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/dolphin-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/plasma-workspace-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/kactivities-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/gwenview-4.8.5::gentoo, installed)
>=kde-base/kdelibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/kget-4.8.5::gentoo, installed)

kde-base/oxygen-icons:4

(kde-base/oxygen-icons-4.9.1::gentoo, ebuild scheduled for merge) pulled in by
>=kde-base/oxygen-icons-4.9.1:4[aqua=] required by (kde-base/katepart-4.9.1::gentoo, ebuild scheduled for merge)
(and 3 more with the same problem)

(kde-base/oxygen-icons-4.8.5::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

kde-base/kdepimlibs:4

(kde-base/kdepimlibs-4.9.1-r1::gentoo, ebuild scheduled for merge) pulled in by
>=kde-base/kdepimlibs-4.8.5:4[aqua=,semantic-desktop] required by (kde-base/kdepim-common-libs-4.8.5::gentoo, ebuild scheduled for merge)
>=kde-base/kdepimlibs-4.8.5:4[aqua=,semantic-desktop] required by (kde-base/kdepim-runtime-4.8.5::gentoo, ebuild scheduled for merge)
>=kde-base/kdepimlibs-4.8.5:4[aqua=,semantic-desktop] required by (kde-base/kalarm-4.8.5::gentoo, ebuild scheduled for merge)

(kde-base/kdepimlibs-4.8.5::gentoo, installed) pulled in by
>=kde-base/kdepimlibs-4.8.5:4[aqua=,semantic-desktop=] required by (kde-base/plasma-workspace-4.8.5::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- sys-kernel/gentoo-sources-3.5.0::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I want to know how to deal with the "slot conflict" . I am a new Gentoo User . Any Idea ?


Last edited by uuhan on Sun Sep 16, 2012 5:51 am; edited 1 time in total
Back to top
View user's profile Send private message
fr3eatlast
n00b
n00b


Joined: 21 Jul 2012
Posts: 41
Location: Marquette, MI

PostPosted: Sun Sep 16, 2012 2:32 am    Post subject: Reply with quote

What version of KDE do you currently have installed now because it looks like your running KDE 4.8.5 and the version of kalarm that portage is trying to install is 4.9.1. There are two ways to fix the slot conflicts that I can think of. One is to update your version of KDE to 4.9.1 and the other would be to mask the 4.9.1 version of kalarm.

hth
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Sun Sep 16, 2012 5:18 am    Post subject: Reply with quote

please post the entire output in code tags
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
uuhan
n00b
n00b


Joined: 26 Aug 2012
Posts: 20

PostPosted: Sun Sep 16, 2012 5:50 am    Post subject: Reply with quote

fr3eatlast wrote:
What version of KDE do you currently have installed now because it looks like your running KDE 4.8.5 and the version of kalarm that portage is trying to install is 4.9.1. There are two ways to fix the slot conflicts that I can think of. One is to update your version of KDE to 4.9.1 and the other would be to mask the 4.9.1 version of kalarm.

hth

En , I have solved it . I unmerged the package of version 4.8.5 and remerged the 4.9.1 one . It works .Thanks :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum