Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]revdep-rebuild:Unable to proceed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oliver2104
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jul 2004
Posts: 141
Location: Wien

PostPosted: Fri Sep 14, 2012 12:50 pm    Post subject: [gelöst]revdep-rebuild:Unable to proceed Reply with quote

Hallo,
hab ein System-Update gemacht :
Code:

emerge --update --deep --with-bdeps=y --newuse world

gefolgt von
Code:

emerge --depclean

und zum Abschluß
Code:

revdep-rebuild

da kommt dann die folgende Ausgabe:
Code:

 * Collecting system binaries and libraries
 * Found existing 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Found existing 2_ldpath.rr.
 * Checking dynamic linking consistency
 * Found existing 3_broken.rr.
 * Assigning files to packages
 *  !!! /usr/lib/ruby/site_ruby/1.8/i686-linux/gdal.backup.0000 not owned by any package is broken !!!
 *   /usr/lib/ruby/site_ruby/1.8/i686-linux/gdal.backup.0000 -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known package
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.rr

Frag mich jetzt, ist das so OK oder sollte ich was nachbessern? (System läuft eigentlich wieder problemlos)
Bitte um Hilfe


Last edited by oliver2104 on Sun Sep 16, 2012 9:07 am; edited 1 time in total
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 568

PostPosted: Fri Sep 14, 2012 1:02 pm    Post subject: Re: revdep-rebuild:Unable to proceed Reply with quote

Hi
oliver2104 wrote:
Hallo,
...
...
Code:

revdep-rebuild

da kommt dann die folgende Ausgabe:
Code:

 * Collecting system binaries and libraries
 * Found existing 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Found existing 2_ldpath.rr.
 * Checking dynamic linking consistency
 * Found existing 3_broken.rr.
 * Assigning files to packages
 *  !!! /usr/lib/ruby/site_ruby/1.8/i686-linux/gdal.backup.0000 not owned by any package is broken !!!
 *   /usr/lib/ruby/site_ruby/1.8/i686-linux/gdal.backup.0000 -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known package
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.rr

Frag mich jetzt, ist das so OK oder sollte ich was nachbessern? (System läuft eigentlich wieder problemlos)
Bitte um Hilfe

Ich hatte da auch immer mal so Backup Dateien/Ordner. Denke einmal das irgend ein Programm diese selber anlegt.
Ich für meinen Teil habe diese immer gelöscht wenn revdep-rebuild gemeckert hat wenn so eine Backup aufgetaucht ist
die zu keinem Installierten ebuild gehört, und hatte auch nie Probleme. Kannst ja auch einfach nur zu Testzwecken
verschieben.

MfG
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2303
Location: Germany

PostPosted: Fri Sep 14, 2012 1:27 pm    Post subject: Reply with quote

oliver2104 wrote:
Code:
* Found existing 1_files.rr
Es gab bei dir wahrscheinlich irgendwann mal ein revdep-rebuild welches nicht vollständig erfolgreich zu ende merged werden konnte - und genau diese noch nicht erfolgreich korrigierten Pakete merkt sich revdep-rebuild im Cache, und wird diese immer wieder versuchen zu re-emergen (auch dann, wenn es das Paket eventuell schon gar nicht mehr gibt).
Versuche es am besten zunächst erst mal mit einem komplett neuen Check (mit der i Option) -->
Code:
revdep-rebuild -i

Genaueres findet sich dazu in "man revdep-rebuild"
Back to top
View user's profile Send private message
oliver2104
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jul 2004
Posts: 141
Location: Wien

PostPosted: Sun Sep 16, 2012 9:01 am    Post subject: [gelöst] revdep-rebuild:Unable to proceed Reply with quote

hab die datei /usr/lib/ruby/site_ruby/1.8/i686-linux/gdal.backup.0000
einfach gelöscht ebenso wie alle *.rr Dateien unter /var/cache/revdep-rebuild/
und revdep-rebuild -i gestartet.
das Ergebnis schaut gut aus :
Code:

 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 100% ]                 

 * Dynamic linking on your system is consistent... All done.

vielen Dank
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum