Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to upgrade Python 2.6 to 2.7
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
dafi
n00b
n00b


Joined: 19 Jul 2007
Posts: 21
Location: Poznań, Poland

PostPosted: Wed Sep 28, 2011 4:55 pm    Post subject: Reply with quote

I can't select python version
Code:
eselect python set python2.7
!!! Error: Couldn't source /usr/share/eselect/modules/python.eselect
Call stack:
    * do_action (core.bash:83)
    * main (eselect:191)
exiting

any ideas ?
_________________
Long distance GentOO User
Back to top
View user's profile Send private message
West201
Tux's lil' helper
Tux's lil' helper


Joined: 22 Dec 2011
Posts: 105

PostPosted: Sat Dec 24, 2011 11:41 pm    Post subject: Reply with quote

Thanks for guide :)

I was just starting to look for this. Although is there a way to tell which version of Python I already have ? I installed Gentoo 4 days ago.
Back to top
View user's profile Send private message
m4chine
Apprentice
Apprentice


Joined: 12 Mar 2003
Posts: 271
Location: Ventura, CA, USA

PostPosted: Thu Jan 05, 2012 4:16 pm    Post subject: Reply with quote

JESSEJJ89 wrote:
Thanks for guide :)

I was just starting to look for this. Although is there a way to tell which version of Python I already have ? I installed Gentoo 4 days ago.


Yes -
Code:
eselect python list

_________________
never trust a man who can count to 1023 on his fingers.

-m4chine
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5743
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Sep 13, 2012 12:56 pm    Post subject: Reply with quote

thanks for this thread to Helena & the answers to everyone who contributed :)

*goes off to system-maintenance"
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 6
Location: There !

PostPosted: Wed Aug 14, 2013 8:52 am    Post subject: update specific package Reply with quote

How do I update an specific package with emerge, I know I can, but how ?
Back to top
View user's profile Send private message
dianemcmillan
n00b
n00b


Joined: 31 Oct 2013
Posts: 1

PostPosted: Wed Nov 06, 2013 3:48 am    Post subject: Reply: Reply with quote

@mikegpitt
Thanks for providing the indication of these steps. Now I know the explanation on those steps.
Back to top
View user's profile Send private message
idoerg
n00b
n00b


Joined: 22 Jan 2012
Posts: 27

PostPosted: Tue Jan 14, 2014 6:04 pm    Post subject: Re: How to upgrade Python 2.6 to 2.7 Reply with quote

Helena wrote:
EDIT revised to quickly display the solution without having to search the entire topic

In the stable tree python 2.7 has been available for some time. However the upgrade from 2.6 needs to be performed in a certain manner.

Immediately after emerging python 2.7 a message is displayed by portage about running python-updater. This message does not list all steps required which are:
Code:
eselect python set python2.7
python-updater
emerge --depclean
revdep-rebuild
NOTE of course the last two lines may affect other packages as well!


So I tried that, but when I try python-update, packages seem to still have 2.6 dependencies, and won't build due to slot conflicts. For example:


Code:

(dev-python/sphinx-1.2::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/sphinx[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/pexpect-3.0::gentoo, ebuild scheduled for merge)
    dev-python/sphinx[python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (dev-python/matplotlib-1.3.1::gentoo, ebuild scheduled for merge)



I tried installing 2.6 before running python-updater, but that didn't help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum