Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problem on boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 308

PostPosted: Mon Sep 03, 2012 8:38 am    Post subject: [SOLVED] Problem on boot Reply with quote

New install on laptop. It boots fast, but when it comes to dhcpcd:
Code:
* Running dhcpcd ....
dhcpcd[12523]: version 5.2.12 starting
dhcpcd[12523]: eth0: rebinding lease of 192.168.0.4
dhcpcd[12523]: eth0: acknowledged 192.168.0.4 from 192.168.0.1
dhcpcd[12523]: eth0: checking for 192.168.0.4
dhcpcd[12523]: eth0: leased 192.168.0.4 for 259200 seconds
dhcpcd[12523]: forked to background, child pid 12540 [ok]
                received address 192.168.0.4/24  [ok]
           Adding routes
                default via 192.168.0.1 ...
SIOCADDRT: File exists     [!!]
* Mounting network filesystems ...  [ok]
Starting syslog-ng ...  [ok]
Doing udev cleanups ...  [ok]
Starting vixie-cron ...     [ok]
Starting local ... [ok]


After this, it drives me to:
Code:
 This is rpil.unknown_domain (Linux i686 3.3.8-gentoo) 07:43:49
rpil login:

What is wrong here?


Last edited by rpil on Wed Sep 12, 2012 8:13 pm; edited 2 times in total
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1141
Location: Austria

PostPosted: Mon Sep 03, 2012 8:40 am    Post subject: Reply with quote

What does your network configuration look like (/etc/conf.d/net)?
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 308

PostPosted: Mon Sep 03, 2012 8:49 am    Post subject: Reply with quote

Code:
dns_domain_lo="ippokratis"
config_eth0="192.168.0.2 netmask 255.255.255.0 brd 192.168.0.255"
routes_eth0="default via 192.168.0.1"
config_eth0="dhcp"
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1141
Location: Austria

PostPosted: Mon Sep 03, 2012 8:53 am    Post subject: Reply with quote

rpil wrote:
Code:
dns_domain_lo="ippokratis"
config_eth0="192.168.0.2 netmask 255.255.255.0 brd 192.168.0.255"
routes_eth0="default via 192.168.0.1"
config_eth0="dhcp"


Remove
Code:
config_eth0="192.168.0.2 netmask 255.255.255.0 brd 192.168.0.255"
routes_eth0="default via 192.168.0.1"
and try again.
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 308

PostPosted: Mon Sep 03, 2012 9:01 am    Post subject: Reply with quote

Now, it's OK but I'm in unknown_domain again? Why?? :?
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1141
Location: Austria

PostPosted: Mon Sep 03, 2012 9:09 am    Post subject: Reply with quote

Update your /etc/hosts:
Code:

127.0.0.1        rpil.ippokratis         rpil

_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 308

PostPosted: Mon Sep 03, 2012 9:13 am    Post subject: Reply with quote

Where? It says:
Code:
#IPv4 and IPv6 localhost aliases
127.0.0.1   localhost
::1            localhost


There?
I must say, that in my Desktop install it is the same and I don't have such problem.
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 372
Location: Buckinghamshire

PostPosted: Tue Sep 04, 2012 3:16 pm    Post subject: Reply with quote

rpil wrote:
Where? It says:
Code:
#IPv4 and IPv6 localhost aliases
127.0.0.1   localhost
::1            localhost


There?
I must say, that in my Desktop install it is the same and I don't have such problem.


Replace both instances of localhost with rpil.ippokratis rpil
Like this:
Code:

127.0.0.1   rpil.ippokratis  rpil
::1            rpil.ippokratis  rpil

_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 308

PostPosted: Wed Sep 12, 2012 8:12 pm    Post subject: Reply with quote

Problem solved! Help appreciated! :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum