Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME 3.4.1 meta-package in portage tree (finally)...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 6:55 pm    Post subject: GNOME 3.4.1 meta-package in portage tree (finally)... Reply with quote

Code:

emerge -avt "=gnome-base/gnome-3.4.1"

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U ~] gnome-base/gnome-3.4.1 [3.2.1] USE="bluetooth%* cups extras fallback -accessibility -cdr" 0 kB


But it pulls a bunch of unstable upgrades, such as udisk, udev, etc..

Is really safe to upgrade to 3.4.1?

And when gnome3 will be marked as stable??
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Tue Sep 11, 2012 7:04 pm    Post subject: Re: GNOME 3.4.1 meta-package in portage tree (finally)... Reply with quote

ahgblopes wrote:
Is really safe to upgrade to 3.4.1?

I've been using it for months without major problems, but since I am the person who unmasked it, my opinion is probably a bit biased.
Quote:
And when gnome3 will be marked as stable??

That decision has not been made yet. If it were only up to me, I would say 3.4.1 is a good candidate for stabilization.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 7:33 pm    Post subject: Re: GNOME 3.4.1 meta-package in portage tree (finally)... Reply with quote

tetromino wrote:
ahgblopes wrote:
Is really safe to upgrade to 3.4.1?

I've been using it for months without major problems, but since I am the person who unmasked it, my opinion is probably a bit biased.
Quote:
And when gnome3 will be marked as stable??

That decision has not been made yet. If it were only up to me, I would say 3.4.1 is a good candidate for stabilization.


I also was using various gnome3.4 packages, but not the gnome3.4.1 meta package, now i will upgrade to a 100% 3.4 gnome...

But i need your help to upgrade it... I didn't found much information about wich files in /etc/portage/ i need to change to upgrade to gnome3. My files inside these folder was a lot confusing, so i remove most of the lines of these files, and i will edit these files from scratch. Now i want to know: How is the easiest and safest way to install the gnome3.4.1 meta package? I don't want to put hundreds of lines in my portage configuration files, because it makes it very slow to calculate the dependency tree.

ps: sorry for my horrible english...
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Tue Sep 11, 2012 8:29 pm    Post subject: Reply with quote

If you want to install gnome-3.4 on a stable system, then the package.keywords.gnome3 file from the gnome overlay is probably what you want. The current version of that file is for gnome-3.5.x, but I believe that it should also work for 3.4.1.
Back to top
View user's profile Send private message
shadywack
n00b
n00b


Joined: 30 Aug 2012
Posts: 5

PostPosted: Tue Sep 11, 2012 9:06 pm    Post subject: Reply with quote

tetromino wrote:
If you want to install gnome-3.4 on a stable system, then the package.keywords.gnome3 file from the gnome overlay is probably what you want. The current version of that file is for gnome-3.5.x, but I believe that it should also work for 3.4.1.


Thanks for that! It fixed one of my issues, I didn't use the right flags to unmask certain packages that forced portage to use a now defunct version of a package. More specifically, one of the packages used a now deprecated function of udev in the build process, since udev is updated. I noticed by examining that, that I wasn't using the right flags for the unmask. Appreciate it.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 10:33 pm    Post subject: Reply with quote

That file is huge!! And about this:

Code:

The following USE changes are necessary to proceed:
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-r1[crypt], required by gnome-base/gvfs-1.12.3[udisks], required by gnome-base/gnome-core-libs-3.4.1, required by gnome-base/gnome-3.4.1, required by @selected, required by @world (argument)
>=dev-libs/libgcrypt-1.5.0-r2 static-libs
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-r1[crypt], required by gnome-base/gvfs-1.12.3[udisks], required by gnome-base/gnome-core-libs-3.4.1, required by gnome-base/gnome-3.4.1, required by @selected, required by @world (argument)
=sys-fs/udev-189 static-libs


is this "static-libs" use flag safe to use with udev and others? (can you explain me what these use flag does?)
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Tue Sep 11, 2012 10:55 pm    Post subject: Reply with quote

ahgblopes wrote:
That file is huge!! And about this:

Code:

The following USE changes are necessary to proceed:
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-r1[crypt], required by gnome-base/gvfs-1.12.3[udisks], required by gnome-base/gnome-core-libs-3.4.1, required by gnome-base/gnome-3.4.1, required by @selected, required by @world (argument)
>=dev-libs/libgcrypt-1.5.0-r2 static-libs
#required by sys-fs/cryptsetup-1.4.1[static], required by sys-fs/udisks-1.99.0-r1[crypt], required by gnome-base/gvfs-1.12.3[udisks], required by gnome-base/gnome-core-libs-3.4.1, required by gnome-base/gnome-3.4.1, required by @selected, required by @world (argument)
=sys-fs/udev-189 static-libs


is this "static-libs" use flag safe to use with udev and others? (can you explain me what these use flag does?)

The "static" flag means building statically-linked executables; "static-libs" means build static library archives that can be used to produce statically-linked executables. Generally speaking, you should only enable these flags for those packages that really need them; otherwise, these flags result in wasted disk space, and in certain situations can introduce bugs.

Genkernel before version 3.4.32 needed a static version of cryptsetup to decrypt encrypted partitions at boot time. And since a static cryptsetup executable requires static libudev and libgcrypt to generate, it pulls in udev[static-libs] and libgcrypt[static-libs] as dependencies.

If you don't use disk encryption, then emerge genkernel with USE="-crypt -cryptsetup", and then you don't need cryptsetup[static] any more. Or alternatively, just update to an unstable version of genkernel that can use dynamically-linked cryptsetup.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 11:09 pm    Post subject: Reply with quote

tetromino wrote:

The "static" flag means building statically-linked executables; "static-libs" means build static library archives that can be used to produce statically-linked executables. Generally speaking, you should only enable these flags for those packages that really need them; otherwise, these flags result in wasted disk space, and in certain situations can introduce bugs.

Genkernel before version 3.4.32 needed a static version of cryptsetup to decrypt encrypted partitions at boot time. And since a static cryptsetup executable requires static libudev and libgcrypt to generate, it pulls in udev[static-libs] and libgcrypt[static-libs] as dependencies.

If you don't use disk encryption, then emerge genkernel with USE="-crypt -cryptsetup", and then you don't need cryptsetup[static] any more. Or alternatively, just update to an unstable version of genkernel that can use dynamically-linked cryptsetup.


But i don't use genkernel!! maybe unetbootin or something similar is pulling it.... I will try to use the global -crypt and -cryptsetup use flag, and i will see what happens... Thank you very much for explain me!

edit:i have a question:

in the unmask file, what means the "~" after a line means? (for example: ~sys-auth/polkit-0.107)
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Tue Sep 11, 2012 11:24 pm    Post subject: Reply with quote

ahgblopes wrote:
I will try to use the global -crypt and -cryptsetup use flag, and i will see what happens...

I do not recommend it. USE=crypt should be enabled globally, with exceptions only for specific packages.
Quote:
in the unmask file, what means the "~" after a line means? (for example: ~sys-auth/polkit-0.107)

The '~' prefix in front of a package and version means "any revision of that version" (so ~sys-auth/polkit-0.107 means sys-auth/polkit-0.107, or sys-auth/polkit-0.107-r1, or sys-auth/polkit-0.107-r2, etc.) See "man 5 ebuild" for an in-depth description of the portage's dependency format ("DEPEND Atoms" section).
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 11:35 pm    Post subject: Reply with quote

tetromino wrote:
ahgblopes wrote:
I will try to use the global -crypt and -cryptsetup use flag, and i will see what happens...

I do not recommend it. USE=crypt should be enabled globally, with exceptions only for specific packages.
Quote:
in the unmask file, what means the "~" after a line means? (for example: ~sys-auth/polkit-0.107)

The '~' prefix in front of a package and version means "any revision of that version" (so ~sys-auth/polkit-0.107 means sys-auth/polkit-0.107, or sys-auth/polkit-0.107-r1, or sys-auth/polkit-0.107-r2, etc.) See "man 5 ebuild" for an in-depth description of the portage's dependency format ("DEPEND Atoms" section).



Thanks for the fast replies! Disabling crypt solved the problem, but if you don't recommend so, i will try to find what app is pulling cryptsetup...

I put that huge file inside the /etc/portage/package.keywords/, but i commented the gnome-base/gnome line, and put this line:

=gnome-base/gnome-3.4.1 in /etc/portage/package.accept_keywords

Now i get a much more clean upgrade, i will post my results son.


edit:

I discovered that sys-fs/udisks-1.99.0-r1 "crypt" use flag is pulling cryptsetup. Can i disable the crypt use flag for udisks? Is it safe?
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 11, 2012 11:58 pm    Post subject: Reply with quote

Code:

sys-fs/udev:0

  (sys-fs/udev-171-r6::gentoo, installed) pulled in by
    <sys-fs/udev-185 required by (net-wireless/bluez-4.99::gentoo, installed)

  (sys-fs/udev-189::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-187 required by (sys-fs/udev-init-scripts-16::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)



What is more safe? to upgrade net-wireless/bluez-4.99 (use a version that accepts >sys-fs/udev-185) or to downgrade sys-fs/udev-init-scripts-16 (use a version that accepts =sys-fs/udev-185)?
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 558

PostPosted: Wed Sep 12, 2012 5:20 pm    Post subject: Reply with quote

Tetromino, so you haven't had any random gnome-shell crashes with 3.4?

With Debian Wheezy and Ubuntu 12.04, I would get a lot of gnome-shell lockups and crashes (particularly with evolution)

Also, every time I try to upgrade gnome 2.32 to gnome 3 in Gentoo, I run into this bug:
https://bugs.gentoo.org/show_bug.cgi?id=403283
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Wed Sep 12, 2012 8:08 pm    Post subject: Reply with quote

ahgblopes: upgrade bluez.

epsilon72: no, gnome-shell-3.4 and evolution-3.4 work well for me. But note that I test only with nvidia-drivers and mesa[video_cards_intel]; I have no personal experience with how things work on nouveau or with ati cards.

About bug #403283: that bug report is a complete mess. By now it's become a bunch of unrelated causes lumped into one bug report, and I suspect that most of those causes are people attempting various weird non-standard configurations with their dbus, polkit, pam, filesystem permissions, and so forth. Until someone in that bug report can explain exactly what is causing their gdm to break, or at least provides a way for me to reproduce the problem on my machine, I can't do anything to help fix it.
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 558

PostPosted: Thu Sep 13, 2012 12:13 am    Post subject: Reply with quote

Regarding bug #403283: I thought the consensus was that it is a polkit problem? I wonder if the only people who are getting it are those that are taking their stable systems and upgrading just gnome and its components to ~unstable.
Back to top
View user's profile Send private message
sedorox
Apprentice
Apprentice


Joined: 13 Feb 2004
Posts: 198
Location: Williamsport, PA

PostPosted: Tue Sep 18, 2012 12:47 am    Post subject: Reply with quote

epsilon72 wrote:
Tetromino, so you haven't had any random gnome-shell crashes with 3.4?

With Debian Wheezy and Ubuntu 12.04, I would get a lot of gnome-shell lockups and crashes (particularly with evolution)

Also, every time I try to upgrade gnome 2.32 to gnome 3 in Gentoo, I run into this bug:
https://bugs.gentoo.org/show_bug.cgi?id=403283


I just updated the bug with my findings, as I ran into the same thing going to 3.4.1 (although 3.2 was fine).
Do you happen to have "ldap" in your use flags, at least for gdm? If so, try compiling without it: USE="-ldap" emerge gdm
I do have my authentication through LDAP, and with nsswitch and PAM still setup, it's working fine.
Edit: I have always ran ~AMD64, so I doubt it's an going to unstable from stable issue.
_________________
Home Desktop: Intel i5-2400 3.10ghz | 8G Ram | 1x 60G SSD, 1x 500G HDD
Home Server: Intel E6750 2.66Ghz| 8G Ram | 1x 500G, 2x 750G (RAID1), 1x 1T, 1x 640G
Work Desktop(GX755): Intel E8200 2.66Ghz | 8G Ram | 2x 80gig 10k rpm, 1x 250gig
All ~AMD64
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 558

PostPosted: Tue Sep 18, 2012 6:54 am    Post subject: Reply with quote

ldap isn't in my make.conf USE flags but it is still enabled with gdm-3.4.1-r1 by default. I'll try building it without ldap and see how it goes.
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 558

PostPosted: Sun Sep 23, 2012 5:20 am    Post subject: Reply with quote

I've tested gdm-3.4.1-r1 and it works, but there's a catch. It will only start if it is started as part of the normal boot process. If I run
Code:
# /etc/init.d/xdm start
I get the spinning busy cursor with a blank screen. How is that even possible?
Back to top
View user's profile Send private message
Anarcho
Advocate
Advocate


Joined: 06 Jun 2004
Posts: 2959
Location: Wuppertal (Germany)

PostPosted: Tue Sep 25, 2012 11:29 am    Post subject: Reply with quote

Does anyone has experience with gnome 3 and xinerama/twinview and 2 monitors?

I use gnome 3.2 on the laptop and its running fine but I have some doubts to upgrade my desktop with 2 monitors.
_________________
...it's only Rock'n'Roll, but I like it!
HOWTO:WLAN mit OpenVPN absichern | TOOL:useedit - USE-flag editor/changer
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 669

PostPosted: Tue Sep 25, 2012 4:02 pm    Post subject: Reply with quote

ahgblopes wrote:
I discovered that sys-fs/udisks-1.99.0-r1 "crypt" use flag is pulling cryptsetup. Can i disable the crypt use flag for udisks? Is it safe?
Yes. The crypt USE flag enables encryption; if you have encrypted disks, and you want to manage them with udisk, you will need that USE flag. But if you don't have encrypted disks, (you probably don't) this is unnecessary.

Do not disable crypt globally, you may lose encryption in places where you really, really need it.
_________________
My political bias.
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 367

PostPosted: Sat Nov 03, 2012 1:25 am    Post subject: Reply with quote

I prefer not to make my package.keywords open-ended. In other words, instead of adding 'gnome-base/gnome', I prefer to add something like '<gnome-base/gnome-3.4.2'. I have multiple reasons, such as wanting to reduce unnecessary installations/upgrades on my solid-state drive. Do you have some sort of list like this, that includes only the lowest necessary upgrade? I could make one, but it would take a while.
Back to top
View user's profile Send private message
EatMeerkats
Apprentice
Apprentice


Joined: 15 Mar 2006
Posts: 234

PostPosted: Sat Nov 03, 2012 2:25 am    Post subject: Reply with quote

keet wrote:
I prefer not to make my package.keywords open-ended. In other words, instead of adding 'gnome-base/gnome', I prefer to add something like '<gnome-base/gnome-3.4.2'. I have multiple reasons, such as wanting to reduce unnecessary installations/upgrades on my solid-state drive. Do you have some sort of list like this, that includes only the lowest necessary upgrade? I could make one, but it would take a while.

"emerge --autounmask-write" will do this for you automatically.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum