Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Update] Gnome 3.4.2 problems with extensions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Mon Sep 10, 2012 12:53 pm    Post subject: [Update] Gnome 3.4.2 problems with extensions Reply with quote

Hi everyone, I had a messy Gnome update this weekend and I would like to know if I'm the only one that had a lot of problems.

On my Gentoo testing(only testing without any overlays) box, I updated from Gnome 3.2 to Gnome 3.4.

I lost all my Gnome extension and even inside Gnome Tweak tools, I had a lot of yellow triangles with a ! that said that all my extensions were disabled.

So, to debug my box I checked these 2 packages :

Gnome-shell-extensions and gnome-shell-frippery

http://en.znurt.org/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.4.0-r1
http://en.znurt.org/gnome-extra/gnome-shell-frippery/gnome-shell-frippery-0.3.6

I had on my box these two and I also checked if these extensions were enabled with the eselect gnome-shell-extensions command.

I tried this actually :

# eselect gnome-shell-extensions update
# eselect gnome-shell-extensions enable 1

They were enable but when I tried to enable or disable an extension I had a lot of messages about changing paths or something like that.

I relaunched the Gnome-shell a lot of times without any success.

So, after seeing all that, I rested my Gnome profile with these 3 commands :

# rm -rf /usr/share/gnome-shell/extensions/
$ rm -rf ~/.local/share/gnome-shell/extensions
$ rm -rf ~/.config/dconf

And I went to https://extensions.gnome.org/ and I reinstalled all my extensions with the webapp.

Now, everything is good, but I would like to know if it's the new way to deal with extensions or there's something wrong with the Gentoo packages ?

For the rest, everything went fine as usual :P

Thanks !!!
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Tue Sep 11, 2012 7:37 am    Post subject: Reply with quote

I am unable to reproduce your symptoms.

After upgrading a machine from gnome-3.2 to gnome-3.4, the extensions started working as soon as I updated from gnome-shell-extensions-3.2.2 to 3.4.0-r1 and restarted gnome-shell.

Note that I did not have any 3.2-era extensions in ~/.local/share/gnome-shell/extensions. If you had some, they might have caused a conflict of some kind, but to determine exactly what happened, you would need to go to the logs from looking glass (Alt-F2 → lg → Extensions → Show Errors).

Another possibility is that all of the extensions that you tried had a 3.2 version that was installed in ~/.local/share/gnome-shell/extensions. Gnome-shell prefers local extensions in ~/.local/share/gnome-shell/extensions over those installed systemwide in /usr/share/local/gnome-shell/extensions/, so when you upgraded systemwide extensions to gnome-extra/gnome-shell-extensions-3.4.0-r1, it would have appeared to have no effect. In that case, a sufficient solution would have been to delete your ~/.local/share/gnome-shell/extensions directory.
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Tue Sep 11, 2012 12:31 pm    Post subject: Reply with quote

I'm gonna retry tonight, but I tested this last sunday :

Code:

# rm -rf /usr/share/gnome-shell/extensions/
$ rm -rf ~/.local/share/gnome-shell/extensions
$ rm -rf ~/.config/dconf
# emerge -av gnome-shell-extensions gnome-shell-frippery


I rebooted my box and I saw that my gnome-shell-extensions submenu inside the gnome-tweak-tool was empty.

Also, can you check if you have some kind of messages or something that output a lot of stuff when you run this :

Code:

# eselect gnome-shell-extensions enable 1

_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec


Last edited by d2_racing on Wed Sep 12, 2012 12:59 am; edited 1 time in total
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Tue Sep 11, 2012 6:40 pm    Post subject: Reply with quote

d2_racing wrote:
Also, can you check if you have some kind of messages or something that output a lot of stuff when you run this :

Code:

# eselect gnome-shell-extensions enable 1

Fixed in eselect-gnome-shell-extensions-20120911. In the future, please report bugs in bugzilla :)
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Sep 12, 2012 1:01 am    Post subject: Reply with quote

Hi, when I try to run this :

Code:

# eselect gnome-shell-extensions list
Available extensions (* means enabled for all users by default):
  [1]   Applications_Menu@rmy.pobox.com *
  [2]   Bottom_Panel@rmy.pobox.com *
  [3]   Move_Clock@rmy.pobox.com
  [4]   Panel_Favorites@rmy.pobox.com
  [5]   Shut_Down_Menu@rmy.pobox.com
  [6]   Static_Workspaces@rmy.pobox.com
  [7]   alternate-tab@gnome-shell-extensions.gcampax.github.com
  [8]   alternative-status-menu@gnome-shell-extensions.gcampax.github.com
  [9]   apps-menu@gnome-shell-extensions.gcampax.github.com
  [10]  auto-move-windows@gnome-shell-extensions.gcampax.github.com
  [11]  dock@gnome-shell-extensions.gcampax.github.com
  [12]  drive-menu@gnome-shell-extensions.gcampax.github.com
  [13]  gajim@gnome-shell-extensions.gcampax.github.com
  [14]  native-window-placement@gnome-shell-extensions.gcampax.github.com
  [15]  places-menu@gnome-shell-extensions.gcampax.github.com
  [16]  systemMonitor@gnome-shell-extensions.gcampax.github.com
  [17]  user-theme@gnome-shell-extensions.gcampax.github.com
  [18]  windowsNavigator@gnome-shell-extensions.gcampax.github.com
  [19]  workspace-indicator@gnome-shell-extensions.gcampax.github.com
  [20]  xrandr-indicator@gnome-shell-extensions.gcampax.github.com


Code:

# eselect gnome-shell-extensions enable 1


Code:

eselect gnome-shell-extensions enable 1
warning: Schema 'org.freedesktop.Geoclue' has path '/apps/geoclue/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.freedesktop.Telepathy.Logger' has path '/apps/telepathy-logger/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.Cheese' has path '/apps/cheese/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.Vino' has path '/desktop/gnome/remote-access/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.crypto.cache' has path '/desktop/gnome/crypto/cache/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.crypto.pgp' has path '/desktop/gnome/crypto/pgp/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.seahorse' has path '/apps/seahorse/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.seahorse.manager' has path '/apps/seahorse/listing/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.locale' has path '/system/locale/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy' has path '/system/proxy/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.http' has path '/system/proxy/http/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.https' has path '/system/proxy/https/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.ftp' has path '/system/proxy/ftp/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.gnome.system.proxy.socks' has path '/system/proxy/socks/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.sharing.org-yorba-shotwell-publishing-piwigo' has path '/apps/shotwell/sharing/org-yorba-shotwell-publishing-piwigo/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.sharing.org-yorba-shotwell-publishing-yandex-fotki' has path '/apps/shotwell/sharing/org-yorba-shotwell-publishing-yandex-fotki/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell' has path '/apps/shotwell/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.preferences' has path '/apps/shotwell/preferences/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.preferences.ui' has path '/apps/shotwell/preferences/ui/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.preferences.slideshow' has path '/apps/shotwell/preferences/slideshow/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.preferences.window' has path '/apps/shotwell/preferences/window/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.preferences.files' has path '/apps/shotwell/preferences/files/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.crop-settings' has path '/apps/shotwell/crop-settings/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.preferences.editing' has path '/apps/shotwell/preferences/editing/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.sharing' has path '/apps/shotwell/sharing/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.sharing.facebook' has path '/apps/shotwell/sharing/facebook/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.sharing.flickr' has path '/apps/shotwell/sharing/flickr/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.sharing.picasa' has path '/apps/shotwell/sharing/picasa/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.sharing.youtube' has path '/apps/shotwell/sharing/youtube/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.dataimports' has path '/apps/shotwell/dataimports/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.video' has path '/apps/shotwell/video/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.printing' has path '/apps/shotwell/printing/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.plugins' has path '/apps/shotwell/plugins/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'org.yorba.shotwell.plugins.enable-state' has path '/apps/shotwell/plugins/enable-state/'.  Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.


Also, I ran the lg command and I have this :

Extension is not compatible with the Current Gnome shell and/or GJS version.

Code:

funtootux ~ # qlist -ICv gnome-shell
app-admin/eselect-gnome-shell-extensions-20111211
gnome-base/gnome-shell-3.4.2
gnome-extra/gnome-shell-extensions-3.4.0-r1
gnome-extra/gnome-shell-frippery-0.3.6


Code:

funtootux ~ # qlist -ICv gjs
dev-libs/gjs-1.32.0


Also, now I can at least have some extensions that are working :

https://www.funtoo-quebec.org/index/Config_Sylvain/Bug_1.png
https://www.funtoo-quebec.org/index/Config_Sylvain/Bug_2.png

Any idea how to fix this ?
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Sep 12, 2012 1:28 am    Post subject: Reply with quote

I have this :

Code:

 /usr/share/gnome-shell/extensions $ ls
Applications_Menu@rmy.pobox.com
Bottom_Panel@rmy.pobox.com
Move_Clock@rmy.pobox.com
Panel_Favorites@rmy.pobox.com
Shut_Down_Menu@rmy.pobox.com
Static_Workspaces@rmy.pobox.com
alternate-tab@gnome-shell-extensions.gcampax.github.com
alternative-status-menu@gnome-shell-extensions.gcampax.github.com
apps-menu@gnome-shell-extensions.gcampax.github.com
auto-move-windows@gnome-shell-extensions.gcampax.github.com
dock@gnome-shell-extensions.gcampax.github.com
drive-menu@gnome-shell-extensions.gcampax.github.com
gajim@gnome-shell-extensions.gcampax.github.com
native-window-placement@gnome-shell-extensions.gcampax.github.com
places-menu@gnome-shell-extensions.gcampax.github.com
systemMonitor@gnome-shell-extensions.gcampax.github.com
user-theme@gnome-shell-extensions.gcampax.github.com
windowsNavigator@gnome-shell-extensions.gcampax.github.com
workspace-indicator@gnome-shell-extensions.gcampax.github.com
xrandr-indicator@gnome-shell-extensions.gcampax.github.com


Code:

~/.local/share/gnome-shell/extensions $ ls -la
total 8
drwxr-xr-x 2 sylvain sylvain 4096 11 sep 20:56 .
drwx------ 3 sylvain sylvain 4096 11 sep 21:22 ..

_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
tetromino
Developer
Developer


Joined: 02 Dec 2003
Posts: 214

PostPosted: Wed Sep 12, 2012 3:48 am    Post subject: Reply with quote

The problem was that gnome-shell-frippery-0.3.6 is incompatible with gnome-shell-3.4. I had forgotten to do a version bump for it; thanks for reminding me about it.

gnome-shell-frippery-0.4.1 is now in portage, and should fix the problem for you. In addition, you can update to eselect-gnome-shell-extensions-20120911 to avoid seeing error messages about paths starting with /apps/.
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Sep 12, 2012 2:46 pm    Post subject: Reply with quote

Thanks Tetromino for the quick fix :P
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum