Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Sep 02, 2012 8:38 pm    Post subject: Reply with quote

shiznix wrote:
OK I've finally managed to fix the window decoration bugs as they relate to the top bar and appmenu.
These were disappearing window decoration on window restore and top window decoration still present on maximise instead of it snapping into the top appmenu bar.

I'll commit a fix ASAP but you can apply the fix yourself in the meantime.

For unity-2d, open up gconf-editor as your desktop user and disable the following key:
Code:
/apps/metacity/general/show_maximized_titlebars

For unity (3d), open up ccsm as your desktop user and go to 'Effects > Window Decoration'.
Where it says 'any' in the 'Decoration Windows' dialog box, change it to:
Code:
!state=maxvert


(in unity3d) It doesn't work :cry: :cry: :cry: :cry:
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Mon Sep 03, 2012 6:36 am    Post subject: Reply with quote

shiznix wrote:
@Aquous
Hi, thanks for the QT report, this has been fixed.
You sure? I'm still getting the failed patch error with qt-gui.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Sep 03, 2012 6:46 am    Post subject: Reply with quote

Aquous wrote:
shiznix wrote:
@Aquous
Hi, thanks for the QT report, this has been fixed.
You sure? I'm still getting the failed patch error with qt-gui.


Did you tried layman -d unity-gentoo; layman -a unity-gentoo; emerge --sync ?
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Mon Sep 03, 2012 7:44 am    Post subject: Reply with quote

ahgblopes wrote:
Aquous wrote:
shiznix wrote:
@Aquous
Hi, thanks for the QT report, this has been fixed.
You sure? I'm still getting the failed patch error with qt-gui.


Did you tried layman -d unity-gentoo; layman -a unity-gentoo; emerge --sync ?
Yes - the patch still fails.

edit: also, unity-base/compiz should depend on dev-python/pyrex or compilation will fail with 'pyrexc: command not found' ;)
Back to top
View user's profile Send private message
Strowi
l33t
l33t


Joined: 19 Aug 2003
Posts: 655
Location: Bonn

PostPosted: Mon Sep 03, 2012 10:42 am    Post subject: Reply with quote

hi,

do you already have a working unity-greeter in that overlay? I checked yesterday and couldn't find it. So i went ahead and got experimental.. So far it seems to work (after i figured out the switched to gsettings instead of a config-file). It's basically working, but i couldn't check the indicator-stuff since i haven't gotten around to figuring that mess out.

If you want to take a look at it or merge it into the unity overlay, please take a look at http://blog.hasnoname.de/linux/funtoogentoo/unity-greeter-12-10-2-on-funtoogentoo/ .
_________________
--
Linux & such ...
http://blog.hasnoname.de


Last edited by Strowi on Mon Sep 03, 2012 10:42 am; edited 1 time in total
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Mon Sep 03, 2012 10:42 am    Post subject: Reply with quote

ahgblopes wrote:
shiznix wrote:
For unity (3d), open up ccsm as your desktop user and go to 'Effects > Window Decoration'.
Where it says 'any' in the 'Decoration Windows' dialog box, change it to:
Code:
!state=maxvert


(in unity3d) It doesn't work :cry: :cry: :cry: :cry:
Does unity-3d work at all ?
Is it just the window decoration not disappearing on maximise ?
You shouldn't have to set this yourself now anyway as it gets applied within the source as a default setting for the decor compiz plugin.
Same goes for unity2d, it auto sets the needed gconf key for metacity.

Aquous, is the patch failing to download or is the patch failing to apply ?
Can you provide some terminal output showing how it fails.

Thanks.
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Mon Sep 03, 2012 11:28 am    Post subject: Reply with quote

The patch fails in exactly the same way as in my previous post --
Code:
>>> Source unpacked in /var/tmp/portage/x11-libs/qt-gui-99.4.8.2/work
>>> Preparing source in /var/tmp/portage/x11-libs/qt-gui-99.4.8.2/work/qt-everywhere-opensource-src-4.8.2 ...
 * Applying qt-gui-4.7.3-cups.patch ...

 * Failed Patch: qt-gui-4.7.3-cups.patch !
 *  ( /var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/x11-libs/qt-gui-99.4.8.2/temp/qt-gui-4.7.3-cups.patch.out

the .out file:
Code:
***** qt-gui-4.7.3-cups.patch *****
PWD: /var/tmp/portage/x11-libs/qt-gui-99.4.8.2/work/qt-everywhere-opensource-src-4.8.2

===================================

PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p1 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
patching file src/gui/dialogs/qprintdialog_unix.cpp
Hunk #1 FAILED at 569.
1 out of 1 hunk FAILED -- saving rejects to file src/gui/dialogs/qprintdialog_unix.cpp.rej
patching file src/gui/painting/qprinter.cpp
Hunk #1 succeeded at 229 with fuzz 2 (offset -398 lines).

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p2 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p3 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p4 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1

If it matters, I have USE=-cups set globally.

edit1: commenting out the patch in the ebuild works around the issue.

edit2: but it doesn't build (this is with MAKEOPTS=-j1 LC_ALL=C):
Code:
x86_64-pc-linux-gnu-g++ -c -O2 -march=native -pipe -ggdb -floop-interchange -floop-strip-mine -floop-block -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -O2 -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_SHARED -DQT_BUILD_DECLARATIVE_LIB -DQT_NO_URL_CAST_FROM_STRING -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_NO_OPENTYPE -DQT_NO_DEBUG -DQT_SCRIPT_LIB -DQT_SQL_LIB -DQT_XMLPATTERNS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 -DQT_HAVE_SSE4_1 -DQT_HAVE_SSE4_2 -DQT_HAVE_AVX -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../mkspecs/linux-g++ -I. -I../../include/QtCore -I../../include/QtNetwork -I../../include/QtGui -I../../include/QtXmlPatterns -I../../include/QtSql -I../../include/QtScript -I../../include -I../../include/QtDeclarative -I.rcc/release-shared -Iutil -Igraphicsitems -Iqml -Iqml/parser -Iqml/rewriter -Idebugger -I../3rdparty/harfbuzz/src -I.moc/release-shared -o .obj/release-shared/qdeclarativeaccessibility.o util/qdeclarativeaccessibility.cpp
In file included from ../../include/QtDeclarative/qdeclarativeitem.h:1:0,
                 from util/qdeclarativeaccessibility.cpp:45:
../../include/QtDeclarative/../../src/declarative/graphicsitems/qdeclarativeitem.h:143:5: error: 'QAccessible' does not name a type
../../include/QtDeclarative/../../src/declarative/graphicsitems/qdeclarativeitem.h:144:28: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp: In member function 'virtual void QDeclarativeAccessibilityUpdater::itemVisibilityChanged(QDeclarativeItem*)':
util/qdeclarativeaccessibility.cpp:98:5: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp:98:67: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp:98:93: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp: In member function 'virtual void QDeclarativeAccessibilityUpdater::itemOpacityChanged(QDeclarativeItem*)':
util/qdeclarativeaccessibility.cpp:103:5: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp:103:79: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp:103:105: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp: In member function 'virtual void QDeclarativeAccessibilityUpdater::itemDestroyed(QDeclarativeItem*)':
util/qdeclarativeaccessibility.cpp:108:5: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp:108:47: error: 'QAccessible' has not been declared
util/qdeclarativeaccessibility.cpp: At global scope:
util/qdeclarativeaccessibility.cpp:111:6: warning: unused parameter 'object' [-Wunused-parameter]
util/qdeclarativeaccessibility.cpp:123:10: warning: unused parameter 'object' [-Wunused-parameter]
make: *** [.obj/release-shared/qdeclarativeaccessibility.o] Error 1

this is with global USE=-accessibility
edit3: fixed with USE=accessibility.

edit4: also, nux is giving a 404 when fetching.
Sorry for all the misfortune I'm reporting :(
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Tue Sep 04, 2012 2:51 am    Post subject: Reply with quote

OK, all fixes should be in now.
Version bumps, missing deps. etc.

Don't feel bad for reporting bugs. I don't necessarily come across the same ones but can usually reproduce them when they're reported.
Thanks for reporting :)

@Strowi
I haven't had a chance to look at unity-greeter yet.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 04, 2012 3:49 am    Post subject: Reply with quote

shiznix wrote:
Does unity-3d work at all ?
Is it just the window decoration not disappearing on maximise ?
You shouldn't have to set this yourself now anyway as it gets applied within the source as a default setting for the decor compiz plugin.
Same goes for unity2d, it auto sets the needed gconf key for metacity.
.


Unity works (5.14) well, but these decoration bug is really to bad for me (i have to hold alt and drag the window every time i restore it, because it is wrong placed...)

I created new user, and ccsm is already correctly configured, i don't change anything, but it doesn't work...


shiznix wrote:

I was also experiencing some problems with it.
Graphics glitches in the lens overlay that would strangely clean itself once the screen was toggled to 'Show Desktop' and back again.

Sometimes, something similar happens to me with unity 5.14 too (maybe a compiz bug?)...



Unity2d is great, but there are two things that i need to make it usable:

1) No really important, but decorated window buttons in the panel

2) really important, the alt+f2 command....

obs: is this unity from your repository using the "maximus" application? It undecorate maximized windows, i guess it might help...
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Tue Sep 04, 2012 8:10 am    Post subject: Reply with quote

Hello again!

I've made a lot of progress with my system. Most importantly, I've got unity-base/unity to merge :D
The bugs I reported have all been fixed now, except for the fact that qt-gui still fails to compile with USE=-accessibility.

I have one small new bug to report: the dependencies for unity-base/unity-webapps are not complete yet:

Code:
configure: error: Package requirements (gdk-pixbuf-2.0 glib-2.0 gobject-2.0 gio-2.0
             gio-unix-2.0 libwnck-3.0 json-glib-1.0 libsoup-2.4 packagekit-glib2 polkit-gobject-1) were not met:

No package 'packagekit-glib2' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
&
Code:
configure: error: Package requirements (libnotify unity indicate-gtk3-0.7 indicate-0.7 gtk+-3.0 sqlite3) were not met:

No package 'indicate-gtk3-0.7' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

You need to depend on app-admin/packagekit-gtk and dev-libs/libindicate[gtk].

Also, I've noticed a bug in Unity itself: unmaximized windows have their coordinates set to (0,0) by default - meaning that any non-fullscreen window will by default be positioned $(unity dock width) pixels too far to the left and $(unity top bar height) pixels too far to the top.

edit: also, the clock does not respect my time zone settings.

Thanks for all the work you do!
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Sep 04, 2012 4:51 pm    Post subject: Reply with quote

Aquous wrote:

Also, I've noticed a bug in Unity itself: unmaximized windows have their coordinates set to (0,0) by default - meaning that any non-fullscreen window will by default be positioned $(unity dock width) pixels too far to the left and $(unity top bar height) pixels too far to the top.
edit: also, the clock does not respect my time zone settings.

Thanks for all the work you do!


In a previous post i said: "Unity works (5.14) well, but these decoration bug is really to bad
for me (i have to hold alt and drag the window every time i restore it, because it is wrong placed...)"

So, it is the same bug that you are getting (windows positioned at 0,0 by default) ! Maybe disabling the "put" plugin in compiz solves it, but i cannot do it (if i change most of the plugins in ccsm, compiz crashes...)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Wed Sep 05, 2012 10:50 pm    Post subject: Reply with quote

Great to read you all got it working finally :)

Quote:
The bugs I reported have all been fixed now, except for the fact that qt-gui still fails to compile with USE=-accessibility.

USE=-accessibility is not an option, the QT patchset has some specific accessibility code for unity2d source requires it.
I've added x11-libs/qt-declarative[accessibility] as a dep. for unity-base/unity2d.
The QT set of ebuilds require 'accessibility' be set globally to the same state for all QT ebuilds, so qt-declarative[accessibility] will also pull in qt-gui[accessibility] as a requirement (or complain hard to the user to fix their package.use).

Haven't made any progress on the wrong window placement bug, aside from seeing that the problem has been a bunch of Unity bugs for some time now :cry:
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Wed Sep 05, 2012 11:36 pm    Post subject: Reply with quote

With unity(5.14), i still getting these bugs:

1) windows placed at 0,0

2) When i move a window placed at 0,0 (holding alt and dragin it), it is undecorated

3) When i disable /enable ANY plugin in ccsm, the next time i login unity doesn't start (compiz segfault)

Even if i disable a previous enabled plugin, for example, viewnport swithcer, and enable it again, compiz crashes in the next login...

When i tried it (disable then enable again a plugin) i got this (running ccsm in terminal):

Code:


ccsm

** (process:15724): WARNING **: Trying to register gtype
'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:15724): WARNING **: Trying to register gtype
'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:15724): WARNING **: Trying to register gtype
'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
Gtk-Message: Failed to load module "pk-gtk-module"
Backend     : ini
Integration : true
Profile     : default
Adding plugins
Initializing core options...done
/usr/lib64/python2.7/site-packages/ccm/Window.py:92: Warning:
g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.LeftPane.pack_start(page.LeftWidget,   True, True)
/usr/lib64/python2.7/site-packages/ccm/Window.py:95: Warning:
g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.show_all()
/usr/lib64/python2.7/site-packages/ccm/Widgets.py:1607: Warning:
g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self._table.attach (button, col, col+1, row, row+1, 0,
xpadding=TableX, ypadding=TableY)
Loading icons...
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve
property `GtkRange::trough-side-details' of type `gboolean' from rc file
value "((GString*) 0x1d4e6c0)" of type `GString'
/usr/lib64/python2.7/site-packages/ccm/Widgets.py:1612: Warning:
g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.show_all ()

** (ccsm:15724): WARNING **: Invalid borders specified for theme pixmap:
        /home/henry/.themes/Adwaita Cupertino L
Unity/gtk-2.0/assets/null.png,
borders don't fit within the image
Initializing compiztoolbox options...done
Initializing mousepoll options...done
Initializing wall options...done
Initializing move options...done
Initializing gnomecompat options...done
Initializing session options...done
Initializing regex options...done
Initializing decor options...done
Initializing scale options...done
Initializing opengl options...done
Initializing animation options...done
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/ccm/Utils.py", line 253, in
ParseSettings
    plugin.Update ()
  File "compizconfig.pyx", line 783, in compizconfig.Plugin.Update
(src/compizconfig.c:6127)
  File "compizconfig.pyx", line 870, in
compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:7239)
KeyError: '0\x06)\x02'
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/ccm/Widgets.py", line 1481,
in enable_plugin
    plugin.Context.UpdateExtensiblePlugins ()
  File "compizconfig.pyx", line 1140, in
compizconfig.Context.UpdateExtensiblePlugins (src/compizconfig.c:10432)
  File "compizconfig.pyx", line 783, in compizconfig.Plugin.Update
(src/compizconfig.c:6127)
  File "compizconfig.pyx", line 870, in
compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:7239)
KeyError: '0\x06)\x02'
Initializing vpswitch options...done
Initializing fade options...done
Initializing snap options...done
Initializing expo options...done
Initializing ezoom options...done
Initializing composite options...done
Initializing unityshell options...done
Initializing grid options...done
Initializing resize options...done
Initializing unitymtgrabhandles options...done
Initializing place options...done
Initializing imgpng options...done
Initializing workarounds options...done
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/ccm/Widgets.py", line 1481,
in enable_plugin
    plugin.Context.UpdateExtensiblePlugins ()
  File "compizconfig.pyx", line 1140, in
compizconfig.Context.UpdateExtensiblePlugins (src/compizconfig.c:10432)
  File "compizconfig.pyx", line 783, in compizconfig.Plugin.Update
(src/compizconfig.c:6127)
  File "compizconfig.pyx", line 870, in
compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:7239)
KeyError: '0\x06)\x02'


Any idea??
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Fri Sep 07, 2012 1:44 am    Post subject: Reply with quote

Can you guys please provide a list of apps. that suffer from the wrong window position bug ?

I get it too but only on some select applications so far such as ccsm, gedit, nautilus, metacity-window-demo.

The common thread is that maybe it just affects some GTK apps.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Fri Sep 07, 2012 2:36 am    Post subject: Reply with quote

Quote:


I take some screenshots:

1) When i launch an application, normally it starts fine (maximized):
http://img26.imageshack.us/img26/5860/ps1e.png


2) But, when i hit the maximize (unmaximize) button, i get the window wrong positioned:
http://img826.imageshack.us/img826/7651/ps2y.png

3) And without borders:

http://img593.imageshack.us/img593/4690/ps3sr.png

4) And if i open it again and maximize, normally it doesn't fit anymore in the panel:

http://img207.imageshack.us/img207/5143/ps4b.png

5) And sometimes the buttons disappear:

http://img207.imageshack.us/img207/8247/ps5.png

6) In Unity-2d, normally, the windows don't fit in the panel, but i see (and they work) the window buttons on the panel:

http://img707.imageshack.us/img707/6844/ps6.png



6 = SOLVED, now unity2d works like a charm (i'm leraning to like it...), the alt + F2 shortcut works now (i don't now why, but it is working!).. The only thing is boring me is the "fallback" window buttons (close, minimize, maximize) in panel, instead of themed buttons.

4 = solved (now windows always fit to panel, thank you for fix it)

2, 3, 5 = no way :cry:

qt apps are also wrong placed, not 0,0, but wrong placed... they start maximized, correctly positioned, but when i restore it, then it gets wrong positioned (not 0,0, but a bit inside my 32px panel)...

i have just emerged the unity-meta-5.14
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Fri Sep 07, 2012 3:25 am    Post subject: Reply with quote

Thanks for the screenshots.

Your item 5 with buttons disappearing is due to the window being unmaximised but the top of the window is hidden behind the top panel.
Again this falls back to wrong window placement.

Do you find it happens with all applications, or just a few ?
If it happens with just a few, which ones are they ?

Interestingly, firing up any of the apps. that get placed in the wrong position (such as gedit or nautilus), then launching 'ccsm' and enabling or disabling the side launcher autohide setting, those already incorrectly placed windows suddenly become aware of where they should be and jump to their correct position.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Fri Sep 07, 2012 3:29 am    Post subject: Reply with quote

shiznix wrote:
Thanks for the screenshots.

Your item 5 with buttons disappearing is due to the window being unmaximised but the top of the window is hidden behind the top panel.
Again this falls back to wrong window placement.

Do you find it happens with all applications, or just a few ?
If it happens with just a few, which ones are they ?

Interestingly, firing up any of the apps. that get placed in the wrong position (such as gedit or nautilus), then launching 'ccsm' and enabling or disabling the side launcher autohide setting, those already incorrectly placed windows suddenly become aware of where they should be and jump to their correct position.


Almost all applications... I will try to find some application that works correctly...

Thank you for the fast reply :)
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Fri Sep 07, 2012 10:11 am    Post subject: Reply with quote

I can add gnome-terminal, firefox, and vmware-workstation to the list of (0,0)-positioned apps.

Also, the launcher is ignoring my autohide settings and is always shown :(
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Fri Sep 07, 2012 10:54 pm    Post subject: Reply with quote

Aquous wrote:
I can add gnome-terminal, firefox, and vmware-workstation to the list of (0,0)-positioned apps.

Also, the launcher is ignoring my autohide settings and is always shown :(

How are you trying to set the autohide setting ?

It can currently only be set in 'ccsm' via 'Desktop > Ubuntu Unity Plugin'.
The more obvious method of setting it in system settings 'Appearance > Behaviour' does not work as it uses gconf to change compiz settings (which we don't use yet).
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Sat Sep 08, 2012 6:59 am    Post subject: Reply with quote

thanks, that explains it :)
Back to top
View user's profile Send private message
Johnny Who
n00b
n00b


Joined: 06 Aug 2012
Posts: 9
Location: Athens, Greece

PostPosted: Sun Sep 09, 2012 10:37 am    Post subject: Reply with quote

I am a sabayon user, and I would like to install unity via the gentoo-unity overlay. When I try to emerge unity-meta, I get a whole bunch of erors, whihc I quote below...
Quote:
[ebuild N ~] dev-util/boost-build-1.49.0 USE="-examples -python"
[ebuild N ] dev-libs/xapian-1.2.8 USE="brass chert flint inmemory remote sse sse2 -doc -static-libs"
[ebuild N ] gnome-base/gnome-common-3.1.0
[ebuild N ] dev-python/oauth-1.0.1
[ebuild N ~] dev-python/configglue-1.0
[ebuild N ~] dev-python/dirspec-3.99.90
[ebuild N ~] unity-base/utouch-evemu-1.0.9
[ebuild N ] dev-python/pyrex-0.9.9 USE="-examples"
[ebuild N ~] dev-python/lazr-restfulclient-0.12.0
[ebuild N ] dev-python/sip-4.13.3 USE="-debug -doc"
[ebuild N ] app-text/scrollkeeper-dtd-1.0
[ebuild N ] app-text/opensp-1.5.2-r3 USE="nls -doc -static-libs -test"
[ebuild N ] app-text/rarian-0.8.1-r1 USE="-static-libs"
[ebuild N ] app-text/scrollkeeper-9999-r1
[ebuild N ] dev-util/gdbus-codegen-2.30.3
[ebuild NS #] sys-libs/db-5.1.29 [4.8.30] USE="cxx -doc -examples -java -tcl -test"
[ebuild N ] app-text/sgml-common-0.6.3-r5
[ebuild N ] dev-libs/xapian-bindings-1.2.8 USE="python -java -lua -mono -perl -php -ruby -tcl" PHP_TARGETS="php5-3"
[ebuild UD ] dev-libs/libxml2-2.8.0_rc1 [2.8.0-r1] USE="-icu*"
[ebuild N ] app-text/docbook-dsssl-stylesheets-1.79
[ebuild N ] app-text/openjade-1.3.2-r3 USE="-static-libs"
[ebuild N ] x11-misc/icon-naming-utils-0.8.90
[ebuild N ] dev-util/gtk-doc-am-1.18
[ebuild U ~] dev-libs/glib-99.2.32.3 [2.32.1]
[ebuild U ~] dev-libs/atk-2.4.0 [2.2.0]
[ebuild NS ] dev-lang/vala-0.16.1-r1 [0.14.0] USE="vapigen -test"
[ebuild N ] x11-misc/lndir-1.0.3
[ebuild N ] x11-proto/trapproto-3.4.3
[ebuild N ] x11-proto/bigreqsproto-1.1.2 USE="-doc"
[ebuild N ] x11-proto/xf86rushproto-1.1.2-r1
[ebuild N ] x11-proto/xcmiscproto-1.2.2 USE="-doc"
[ebuild N ] x11-proto/xf86driproto-2.1.1
[ebuild U ~] x11-proto/fixesproto-5.0-r9999 [5.0]
[ebuild NS ] dev-lang/vala-0.12.1 [0.14.0] USE="vapigen -test"
[ebuild U ] media-libs/gstreamer-0.10.36 [0.10.35]
[ebuild U ~] x11-themes/gnome-icon-theme-3.4.0 [3.2.1.2] USE="branding*"
[ebuild N ] x11-apps/xvinfo-1.1.1
[ebuild N ~] x11-themes/ubuntu-mono-0.0.40
[ebuild U ~] x11-libs/libXfixes-5.0-r9999 [5.0]
[ebuild N ~] x11-themes/unity-asset-pool-0.8.23 USE="-debug"
[ebuild N ~] dev-libs/libwacom-0.5 USE="-doc -static-libs"
[ebuild U ~] app-accessibility/at-spi2-atk-2.5.3 [2.4.0]
[ebuild N ] dev-python/imaging-1.1.7-r1 USE="X lcms -doc -examples -scanner -tk"
[ebuild U ~] x11-libs/qt-core-99.4.8.2 [4.8.2]
[ebuild U ~] x11-libs/qt-dbus-99.4.8.2 [4.8.2]
[ebuild N ~] x11-libs/qt-xmlpatterns-99.4.8.2 USE="(-aqua) -c++0x -debug -pch -qpa"
[ebuild U ~] x11-libs/qt-script-99.4.8.2 [4.8.2]
[ebuild U ~] x11-libs/qt-test-99.4.8.2 [4.8.2]
[blocks b ] <x11-libs/qt-test-99.4.8.2:4 ("<x11-libs/qt-test-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[ebuild U ~] x11-libs/gtk+-99.2.24.11-r1 [2.24.10-r1] USE="-xinerama*"
[ebuild N ] x11-themes/gtk-engines-murrine-0.98.2 USE="-animation-rtl -themes"
[ebuild N ] x11-themes/light-themes-0.1.8.29 USE="-gtk3"
[ebuild U ~] gnome-base/gsettings-desktop-schemas-99.3.5.91 [3.4.2]
[ebuild N ] dev-dotnet/gtk-sharp-gapi-2.12.10 USE="-debug"
[ebuild UD ] media-libs/cogl-1.8.2 [1.10.2]
[ebuild UD ] media-libs/clutter-1.8.4 [1.10.4]
[ebuild U ~] x11-base/xorg-server-1.12.3-r9999 [1.12.3]
[ebuild U ~] x11-libs/gtk+-99.3.4.2 [3.4.3-r1] USE="-xinerama*"
[ebuild U ~] gnome-base/gconf-99.3.2.5 [3.2.5]
[ebuild N ~] dev-libs/libdbusmenu-0.6.2 USE="gtk introspection -test"
[ebuild UD ] media-libs/clutter-gtk-1.0.4 [1.2.0]
[ebuild N ~] dev-libs/libindicator-99.12.10.0
[ebuild N ~] unity-base/ido-0.3.4 USE="-debug"
[ebuild N ~] dev-libs/libtimezonemap-0.3.2 USE="-debug"
[ebuild U ] gnome-extra/polkit-gnome-99.0.105 [0.105]
[ebuild N ~] dev-libs/libunity-misc-4.0.4
[ebuild U ~] gnome-base/gnome-settings-daemon-99.3.4.2-r1 [3.4.2]
[ebuild U ~] gnome-base/gnome-session-99.3.2.1 [3.4.2.1]
[ebuild U ] app-admin/eselect-boost-0.4 [0.3]
[ebuild NS ] dev-lang/python-3.2.3 [2.7.3-r2] USE="gdbm ipv6 ncurses readline sqlite ssl threads (wide-unicode) xml -build -doc -examples -tk -wininst"
[ebuild N ] dev-libs/protobuf-2.4.0a USE="python -emacs -examples -java -source -static-libs -vim-syntax"
[ebuild NS ~] dev-libs/boost-1.49.0-r1 [1.46.1-r1] USE="eselect python -debug -doc -icu -mpi -static-libs -test -tools"
[ebuild N ~] dev-python/python-geoclue-0.1.0 USE="-test"
[ebuild N ] dev-python/bsddb3-5.3.0 USE="-doc"
[ebuild N ~] dev-python/isodate-0.4.8
[ebuild N ~] dev-python/rdflib-3.2.1 USE="berkdb -examples -mysql -redland -sqlite -test"
[ebuild N ] app-text/docbook-sgml-dtd-3.0-r3
[ebuild NS ] app-text/docbook-xml-dtd-4.3-r1 [4.2-r2]
[ebuild NS ] app-text/docbook-xml-dtd-4.4-r2 [4.2-r2]
[ebuild N ] app-text/gnome-doc-utils-0.20.10
[ebuild N ] dev-util/gtk-doc-1.18-r1 USE="-debug -doc -emacs -highlight -test -vim"
[ebuild N ~] dev-libs/libzeitgeist-0.3.18 USE="-static-libs"
[ebuild N ~] dev-libs/libindicate-12.10.0 USE="gtk introspection"
[ebuild N ~] dev-libs/dee-1.0.12 USE="icu -debug -doc -examples -static-libs -test"
[ebuild N ~] dev-libs/libunity-5.96.0
[ebuild NS ] app-text/docbook-xml-dtd-4.1.2-r6 [4.2-r2]
[ebuild UD~] app-admin/packagekit-base-0.7.4 [0.7.5] USE="networkmanager* -nsplugin*" LINGUAS="-bg* -bn* -ca* -cs* -da* -de* -el* -en_GB* -es* -fi* -fr* -gu* -he* -hi* -hu* -it* -ja* -ko* -ms* -nb* -nl* -pa* -pl* -pt* -pt_BR* -ro* -ru* -sk* -sr* -sv* -ta* -tr* -uk* -zh_CN* -zh_TW*"
[ebuild UD~] app-admin/packagekit-gtk-0.7.4 [0.7.5]
[ebuild U #] x11-wm/metacity-99.2.34.1 [2.34.1] USE="-xinerama*"
[ebuild N ~] dev-python/python-distutils-extra-2.35
[ebuild N ] net-zope/zope-fixers-1.0
[ebuild N ] net-zope/zope-interface-3.8.0
[ebuild N ~] dev-util/gdbus-codegen-2.32.4 PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1"
[ebuild N ~] unity-base/utouch-frame-2.2.3
[ebuild N ~] unity-base/utouch-grail-3.0.5
[ebuild N ~] unity-base/utouch-geis-2.2.9
[ebuild N ~] unity-base/unity-webapps-2.1
[ebuild N ~] unity-base/bamf-0.3.0 USE="introspection"
[ebuild N ] dev-python/cython-0.16 USE="-doc -examples -numpy"
[ebuild N ] dev-python/twisted-11.0.0 USE="crypt gtk -serial"
[ebuild N ] dev-python/twisted-web-11.0.0 USE="-soap"
[ebuild N ] dev-python/twisted-names-11.0.0
[ebuild N ~] unity-base/ubuntuone-storage-protocol-3.99.90
[ebuild N ~] net-wireless/blueman-1.23-r2 USE="nls policykit -gconf -network -pulseaudio -sendto"
[ebuild U ~] net-wireless/gnome-bluetooth-99.3.4.2 [3.4.0]
[ebuild N ] dev-python/gnome-python-desktop-base-2.32.0
[ebuild N ~] unity-base/launchpad-integration-0.1.56.1 USE="-debug"
[ebuild N ] app-i18n/ibus-1.4.1 USE="X gconf gtk introspection nls python -dconf -doc -gtk3 -vala"
[ebuild N ~] unity-base/nux-2.14.0
[ebuild U ~] gnome-base/gnome-menus-99.3.4.0 [3.4.2]
[ebuild N ~] gnome-extra/zeitgeist-extensions-0.0.13-r1 USE="fts geolocation -memprofile -sqldebug -tracker"
[ebuild UD ] gnome-base/gnome-keyring-2.32.1-r1 [3.4.1]
[ebuild UD ] gnome-base/libgnome-keyring-2.32.0 [3.4.1]
[ebuild N ] dev-python/gnome-keyring-python-2.32.0 USE="-examples"
[ebuild N ~] unity-base/indicator-applet-12.10.0
[ebuild N ] dev-util/cmake-2.8.8-r3 USE="ncurses qt4 -emacs -test -vim-syntax"
[ebuild N ~] dev-libs/libindicate-qt-0.2.5.91 USE="-test"
[ebuild N ~] unity-base/compiz-0.9.7.8-r1 USE="-debug"
[ebuild N ~] x11-libs/libcompizconfig-0.9.5.94 USE="-debug"
[ebuild N ~] unity-base/compizconfig-python-0.9.5.94
[ebuild N ~] x11-plugins/compiz-plugins-main-0.9.7.0 USE="-debug"
[ebuild N ~] dev-libs/libdbusmenu-qt-0.9.2 USE="-debug -doc -test"
[ebuild N ~] x11-misc/appmenu-qt-0.2.6
[ebuild N ~] unity-base/compizconfig-backend-gconf-0.9.5.92
[ebuild N ~] unity-base/ccsm-0.9.5.92
[ebuild N ~] gnome-extra/zeitgeist-datasources-0.8.0.1 USE="telepathy -bzr -chromium -emacs -eog -geany -gedit -rhythmbox -static-libs -tomboy -totem -vim -xchat"
[ebuild N ~] gnome-extra/zeitgeist-datahub-0.8.2 USE="-download"
[ebuild N ~] gnome-extra/zeitgeist-0.9.5 USE="dbus extensions fts nls passiv plugins -icu -sql-debug"
[ebuild N ~] dev-libs/libappindicator-99.12.10.0 USE="-vala"
[ebuild N ~] unity-base/indicator-appmenu-12.10.0 USE="-debug"
[ebuild U ~] gnome-extra/nm-applet-99.0.9.4.1 [0.9.4.1] USE="-debug%"
[ebuild N ~] unity-base/indicator-application-12.10.0
[ebuild N ~] unity-base/indicator-datetime-0.3.94 USE="-debug"
[ebuild N ~] unity-base/indicator-sound-12.10.0 USE="-debug"
[ebuild N ~] x11-misc/appmenu-gtk-12.10.0
[ebuild UD ] dev-db/mysql-5.1.62-r1 [5.5.22-r1] USE="-big-tables% -extraengine* -pbxt% -xtradb%"
[ebuild UD ] virtual/mysql-5.1 [5.5]
[ebuild U ~] x11-libs/qt-sql-99.4.8.2 [4.8.2]
[ebuild U ~] x11-libs/qt-gui-99.4.8.2 [4.8.2] USE="-xinerama*"
[ebuild U ~] x11-libs/qt-qt3support-99.4.8.2 [4.8.2]
[ebuild U ~] x11-libs/qt-opengl-99.4.8.2 [4.8.2]
[blocks b ] <x11-libs/qt-opengl-99.4.8.2:4 ("<x11-libs/qt-opengl-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[ebuild U ~] x11-libs/qt-svg-99.4.8.2 [4.8.2]
[blocks b ] <x11-libs/qt-svg-99.4.8.2:4 ("<x11-libs/qt-svg-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[ebuild N ~] x11-libs/qt-webkit-99.4.8.2 USE="exceptions gstreamer jit (-aqua) -debug -icu -pch -qpa"
[ebuild N ~] x11-libs/qt-declarative-99.4.8.2 USE="accessibility exceptions qt3support webkit (-aqua) -c++0x -debug -pch -qpa"
[ebuild N ~] app-admin/packagekit-qt4-0.7.4
[ebuild N ] x11-libs/qt-assistant-4.8.2-r1 USE="compat exceptions glib qt3support (-aqua) (-c++0x) -debug -doc -pch (-qpa) -trace -webkit"
[ebuild N ~] dev-libs/libqtgconf-0.1 USE="-debug"
[ebuild N ~] app-admin/packagekit-0.7.4 USE="gtk qt4"
[ebuild N ] dev-python/PyQt4-4.9.4 USE="X assistant dbus declarative examples opengl sql svg webkit -debug -doc -kde -multimedia -phonon -xmlpatterns"
[ebuild N ~] dev-libs/libqtbamf-0.2.4 USE="-debug"
[ebuild N ~] dev-libs/libqtdee-0.2.4 USE="-debug"
[ebuild N ~] unity-base/dconf-qt-0.0.0.110722 USE="-debug"
[ebuild N ~] unity-base/ubuntu-sso-client-3.99.90
[ebuild N ~] unity-base/indicator-session-0.3.96 USE="-debug"
[ebuild N ~] unity-base/ubuntuone-control-panel-3.99.90
[ebuild U ~] gnome-base/gnome-control-center-99.3.4.2 [3.4.2-r1]
[ebuild N ~] unity-base/unity-5.14.0 USE="-debug"
[ebuild N ~] unity-base/unity-lens-applications-5.12.0 USE="-debug"
[ebuild N ~] unity-base/unity-lens-video-0.3.5
[ebuild N ~] unity-base/unity2d-5.12.0 USE="-debug"
[ebuild N ~] unity-base/unity-scope-video-remote-0.3.6
[ebuild N ~] unity-base/unity-lens-files-5.10.0 USE="-debug"
[ebuild U ~] gnome-base/nautilus-99.3.4.2 [3.2.1-r1] USE="-debug%"
[ebuild N ~] unity-base/ubuntuone-client-3.99.90 USE="-doc"
[ebuild N ~] dev-libs/libubuntuone-3.99.90
[ebuild N ~] media-sound/rhythmbox-2.97 USE="cdr dbus libnotify python udev -clutter -daap -debug -doc -gnome-keyring -html -ipod -lirc -mtp -musicbrainz -nsplugin -test -upnp -webkit -zeitgeist"
[ebuild N ~] unity-base/rhythmbox-ubuntuone-3.99.90
[ebuild N ~] unity-base/unity-lens-music-5.12.0
[ebuild N ~] unity-base/unity-meta-5.14.0
[blocks B ] >x11-libs/qt-script-4.8.2-r9999:4 (">x11-libs/qt-script-4.8.2-r9999:4" is blocking x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] <x11-libs/qt-gui-99.4.8.2:4 ("<x11-libs/qt-gui-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[blocks B ] <x11-libs/qt-qt3support-99.4.8.2:4 ("<x11-libs/qt-qt3support-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[blocks B ] gnome-extra/zeitgeist[fts] ("gnome-extra/zeitgeist[fts]" is blocking gnome-extra/zeitgeist-extensions-0.0.13-r1)
[blocks B ] >x11-libs/qt-svg-4.8.2-r9999:4 (">x11-libs/qt-svg-4.8.2-r9999:4" is blocking x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] >x11-libs/qt-xmlpatterns-4.8.2-r9999:4 (">x11-libs/qt-xmlpatterns-4.8.2-r9999:4" is blocking x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] <x11-libs/qt-dbus-99.4.8.2:4 ("<x11-libs/qt-dbus-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[blocks B ] >x11-libs/qt-qt3support-4.8.2-r9999:4 (">x11-libs/qt-qt3support-4.8.2-r9999:4" is blocking x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.4.1)
[blocks B ] >x11-libs/qt-opengl-4.8.2-r9999:4 (">x11-libs/qt-opengl-4.8.2-r9999:4" is blocking x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] >x11-libs/qt-declarative-4.8.2-r9999:4 (">x11-libs/qt-declarative-4.8.2-r9999:4" is blocking x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] >x11-libs/qt-webkit-4.8.2-r9999:4 (">x11-libs/qt-webkit-4.8.2-r9999:4" is blocking x11-libs/qt-svg-4.8.2, x11-libs/qt-test-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] <x11-libs/qt-core-99.4.8.2:4 ("<x11-libs/qt-core-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[blocks B ] <x11-libs/qt-sql-99.4.8.2:4 ("<x11-libs/qt-sql-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[blocks B ] <x11-libs/qt-assistant-99.4.8.2:4 ("<x11-libs/qt-assistant-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-test-99.4.8.2, x11-libs/qt-script-99.4.8.2)
[blocks B ] >x11-libs/qt-test-4.8.2-r9999:4 (">x11-libs/qt-test-4.8.2-r9999:4" is blocking x11-libs/qt-svg-4.8.2, x11-libs/qt-core-4.8.2, x11-libs/qt-assistant-4.8.2-r1, x11-libs/qt-sql-4.8.2, x11-libs/qt-gui-4.8.2, x11-libs/qt-opengl-4.8.2, x11-libs/qt-dbus-4.8.2)
[blocks B ] <x11-libs/qt-script-99.4.8.2:4 ("<x11-libs/qt-script-99.4.8.2:4" is blocking x11-libs/qt-xmlpatterns-99.4.8.2, x11-libs/qt-webkit-99.4.8.2, x11-libs/qt-opengl-99.4.8.2, x11-libs/qt-qt3support-99.4.8.2, x11-libs/qt-declarative-99.4.8.2, x11-libs/qt-svg-99.4.8.2, x11-libs/qt-test-99.4.8.2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libXfixes:0

(x11-libs/libXfixes-5.0::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
>=x11-libs/libXfixes-5.0-r9999 required by (dev-libs/libunity-misc-4.0.4::unity-gentoo, ebuild scheduled for merge)
=x11-libs/libXfixes-5.0-r9999 required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)
(and 4 more with the same problems)

x11-proto/fixesproto:0

(x11-proto/fixesproto-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
=x11-proto/fixesproto-5.0-r9999 required by (x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge)

(x11-proto/fixesproto-5.0::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

x11-libs/qt-core:4

(x11-libs/qt-core-4.8.2::gentoo, installed) pulled in by
~x11-libs/qt-core-4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support] required by (x11-libs/qt-qt3support-4.8.2::gentoo, installed)
(and 4 more with the same problem)

(x11-libs/qt-core-99.4.8.2::unity-gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-core-99.4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support] required by (x11-libs/qt-qt3support-99.4.8.2::unity-gentoo, ebuild scheduled for merge)
>=x11-libs/qt-core-99.4.8.2:4 required by (dev-libs/libqtgconf-0.1::unity-gentoo, ebuild scheduled for merge)
(and 13 more with the same problems)

x11-libs/qt-gui:4

(x11-libs/qt-gui-4.8.2::gentoo, installed) pulled in by
~x11-libs/qt-gui-4.8.2[aqua=,c++0x=,debug=,glib=,qpa=,qt3support] required by (x11-libs/qt-core-4.8.2::gentoo, installed)
(and 2 more with the same problem)

(x11-libs/qt-gui-99.4.8.2::unity-gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-gui-99.4.8.2[aqua=,debug=,qpa=] required by (x11-libs/qt-webkit-99.4.8.2::unity-gentoo, ebuild scheduled for merge)
(and 5 more with the same problem)

x11-libs/qt-sql:4

(x11-libs/qt-sql-99.4.8.2::unity-gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-sql-99.4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support=] required by (x11-libs/qt-declarative-99.4.8.2::unity-gentoo, ebuild scheduled for merge)
(and 2 more with the same problem)

(x11-libs/qt-sql-4.8.2::gentoo, installed) pulled in by
~x11-libs/qt-sql-4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support=,sqlite] required by (x11-libs/qt-assistant-4.8.2-r1::gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

x11-libs/qt-dbus:4

(x11-libs/qt-dbus-4.8.2::gentoo, installed) pulled in by
~x11-libs/qt-dbus-4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-4.8.2::gentoo, installed)

(x11-libs/qt-dbus-99.4.8.2::unity-gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-dbus-99.4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-99.4.8.2::unity-gentoo, ebuild scheduled for merge)

dev-libs/libxml2:2

(dev-libs/libxml2-2.8.0-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(dev-libs/libxml2-2.8.0_rc1::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/libxml2:2[!icu?] required by (x11-libs/qt-webkit-99.4.8.2::unity-gentoo, ebuild scheduled for merge)

media-libs/gstreamer:0.10

(media-libs/gstreamer-0.10.36::unity-gentoo, ebuild scheduled for merge) pulled in by
>=media-libs/gstreamer-0.10.36 required by (unity-base/unity-lens-music-5.12.0::unity-gentoo, ebuild scheduled for merge)

(media-libs/gstreamer-0.10.35::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

gnome-base/gnome-menus:3

(gnome-base/gnome-menus-99.3.4.0::unity-gentoo, ebuild scheduled for merge) pulled in by
>=gnome-base/gnome-menus-99.3.4.0 required by (unity-base/unity-5.14.0::unity-gentoo, ebuild scheduled for merge)
(and 2 more with the same problem)

(gnome-base/gnome-menus-3.4.2::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

dev-util/gdbus-codegen:0

(dev-util/gdbus-codegen-2.32.4::gentoo, ebuild scheduled for merge) pulled in by
>=dev-util/gdbus-codegen-2.31.0 required by (gnome-base/nautilus-99.3.4.2::unity-gentoo, ebuild scheduled for merge)

(dev-util/gdbus-codegen-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

gnome-base/gsettings-desktop-schemas:0

(gnome-base/gsettings-desktop-schemas-99.3.5.91::unity-gentoo, ebuild scheduled for merge) pulled in by
>=gnome-base/gsettings-desktop-schemas-99.3.4.1 required by (unity-base/unity-5.14.0::unity-gentoo, ebuild scheduled for merge)

(gnome-base/gsettings-desktop-schemas-3.4.2::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

x11-themes/gnome-icon-theme:0

(x11-themes/gnome-icon-theme-3.4.0::gentoo, ebuild scheduled for merge) pulled in by
>=x11-themes/gnome-icon-theme-3.4.0 required by (x11-themes/unity-asset-pool-0.8.23::unity-gentoo, ebuild scheduled for merge)

(x11-themes/gnome-icon-theme-3.2.1.2::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

media-libs/clutter:1.0

(media-libs/clutter-1.10.4::gentoo, installed) pulled in by
>=media-libs/clutter-1.10.0:1.0[introspection] required by (gnome-extra/sushi-0.4.1::gentoo, installed)
(and 4 more with the same problem)

(media-libs/clutter-1.8.4::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

media-libs/cogl:1.0

(media-libs/cogl-1.8.2::gentoo, ebuild scheduled for merge) pulled in by
<=media-libs/cogl-1.9.2:1.0 required by (media-libs/clutter-1.8.4::gentoo, ebuild scheduled for merge)

(media-libs/cogl-1.10.2::gentoo, installed) pulled in by
>=media-libs/cogl-1.9.6:1.0[introspection?,pango] required by (media-libs/clutter-1.10.4::gentoo, installed)
(and 1 more with the same problem)

gnome-base/gnome-keyring:0

(gnome-base/gnome-keyring-3.4.1::gentoo, installed) pulled in by
>=gnome-base/gnome-keyring-3.3.90 required by (gnome-base/gnome-shell-3.4.1::sabayon-distro, installed)
(and 4 more with the same problem)

(gnome-base/gnome-keyring-2.32.1-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

gnome-base/libgnome-keyring:0

(gnome-base/libgnome-keyring-3.4.1::gentoo, installed) pulled in by
>=gnome-base/libgnome-keyring-3.2 required by (gnome-base/gnome-core-apps-3.2.1::gentoo, installed)
(and 1 more with the same problem)

(gnome-base/libgnome-keyring-2.32.0::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

media-libs/clutter-gtk:1.0

(media-libs/clutter-gtk-1.2.0::gentoo, installed) pulled in by
>=media-libs/clutter-gtk-1.1.2:1.0 required by (net-im/empathy-3.4.2.1::gentoo, installed)

(media-libs/clutter-gtk-1.0.4::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

x11-libs/qt-qt3support:4

(x11-libs/qt-qt3support-99.4.8.2::unity-gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-qt3support-99.4.8.2[accessibility=,aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-declarative-99.4.8.2::unity-gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

(x11-libs/qt-qt3support-4.8.2::gentoo, installed) pulled in by
~x11-libs/qt-qt3support-4.8.2[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-gui-4.8.2::gentoo, installed)

x11-libs/qt-script:4

(x11-libs/qt-script-99.4.8.2::unity-gentoo, ebuild scheduled for merge) pulled in by
~x11-libs/qt-script-99.4.8.2[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-declarative-99.4.8.2::unity-gentoo, ebuild scheduled for merge)
(and 1 more with the same problem)

(x11-libs/qt-script-4.8.2::gentoo, installed) pulled in by
~x11-libs/qt-script-4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-4.8.2::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libqtdee-0.2.4 ~amd64
#required by unity-base/ubuntuone-client-3.99.90, required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/nautilus-99.3.4.2 ~amd64
#required by app-admin/packagekit-0.7.4[qt4], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-qt4-0.7.4 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-plugins/compiz-plugins-main-0.9.7.0 ~amd64
#required by x11-libs/qt-gui-99.4.8.2[dbus], required by x11-libs/qt-opengl-99.4.8.2, required by x11-libs/qt-declarative-99.4.8.2, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-dbus-99.4.8.2 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by unity-base/ido-0.3.4, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/atk-2.4.0 ~amd64
#required by unity-base/ubuntuone-client-3.99.90, required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/ubuntu-sso-client-3.99.90 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/indicator-session-0.3.96 ~amd64
#required by unity-base/ubuntu-sso-client-3.99.90, required by unity-base/ubuntuone-control-panel-3.99.90, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/python-distutils-extra-2.35 ~amd64
#required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/rhythmbox-ubuntuone-3.99.90 ~amd64
#required by net-irc/xchat-2.8.8-r2[gtk], required by @selected, required by @world (argument)
=x11-libs/gtk+-99.2.24.11-r1 ~amd64
#required by gnome-extra/nm-applet-99.0.9.4.1[bluetooth], required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-wireless/gnome-bluetooth-99.3.4.2 ~amd64
#required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libtimezonemap-0.3.2 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity-5.14.0 ~amd64
#required by x11-libs/qt-gui-99.4.8.2[qt3support], required by x11-libs/qt-opengl-99.4.8.2, required by x11-libs/qt-declarative-99.4.8.2, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-qt3support-99.4.8.2 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libqtbamf-0.2.4 ~amd64
#required by gnome-base/gnome-core-apps-3.2.1, required by gnome-base/gnome-3.2.1, required by @selected, required by @world (argument)
=gnome-base/gnome-menus-99.3.4.0 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/ido-0.3.4 ~amd64
#required by app-arch/file-roller-3.4.2, required by @selected, required by @world (argument)
=x11-libs/gtk+-99.3.4.2 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/ccsm-0.9.5.92 ~amd64
#required by unity-base/ccsm-0.9.5.92, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/compizconfig-backend-gconf-0.9.5.92 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-misc/appmenu-qt-0.2.6 ~amd64
#required by unity-base/ubuntuone-client-3.99.90, required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/configglue-1.0 ~amd64
#required by x11-wm/muffin-1.0.2-r1, required by gnome-extra/cinnamon-1.4-r1, required by @selected, required by @world (argument)
=gnome-base/gconf-99.3.2.5 ~amd64
#required by dev-libs/libqtbamf-0.2.4, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-declarative-99.4.8.2 ~amd64
#required by x11-misc/appmenu-gtk-12.10.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/indicator-appmenu-12.10.0 ~amd64
#required by unity-base/utouch-frame-2.2.3, required by unity-base/utouch-grail-3.0.5, required by unity-base/utouch-geis-2.2.9, required by unity-base/nux-2.14.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/utouch-evemu-1.0.9 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libunity-misc-4.0.4 ~amd64
#required by unity-base/indicator-application-12.10.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libappindicator-99.12.10.0 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/indicator-datetime-0.3.94 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-control-center-99.3.4.2 ~amd64
#required by x11-libs/qt-webkit-99.4.8.2, required by x11-libs/qt-declarative-99.4.8.2[webkit], required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-xmlpatterns-99.4.8.2 ~amd64
#required by app-admin/packagekit-0.7.4[gtk], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-gtk-0.7.4 ~amd64
#required by unity-base/ubuntuone-storage-protocol-3.99.90, required by unity-base/ubuntuone-control-panel-3.99.90, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/dirspec-3.99.90 ~amd64
#required by unity-base/ubuntuone-control-panel-3.99.90, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/ubuntuone-storage-protocol-3.99.90 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/boost-1.49.0-r1 ~amd64
#required by x11-libs/qt-gui-99.4.8.2, required by x11-libs/qt-opengl-99.4.8.2, required by x11-libs/qt-declarative-99.4.8.2, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-script-99.4.8.2 ~amd64
#required by unity-base/utouch-geis-2.2.9, required by unity-base/nux-2.14.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/utouch-grail-3.0.5 ~amd64
#required by gnome-extra/zeitgeist-0.9.5[plugins], required by gnome-extra/zeitgeist-datahub-0.8.2
=gnome-extra/zeitgeist-datasources-0.8.0.1 ~amd64
#required by gnome-base/gsettings-desktop-schemas-99.3.5.91, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-themes/ubuntu-mono-0.0.40 ~amd64
#required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/ubuntuone-client-3.99.90 ~amd64
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-0.7.4 ~amd64
#required by unity-base/bamf-0.3.0, required by dev-libs/libqtbamf-0.2.4, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity-webapps-2.1 ~amd64
#required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-sound/rhythmbox-2.97 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/indicator-application-12.10.0 ~amd64
#required by unity-base/compizconfig-python-0.9.5.94, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/libcompizconfig-0.9.5.94 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-session-99.3.2.1 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gsettings-desktop-schemas-99.3.5.91 ~amd64
#required by unity-base/utouch-grail-3.0.5, required by unity-base/utouch-geis-2.2.9, required by unity-base/nux-2.14.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/utouch-frame-2.2.3 ~amd64
#required by x11-plugins/compiz-plugins-main-0.9.7.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/compiz-0.9.7.8-r1 ~amd64
#required by x11-libs/libXfixes-5.0-r9999, required by unity-base/bamf-0.3.0, required by dev-libs/libqtbamf-0.2.4, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-proto/fixesproto-5.0-r9999 ~amd64
#required by x11-libs/qt-declarative-99.4.8.2, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-svg-99.4.8.2 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/indicator-sound-12.10.0 ~amd64
#required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libqtgconf-0.1 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-themes/unity-asset-pool-0.8.23 ~amd64
#required by x11-libs/qt-svg-99.4.8.2, required by x11-libs/qt-declarative-99.4.8.2, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-gui-99.4.8.2 ~amd64
#required by app-admin/packagekit-qt4-0.7.4, required by app-admin/packagekit-0.7.4[qt4], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-base-0.7.4 ~amd64
#required by gnome-base/gnome-settings-daemon-99.3.4.2-r1, required by gnome-base/gnome-session-99.3.2.1, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libwacom-0.5 ~amd64
#required by gnome-extra/zeitgeist-0.9.5, required by gnome-extra/zeitgeist-datahub-0.8.2
=dev-python/rdflib-3.2.1 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/dconf-qt-0.0.0.110722 ~amd64
#required by net-libs/glib-networking-2.30.2, required by net-libs/libsoup-2.38.0, required by media-sound/rhythmbox-2.97, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/glib-99.2.32.3 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libunity-5.96.0 ~amd64
#required by unity-base/indicator-applet-12.10.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libindicator-99.12.10.0 ~amd64
#required by unity-base/utouch-frame-2.2.3, required by unity-base/utouch-grail-3.0.5, required by unity-base/utouch-geis-2.2.9, required by unity-base/nux-2.14.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-base/xorg-server-1.12.3-r9999 ~amd64
#required by x11-libs/qt-webkit-99.4.8.2, required by x11-libs/qt-declarative-99.4.8.2[webkit], required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-core-99.4.8.2 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/indicator-applet-12.10.0 ~amd64
#required by unity-base/ubuntuone-control-panel-3.99.90, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/lazr-restfulclient-0.12.0 ~amd64
#required by unity-base/nux-2.14.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/utouch-geis-2.2.9 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity-scope-video-remote-0.3.6 ~amd64
#required by dev-libs/libindicate-qt-0.2.5.91, required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libindicate-12.10.0 ~amd64
#required by dev-python/PyQt4-4.9.4[X], required by unity-base/ubuntu-sso-client-3.99.90, required by unity-base/ubuntuone-control-panel-3.99.90, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-test-99.4.8.2 ~amd64
#required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libindicate-qt-0.2.5.91 ~amd64
#required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/zeitgeist-0.9.5 ~amd64
#required by unity-base/ccsm-0.9.5.92, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/compizconfig-python-0.9.5.94 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/nux-2.14.0 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/ubuntuone-control-panel-3.99.90 ~amd64
#required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libubuntuone-3.99.90 ~amd64
#required by gnome-base/nautilus-99.3.4.2, required by unity-base/ubuntuone-client-3.99.90, required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-util/gdbus-codegen-2.32.4 ~amd64
#required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/zeitgeist-extensions-0.0.13-r1 ~amd64
#required by x11-libs/qt-declarative-99.4.8.2, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-opengl-99.4.8.2 ~amd64
#required by @selected, required by @world (argument)
=x11-themes/gnome-icon-theme-3.4.0 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity-lens-music-5.12.0 ~amd64
#required by net-wireless/gnome-bluetooth-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1[bluetooth], required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-wireless/blueman-1.23-r2 ~amd64
#required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-wm/metacity-99.2.34.1 ~amd64
#required by dev-libs/boost-1.49.0-r1, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-util/boost-build-1.49.0 ~amd64
#required by dev-libs/libunity-5.96.0, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/dee-1.0.12 ~amd64
#required by x11-misc/appmenu-qt-0.2.6, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libdbusmenu-qt-0.9.2 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity-lens-files-5.10.0 ~amd64
#required by dev-libs/libindicate-12.10.0, required by unity-base/unity-webapps-2.1, required by unity-base/bamf-0.3.0, required by dev-libs/libqtbamf-0.2.4, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libdbusmenu-0.6.2 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gnome-settings-daemon-99.3.4.2-r1 ~amd64
#required by gnome-extra/zeitgeist-0.9.5[passiv], required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/zeitgeist-datahub-0.8.2 ~amd64
#required by x11-libs/qt-gui-99.4.8.2, required by x11-libs/qt-opengl-99.4.8.2, required by x11-libs/qt-declarative-99.4.8.2, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-sql-99.4.8.2 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-misc/appmenu-gtk-12.10.0 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity2d-5.12.0 ~amd64
#required by gnome-extra/zeitgeist-datahub-0.8.2, required by gnome-extra/zeitgeist-0.9.5[passiv], required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libzeitgeist-0.3.18 ~amd64
#required by gnome-base/nautilus-99.3.4.2, required by unity-base/ubuntuone-client-3.99.90, required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/launchpad-integration-0.1.56.1 ~amd64
#required by x11-libs/gtk+-99.3.4.2, required by unity-base/ido-0.3.4, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-accessibility/at-spi2-atk-2.5.3 ~amd64
#required by dev-libs/libqtbamf-0.2.4, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/bamf-0.3.0 ~amd64
#required by x11-libs/qt-declarative-99.4.8.2[webkit], required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/qt-webkit-99.4.8.2 ~amd64
#required by unity-base/unity-meta (argument)
=unity-base/unity-meta-5.14.0 ~amd64
#required by dev-libs/libindicator-99.12.10.0, required by unity-base/indicator-applet-12.10.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-libs/libXfixes-5.0-r9999 ~amd64
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=sys-libs/db-5.1.29 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity-lens-applications-5.12.0 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=unity-base/unity-lens-video-0.3.5 ~amd64
#required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/nm-applet-99.0.9.4.1 ~amd64
#required by gnome-extra/zeitgeist-extensions-0.0.13-r1[geolocation], required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/python-geoclue-0.1.0 ~amd64
#required by dev-python/rdflib-3.2.1, required by gnome-extra/zeitgeist-0.9.5, required by gnome-extra/zeitgeist-datahub-0.8.2
=dev-python/isodate-0.4.8 ~amd64

The following mask changes are necessary to proceed:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29
#required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=x11-wm/metacity-99.2.34.1

The following USE changes are necessary to proceed:
#required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
>=gnome-extra/zeitgeist-0.9.5 passiv extensions plugins
#required by unity-base/ubuntuone-storage-protocol-3.99.90, required by unity-base/ubuntuone-control-panel-3.99.90, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/protobuf-2.4.0a python
#required by x11-libs/qt-webkit-99.4.8.2[gstreamer], required by x11-libs/qt-declarative-99.4.8.2[webkit], required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libxml2-2.8.0_rc1 -icu
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
>=app-admin/packagekit-0.7.4 qt4 gtk
#required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
>=gnome-extra/zeitgeist-datasources-0.8.0.1 telepathy
#required by gnome-extra/zeitgeist-extensions-0.0.13-r1[fts], required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/xapian-bindings-1.2.8 python
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-base-0.7.4 networkmanager
#required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
>=gnome-extra/zeitgeist-extensions-0.0.13-r1 geolocation

NOTE: The --autounmask-keep-masks option will prevent emerge
from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

!!! The following installed packages are masked:
- gnome-extra/gnome-user-docs-3.4.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:

- gnome-base/gnome-desktop-3.4.2::gentoo (masked by: package.mask)
- media-libs/clutter-gst-1.5.6::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
# New clutter API breaks almost everything

- www-plugins/adobe-flash-11.2.202.238::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

- dev-libs/libgdata-0.12.0::gentoo (masked by: package.mask)
- app-crypt/seahorse-3.4.1::gentoo (masked by: package.mask)
- net-im/skype-4.0.0.8::gentoo (masked by: skype-4.0.0.7-copyright license(s))
A copy of the 'skype-4.0.0.7-copyright' license is located at '/usr/portage/licenses/skype-4.0.0.7-copyright'.

- net-im/empathy-3.4.2.1::gentoo (masked by: package.mask)
- gnome-extra/mousetweaks-3.4.2::gentoo (masked by: package.mask)
- app-cdr/nero-4.0.0.0b::gentoo (masked by: Nero-EULA-US license(s))
A copy of the 'Nero-EULA-US' license is located at '/usr/portage/licenses/Nero-EULA-US'.

- sci-geosciences/googleearth-6.2.1.6014-r1::gentoo (masked by: googleearth license(s))
A copy of the 'googleearth' license is located at '/usr/portage/licenses/googleearth'.

- app-accessibility/at-spi2-core-2.4.2::gentoo (masked by: package.mask)
- dev-libs/folks-0.6.9::gentoo (masked by: package.mask)
- gnome-extra/gnome-color-manager-3.4.2::gentoo (masked by: package.mask)
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- net-libs/telepathy-farstream-0.2.3::gentoo (masked by: package.mask)
- gnome-extra/gnome-contacts-3.4.1::gentoo (masked by: package.mask)
- gnome-extra/evolution-data-server-3.4.3::gentoo (masked by: package.mask)
- media-video/cheese-3.4.2::gentoo (masked by: package.mask)
- gnome-extra/sushi-0.4.1::gentoo (masked by: package.mask)
- x11-wm/mutter-3.4.1-r1::gentoo (masked by: package.mask)
- app-emulation/virtualbox-bin-4.1.18::gentoo (masked by: PUEL license(s))
A copy of the 'PUEL' license is located at '/usr/portage/licenses/PUEL'.

- media-video/totem-3.4.3::gentoo (masked by: package.mask)
- gnome-base/libgnomekbd-3.4.0.2::gentoo (masked by: package.mask)
- gnome-base/gnome-panel-3.4.1::gentoo (masked by: package.mask)
- app-crypt/gcr-3.4.1::gentoo (masked by: package.mask)
- app-accessibility/orca-3.4.2::gentoo (masked by: package.mask)
- gnome-base/gnome-menus-3.4.2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Which use flags should I activate, and generally, how can I install it? (Other sabayon users have redirected me here)... :roll:
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 361
Location: Adelaide, Australia

PostPosted: Sun Sep 09, 2012 11:49 am    Post subject: Reply with quote

Hi and welcome Johnny Who!!

The errors you see are normal on a raw unconfigured setup.
All the packages in the unity-gentoo overlay are masked in some way.
You can read about masked packages and the different types of masking in the Gentoo handbook.

But for getting the overlay packages quickly installed you can do the following configuration:
Code:
 ~ # mkdir -p /etc/portage/package.keywords
 ~ # ln -s /var/lib/layman/unity-gentoo/PACKAGES /etc/portage/package.keywords/unity-gentoo
If you already have an /etc/portage/package.keywords file, rename it first to something other than 'package.keywords' and then copy that renamed file into the new /etc/portage/package.keywords/ directory.
This configuration will have the overlay automatically handle the keyword unmasking of the needed packages from the overlay only.

Once you've setup this configuration, doing the following should clear up the x11-libs/qt blocks you have:
Code:
emerge -1a $(qlist -IC x11-libs/qt)

For all other packages, you'll need to unmask these yourself.
Good luck :wink:
Back to top
View user's profile Send private message
Johnny Who
n00b
n00b


Joined: 06 Aug 2012
Posts: 9
Location: Athens, Greece

PostPosted: Sun Sep 09, 2012 12:59 pm    Post subject: Reply with quote

Thank you very much. I have read the Gentoo handbook plenty of times, and the only reason I have installed sabayon instead of gentoo is that I usually use my computer in libraries, and I simply cannot wait for packages to compile when in an emergency. I like portage...!
Back to top
View user's profile Send private message
Johnny Who
n00b
n00b


Joined: 06 Aug 2012
Posts: 9
Location: Athens, Greece

PostPosted: Sun Sep 09, 2012 8:48 pm    Post subject: Reply with quote

Now I get this output when I emerge unity-meta.:
Code:
[ebuild  N    ~] dev-util/boost-build-1.49.0  USE="-examples -python"
[ebuild  N     ] dev-libs/xapian-1.2.8  USE="brass chert flint inmemory remote sse sse2 -doc -static-libs"
[ebuild  N     ] gnome-base/gnome-common-3.1.0
[ebuild  N     ] dev-python/oauth-1.0.1
[ebuild  N    ~] dev-python/configglue-1.0
[ebuild  N    ~] dev-python/dirspec-3.99.90
[ebuild  N    ~] unity-base/utouch-evemu-1.0.9
[ebuild  N     ] dev-python/pyrex-0.9.9  USE="-examples"
[ebuild  N    ~] dev-python/lazr-restfulclient-0.12.0
[ebuild  N     ] dev-python/sip-4.13.3  USE="-debug -doc"
[ebuild  N     ] app-text/scrollkeeper-dtd-1.0
[ebuild  N     ] app-text/opensp-1.5.2-r3  USE="nls -doc -static-libs -test"
[ebuild  N     ] app-text/rarian-0.8.1-r1  USE="-static-libs"
[ebuild  N     ] app-text/scrollkeeper-9999-r1
[ebuild  N     ] dev-util/gdbus-codegen-2.30.3
[ebuild  NS   #] sys-libs/db-5.1.29 [4.8.30] USE="cxx -doc -examples -java -tcl -test"
[ebuild  N     ] app-text/sgml-common-0.6.3-r5
[ebuild  N     ] dev-libs/xapian-bindings-1.2.8  USE="python -java -lua -mono -perl -php -ruby -tcl" PHP_TARGETS="php5-3"
[ebuild     UD ] dev-libs/libxml2-2.8.0_rc1 [2.8.0-r1] USE="-icu*"
[ebuild  N     ] app-text/docbook-dsssl-stylesheets-1.79
[ebuild  N     ] app-text/openjade-1.3.2-r3  USE="-static-libs"
[ebuild  N     ] x11-misc/icon-naming-utils-0.8.90
[ebuild  N     ] dev-util/gtk-doc-am-1.18
[ebuild     U ~] dev-libs/glib-99.2.32.3 [2.32.1]
[ebuild     U ~] dev-libs/atk-2.4.0 [2.2.0]
[ebuild  NS    ] dev-lang/vala-0.16.1-r1 [0.14.0] USE="vapigen -test"
[ebuild  N     ] x11-misc/lndir-1.0.3
[ebuild  N     ] x11-proto/trapproto-3.4.3
[ebuild  N     ] x11-proto/bigreqsproto-1.1.2  USE="-doc"
[ebuild  N     ] x11-proto/xf86driproto-2.1.1
[ebuild  N     ] x11-proto/xf86rushproto-1.1.2-r1
[ebuild  N     ] x11-proto/xcmiscproto-1.2.2  USE="-doc"
[ebuild     U ~] x11-proto/fixesproto-5.0-r9999 [5.0]
[ebuild  NS    ] dev-lang/vala-0.12.1 [0.14.0] USE="vapigen -test"
[ebuild     U  ] media-libs/gstreamer-0.10.36 [0.10.35]
[ebuild     U ~] x11-themes/gnome-icon-theme-3.4.0 [3.2.1.2] USE="branding*"
[ebuild  N     ] x11-apps/xvinfo-1.1.1
[ebuild  N    ~] x11-themes/ubuntu-mono-0.0.40
[ebuild     U ~] x11-libs/libXfixes-5.0-r9999 [5.0]
[ebuild  N    ~] x11-themes/unity-asset-pool-0.8.23  USE="-debug"
[ebuild  N    ~] dev-libs/libwacom-0.5  USE="-doc -static-libs"
[ebuild     U ~] app-accessibility/at-spi2-atk-2.5.3 [2.4.0]
[ebuild  N     ] dev-python/imaging-1.1.7-r1  USE="X lcms -doc -examples -scanner -tk"
[ebuild     U ~] x11-libs/gtk+-99.2.24.11-r1 [2.24.10-r1] USE="-xinerama*"
[ebuild  N     ] dev-dotnet/gtk-sharp-gapi-2.12.10  USE="-debug"
[ebuild  N     ] x11-themes/gtk-engines-murrine-0.98.2  USE="-animation-rtl -themes"
[ebuild  N     ] x11-themes/light-themes-0.1.8.29  USE="-gtk3"
[ebuild     U ~] gnome-base/gsettings-desktop-schemas-99.3.5.91 [3.4.2]
[ebuild     UD ] media-libs/cogl-1.8.2 [1.10.2]
[ebuild     UD ] media-libs/clutter-1.8.4 [1.10.4]
[ebuild     U  ] app-admin/eselect-boost-0.4 [0.3]
[ebuild     U ~] x11-base/xorg-server-1.12.3-r9999 [1.12.3]
[ebuild     U ~] x11-libs/gtk+-99.3.4.2 [3.4.3-r1] USE="-xinerama*"
[ebuild     U ~] gnome-base/gconf-99.3.2.5 [3.2.5]
[ebuild  N    ~] dev-libs/libdbusmenu-0.6.2  USE="gtk introspection -test"
[ebuild     UD ] media-libs/clutter-gtk-1.0.4 [1.2.0]
[ebuild  N    ~] dev-libs/libindicator-99.12.10.0
[ebuild  N    ~] unity-base/ido-0.3.4  USE="-debug"
[ebuild  N    ~] dev-libs/libtimezonemap-0.3.2  USE="-debug"
[ebuild     U  ] gnome-extra/polkit-gnome-99.0.105 [0.105]
[ebuild  N    ~] dev-libs/libunity-misc-4.0.4
[ebuild     U ~] gnome-base/gnome-settings-daemon-99.3.4.2-r1 [3.4.2]
[ebuild     U ~] gnome-base/gnome-session-99.3.2.1 [3.4.2.1]
[ebuild  NS    ] dev-lang/python-3.2.3 [2.7.3-r2] USE="gdbm ipv6 ncurses readline sqlite ssl threads (wide-unicode) xml -build -doc -examples -tk -wininst"
[ebuild  NS   ~] dev-libs/boost-1.49.0-r1 [1.46.1-r1] USE="eselect python -debug -doc -icu -mpi -static-libs -test -tools"
[ebuild  N    ~] dev-util/gdbus-codegen-2.32.4  PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1"
[ebuild  N     ] dev-python/cython-0.16  USE="-doc -examples -numpy"
[ebuild  N     ] dev-libs/protobuf-2.4.0a  USE="python -emacs -examples -java -source -static-libs -vim-syntax"
[ebuild  N    ~] dev-python/python-geoclue-0.1.0  USE="-test"
[ebuild  N     ] dev-python/bsddb3-5.3.0  USE="-doc"
[ebuild  N    ~] dev-python/isodate-0.4.8
[ebuild  N     ] net-zope/zope-fixers-1.0
[ebuild  N    ~] dev-python/python-distutils-extra-2.35
[ebuild     UD~] app-admin/packagekit-base-0.7.4 [0.7.5] USE="networkmanager* -nsplugin*" LINGUAS="-bg* -bn* -ca* -cs* -da* -de* -el* -en_GB* -es* -fi* -fr* -gu* -he* -hi* -hu* -it* -ja* -ko* -ms* -nb* -nl* -pa* -pl* -pt* -pt_BR* -ro* -ru* -sk* -sr* -sv* -ta* -tr* -uk* -zh_CN* -zh_TW*"
[ebuild  N    ~] dev-python/rdflib-3.2.1  USE="berkdb -examples -mysql -redland -sqlite -test"
[ebuild  N     ] app-text/docbook-sgml-dtd-3.0-r3
[ebuild  NS    ] app-text/docbook-xml-dtd-4.3-r1 [4.2-r2]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.4-r2 [4.2-r2]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.1.2-r6 [4.2-r2]
[ebuild  N     ] net-zope/zope-interface-3.8.0
[ebuild  N     ] app-text/gnome-doc-utils-0.20.10
[ebuild  N     ] dev-python/twisted-11.0.0  USE="crypt gtk -serial"
[ebuild     U ~] gnome-base/gnome-menus-99.3.4.0 [3.4.2]
[ebuild  N    ~] gnome-extra/zeitgeist-extensions-0.0.13-r1  USE="fts geolocation -memprofile -sqldebug -tracker"
[ebuild     UD~] app-admin/packagekit-gtk-0.7.4 [0.7.5]
[ebuild  N    ~] app-admin/packagekit-qt4-0.7.4
[ebuild  N     ] dev-python/gnome-python-desktop-base-2.32.0
[ebuild  N    ~] unity-base/launchpad-integration-0.1.56.1  USE="-debug"
[ebuild  N    ~] unity-base/utouch-frame-2.2.3
[ebuild  N     ] dev-python/twisted-web-11.0.0  USE="-soap"
[ebuild  N     ] dev-python/twisted-names-11.0.0
[ebuild  N     ] dev-util/gtk-doc-1.18-r1  USE="-debug -doc -emacs -highlight -test -vim"
[ebuild  N    ~] dev-libs/libindicate-12.10.0  USE="gtk introspection"
[ebuild  N    ~] unity-base/ubuntuone-storage-protocol-3.99.90
[ebuild  N    ~] net-wireless/blueman-1.23-r2  USE="nls policykit -gconf -network -pulseaudio -sendto"
[ebuild  N    ~] app-admin/packagekit-0.7.4  USE="gtk qt4"
[ebuild     U #] x11-wm/metacity-99.2.34.1 [2.34.1] USE="-xinerama*"
[ebuild  N     ] app-i18n/ibus-1.4.1  USE="X gconf gtk introspection nls python -dconf -doc -gtk3 -vala"
[ebuild  N    ~] unity-base/utouch-grail-3.0.5
[ebuild  N    ~] dev-libs/libzeitgeist-0.3.18  USE="-static-libs"
[ebuild     U ~] net-wireless/gnome-bluetooth-99.3.4.2 [3.4.0]
[ebuild  N    ~] dev-libs/dee-1.0.12  USE="icu -debug -doc -examples -static-libs -test"
[ebuild  N    ~] unity-base/utouch-geis-2.2.9
[ebuild  N    ~] unity-base/unity-webapps-2.1
[ebuild  N    ~] dev-libs/libunity-5.96.0
[ebuild  N    ~] unity-base/nux-2.14.0
[ebuild  N    ~] unity-base/bamf-0.3.0  USE="introspection"
[ebuild  N    ~] x11-libs/qt-webkit-99.4.8.2  USE="exceptions gstreamer jit (-aqua) -debug -icu -pch -qpa"
[ebuild  N    ~] x11-libs/qt-assistant-99.4.8.2  USE="compat exceptions glib qt3support (-aqua) -c++0x -debug -doc -pch -qpa -trace -webkit"
[ebuild  N    ~] dev-libs/libindicate-qt-0.2.5.91  USE="-test"
[ebuild  N    ~] x11-libs/qt-declarative-99.4.8.2  USE="accessibility exceptions qt3support webkit (-aqua) -c++0x -debug -pch -qpa"
[ebuild  N    ~] unity-base/compiz-0.9.7.8-r1  USE="-debug"
[ebuild  N    ~] dev-libs/libdbusmenu-qt-0.9.2  USE="-debug -doc -test"
[ebuild  N    ~] x11-libs/libcompizconfig-0.9.5.94  USE="-debug"
[ebuild  N    ~] dev-libs/libqtgconf-0.1  USE="-debug"
[ebuild  N     ] dev-python/PyQt4-4.9.4  USE="X assistant dbus declarative examples opengl sql svg webkit -debug -doc -kde -multimedia -phonon -xmlpatterns"
[ebuild  N    ~] dev-libs/libqtbamf-0.2.4  USE="-debug"
[ebuild  N    ~] dev-libs/libqtdee-0.2.4  USE="-debug"
[ebuild  N    ~] unity-base/dconf-qt-0.0.0.110722  USE="-debug"
[ebuild  N    ~] x11-plugins/compiz-plugins-main-0.9.7.0  USE="-debug"
[ebuild  N    ~] x11-misc/appmenu-qt-0.2.6
[ebuild  N    ~] unity-base/compizconfig-python-0.9.5.94
[ebuild  N    ~] unity-base/compizconfig-backend-gconf-0.9.5.92
[ebuild  N    ~] unity-base/ccsm-0.9.5.92
[ebuild     UD ] gnome-base/gnome-keyring-2.32.1-r1 [3.4.1]
[ebuild     UD ] gnome-base/libgnome-keyring-2.32.0 [3.4.1]
[ebuild  N     ] dev-python/gnome-keyring-python-2.32.0  USE="-examples"
[ebuild  N    ~] unity-base/ubuntu-sso-client-3.99.90
[ebuild  N    ~] unity-base/ubuntuone-control-panel-3.99.90
[ebuild  N    ~] unity-base/indicator-applet-12.10.0
[ebuild  N    ~] gnome-extra/zeitgeist-datasources-0.8.0.1  USE="telepathy -bzr -chromium -emacs -eog -geany -gedit -rhythmbox -static-libs -tomboy -totem -vim -xchat"
[ebuild  N    ~] gnome-extra/zeitgeist-datahub-0.8.2  USE="-download"
[ebuild  N    ~] gnome-extra/zeitgeist-0.9.5  USE="dbus extensions fts nls passiv plugins -icu -sql-debug"
[ebuild  N    ~] dev-libs/libappindicator-99.12.10.0  USE="-vala"
[ebuild  N    ~] unity-base/indicator-appmenu-12.10.0  USE="-debug"
[ebuild     U ~] gnome-extra/nm-applet-99.0.9.4.1 [0.9.4.1] USE="-debug%"
[ebuild  N    ~] unity-base/indicator-sound-12.10.0  USE="-debug"
[ebuild  N    ~] unity-base/indicator-application-12.10.0
[ebuild  N    ~] unity-base/indicator-datetime-0.3.94  USE="-debug"
[ebuild  N    ~] unity-base/indicator-session-0.3.96  USE="-debug"
[ebuild     U ~] gnome-base/gnome-control-center-99.3.4.2 [3.4.2-r1]
[ebuild  N    ~] x11-misc/appmenu-gtk-12.10.0
[ebuild  N    ~] unity-base/unity-5.14.0  USE="-debug"
[ebuild  N    ~] unity-base/unity-lens-applications-5.12.0  USE="-debug"
[ebuild  N    ~] unity-base/unity-lens-video-0.3.5
[ebuild  N    ~] unity-base/unity2d-5.12.0  USE="-debug"
[ebuild  N    ~] unity-base/unity-scope-video-remote-0.3.6
[ebuild  N    ~] unity-base/unity-lens-files-5.10.0  USE="-debug"
[ebuild     U ~] gnome-base/nautilus-99.3.4.2 [3.2.1-r1] USE="-debug%"
[ebuild  N    ~] unity-base/ubuntuone-client-3.99.90  USE="-doc"
[ebuild  N    ~] dev-libs/libubuntuone-3.99.90
[ebuild  N    ~] media-sound/rhythmbox-2.97  USE="cdr dbus libnotify python udev -clutter -daap -debug -doc -gnome-keyring -html -ipod -lirc -mtp -musicbrainz -nsplugin -test -upnp -webkit -zeitgeist"
[ebuild  N    ~] unity-base/rhythmbox-ubuntuone-3.99.90
[ebuild  N    ~] unity-base/unity-lens-music-5.12.0
[ebuild  N    ~] unity-base/unity-meta-5.14.0
[blocks B      ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.4.1)
[blocks B      ] gnome-extra/zeitgeist[fts] ("gnome-extra/zeitgeist[fts]" is blocking gnome-extra/zeitgeist-extensions-0.0.13-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libXfixes:0

  (x11-libs/libXfixes-5.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libXfixes-5.0-r9999 required by (dev-libs/libunity-misc-4.0.4::unity-gentoo, ebuild scheduled for merge)
    =x11-libs/libXfixes-5.0-r9999 required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)
    (and 4 more with the same problems)

x11-proto/fixesproto:0

  (x11-proto/fixesproto-5.0-r9999::unity-gentoo, ebuild scheduled for merge) pulled in by
    =x11-proto/fixesproto-5.0-r9999 required by (x11-libs/libXfixes-5.0-r9999::unity-gentoo, ebuild scheduled for merge)

  (x11-proto/fixesproto-5.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/libxml2:2

  (dev-libs/libxml2-2.8.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libxml2-2.8.0_rc1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:2[!icu?] required by (x11-libs/qt-webkit-99.4.8.2::unity-gentoo, ebuild scheduled for merge)

media-libs/gstreamer:0.10

  (media-libs/gstreamer-0.10.36::unity-gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/gstreamer-0.10.36 required by (unity-base/unity-lens-music-5.12.0::unity-gentoo, ebuild scheduled for merge)

  (media-libs/gstreamer-0.10.35::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-base/gnome-menus:3

  (gnome-base/gnome-menus-99.3.4.0::unity-gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-menus-99.3.4.0 required by (unity-base/unity-5.14.0::unity-gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

  (gnome-base/gnome-menus-3.4.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-util/gdbus-codegen:0

  (dev-util/gdbus-codegen-2.32.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-util/gdbus-codegen-2.31.0 required by (gnome-base/nautilus-99.3.4.2::unity-gentoo, ebuild scheduled for merge)

  (dev-util/gdbus-codegen-2.30.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-base/gsettings-desktop-schemas:0

  (gnome-base/gsettings-desktop-schemas-99.3.5.91::unity-gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gsettings-desktop-schemas-99.3.4.1 required by (unity-base/unity-5.14.0::unity-gentoo, ebuild scheduled for merge)

  (gnome-base/gsettings-desktop-schemas-3.4.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-themes/gnome-icon-theme:0

  (x11-themes/gnome-icon-theme-3.4.0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-themes/gnome-icon-theme-3.4.0 required by (x11-themes/unity-asset-pool-0.8.23::unity-gentoo, ebuild scheduled for merge)

  (x11-themes/gnome-icon-theme-3.2.1.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/clutter:1.0

  (media-libs/clutter-1.10.4::gentoo, installed) pulled in by
    >=media-libs/clutter-1.10.0:1.0[introspection] required by (gnome-extra/sushi-0.4.1::gentoo, installed)
    (and 4 more with the same problem)

  (media-libs/clutter-1.8.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/cogl:1.0

  (media-libs/cogl-1.8.2::gentoo, ebuild scheduled for merge) pulled in by
    <=media-libs/cogl-1.9.2:1.0 required by (media-libs/clutter-1.8.4::gentoo, ebuild scheduled for merge)

  (media-libs/cogl-1.10.2::gentoo, installed) pulled in by
    >=media-libs/cogl-1.9.6:1.0[introspection?,pango] required by (media-libs/clutter-1.10.4::gentoo, installed)
    (and 1 more with the same problem)

gnome-base/gnome-keyring:0

  (gnome-base/gnome-keyring-3.4.1::gentoo, installed) pulled in by
    >=gnome-base/gnome-keyring-3.3.90 required by (gnome-base/gnome-shell-3.4.1::sabayon-distro, installed)
    (and 4 more with the same problem)

  (gnome-base/gnome-keyring-2.32.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

gnome-base/libgnome-keyring:0

  (gnome-base/libgnome-keyring-3.4.1::gentoo, installed) pulled in by
    >=gnome-base/libgnome-keyring-3.2 required by (gnome-base/gnome-core-apps-3.2.1::gentoo, installed)
    (and 1 more with the same problem)

  (gnome-base/libgnome-keyring-2.32.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/clutter-gtk:1.0

  (media-libs/clutter-gtk-1.2.0::gentoo, installed) pulled in by
    >=media-libs/clutter-gtk-1.1.2:1.0 required by (net-im/empathy-3.4.2.1::gentoo, installed)

  (media-libs/clutter-gtk-1.0.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
#required by @selected, required by @world (argument)
=x11-themes/gnome-icon-theme-3.4.0 ~amd64
#required by net-wireless/gnome-bluetooth-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1[bluetooth], required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-wireless/blueman-1.23-r2 ~amd64
#required by app-admin/packagekit-qt4-0.7.4, required by app-admin/packagekit-0.7.4[qt4], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-base-0.7.4 ~amd64
#required by x11-misc/appmenu-qt-0.2.6, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libdbusmenu-qt-0.9.2 ~amd64
#required by dev-libs/boost-1.49.0-r1, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-util/boost-build-1.49.0 ~amd64
#required by gnome-extra/zeitgeist-0.9.5, required by gnome-extra/zeitgeist-datahub-0.8.2
=dev-python/rdflib-3.2.1 ~amd64
#required by app-admin/packagekit-0.7.4[qt4], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-qt4-0.7.4 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/boost-1.49.0-r1 ~amd64
#required by gnome-base/gnome-settings-daemon-99.3.4.2-r1, required by gnome-base/gnome-session-99.3.2.1, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libwacom-0.5 ~amd64
#required by gnome-extra/zeitgeist-0.9.5[plugins], required by gnome-extra/zeitgeist-datahub-0.8.2
=gnome-extra/zeitgeist-datasources-0.8.0.1 ~amd64
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-0.7.4 ~amd64
#required by dev-libs/libindicate-qt-0.2.5.91, required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libindicate-12.10.0 ~amd64
#required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-sound/rhythmbox-2.97 ~amd64
#required by gnome-base/gnome-core-apps-3.2.1, required by gnome-base/gnome-3.2.1, required by @selected, required by @world (argument)
=gnome-base/gnome-menus-99.3.4.0 ~amd64
#required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libindicate-qt-0.2.5.91 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gsettings-desktop-schemas-99.3.5.91 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-misc/appmenu-qt-0.2.6 ~amd64
#required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/zeitgeist-0.9.5 ~amd64
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=sys-libs/db-5.1.29 ~amd64
#required by gnome-base/nautilus-99.3.4.2, required by unity-base/ubuntuone-client-3.99.90, required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-util/gdbus-codegen-2.32.4 ~amd64
#required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/zeitgeist-extensions-0.0.13-r1 ~amd64
#required by app-admin/packagekit-0.7.4[gtk], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-gtk-0.7.4 ~amd64
#required by gnome-extra/zeitgeist-extensions-0.0.13-r1[geolocation], required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/python-geoclue-0.1.0 ~amd64
#required by dev-python/rdflib-3.2.1, required by gnome-extra/zeitgeist-0.9.5, required by gnome-extra/zeitgeist-datahub-0.8.2
=dev-python/isodate-0.4.8 ~amd64

The following mask changes are necessary to proceed:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29
#required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=x11-wm/metacity-99.2.34.1

The following USE changes are necessary to proceed:
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-base-0.7.4 networkmanager
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
>=app-admin/packagekit-0.7.4 qt4 gtk

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

!!! The following installed packages are masked:
- gnome-extra/gnome-user-docs-3.4.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:

- gnome-base/gnome-desktop-3.4.2::gentoo (masked by: package.mask)
- media-libs/clutter-gst-1.5.6::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
# New clutter API breaks almost everything

- www-plugins/adobe-flash-11.2.202.238::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

- dev-libs/libgdata-0.12.0::gentoo (masked by: package.mask)
- app-crypt/seahorse-3.4.1::gentoo (masked by: package.mask)
- net-im/skype-4.0.0.8::gentoo (masked by: skype-4.0.0.7-copyright license(s))
A copy of the 'skype-4.0.0.7-copyright' license is located at '/usr/portage/licenses/skype-4.0.0.7-copyright'.

- net-im/empathy-3.4.2.1::gentoo (masked by: package.mask)
- gnome-extra/mousetweaks-3.4.2::gentoo (masked by: package.mask)
- app-cdr/nero-4.0.0.0b::gentoo (masked by: Nero-EULA-US license(s))
A copy of the 'Nero-EULA-US' license is located at '/usr/portage/licenses/Nero-EULA-US'.

- sci-geosciences/googleearth-6.2.1.6014-r1::gentoo (masked by: googleearth license(s))
A copy of the 'googleearth' license is located at '/usr/portage/licenses/googleearth'.

- app-accessibility/at-spi2-core-2.4.2::gentoo (masked by: package.mask)
- dev-libs/folks-0.6.9::gentoo (masked by: package.mask)
- gnome-extra/gnome-color-manager-3.4.2::gentoo (masked by: package.mask)
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- net-libs/telepathy-farstream-0.2.3::gentoo (masked by: package.mask)
- gnome-extra/gnome-contacts-3.4.1::gentoo (masked by: package.mask)
- gnome-extra/evolution-data-server-3.4.3::gentoo (masked by: package.mask)
- media-video/cheese-3.4.2::gentoo (masked by: package.mask)
- gnome-extra/sushi-0.4.1::gentoo (masked by: package.mask)
- x11-wm/mutter-3.4.1-r1::gentoo (masked by: package.mask)
- app-emulation/virtualbox-bin-4.1.18::gentoo (masked by: PUEL license(s))
A copy of the 'PUEL' license is located at '/usr/portage/licenses/PUEL'.

- media-video/totem-3.4.3::gentoo (masked by: package.mask)
- gnome-base/libgnomekbd-3.4.0.2::gentoo (masked by: package.mask)
- gnome-base/gnome-panel-3.4.1::gentoo (masked by: package.mask)
- app-crypt/gcr-3.4.1::gentoo (masked by: package.mask)
- app-accessibility/orca-3.4.2::gentoo (masked by: package.mask)
- gnome-base/gnome-menus-3.4.2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I suppose that I will need to edit the USE flags in order to continue. Your configuration unmasked the packages rather painlessly...
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Sep 09, 2012 9:00 pm    Post subject: Reply with quote

Just put this:

Code:

#required by @selected, required by @world (argument)
=x11-themes/gnome-icon-theme-3.4.0 ~amd64
#required by net-wireless/gnome-bluetooth-99.3.4.2, required by gnome-extra/nm-applet-99.0.9.4.1[bluetooth], required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=net-wireless/blueman-1.23-r2 ~amd64
#required by app-admin/packagekit-qt4-0.7.4, required by app-admin/packagekit-0.7.4[qt4], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-base-0.7.4 ~amd64
#required by x11-misc/appmenu-qt-0.2.6, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libdbusmenu-qt-0.9.2 ~amd64
#required by dev-libs/boost-1.49.0-r1, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-util/boost-build-1.49.0 ~amd64
#required by gnome-extra/zeitgeist-0.9.5, required by gnome-extra/zeitgeist-datahub-0.8.2
=dev-python/rdflib-3.2.1 ~amd64
#required by app-admin/packagekit-0.7.4[qt4], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-qt4-0.7.4 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/boost-1.49.0-r1 ~amd64
#required by gnome-base/gnome-settings-daemon-99.3.4.2-r1, required by gnome-base/gnome-session-99.3.2.1, required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libwacom-0.5 ~amd64
#required by gnome-extra/zeitgeist-0.9.5[plugins], required by gnome-extra/zeitgeist-datahub-0.8.2
=gnome-extra/zeitgeist-datasources-0.8.0.1 ~amd64
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-0.7.4 ~amd64
#required by dev-libs/libindicate-qt-0.2.5.91, required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libindicate-12.10.0 ~amd64
#required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=media-sound/rhythmbox-2.97 ~amd64
#required by gnome-base/gnome-core-apps-3.2.1, required by gnome-base/gnome-3.2.1, required by @selected, required by @world (argument)
=gnome-base/gnome-menus-99.3.4.0 ~amd64
#required by unity-base/indicator-datetime-0.3.94, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-libs/libindicate-qt-0.2.5.91 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-base/gsettings-desktop-schemas-99.3.5.91 ~amd64
#required by unity-base/unity-5.14.0, required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=x11-misc/appmenu-qt-0.2.6 ~amd64
#required by gnome-extra/zeitgeist-datasources-0.8.0.1, required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/zeitgeist-0.9.5 ~amd64
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=sys-libs/db-5.1.29 ~amd64
#required by gnome-base/nautilus-99.3.4.2, required by unity-base/ubuntuone-client-3.99.90, required by dev-libs/libubuntuone-3.99.90, required by unity-base/rhythmbox-ubuntuone-3.99.90, required by unity-base/unity-lens-music-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-util/gdbus-codegen-2.32.4 ~amd64
#required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=gnome-extra/zeitgeist-extensions-0.0.13-r1 ~amd64
#required by app-admin/packagekit-0.7.4[gtk], required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-gtk-0.7.4 ~amd64
#required by gnome-extra/zeitgeist-extensions-0.0.13-r1[geolocation], required by dev-libs/libappindicator-99.12.10.0, required by gnome-extra/nm-applet-99.0.9.4.1, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=dev-python/python-geoclue-0.1.0 ~amd64
#required by dev-python/rdflib-3.2.1, required by gnome-extra/zeitgeist-0.9.5, required by gnome-extra/zeitgeist-datahub-0.8.2
=dev-python/isodate-0.4.8 ~amd64

The following mask changes are necessary to proceed:
#required by unity-base/unity-lens-applications-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Robin H. Johnson <robbat2@gentoo.org> (08 Oct 2010)
# Masked for testing, and some testsuite failures.
=sys-libs/db-5.1.29
#required by unity-base/unity2d-5.12.0, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
# /usr/portage/profiles/package.mask:
# Nirbheek Chauhan <nirbheek@gentoo.org> (25 Mar 2012)
# This is now the GNOME 3.4 mask
# Masked for testing, clutter-1.10, and bugs in some packages:
=x11-wm/metacity-99.2.34.1


into /etc/portage/package.accept_keywords

and this:

Code:

#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
=app-admin/packagekit-base-0.7.4 networkmanager
#required by unity-base/indicator-session-0.3.96, required by unity-base/unity-meta-5.14.0, required by unity-base/unity-meta (argument)
>=app-admin/packagekit-0.7.4 qt4 gtk


into /etc/portage/package.use

and tell us what you get after this (latter you will have to mask that, unmask that, etc...).


shiznix, and about that wrong positioned windows, i can add the "gnome-control-center" for the whitelist (it is always positioned at the center of the screen). I tried to play with the put plugin, but seems that my changes don't make any effects...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6 ... 24, 25, 26  Next
Page 5 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum