Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alsa Lib conf.c:3314 Cannot open shared library [SOLVED]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Sun Mar 11, 2012 1:44 pm    Post subject: Alsa Lib conf.c:3314 Cannot open shared library [SOLVED] Reply with quote

Hello everybody, I recently updated the alsa-lib and I cannot play sound.
The device /dev/dsp disappeared and whenever I call the command alsamixer appears this warning:
Code:

$alsamixer
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL default
cannot open mixer: No such file or directory

Could anyone help me?
_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"


Last edited by midnigther on Mon Mar 12, 2012 10:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Sun Mar 11, 2012 2:28 pm    Post subject: Reply with quote

run revdep-rebuild
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Sun Mar 11, 2012 2:51 pm    Post subject: Reply with quote

The trouble remains...
_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Sun Mar 11, 2012 2:53 pm    Post subject: Reply with quote

what is the output of
Code:
ldd $(which alsamixer)
ls -l /usr/lib/alsa-lib/libasound_module_conf_pulse.so

?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Sun Mar 11, 2012 2:58 pm    Post subject: Reply with quote

How did you make your sound drivers. (In kernel or from the media-sound/alsa-driver package ?)
_________________
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Sun Mar 11, 2012 5:42 pm    Post subject: Reply with quote

DaggyStyle wrote:
what is the output of
Code:
ldd $(which alsamixer)
ls -l /usr/lib/alsa-lib/libasound_module_conf_pulse.so

?


Code:

ldd $(which alsamixer)
   linux-vdso.so.1 =>  (0x00007fffc27ff000)
   libformw.so.5 => /usr/lib64/libformw.so.5 (0x00007f8c430de000)
   libmenuw.so.5 => /usr/lib64/libmenuw.so.5 (0x00007f8c42ed5000)
   libpanelw.so.5 => /usr/lib64/libpanelw.so.5 (0x00007f8c42cd1000)
   libncursesw.so.5 => /lib64/libncursesw.so.5 (0x00007f8c42a71000)
   libasound.so.2 => /usr/lib64/libasound.so.2 (0x00007f8c42791000)
   libm.so.6 => /lib64/libm.so.6 (0x00007f8c4250f000)
   libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f8c422f2000)
   libc.so.6 => /lib64/libc.so.6 (0x00007f8c41f6a000)
   libdl.so.2 => /lib64/libdl.so.2 (0x00007f8c41d66000)
   librt.so.1 => /lib64/librt.so.1 (0x00007f8c41b5d000)
   /lib64/ld-linux-x86-64.so.2 (0x00007f8c432ef000)


Code:

ls -l /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ls: cannot access /usr/lib/alsa-lib/libasound_module_conf_pulse.so: No such file or directory

_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Sun Mar 11, 2012 5:43 pm    Post subject: Reply with quote

aCOSwt wrote:
How did you make your sound drivers. (In kernel or from the media-sound/alsa-driver package ?)


Built-in kernel.
_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Mon Mar 12, 2012 6:52 am    Post subject: Reply with quote

try as modules, build it always caused problems here
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Mon Mar 12, 2012 2:03 pm    Post subject: Reply with quote

DaggyStyle wrote:
try as modules, build it always caused problems here


Build as module.
Code:

grep SOUND /usr/src/.config
CONFIG_SOUND=m
CONFIG_SOUND_OSS_CORE=y
CONFIG_SOUND_OSS_CORE_PRECLAIM=y
# CONFIG_SOUND_PRIME is not set

$ grep CONFIG_SND /usr/src/.config
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_SEQ_DUMMY=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_HRTIMER=m
CONFIG_SND_SEQ_HRTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
# CONFIG_SND_SUPPORT_OLD_API is not set
CONFIG_SND_VERBOSE_PROCFS=y
# CONFIG_SND_VERBOSE_PRINTK is not set
# CONFIG_SND_DEBUG is not set
CONFIG_SND_VMASTER=y
CONFIG_SND_DMA_SGBUF=y
# CONFIG_SND_RAWMIDI_SEQ is not set
# CONFIG_SND_OPL3_LIB_SEQ is not set
# CONFIG_SND_OPL4_LIB_SEQ is not set
# CONFIG_SND_SBAWE_SEQ is not set
# CONFIG_SND_EMU10K1_SEQ is not set
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_DRIVERS=y
# CONFIG_SND_PCSP is not set
# CONFIG_SND_DUMMY is not set
# CONFIG_SND_ALOOP is not set
# CONFIG_SND_VIRMIDI is not set
# CONFIG_SND_MTPAV is not set
# CONFIG_SND_SERIAL_U16550 is not set
# CONFIG_SND_MPU401 is not set
# CONFIG_SND_AC97_POWER_SAVE is not set
CONFIG_SND_PCI=y
# CONFIG_SND_AD1889 is not set
# CONFIG_SND_ALS300 is not set
# CONFIG_SND_ALS4000 is not set
# CONFIG_SND_ALI5451 is not set
# CONFIG_SND_ASIHPI is not set
CONFIG_SND_ATIIXP=m
CONFIG_SND_ATIIXP_MODEM=m
# CONFIG_SND_AU8810 is not set
# CONFIG_SND_AU8820 is not set
# CONFIG_SND_AU8830 is not set
# CONFIG_SND_AW2 is not set
# CONFIG_SND_AZT3328 is not set
# CONFIG_SND_BT87X is not set
# CONFIG_SND_CA0106 is not set
# CONFIG_SND_CMIPCI is not set
# CONFIG_SND_OXYGEN is not set
# CONFIG_SND_CS4281 is not set
# CONFIG_SND_CS46XX is not set
# CONFIG_SND_CS5530 is not set
# CONFIG_SND_CS5535AUDIO is not set
# CONFIG_SND_CTXFI is not set
# CONFIG_SND_DARLA20 is not set
# CONFIG_SND_GINA20 is not set
# CONFIG_SND_LAYLA20 is not set
# CONFIG_SND_DARLA24 is not set
# CONFIG_SND_GINA24 is not set
# CONFIG_SND_LAYLA24 is not set
# CONFIG_SND_MONA is not set
# CONFIG_SND_MIA is not set
# CONFIG_SND_ECHO3G is not set
# CONFIG_SND_INDIGO is not set
# CONFIG_SND_INDIGOIO is not set
# CONFIG_SND_INDIGODJ is not set
# CONFIG_SND_INDIGOIOX is not set
# CONFIG_SND_INDIGODJX is not set
# CONFIG_SND_EMU10K1 is not set
# CONFIG_SND_EMU10K1X is not set
# CONFIG_SND_ENS1370 is not set
# CONFIG_SND_ENS1371 is not set
# CONFIG_SND_ES1938 is not set
# CONFIG_SND_ES1968 is not set
# CONFIG_SND_FM801 is not set
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
# CONFIG_SND_HDA_RECONFIG is not set
# CONFIG_SND_HDA_INPUT_BEEP is not set
# CONFIG_SND_HDA_INPUT_JACK is not set
# CONFIG_SND_HDA_PATCH_LOADER is not set
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_ENABLE_REALTEK_QUIRKS=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CA0132=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
CONFIG_SND_HDA_POWER_SAVE=y
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0
# CONFIG_SND_HDSP is not set
# CONFIG_SND_HDSPM is not set
# CONFIG_SND_ICE1712 is not set
# CONFIG_SND_ICE1724 is not set
# CONFIG_SND_INTEL8X0 is not set
# CONFIG_SND_INTEL8X0M is not set
# CONFIG_SND_KORG1212 is not set
# CONFIG_SND_LOLA is not set
# CONFIG_SND_LX6464ES is not set
# CONFIG_SND_MAESTRO3 is not set
# CONFIG_SND_MIXART is not set
# CONFIG_SND_NM256 is not set
# CONFIG_SND_PCXHR is not set
# CONFIG_SND_RIPTIDE is not set
# CONFIG_SND_RME32 is not set
# CONFIG_SND_RME96 is not set
# CONFIG_SND_RME9652 is not set
# CONFIG_SND_SONICVIBES is not set
# CONFIG_SND_TRIDENT is not set
# CONFIG_SND_VIA82XX is not set
# CONFIG_SND_VIA82XX_MODEM is not set
# CONFIG_SND_VIRTUOSO is not set
# CONFIG_SND_VX222 is not set
# CONFIG_SND_YMFPCI is not set
# CONFIG_SND_USB is not set
# CONFIG_SND_PCMCIA is not set
# CONFIG_SND_SOC is not set


The trouble remains...
_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Mon Mar 12, 2012 2:33 pm    Post subject: Reply with quote

OK then, I suggest you emerge :

app-emulation/emul-linux-x86-soundlibs with the pulseaudio use flag set.
_________________
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Mon Mar 12, 2012 2:57 pm    Post subject: Reply with quote

aCOSwt wrote:
OK then, I suggest you emerge :

app-emulation/emul-linux-x86-soundlibs with the pulseaudio use flag set.


The flag is set.

Code:

* Found these USE flags for app-emulation/emul-linux-x86-soundlibs-20120127:
 U I
 + + alsa        : Adds support for media-libs/alsa-lib (Advanced Linux Sound
                   Architecture)
 - - development : Install pkgconfig files
 + + pulseaudio  : Adds support for PulseAudio sound server

_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Mon Mar 12, 2012 3:02 pm    Post subject: Reply with quote

:?
Please post the cat of your /etc/asound.conf or .asoundrc
_________________
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Mon Mar 12, 2012 3:08 pm    Post subject: Reply with quote

aCOSwt wrote:
:?
Please post the cat of your /etc/asound.conf or .asoundrc


I don't have the specific file. :(

Code:

ls /etc/asound.conf
ls: cannot access /etc/asound.conf: No such file or directory
$ ls ~.asound
ls: cannot access ~.asound: No such file or directory

_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Mon Mar 12, 2012 3:17 pm    Post subject: Reply with quote

I received the following error after restart the alsasound daemon.

Code:
$ sudo /etc/init.d/alsasound restart
 * WARNING: you are stopping a boot service
 * Storing ALSA Mixer Levels ...
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:0
alsactl: get_controls:570: snd_ctl_open error: No such file or directory
 * Error saving levels.                                                   [ !! ]
 * Restoring Mixer Levels ...
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:0
alsactl: set_controls:1485: snd_ctl_open error: No such file or directory
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:1
alsactl: set_controls:1485: snd_ctl_open error: No such file or directory [ ok ]

_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Mon Mar 12, 2012 3:17 pm    Post subject: Reply with quote

any reason why you are using pulseaudio?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Mon Mar 12, 2012 3:17 pm    Post subject: Reply with quote

:? :?
Well so sorry ! I am afraid I am a bit lost on this problem.
_________________
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Mon Mar 12, 2012 3:23 pm    Post subject: Reply with quote

DaggyStyle wrote:
any reason why you are using pulseaudio?

Not anymore. Do I disable the pulseaudio flag?
_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
midnigther
n00b
n00b


Joined: 05 Mar 2010
Posts: 36
Location: Portugal, VC

PostPosted: Mon Mar 12, 2012 10:14 pm    Post subject: Reply with quote

Problem solved. I disabled the pulseaudio flag.
_________________
"Genius is one per cent inspiration, ninety-nine per cent perspiration" - Thomas Edison
"It is not the position you stand, but the direction in which you look"
Back to top
View user's profile Send private message
AC Tsai
n00b
n00b


Joined: 26 Mar 2012
Posts: 1
Location: Taiwan

PostPosted: Mon Mar 26, 2012 3:08 am    Post subject: Reply with quote

Dear midnigther,

I also have this kind of problem:
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM

Could you please show me how do you solve your problem.

Thank you very much.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Mon Mar 26, 2012 6:41 am    Post subject: Reply with quote

AC Tsai wrote:
Dear midnigther,

I also have this kind of problem:
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM

Could you please show me how do you solve your problem.

Thank you very much.

look one post above you...
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Neskweek
n00b
n00b


Joined: 20 Jun 2004
Posts: 35
Location: Nantes - France

PostPosted: Sun Jun 10, 2012 4:22 pm    Post subject: Reply with quote

midnigther wrote:
Problem solved. I disabled the pulseaudio flag.

Ooooww Common ! :/... Disabling the feature doesn't solve the the problem !!!...

Well then, I got the same problem, and did found the solution here.

The cause : It's a multilib problem:
PulseAudio is set to ALWAYS use 64 bit libraries.
So porgram like Skype, GuitarPro6, Wine 32bit etc... doesn't work because they need 32bit libraries.

There you go for Gentoo (tested and working) :

0. Install, if not done, emul-linux-x86-soundlibs
emerge emul-linux-x86-soundlibs

1. Create /etc/ld.so.conf.d/alsa32.conf with the following contents:
Code:
/usr/lib32/alsa-lib


2. Create /etc/ld.so.conf.d/alsa64.conf with the following contents:
Code:
/usr/lib/alsa-lib


3. ldconfig

4. Open /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf in the editor and remove the "/usr/lib/alsa-lib/" prefix from the libasound_module_conf_pulse.so file.
like this :

Code:
# PulseAudio alsa plugin configuration file to set the pulseaudio plugin as
# default output for applications using alsa when pulseaudio is running.

hook_func.pulse_load_if_running {
#replace this         
#       lib "/usr/lib/alsa-lib/libasound_module_conf_pulse.so"
#by this : 
        lib "libasound_module_conf_pulse.so"
        func "conf_pulse_hook_load_if_running"
}

@hooks [
        {
                func pulse_load_if_running
                files [
                        "/usr/share/alsa/pulse-default.conf"
                        "/etc/asound.conf"
                        "~/.asoundrc"
                ]
                errors false
        }
]



And that should do it.
Back to top
View user's profile Send private message
apetridis
n00b
n00b


Joined: 21 Mar 2008
Posts: 6

PostPosted: Thu Aug 30, 2012 10:39 pm    Post subject: Reply with quote

It worked!

Thank you very much for that Neskweek :D
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 754
Location: Stuttgart, Germany

PostPosted: Fri Sep 07, 2012 8:16 pm    Post subject: Reply with quote

I tried this same fix, and now all my audio in wine (say, playing games) sounds horribly distorted and overdriven (and oddly, the intro cinematic plays twice as fast). Further, every time I open alsamixer, the volume for PCM, Surround, and a bunch of other channels is set to 100%. Any guess what's going wrong?

Cheers,

EE
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5525

PostPosted: Sat Sep 08, 2012 3:06 pm    Post subject: Reply with quote

As for alsamixer, you do see that "F6..." line near top right corner, right ?
Back to top
View user's profile Send private message
Barade
n00b
n00b


Joined: 03 Feb 2009
Posts: 25

PostPosted: Sat Nov 17, 2012 6:48 pm    Post subject: Reply with quote

@Neskweek: Thank you so much for the solution. Now I have sound with wine again :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum