Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gametreelinux[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
pelargos
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 129

PostPosted: Tue Sep 04, 2012 1:45 pm    Post subject: Gametreelinux[solved] Reply with quote

How can i install it???? I download it, i unrar it i copy it to usr but it doesn't work...

Last edited by pelargos on Thu Sep 06, 2012 7:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
pelargos
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 129

PostPosted: Tue Sep 04, 2012 9:07 pm    Post subject: Re: Gametreelinux Reply with quote

pelargos wrote:
How can i install it???? I download it, i unrar it i copy it to usr but it doesn't work...


noyone knows?
Back to top
View user's profile Send private message
pelargos
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 129

PostPosted: Thu Sep 06, 2012 1:47 pm    Post subject: Re: Gametreelinux Reply with quote

pelargos wrote:
pelargos wrote:
How can i install it???? I download it, i unrar it i copy it to usr but it doesn't work...


noyone knows?
IT SHOWS ME THIS ERROR:
Code:
 ~ $ gametree
Running Cedega installer
  File "/usr/lib/gametree/app/installer/main.py", line 10
    print "ERROR: You must have Python version 2.4 or later"
                                                           ^
SyntaxError: invalid syntax
The Cedega updater failed to complete successfully.


I have python installed.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7741
Location: Somewhere over Atlanta, Georgia

PostPosted: Thu Sep 06, 2012 2:21 pm    Post subject: Reply with quote

Please post the output of
Code:
eselect python list
- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
pelargos
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 129

PostPosted: Thu Sep 06, 2012 7:15 pm    Post subject: Reply with quote

John R. Graham wrote:
Please post the output of
Code:
eselect python list
- John


here :)
Code:
# eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.2 *
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7741
Location: Somewhere over Atlanta, Georgia

PostPosted: Thu Sep 06, 2012 7:17 pm    Post subject: Reply with quote

Run
Code:
eselect python set 1
and then retry your install.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31875
Location: 56N 3W

PostPosted: Thu Sep 06, 2012 7:20 pm    Post subject: Reply with quote

pelargos,

Python 3.x and 2.x are not compatible. Properly maintained code now works with either but old code will require python 2.x.

Use eselect to choose python 2.7 and try your installer again.
If it works, eselect python 3.2. Provided only the installer needs python 2.x you should be good.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pelargos
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 129

PostPosted: Thu Sep 06, 2012 7:30 pm    Post subject: Reply with quote

NeddySeagoon wrote:
pelargos,

Python 3.x and 2.x are not compatible. Properly maintained code now works with either but old code will require python 2.x.

Use eselect to choose python 2.7 and try your installer again.
If it works, eselect python 3.2. Provided only the installer needs python 2.x you should be good.


OK thank u a lot! :)
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 388
Location: Sota algun pi de l'empordà

PostPosted: Mon Dec 17, 2012 9:14 pm    Post subject: Reply with quote

hi , i try to install , but don't work, ¿there are no updates of this software?

Quote:
gametree
Running Cedega installer
WARNING: Unsupported version of Python: 2.7
Only Python 2.4 - 2.6 is officially supported
Traceback (most recent call last):
File "/usr/lib/gametree/app/installer/main.py", line 28, in <module>
import installer
File "/usr/lib/gametree/lib/installer/__init__.py", line 6, in <module>
from _InstallContext import InstallContext
File "/usr/lib/gametree/lib/installer/_InstallContext.py", line 5, in <module>
from _InstallerUI import InstallUI
File "/usr/lib/gametree/lib/installer/_InstallerUI.py", line 10, in <module>
import gtk
ImportError: No module named gtk
The Cedega updater failed to complete successfully.


thanks, :O
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum