Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge gentoo-sources does not complete [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jbru362
n00b
n00b


Joined: 27 Jun 2008
Posts: 7

PostPosted: Wed Sep 05, 2012 12:22 am    Post subject: Emerge gentoo-sources does not complete [SOLVED] Reply with quote

When running
Code:
emerge gentoo-sources

I get the following at the end:
Code:
Failed to install sys/kernel/gentoo-sources-3.3.8

The final entry in the log file is:
Code:
>>> Completed installing gentoo-sources-3.3.8 into /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/image

/mnt/gentoo/usr/src/linux-3.3.8-gentoo is created and partially populated but no /usr/linux symlink is created. I can tell not everything in /mnt/gentoo/usr/src/linux-3.3.8-gentoo is created properly because
Code:
make menuconfig

fails due to no Makefile created

I am using stage3-i486-20120710 and have had no install problems up until this. I ran the emerge from the proper chroot environment (env-update called and all that). I have installed Gentoo multiple times over the years (but the last time was at least two years ago--I might be rusty on something)

I have seen a similar error posted elsewhere on the forum, but no solutions given. I can't figure out why the emerge would go smoothly and then just seemingly halt during the install portion.

I'm not sure what else is relevant other than the error messages and the stage3 version, but will provide any additional information requested. I'd appreciate any help. I keep coming back to Gentoo after trying other distros, but this time I'm stumped.


Last edited by jbru362 on Thu Sep 06, 2012 1:10 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9168

PostPosted: Wed Sep 05, 2012 12:47 am    Post subject: Reply with quote

Based on the information provided, it looks like =sys/kernel/gentoo-sources-3.3.8 failed to install. Check the output for more detailed error messages. If in doubt, please post the full build log to a pastebin.
Back to top
View user's profile Send private message
jbru362
n00b
n00b


Joined: 27 Jun 2008
Posts: 7

PostPosted: Wed Sep 05, 2012 12:51 am    Post subject: Reply with quote

That's what's odd--there are no errors in the build log, only the output of the emerge command. Without knowing what a successful build log for gentoo-sources looks like, I don't know what the install failed to do (command-wise. practically I think I have a good sense of what failed to happen)
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6719
Location: Goose Creek SC

PostPosted: Wed Sep 05, 2012 1:21 am    Post subject: Reply with quote

from the chroot:
Code:
emerge wgetpaste
wgetpaste /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/temp/build.log
emerge --info | wgetpaste
post the url's returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jbru362
n00b
n00b


Joined: 27 Jun 2008
Posts: 7

PostPosted: Wed Sep 05, 2012 1:37 am    Post subject: Reply with quote

Code:
wgetpaste /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/temp/build.log

http://bpaste.net/show/43820
Code:
emerge --info | wgetpaste

http://bpaste.net/show/43821
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6719
Location: Goose Creek SC

PostPosted: Wed Sep 05, 2012 2:38 am    Post subject: Reply with quote

Quote:
/mnt/gentoo/usr/src/linux-3.3.8-gentoo is created and partially populated but no /usr/linux symlink is created. I can tell not everything in /mnt/gentoo/usr/src/linux-3.3.8-gentoo is created properly because
Code:
make menuconfig
is suspicious. If you were in fact booted into cd system with gentoo partitions mounted but not in the chroot you would very likely get the results you report.

Suggest boot cd, and enter the chroot, nominally:
Code:
 mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
cp /etc/resolv.conf /mnt/gentoo/etc/resolv.conf
mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"
emerge gentoo-sources
cd /usr/src/linux
make menuconfig


If my guess is wrong, the following provided for info. The build log for a successful amd64 emerge is essentially same as yours.
Quote:
 * Package: sys-kernel/gentoo-sources-3.3.8
 * Repository: gentoo
 * Maintainer: kernel@gentoo.org
 * USE: amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES: sandbox
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-3.3.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work
>>> Unpacking genpatches-3.3-9.base.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/patches
>>> Unpacking genpatches-3.3-9.extras.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/patches
* Applying 1000_linux-3.3.1.patch (-p0+) ...
 [ ok ]
* Applying 1001_linux-3.3.2.patch (-p0+) ...
 [ ok ]
* Applying 1002_linux-3.3.3.patch (-p0+) ...
 [ ok ]
* Applying 1003_linux-3.3.4.patch (-p0+) ...
 [ ok ]
* Applying 1004_linux-3.3.5.patch (-p0+) ...
 [ ok ]
* Applying 1005_linux-3.3.6.patch (-p0+) ...
 [ ok ]
* Applying 1006_linux-3.3.7.patch (-p0+) ...
 [ ok ]
* Applying 1007_linux-3.3.8.patch (-p0+) ...
 [ ok ]
* Applying 1700_tsunami-modpost-include-fix.patch (-p0+) ...
 [ ok ]
* Applying 2400_kcopy-patch-for-infiniband-driver.patch (-p0+) ...
 [ ok ]
* Applying 4200_fbcondecor-0.9.6.patch (-p0+) ...
 [ ok ]
>>> Source unpacked in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work
>>> Preparing source in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/linux-3.3.8-gentoo ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/linux-3.3.8-gentoo ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/linux-3.3.8-gentoo ...
>>> Source compiled.
>>> Test phase [not enabled]: sys-kernel/gentoo-sources-3.3.8

>>> Install gentoo-sources-3.3.8 into /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/image/ category sys-kernel
>>> Copying sources ...
>>> Completed installing gentoo-sources-3.3.8 into /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/image/

the screen output:
Quote:
merge =sys-kernel/gentoo-sources-3.3.8
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-kernel/gentoo-sources-3.3.8
* linux-3.3.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Downloading 'http://distfiles.gentoo.org/distfiles/genpatches-3.3-9.base.tar.bz2'
--2012-09-04 22:02:22-- http://distfiles.gentoo.org/distfiles/genpatches-3.3-9.base.tar.bz2
Resolving distfiles.gentoo.org... 64.50.236.52, 137.226.34.42, 140.211.166.134, ...
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 220169 (215K) [application/x-bzip2]
Saving to: `/usr/portage/distfiles/genpatches-3.3-9.base.tar.bz2'

100%[======================================>] 220,169 614K/s in 0.3s

2012-09-04 22:02:22 (614 KB/s) - `/usr/portage/distfiles/genpatches-3.3-9.base.tar.bz2' saved [220169/220169]

* genpatches-3.3-9.base.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Downloading 'http://distfiles.gentoo.org/distfiles/genpatches-3.3-9.extras.tar.bz2'
--2012-09-04 22:02:23-- http://distfiles.gentoo.org/distfiles/genpatches-3.3-9.extras.tar.bz2
Resolving distfiles.gentoo.org... 64.50.236.52, 137.226.34.42, 140.211.166.134, ...
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 17199 (17K) [application/x-bzip2]
Saving to: `/usr/portage/distfiles/genpatches-3.3-9.extras.tar.bz2'

100%[======================================>] 17,199 --.-K/s in 0.06s

2012-09-04 22:02:23 (284 KB/s) - `/usr/portage/distfiles/genpatches-3.3-9.extras.tar.bz2' saved [17199/17199]

* genpatches-3.3-9.extras.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-3.3.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work
>>> Unpacking genpatches-3.3-9.base.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/patches
>>> Unpacking genpatches-3.3-9.extras.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/patches
* Applying 1000_linux-3.3.1.patch (-p0+) ... [ ok ]
* Applying 1001_linux-3.3.2.patch (-p0+) ... [ ok ]
* Applying 1002_linux-3.3.3.patch (-p0+) ... [ ok ]
* Applying 1003_linux-3.3.4.patch (-p0+) ... [ ok ]
* Applying 1004_linux-3.3.5.patch (-p0+) ... [ ok ]
* Applying 1005_linux-3.3.6.patch (-p0+) ... [ ok ]
* Applying 1006_linux-3.3.7.patch (-p0+) ... [ ok ]
* Applying 1007_linux-3.3.8.patch (-p0+) ... [ ok ]
* Applying 1700_tsunami-modpost-include-fix.patch (-p0+) ... [ ok ]
* Applying 2400_kcopy-patch-for-infiniband-driver.patch (-p0+) ... [ ok ]
* Applying 4200_fbcondecor-0.9.6.patch (-p0+) ... [ ok ]
>>> Source unpacked in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work
>>> Preparing source in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/linux-3.3.8-gentoo ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/linux-3.3.8-gentoo ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/work/linux-3.3.8-gentoo ...
>>> Source compiled.
>>> Test phase [not enabled]: sys-kernel/gentoo-sources-3.3.8

>>> Install gentoo-sources-3.3.8 into /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/image/ category sys-kernel
>>> Copying sources ...
>>> Completed installing gentoo-sources-3.3.8 into /var/tmp/portage/sys-kernel/gentoo-sources-3.3.8/image/


>>> Installing (1 of 1) sys-kernel/gentoo-sources-3.3.8

* If you are upgrading from a previous kernel, you may be interested
* in the following document:
* - General upgrade guide: http://www.gentoo.org/doc/en/kernel-upgrade.xml

* For more info on this patchset, and how to report problems, see:
* http://dev.gentoo.org/~mpagano/genpatches

>>> Recording sys-kernel/gentoo-sources:3.3.8 in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.


running as root?
not running out of drive space?
I'd try a different version.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jbru362
n00b
n00b


Joined: 27 Jun 2008
Posts: 7

PostPosted: Wed Sep 05, 2012 2:43 am    Post subject: Reply with quote

DONAHUE wrote:

running as root?
not running out of drive space?
I'd try a different version.


I'm running as root and have about 20 Gb free
Different version of what?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6719
Location: Goose Creek SC

PostPosted: Wed Sep 05, 2012 2:54 am    Post subject: Reply with quote

Again what I really suspect is that you were in the cd system not in the chroot for the emerge gentoo-sources and make menuconfig commands. I suggest running the steps below.
Quote:
/mnt/gentoo/usr/src/linux-3.3.8-gentoo is created and partially populated but no /usr/linux symlink is created. I can tell not everything in /mnt/gentoo/usr/src/linux-3.3.8-gentoo is created properly because
Code:
make menuconfig
is suspicious. If you were in fact booted into cd system with gentoo partitions mounted but not in the chroot you would very likely get the results you report.

Suggest boot cd, and enter the chroot, nominally:
Code:
 mount /dev/sda3 /mnt/gentoo
mount /dev/sda1 /mnt/gentoo/boot
cp /etc/resolv.conf /mnt/gentoo/etc/resolv.conf
mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash
env-update
source /etc/profile
export PS1="(chroot) $PS1"
emerge gentoo-sources
cd /usr/src/linux
make menuconfig


Different version of what? --> different version of gentoo-sources, either experimental newer version or an older stable version. If the steps above do not solve the problem.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jbru362
n00b
n00b


Joined: 27 Jun 2008
Posts: 7

PostPosted: Thu Sep 06, 2012 1:09 am    Post subject: Reply with quote

Not sure what the problem was. I wiped the HD, tried again and it worked. Weird
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum