Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X forward, can start virtualbox, but not console? On/off
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
madchaz
l33t
l33t


Joined: 01 Jul 2003
Posts: 981
Location: Quebec, Canada

PostPosted: Wed Sep 05, 2012 4:24 pm    Post subject: X forward, can start virtualbox, but not console? On/off Reply with quote

Hello all,
having a bit of a weird problem. Feel free to move this post if it's the wrong place, because I honestly don't know where else to put it.

My server is a headless gentoo box running, among other things, a lot of virtual machines. Due to USB problems in qemu-kvm, I had to switch to virtualbox.

This morning, I ran into a very weird problem I can't figure out for the life of me. I normally login to the machine from my windows desktop, using mobaxterm as a X server. This as and still does work well, but this morning, I can't use this setup to start virtual machines with a visible/usable console.

Edit: I tested it from my linux netbook as well and I get the exact same results with ssh -Y

Code:
shenron ~ # VirtualBox

This works fine. VirtualBox gui starts and I can play with the virtual machines, create them, delete, etc. However, if I try to start one, I get this in the console I started VirtualBox from.

Code:
X11 connection rejected because of wrong authentication.


Starting it from the console, I get this.

Code:
shenron ~ # VBoxManage startvm dragonball1
Waiting for VM "dragonball1" to power on...
X11 connection rejected because of wrong authentication.
VBoxManage: error: The virtual machine 'dragonball1' has terminated unexpectedly during startup with exit code 0
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine, callee


But this works fine.

Code:
shenron ~ # VBoxManage startvm dragonball1 --type headless
Waiting for VM "dragonball1" to power on...
VM "dragonball1" has been successfully started.


I could use a console for at least booting the livecd ...
_________________
Someone asked me once if I suffered from mental illness. I told him I enjoyed every second of it.
www.madchaz.com A small candle of a website. As my lab specs on it.


Last edited by madchaz on Sun Sep 23, 2012 9:06 pm; edited 2 times in total
Back to top
View user's profile Send private message
madchaz
l33t
l33t


Joined: 01 Jul 2003
Posts: 981
Location: Quebec, Canada

PostPosted: Wed Sep 05, 2012 5:50 pm    Post subject: Reply with quote

I'm not completly confused. I haven't changed anything and the problem went away?

Yea, confused.
_________________
Someone asked me once if I suffered from mental illness. I told him I enjoyed every second of it.
www.madchaz.com A small candle of a website. As my lab specs on it.
Back to top
View user's profile Send private message
madchaz
l33t
l33t


Joined: 01 Jul 2003
Posts: 981
Location: Quebec, Canada

PostPosted: Sun Sep 23, 2012 9:05 pm    Post subject: Reply with quote

Using VBoxSDL to start virtual machines with a console appears to bypass the issue. When it came back, I still had the issue with VBoxManage and Virtualbox GUI, but VBoxSDL was able to do it.
Still no clue as to why, but it doesn't appear to have anything to do with SSH, as even using a "local" terminal over vnc, still had the issue.
_________________
Someone asked me once if I suffered from mental illness. I told him I enjoyed every second of it.
www.madchaz.com A small candle of a website. As my lab specs on it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum