Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgrade valgrind error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
paynalton
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2006
Posts: 106
Location: Mexico

PostPosted: Mon Aug 27, 2012 5:53 pm    Post subject: upgrade valgrind error Reply with quote

Hola a todos, estoy tratando de hacer un

Code:
emerge -vuND woeld


y obtengo un error al llegar al paquete dev-util/valgrind que solo necesita actualizar de la version 3.6.1-r1 a la versión 3.6.1-r3

Al ver el registro del ebuild dice que necesito estoy usando glibc versión 1.15 y que valgrind requiere la versión 2.X

pero en portage sys-libs/glibc tiene como ultima versión estable la 2.15-r2

entonces... como puedo saltarme la actualización de valgrind hasta que glibc 2 este estable???

o como puedo forzar la actualización de valgrind???
_________________
"Si un ave no rompe su huevo morirá antes de nacer.... Nosotros somos el ave y el mundo es nuestro huevo. POR LA REVOLUCION DEL MUNDO!!!!" Utena
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1059
Location: La Plata, Argentina

PostPosted: Mon Aug 27, 2012 8:47 pm    Post subject: Reply with quote

enmascara el paquete
nano /etc/portage/package.mask

si no existe crea el directorio y el fichero

y agrega la linea:
=dev-util/valgrind-3.6.1-r3

si sigue queriendo actualizar a *-r2 podes usar esta linea:
>dev-util/valgrind-3.6.1-r3
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Mon Aug 27, 2012 9:45 pm    Post subject: Reply with quote

Antes de nada prueba a hacer:

Code:
revdep-rebuild


necesitarás tener instalado gentoolkit

la versión estable de glibc es:

Code:
sys-libs/glibc-2.15-r2


aunque al ser una actualización por revisión , no debería de implicar cambios de semejante calado en las dependencias.

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
Inodoro_Pereyra
Advocate
Advocate


Joined: 03 Nov 2006
Posts: 2631
Location: En la otra punta del cable

PostPosted: Sun Sep 02, 2012 12:19 pm    Post subject: Reply with quote

paynalton wrote:
entonces... como puedo saltarme la actualización de valgrind hasta que glibc 2 este estable???


Creo que lo mas fàcil hubiera sido:
Code:
emerge --skipfirst --resume


¡Salud!
_________________
Mi Blog.

Si no fuera por C, estaríamos escribiendo programas en BASI, PASAL y OBOL.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum