Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Minecraft (ebuild to build deps from source!)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2592
Location: UK

PostPosted: Sat Aug 04, 2012 4:15 pm    Post subject: Reply with quote

As I said above, they've updated the launcher. The ebuild needs to be updated because the download URL doesn't change.
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Sat Aug 04, 2012 4:19 pm    Post subject: Reply with quote

Ah, okay, makes sense. Is there a work around yet? Or will I need to remove it from my world file for future updates?
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2592
Location: UK

PostPosted: Sat Aug 04, 2012 4:22 pm    Post subject: Reply with quote

Re-digesting the ebuild should be good enough for now.
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Sat Aug 04, 2012 4:36 pm    Post subject: Reply with quote

Unfortunately that did not make any difference...

"I have also noticed that if my system is set to use IT-bin-7 i am stuck at the back go game screen, where as all works fine with IT-bin-6." < --- Nevermind, something magically changed, or is at least intermittent. :) Oh boy, I love problems that aren't consistent, so fun to chase down.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Mon Aug 06, 2012 2:34 pm    Post subject: Reply with quote

Sorry for my disappearance. I don't play Minecraft any more and I wasn't getting further updates from this thread. The client (launcher) ebuild has now been updated. games-server/minecraft-server has been updated to 1.3.1. CraftBukkit has been updated to 2262 (1.2.5-R5.0). Many thanks to Robert Förster for doing the initial leg work. I will try to update again when CraftBukkit comes out for 1.3.1 but this isn't a priority for me any more.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Tue Aug 07, 2012 9:28 pm    Post subject: Reply with quote

I don't think anyone noticed but if you had trouble building Ebean with JDK7, that's fixed now. And CraftBukkit #2317 (1.3.1) is up! :D
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Tue Aug 07, 2012 10:20 pm    Post subject: Reply with quote

Chewi,

No worries on the updates on the ebuild, you have done fine. Sometimes there are just no updates that need to be done until something is broken.
Back to top
View user's profile Send private message
monicajae
Guru
Guru


Joined: 03 Sep 2003
Posts: 363
Location: Dorset, VT

PostPosted: Thu Aug 16, 2012 9:20 pm    Post subject: Omfg Reply with quote

you know i have to laugh at myself. if i don't i may just commit suicide...all joking aside:

i bought minecrap craft- intending to use it on my laptop which i bought before i ever even HEARD of minecrap. long story short: EMBEDDED INTEL GPU. need i say more?

then i thought ok, we'll just play it on my son's desktop which has an nvidia agp. well it may be pci, but no matter, it's not embedded and it's an awesome card.

i had winxp 32bit pro on it. the pc was a hand-me-down from my dad to my son. it's a p4/1g/60 gb sata/nvidia geforce gtx 680/gigabit ethernet/and some other specs. before the xp install crapped on me, we had mc running with NO LAG.

THEN:
xp pro updates fail; no working os; decide to install linux as alternative because it's faster and less resource intensive than windows could ever be; decide to install ubuntu.

FAIL. extremely laggy, mc working, can't play.
think of going back to gentoo, it's never failed me, but then decide, oh, lets try something less labor intensive. install absolute.
FAIL. cannot get mc to play, it loads, i go through the extremeley tedious process of dl'ing previous game patchers, mods, jdk, jre, trying to rearchive minecraft.jar, ad infinitum.

needless to say, after 3 days of unnecessary BS, aggravation and almost selling my account, i decided to do a search here and install gentoo anyway because i like it so much better. like i said gentoo has NEVER, i repeat NEVER failed me, yet i just had to try something else thinking maybe i can get the same results or "better". NOT A CHANCE. i find out? MC-frikken-ebuild! i could've saved myself so much ridiculousness it's not even funny.

thank you gentoo and gentoo developers and maintainers and community. i appreciate you all.

PEACE OUT
Back to top
View user's profile Send private message
monicajae
Guru
Guru


Joined: 03 Sep 2003
Posts: 363
Location: Dorset, VT

PostPosted: Thu Aug 16, 2012 9:21 pm    Post subject: Reply with quote

Chewi wrote:
Sorry for my disappearance. I don't play Minecraft any more and I wasn't getting further updates from this thread. The client (launcher) ebuild has now been updated. games-server/minecraft-server has been updated to 1.3.1. CraftBukkit has been updated to 2262 (1.2.5-R5.0). Many thanks to Robert Förster for doing the initial leg work. I will try to update again when CraftBukkit comes out for 1.3.1 but this isn't a priority for me any more.


Hey Chewi? you joined this forum the day befoe i did! LOL
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Thu Aug 16, 2012 9:41 pm    Post subject: Reply with quote

Heh it worked better in the end then? Glad I could help. My wife's laptop (she still plays it even though I don't) only has an i915 and it's just about playable. I wasn't expecting much from that chipset. It didn't work at all in Vista.

Nice to meet a fellow old timer. :wink:
Back to top
View user's profile Send private message
monicajae
Guru
Guru


Joined: 03 Sep 2003
Posts: 363
Location: Dorset, VT

PostPosted: Sat Aug 18, 2012 9:36 am    Post subject: Reply with quote

Chewi wrote:
Heh it worked better in the end then? Glad I could help. My wife's laptop (she still plays it even though I don't) only has an i915 and it's just about playable. I wasn't expecting much from that chipset. It didn't work at all in Vista.

Nice to meet a fellow old timer. :wink:
I haven't even installed it yet, but i anticipate it to be fairly basic and conventional. just need to brush up on layman.
Oh man vista made me want to string up
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Sat Aug 18, 2012 10:10 am    Post subject: Reply with quote

You may well find it works better because we use the (almost) latest version of LWJGL, 2.8.3. The last time I checked, upstream was still using the ancient version 2.4. There are many tutorials on updating it manually because it is highly recommended but Gentoo is the only place where it'll do it for you automatically. :D Our version also allows you to use PulseAudio natively whereas upstream relies on ALSA.
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Wed Aug 29, 2012 12:22 am    Post subject: Reply with quote

Okay Chewi, I got a question for you...I have upgraded minecraft to 1.3.1 and also 1.3.2 and both had issues with modloader installed but fine with out. The reason I bring this up is that because the the error involves lwjgl. I remember you mentioning that the way minecraft is set up we are fooling minecraft in some manner that involves lwjgl. I have posted the crash report and the reply I recieved on the modloader thread from the official minecraft forums.

If you have any suggestions please let me know.

Code:
--- crash report ---
Time: 8/27/12 9:24 AM
Description: Failed to start game

org.lwjgl.LWJGLException: X Error - disp: 0x18d29d0 serial: 102 error: BadDrawable (invalid Pixmap or Window parameter) request_code: 137 minor_code: 7
at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:316)
at org.lwjgl.opengl.GL11.nglClear(Native Method)
at org.lwjgl.opengl.GL11.glClear(GL11.java:588)
at net.minecraft.client.Minecraft.I(SourceFile:333)
at net.minecraft.client.Minecraft.a(SourceFile:273)
at net.minecraft.client.Minecraft.run(SourceFile:516)
at java.lang.Thread.run(Thread.java:679)

Relevant Details:
- Minecraft Version: 1.3.2
- Operating System: Linux (amd64) version 3.2.12-gentoo
- Java Version: 1.6.0_24, Sun Microsystems Inc.
- Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
- Memory: 1446192248 bytes (1379 MB) / 1543503872 bytes (1472 MB) up to 1908932608 bytes (1820 MB)
- JVM Flags: 2 total; -Xmx2048M -Xms1536M
- ModLoader: Mods loaded: 1
ModLoader 1.3.2

- LWJGL: 2.8.3
- OpenGL: Gallium 0.4 on AMD RV610 GL version 2.1 Mesa 8.0.3, X.Org
- Is Modded: Very likely
- Type: Client
- Texture Pack: DokuCraft High (32x32 v131).zip
- Profiler Position: N/A (disabled)


Quote:

Weird, LWJGL errors are usually due to corrupt install of LWJGL, I don't see how modloader could be doing this. Though I suppose if it's looking for a graphics file and can't find it, might be that. Since you're on Linux, I don't really know. Try deleting the bin and mods folders from your minecraft folder. Do a force update, then run minecraft. If it works, run the texture patcher and install modloader with it only. Run minecraft. If it works, then try again with a clean jar and add one mod at a time until the problem pops up. modloader works, it should be no different on Linux unless you've got something else weird going on.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Wed Aug 29, 2012 8:15 am    Post subject: Reply with quote

Us? Doing something weird? :lol:

The only thing we do that may cause a problem is use a more recent version of LWJGL. However, updating this manually is quite common and it is generally recommended within the community. I doubt you're the first person to try a newer LWJGL with modloader but you may be the first person to do this on Linux. It is a very X-specific error, after all. I'll try updating LWJGL to the very latest version. If that doesn't help, I'll try it with the old version, and then with the bundled version.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Wed Aug 29, 2012 8:16 pm    Post subject: Reply with quote

I bumped LWJGL to 2.8.4 and then gave modloader a try and it worked fine. I used the Biosphere mod. I didn't try with 2.8.3 so I don't know if the bump fixed it. Try it out and let me know.
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Wed Aug 29, 2012 9:08 pm    Post subject: Reply with quote

I updated just lwjgl to 2.8.4 and received the same error, going to try updating world to see if that makes a difference. It's not likely but worth a shot. What is the possibility that a compatibility issue between modloader/lwjgl and my video drivers/card since this could be an X issue. Just a thought.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Wed Aug 29, 2012 9:35 pm    Post subject: Reply with quote

It's possible but it could equally be the xorg-server or Mesa version or something like that, though I seem to have the same Mesa version. I just tried with icedtea-bin-6 after noticing that you're using Java 6 but no change. I'm not sure whether you're using Sun's JRE or icedtea though. Try the other and also try 7. I'm not using a texture pack either so try disabling that.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Wed Aug 29, 2012 9:40 pm    Post subject: Reply with quote

This thread suggests it's actually much more specific to the game itself. Are you sure you applied modloader correctly? I'm mulling over making an eselect module for it but I really have more important things to do!
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Thu Aug 30, 2012 12:44 am    Post subject: Reply with quote

Okay, after reading your posts here is what I have tried with no change in results.

1) Switched to default texture pack with ML installed
2) Swapped in clean backup of 1.3.2 and used my mod script posted earlier in this thread (which worked fine with everything prior to this) (...still with default texture pack)
3) Changed to icedtea 7 (are there any benefits to using 7 over 6?)

On a side note, where did you get your copy of modloader, I am not convinced I got a good copy of it. I have found several files that said they were modloader.zip for 1.3.2 but none of them have worked. Maybe that is another path I should take.

I do not have sun-jre-bin installed...should I try that if emerge world does not work?

I just so wish that mojang would incorporate modloader into the main code and get it over with since it already does what they want an allow mods to work by putting zip files in a mod folder. (my .02)

Thanks for helping me out, I truly wish I knew what you do what is needed to get this stuff to work. I would love to help out on projects like this, but I don't have the programming expertise that is likely needed just mostly OS and networking type knowledge.
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Thu Aug 30, 2012 8:28 am    Post subject: Reply with quote

Okay I tried using modloader with Sun's JRE with the same results, which more or less points to modloader itself. Now I really need to know If I am using the proper file.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Thu Aug 30, 2012 7:08 pm    Post subject: Reply with quote

I got modloader from here.

Regarding 7 vs 6, newer is better? I would guess that 7 is faster and uses less RAM but I've never verified this myself. It also looks as though some mods only work with 7, depending on how they were built. I really don't recommend Sun or Oracle's JRE. I always use icedtea.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2592
Location: UK

PostPosted: Thu Aug 30, 2012 7:25 pm    Post subject: Reply with quote

icedtea-7 seems to perform better, but it may not be worth it for the ridiculous non-optional dependency bloat (especially on a game server - gtk, cairo, cups, alsa, X11, wtf?!?)
Back to top
View user's profile Send private message
gjy0724
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2005
Posts: 124
Location: Seffner, Florida (Heaven)

PostPosted: Thu Aug 30, 2012 8:03 pm    Post subject: Reply with quote

Okay, short rewrite since I may original post took to long...

I figured out my problem...I still had JourneyMap for 1.2.5 in my mods folder, once I took it out everything thing seems to work. I thought I had cleared out the folder a long time ago. I have another mod that is in the mod folder that is supposed to work with 1.3.1 and 1.3.2. I will see if the mod is working shortly and let you know.

Additional sidebar and is likely a non-issue...if I use icedtea-7 the world will load but I can only get the back to game menu, while with icedtea-6 all is well.

Sorry for having you jump through hoops like that, I kinda feel like a dolt now. But I do appreciate the help.

Thank you.
Back to top
View user's profile Send private message
Chewi
l33t
l33t


Joined: 01 Sep 2003
Posts: 789
Location: Edinburgh, Scotland

PostPosted: Sat Sep 29, 2012 5:39 pm    Post subject: Reply with quote

No worries, good to know it works.

Bumped minecraft-server and craftbukkit today. I now use vcs-snapshot.eclass for slightly easier bumping. Have fun. :)
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2592
Location: UK

PostPosted: Thu Oct 25, 2012 11:42 am    Post subject: Reply with quote

(minor feature request)

It'd be nice if we could set the path to the jar and data dir from conf.d... the former to make it easier for people to run weekly snapshots, the latter so I can satisfy my OCD and run everything in /srv :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10, 11, 12  Next
Page 9 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum