Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA w/ USB and multiple sources?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
MisterMagister
n00b
n00b


Joined: 28 Aug 2011
Posts: 11

PostPosted: Tue Aug 28, 2012 11:42 pm    Post subject: ALSA w/ USB and multiple sources? Reply with quote

I have a Sound Blaster X-Fi Go! Pro USB sound card (primarily because my onboard sound won't work with OSX) that I'm having trouble with on Gentoo. My onboard sound is disabled, but my NVidia GTS450 has an HD audio device that can't be disabled and it keeps taking the default slot with ALSA. Alsamixer sees both devices and I can switch back and forth, but I just can't get any sound out of my USB device.

Asus Sabertooth X58
Gentoo AMD64 stable (w/ GCC 4.6.3)
Gnome 2.32
USE="alsa gnome etc"
NVidia GTS 450

Alsamixer shows the following at F6:

- (default)
0 HDA NVidia
1 USB Device 0x46d:0x8b2
2 Sound Blaster X-FI Go! Pro
enter device name

/etc/modprobe.d/alsa.conf below:

Code:
# Alsa kernel modules' configuration file.

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5282

PostPosted: Wed Aug 29, 2012 12:23 pm    Post subject: Reply with quote

Can you post the output of lspci -n?

Do you have the snd_usb_audio module loaded?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Wed Aug 29, 2012 7:05 pm    Post subject: Re: ALSA w/ USB and multiple sources? Reply with quote

MisterMagister wrote:
default slot

There's a few different ways. Personally, I favour using ~/.asoundrc, because there's plenty of other customizations to put there also - see my sig for an example.

MisterMagister wrote:
options snd cards_limit=1

You've just mentioned having 2 or 3 audio cards, so set that to 3.
_________________
Improve your font rendering and ALSA sound
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2524
Location: UK

PostPosted: Wed Aug 29, 2012 10:55 pm    Post subject: Reply with quote

My modprobe.d file looks like this, you probably just want to put usb-audio before hda-intel:
Code:
options snd cards_limit=8

alias snd-card-0 snd-au8830
alias snd-card-1 snd-hda-intel
alias snd-card-2 snd-hda-intel
alias snd-card-3 snd-usb-audio
alias snd-card-4 snd-aloop
alias snd-card-5 snd-aloop

options snd-au8830 index=0
options snd-hda-intel index=1,2
options snd-usb-audio index=3 id=Headset
options snd-aloop index=4,5 enable=Y,Y
Back to top
View user's profile Send private message
MisterMagister
n00b
n00b


Joined: 28 Aug 2011
Posts: 11

PostPosted: Thu Aug 30, 2012 11:49 pm    Post subject: Reply with quote

audiodef wrote:
Can you post the output of lspci -n?

Do you have the snd_usb_audio module loaded?


I don't know if it was loaded, but I loaded it with modprobe and restarted /etc/init.d/alsasound. That would do it, right? No joy.

lspci -n output below:

Code:
00:00.0 0600: 8086:3405 (rev 13)
00:01.0 0604: 8086:3408 (rev 13)
00:02.0 0604: 8086:3409 (rev 13)
00:03.0 0604: 8086:340a (rev 13)
00:07.0 0604: 8086:340e (rev 13)
00:14.0 0800: 8086:342e (rev 13)
00:14.1 0800: 8086:3422 (rev 13)
00:14.2 0800: 8086:3423 (rev 13)
00:14.3 0800: 8086:3438 (rev 13)
00:1a.0 0c03: 8086:3a37
00:1a.1 0c03: 8086:3a38
00:1a.2 0c03: 8086:3a39
00:1a.7 0c03: 8086:3a3c
00:1c.0 0604: 8086:3a40
00:1c.4 0604: 8086:3a48
00:1d.0 0c03: 8086:3a34
00:1d.1 0c03: 8086:3a35
00:1d.2 0c03: 8086:3a36
00:1d.7 0c03: 8086:3a3a
00:1e.0 0604: 8086:244e (rev 90)
00:1f.0 0601: 8086:3a16
00:1f.2 0106: 8086:3a22
00:1f.3 0c05: 8086:3a30
02:00.0 0c03: 1033:0194 (rev 03)
04:00.0 0300: 10de:1245 (rev a1)
04:00.1 0403: 10de:0bee (rev a1)
05:00.0 0106: 197b:2362 (rev 10)
07:01.0 0200: 10ec:8167 (rev 10)
07:02.0 0c00: 1106:3044 (rev c0)
ff:00.0 0600: 8086:2c71 (rev 02)
ff:00.1 0600: 8086:2d81 (rev 02)
ff:02.0 0600: 8086:2d90 (rev 02)
ff:02.1 0600: 8086:2d91 (rev 02)
ff:02.2 0600: 8086:2d92 (rev 02)
ff:02.3 0600: 8086:2d93 (rev 02)
ff:03.0 0600: 8086:2d98 (rev 02)
ff:03.1 0600: 8086:2d99 (rev 02)
ff:03.4 0600: 8086:2d9c (rev 02)
ff:04.0 0600: 8086:2da0 (rev 02)
ff:04.1 0600: 8086:2da1 (rev 02)
ff:04.2 0600: 8086:2da2 (rev 02)
ff:04.3 0600: 8086:2da3 (rev 02)
ff:05.0 0600: 8086:2da8 (rev 02)
ff:05.1 0600: 8086:2da9 (rev 02)
ff:05.2 0600: 8086:2daa (rev 02)
ff:05.3 0600: 8086:2dab (rev 02)
ff:06.0 0600: 8086:2db0 (rev 02)
ff:06.1 0600: 8086:2db1 (rev 02)
ff:06.2 0600: 8086:2db2 (rev 02)
ff:06.3 0600: 8086:2db3 (rev 02)
Back to top
View user's profile Send private message
MisterMagister
n00b
n00b


Joined: 28 Aug 2011
Posts: 11

PostPosted: Thu Aug 30, 2012 11:54 pm    Post subject: Re: ALSA w/ USB and multiple sources? Reply with quote

PaulBredbury wrote:

MisterMagister wrote:
options snd cards_limit=1

You've just mentioned having 2 or 3 audio cards, so set that to 3.


Sorry, yes, I had it set to 3 at one point but completely hosed the file and started over. I forgot to change it back to 3 before I posted, but it was correct at one point in my fiddling.

Will try all of the above suggestions and report back.
Back to top
View user's profile Send private message
MisterMagister
n00b
n00b


Joined: 28 Aug 2011
Posts: 11

PostPosted: Fri Aug 31, 2012 10:17 pm    Post subject: Reply with quote

Ok, thanks for all the replies. After a couple of days of playing around with asound.conf I finally got it working.

However, this REALLY should not be this much trouble. I've been playing around with Linux, OS/2, and other alternative OSes as a hobby since 1994 just because I like a challenge and I like to break things, but this really is too much. You would think with all the advances in usability the OSS community has made in the last several years it wouldn't take a small feat of engineering to select a sound device. Somebody really needs to work on this.

Again, thanks for the help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum