Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub Problem [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1815
Location: Germany

PostPosted: Wed Aug 29, 2012 1:09 pm    Post subject: Grub Problem [solved] Reply with quote

Hallo,

ich habe wohl ein Update von Grub gemacht obwohl die Boot-Partition nicht eingebunden war. Demnach sind entsprechende Dateien auf der Root-Partition angelegt wurden. Ein kopieren der Dateien hat leider nicht geholfen. Vermutlich muss ich grub auch wieder in den MBR schreiben.

Das Problem: Ich kann den Rechner nicht mehr booten. Mit der Grub-Shell kenne ich mich nicht gut genug aus um damit grub zu installieren. Welche Dateien will der Install Befehl der Grubshell denn haben?

Mal schauen ob ich in der Dokumentation was finde, bin ziemlich genervt das mir der Fehler unterlaufen ist. Dachte nach dem Grub update - ach der Rechner läuft eh immer da brauche ich grub nicht sofort zu installieren. Bei einem World update ist es mir dann wohl dazwischen gerutscht.

Grüße

Chris

Edit: Ach ich glaub ich habs schon, der Fehler liegt ja darin das es keine menu.lst gibt deswegen lande ich wohl auf der Shell. Wahrscheinlich auch ein Falscher grup-install Defehl der dann von der Root-Partition versucht zu booten. Alles halb so wild.


Last edited by ChrisJumper on Wed Aug 29, 2012 1:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 155
Location: Switzerland

PostPosted: Wed Aug 29, 2012 1:30 pm    Post subject: Reply with quote

hi,
also wenn du in die grub shell kommst, ist schon einiges gut. wenn du dich auf grub-legacy beziehst, könnte das etwa so aussehen:

Code:

grub> root (hd0,0) # erste partition auf erster hdd
grub> kernel (hd0,0)/kernel-xxx root=/dev/sdxx # laden des kernels
grub> initrd (hd0,0)/initrd-xxx # nur ausführen, falls du ein initrd benutzt
grub> boot # system booten


grüsse
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1815
Location: Germany

PostPosted: Wed Aug 29, 2012 1:59 pm    Post subject: Reply with quote

Danke mvaterlaus!

Das Problem hab ich mittlerweile genau so behoben und eben grub noch mal neu installiert jetzt ist alles bestens.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum