Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tdfsb: SDL ERROR Video mode set failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
skelter
n00b
n00b


Joined: 26 Jun 2004
Posts: 22

PostPosted: Tue Aug 28, 2007 10:12 pm    Post subject: tdfsb: SDL ERROR Video mode set failed Reply with quote

been wrestling with this for a bit and I do not understand something fundamental to the problem.

tdfsb reports
Quote:
SDL ERROR Video mode set failed: X11 driver not configured with OpenGL


Code:

di79suehs libsdl # eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *
di79suehs libsdl # eselect opengl set 1
Switching to nvidia OpenGL interface... done


I even tried flipping it back to xorg-x11, rebuild libsdl, and flipping it back. Alas, no joy. Any clues?

other gl programs seem to run just fine.
Back to top
View user's profile Send private message
PM17E5
Apprentice
Apprentice


Joined: 10 Feb 2009
Posts: 230

PostPosted: Tue Aug 28, 2012 5:56 pm    Post subject: Reply with quote

I hate to dig up such an old thread, but I have the same exact problem 4 years later. I'm getting:

Code:
SDL ERROR Video mode set failed: X11 driver not configured with OpenGL


My opengl driver seems to be xorg-x11 which is weird because months ago it also had intel on the list, but I didn't think much of it because games like Enemey Territory still play the same as ever without any lag, so I'm assuming it still properly doing hardware acceleration?

Code:
eselect opengl list
Available OpenGL implementations:
  [1]   xorg-x11 *


This whole thing isn't at the top of my priorities list, but I really wanted to try out the 3d file browser tdfsb. It seems pretty interesting.
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 260

PostPosted: Sat Sep 01, 2012 10:23 pm    Post subject: Reply with quote

what are your media-libs/libsdl useflags?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum