Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Tue Aug 21, 2012 6:04 am    Post subject: Reply with quote

Thanks for the info.
ahgblopes wrote:
My xorg is really strange (sometimes the screen goes black in some places or the mouse stops working (only working again after changing to a text terminal then changing again to X screen))

Definitely sounds like glitchy nvidia drivers.
You could try downgrading back to a lower version of nvidia-drivers (don't forget to quit xorg and 'rmmod nvidia' each time before restarting X).

By 'work' I mean that you get a desktop without compiz segfaulting.
It's great that unity-2d does work for you in this instance and points more strongly to the opengl/compiz implementation being a bit touchy.
Those decoration bugs (while not as frequent) are still present in unity-6.2 and strangely seem to only occur for GTK+ applications, nautilus is especially sensitive.

Quote:
And about start unity from command line ?

I would guess that using "XSESSION=unity startx" is failing for the same reason launching unity from gdm fails (ie. opengl and compiz not liking each other or it's unityshell plugin).
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Aug 22, 2012 12:16 am    Post subject: Reply with quote

OK I've finally managed to fix the window decoration bugs as they relate to the top bar and appmenu.
These were disappearing window decoration on window restore and top window decoration still present on maximise instead of it snapping into the top appmenu bar.

I'll commit a fix ASAP but you can apply the fix yourself in the meantime.

For unity-2d, open up gconf-editor as your desktop user and disable the following key:
Code:
/apps/metacity/general/show_maximized_titlebars

For unity (3d), open up ccsm as your desktop user and go to 'Effects > Window Decoration'.
Where it says 'any' in the 'Decoration Windows' dialog box, change it to:
Code:
!state=maxvert
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Thu Aug 23, 2012 1:40 am    Post subject: Reply with quote

shiznix wrote:
OK I've finally managed to fix the window decoration bugs as they relate to the top bar and appmenu.
These were disappearing window decoration on window restore and top window decoration still present on maximise instead of it snapping into the top appmenu bar.

I'll commit a fix ASAP but you can apply the fix yourself in the meantime.

For unity-2d, open up gconf-editor as your desktop user and disable the following key:
Code:
/apps/metacity/general/show_maximized_titlebars

For unity (3d), open up ccsm as your desktop user and go to 'Effects > Window Decoration'.
Where it says 'any' in the 'Decoration Windows' dialog box, change it to:
Code:
!state=maxvert


You are a genius!!
I will try it, NOW!!!

EDIT:

I cannot try it in unity, because the segfault, but it worked like a chamr in unity2d!!! Thank you!

Now there are two things that i want to do:

EDIT:

1) Change the launcher icons size --->> SOLVED

2) Possibility to use the window buttons from my theme in panel (but i guess it isn't possible)

I will stick with unity2d until i solve the segfault with unity. --->> Downgrading compiz now, I hope unity6.2 works with compiz-0.9.7.8-r1...
Back to top
View user's profile Send private message
Smolkov
n00b
n00b


Joined: 24 Aug 2012
Posts: 1

PostPosted: Fri Aug 24, 2012 12:25 pm    Post subject: Reply with quote

Hi, i have some problem with indicator-datetime package on unity installation.
So, what's wrong?
http://pastebin.com/hyxRZxir Build log
http://pastebin.com/W8Gnc2T8 emerge --info '=unity-base/indicator-datetime-12.10.0
http://pastebin.com/xTj0TGSc make.conf
http://pastebin.com/QsdwY0BE package.use
http://pastebin.com/CU41Xib5 package.accept_keywords
http://pastebin.com/zydddUrH package.unmask
http://pastebin.com/xd1gbKuN WORLD

I installed Unity on http://wiki.gentoo.org/wiki/Unity this manual
Please help me guys.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Aug 25, 2012 2:22 am    Post subject: Reply with quote

Smolkov wrote:
Hi, i have some problem with indicator-datetime package on unity installation.
So, what's wrong?
http://pastebin.com/hyxRZxir Build log
http://pastebin.com/W8Gnc2T8 emerge --info '=unity-base/indicator-datetime-12.10.0
http://pastebin.com/xTj0TGSc make.conf
http://pastebin.com/QsdwY0BE package.use
http://pastebin.com/CU41Xib5 package.accept_keywords
http://pastebin.com/zydddUrH package.unmask
http://pastebin.com/xd1gbKuN WORLD

I installed Unity on http://wiki.gentoo.org/wiki/Unity this manual
Please help me guys.



Code:

checking for SERVICE... no
configure: error: Package requirements (indicator3-0.4 >= 0.3.19
                           glib-2.0 >= 2.29.19
                           dbusmenu-glib-0.4 >= 0.1.1
                           dbusmenu-gtk3-0.4 >= 0.5.90
                           libido3-0.1 >= 0.2.2
                           gio-2.0 >= 2.25.11
                           geoclue >= 0.12.0
                           libecal-1.2 >= 2.30
                           libical >= 0.44
                           libedataserver-1.2 >= EDS_REQUIRED_VERSION
                           libedataserverui-3.0 >= EDS_REQUIRED_VERSION
                           cairo >= CAIRO_REQUIRED_VERSION
                           gdk-3.0 >= GDK_REQUIRED_VERSION
                           gconf-2.0 >= GCONF_REQUIRED_VERSION) were not met:
 
No package 'libecal-1.2' found
No package 'libedataserver-1.2' found
No package 'libedataserverui-3.0' found



edit: indicator-datetime seems to depend on evolution, so try emerge evolution, this should work.

for the maintainer: if it works, i guess you should add evolution as a dep in the ebuild, or if it is optional, you should make a patch in the config file to don't ask for these deps, or am i wrong?
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Aug 25, 2012 8:27 pm    Post subject: Reply with quote

The problem is really with compiz.

I cannot downgrade unity from 6.2 to 5.12 anymore, so is there any way to use compiz 6.2 with a previous version of compiz ?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Aug 27, 2012 2:10 am    Post subject: Reply with quote

Fixed the unity-base/indicator-datetime depend on gnome-extra/evolution-data-server and rolled it's version back to the Precise release of 0.3.94 as the 12.10.0 Quantal version needs evolution-data-server-3.5 which hasn't made it into the portage tree yet.
Thanks for the report!! :)
Quote:
I cannot downgrade unity from 6.2 to 5.12 anymore, so is there any way to use compiz 6.2 with a previous version of compiz ?

Unity 6.2 can use either compiz-0.9.7.8-r1 or compiz-0.9.8-r1.
If you require the lower version, mask the higher version.
Code:
echo ">=unity-base/compiz-0.9.8" >> /etc/portage/package.mask
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Aug 27, 2012 3:13 am    Post subject: Reply with quote

shiznix wrote:
Fixed the unity-base/indicator-datetime depend on gnome-extra/evolution-data-server and rolled it's version back to the Precise release of 0.3.94 as the 12.10.0 Quantal version needs evolution-data-server-3.5 which hasn't made it into the portage tree yet.
Thanks for the report!! :)
Quote:
I cannot downgrade unity from 6.2 to 5.12 anymore, so is there any way to use compiz 6.2 with a previous version of compiz ?

Unity 6.2 can use either compiz-0.9.7.8-r1 or compiz-0.9.8-r1.
If you require the lower version, mask the higher version.
Code:
echo ">=unity-base/compiz-0.9.8" >> /etc/portage/package.mask



No, i can't...

Am i going crazy?!?!


Code:

Calculating dependencies... done!
[ebuild   R   ~] unity-base/unity-meta-6.2.0::unity-gentoo  0 kB
[ebuild  N    ~]  unity-base/unity-6.2.0::unity-gentoo  USE="-debug" 0 kB
[ebuild  N    #]   unity-base/compiz-0.9.8-r1::unity-gentoo  USE="-debug" 0 kB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 0 kB

The following keyword changes are necessary to proceed:
#required by unity-base/unity-6.2.0, required by unity-base/unity-meta-6.2.0, required by unity-meta (argument)
=unity-base/compiz-0.9.8-r1 ~amd64

The following mask changes are necessary to proceed:
#required by unity-base/unity-6.2.0, required by unity-base/unity-meta-6.2.0, required by unity-meta (argument)
=unity-base/compiz-0.9.8-r1


Is this a bug or am i bugged ??...

There is another thing that are making me crazy...

THE CEDILLA....

Cedilla (Ç) works for all applications, except for the gtk2 ones (firefox, libreoffice, leafpad, porthole, etc)...

In GTK2 apps i have to type right alt + , to get Cedilla, instead of '(accute) + C, that is the correct....

I googled about it and i discover that i need to change inmmodules file inside the /etc/gtk-2.0 folder, and add "en" to the cedilla line. I also put "export GTK_IM_MODULE=cedilla" in various files (/etc/profile, /etc/environment, ~/.env, etc...) I also replaced the ć to ç in compose file, but nothing works!!!!

But why am i posting this here? Because i suspect that it is a bug from this patched gtk2 version (or i'm going crazy!!)..
In gtk3 apps, in the popup menu from text boxes, i have an option called "input methods", and i have the "cedilla" option in it (is the default), but not in gtk2 ones (in gtk2 apps i have only one choice, labeled "simples" in portuguese, that means simple, i guess...)...

When i was using gnome2 all gtk2 apps worked fine with the cedilla....


Any help well be appreciated! And sorry for my english, i post this in hurry...
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Aug 27, 2012 12:30 pm    Post subject: Reply with quote

See if a sync update fixes.

I commited a fix for x11-plugins/compiz-plugins-main in https://github.com/shiznix/unity-gentoo/commit/7872306ed518c7c233d7b80572b070c8a550629d
This may or may not have been causing you the grief, so if it makes no difference, try and see why it's complaining with:
Code:
emerge -p =compiz-0.9.7.8-r1

Thanks :)
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Aug 27, 2012 11:05 pm    Post subject: Reply with quote

shiznix wrote:
See if a sync update fixes.

I commited a fix for x11-plugins/compiz-plugins-main in https://github.com/shiznix/unity-gentoo/commit/7872306ed518c7c233d7b80572b070c8a550629d
This may or may not have been causing you the grief, so if it makes no difference, try and see why it's complaining with:
Code:
emerge -p =compiz-0.9.7.8-r1

Thanks :)


No way :(

after layman -d unity-gentoo, layman -a unity-gentoo, emerge --sync, and emerge -avt unity-meta, i go

t this again:

Code:

sudo emerge -avt unity-meta

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ~] unity-base/unity-meta-6.2.0::unity-gentoo  0 kB
[ebuild  N    ~]  unity-base/unity-6.2.0::unity-gentoo  USE="-debug" 0 kB
[ebuild  N    #]   unity-base/compiz-0.9.8-r1::unity-gentoo  USE="-debug" 0 kB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 0 kB

The following keyword changes are necessary to proceed:
#required by unity-base/unity-6.2.0, required by unity-base/unity-meta-6.2.0, required by unity-meta (argument)
=unity-base/compiz-0.9.8-r1 ~amd64

The following mask changes are necessary to proceed:
#required by unity-base/unity-6.2.0, required by unity-base/unity-meta-6.2.0, required by unity-meta (argument)
# /etc/portage/package.mask:
#>=dev-libs/dbus-glib-0.100
#>=sys-apps/dbus-1.6.0
#<x11-wm/metacity-99.2.34.1
#=x11-base/xorg-server-1.12.3-r9999
=unity-base/compiz-0.9.8-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).



Code:

sudo emerge -p =unity-base/compiz-0.9.7.8-r1
Senha:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] unity-base/compiz-0.9.7.8-r1  USE="-debug"




And about the cedilla, some idea?
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Wed Aug 29, 2012 3:57 am    Post subject: Reply with quote

No, i'm not crazy!!!....

After i updated the repository (layman -d unity-gentoo; layman -a unity-gentoo)
i extracted this from unity-6.2.0.ebuild :

Code:

DEPEND="|| ( >=unity-base/compiz-0.9.8
      ( <unity-base/compiz-0.9.8 unity-base/ccsm unity-base/compizconfig-python x11-libs/libcompizconfig x11-plugins/compiz-plugins-main ) )



edit:

strange...This seems a portage bug. There isn't any error in repo side, i guess. The ebuild is telling to install >=unity-base/compiz-0.9.8 OR <unity-base/compiz-0.9.8 unity-base/ccsm unity-base/compizconfig-python x11-libs/libcompizconfig x11-plugins/compiz-plugins-main.

Portage should tell me that:
Code:

The following keyword changes are necessary to proceed:
#required by unity-base/compizconfig-python-0.9.5.94, required by unity-base/ccsm-0.9.5.92, required by unity-base/ccsm (argument)
=x11-libs/libcompizconfig-0.9.5.94 ~amd64
#required by x11-plugins/compiz-plugins-main (argument)
=x11-plugins/compiz-plugins-main-0.9.7.0 ~amd64
#required by unity-base/ccsm-0.9.5.92, required by unity-base/ccsm (argument)
=unity-base/compizconfig-python-0.9.5.94 ~amd64
#required by unity-base/ccsm-0.9.5.92, required by unity-base/ccsm (argument)
=unity-base/compizconfig-backend-gconf-0.9.5.92 ~amd64

The following mask changes are necessary to proceed:
#required by x11-plugins/compiz-plugins-main (argument)
# /usr/portage/profiles/package.mask:
# Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (22 Jan 2012)
# Mask compiz for last-rites unless someone steps up
# to maintain it. Proxy maintainers will take care of this.
=x11-plugins/compiz-plugins-main-0.9.7.0


when i tried to install unity with compiz <unity-base/compiz-0.9.8, but it doesn't.

So i tried it:

emerge -av unity-base/ccsm unity-base/compizconfig-python x11-libs/libcompizconfig x11-plugins/compiz-plugins-main

and i got the keyword/mask instructions above.


I did it (keyworded and unmasked these packages), and now it works fine:

Code:

sudo emerge -avt unity

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N    ~] unity-base/unity-6.2.0::unity-gentoo  USE="-debug" 0 kB
[ebuild  N    #]  x11-plugins/compiz-plugins-main-0.9.7.0::unity-gentoo  USE="-debug" 0 kB
[ebuild  N    ~]  unity-base/ccsm-0.9.5.92::unity-gentoo  0 kB
[ebuild  N    ~]   unity-base/compizconfig-python-0.9.5.94::unity-gentoo  0 kB
[ebuild  N     ]    dev-python/cython-0.16  USE="-doc -examples -numpy" 0 kB
[ebuild  N    ~]   unity-base/compizconfig-backend-gconf-0.9.5.92::unity-gentoo  0 kB
[ebuild  N    ~]    x11-libs/libcompizconfig-0.9.5.94::unity-gentoo  USE="-debug" 0 kB
[ebuild  N    ~]     unity-base/compiz-0.9.7.8-r1::unity-gentoo  USE="-debug" 0 kB

Total: 8 packages (8 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]



So, it seems a portage error, that don't ask for unmask those packages to use a compiz < 0.9.8.

Compiling, results soon....

Thank you again for the help :)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Aug 29, 2012 8:06 am    Post subject: Reply with quote

Glad you got it sorted, let us know how it goes.

I've just done a heap of version bumps to the packages that already use Quantal versions.
https://github.com/shiznix/unity-gentoo/commit/e01ef2ce5f131c91bdf0e3ef5d423c9d979752ff

They're a lively lot these Ubuntu devs. and I wonder if I was a bit premature starting to bump packages up to Quantal.
No real major breakages and it's pretty rock solid, just the version updates are thick and fast at the moment.
Lots of fixes but a few regressions also that all need testing and it sucks a bit of time that I could be spending on issues such as you're seeing ahgblopes.

I'll live with that decision for now and keep maintaining the Quantal revisions as it should start to calm down somewhat in the next couple of days with feature freezes.
Following https://wiki.ubuntu.com/QuantalQuetzal/ReleaseSchedule , I'll jump in with the version bumps at the 1st Beta release next time :roll:
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Aug 29, 2012 8:45 am    Post subject: Reply with quote

ahgblopes wrote:
Code:

The following keyword changes are necessary to proceed:
#required by unity-base/compizconfig-python-0.9.5.94, required by unity-base/ccsm-0.9.5.92, required by unity-base/ccsm (argument)
=x11-libs/libcompizconfig-0.9.5.94 ~amd64
#required by x11-plugins/compiz-plugins-main (argument)
=x11-plugins/compiz-plugins-main-0.9.7.0 ~amd64
#required by unity-base/ccsm-0.9.5.92, required by unity-base/ccsm (argument)
=unity-base/compizconfig-python-0.9.5.94 ~amd64
#required by unity-base/ccsm-0.9.5.92, required by unity-base/ccsm (argument)
=unity-base/compizconfig-backend-gconf-0.9.5.92 ~amd64

The following mask changes are necessary to proceed:
#required by x11-plugins/compiz-plugins-main (argument)
# /usr/portage/profiles/package.mask:
# Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> (22 Jan 2012)
# Mask compiz for last-rites unless someone steps up
# to maintain it. Proxy maintainers will take care of this.
=x11-plugins/compiz-plugins-main-0.9.7.0

Therein lies the problem.

x11-plugins/compiz-plugins-main is masked in portage tree but is required by unity-base/compiz-0.9.7.8
As a result, emerge can't fulfill the requirements for installing compiz-0.9.7.8, so correctly falls through to attempting to install compiz-0.9.8.

So to get the achieved result of installing unity-6.2 with compiz-0.9.7.8, the following is required:
Code:
echo "x11-plugins/compiz-plugins-main" >> /etc/portage/package.unmask
echo ">=unity-base/compiz-0.9.8" >> /etc/portage/package.mask
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Thu Aug 30, 2012 2:23 am    Post subject: Reply with quote

shiznix wrote:
Glad you got it sorted, let us know how it goes.


Code:

Initializing unityshell options...done
ERROR 2012-08-29 23:21:19 nux.gestures_subscription GesturesSubscription.cpp:299 Failed to activate Geis subscription.
Falha de segmentação (Segmentation fault)



:cry:
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Thu Aug 30, 2012 2:35 am    Post subject: Reply with quote

I will think about perform a fresh install ...
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Thu Aug 30, 2012 3:11 am    Post subject: Reply with quote

Sorry for post again, but this is a very relevant info:

I uninstall unity (only the "unity" package), and now compiz works very well (without unity, of course)...

The problem is really with unity 6.2 (or nux 3.2, i guess).

Is there any way to downgrade to a previous version of unity (5.12 i guess) ? 5.12 worked fine, except the decoration bug (that is solved now.....).
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Thu Aug 30, 2012 9:07 am    Post subject: Reply with quote

ahgblopes wrote:
Sorry for post again, but this is a very relevant info:

I uninstall unity (only the "unity" package), and now compiz works very well (without unity, of course)...

The problem is really with unity 6.2 (or nux 3.2, i guess).

Is there any way to downgrade to a previous version of unity (5.12 i guess) ? 5.12 worked fine, except the decoration bug (that is solved now.....).

Good to know that compiz is probably not to blame here and we can strike one possibility off the list.
Looks like unityshell hands off some function to nux, nux fails on it's geis implementation and so unityshell segfaults accordingly.

Unfortunately to have unity-5.12 (now unity-5.14) in the overlay, nux and all the utouch packages would also have to be downgraded.
I'll look at doing that but it will take a bit of time and ideally we should see if the problem can be fixed.

So to fixing the problem between unity/nux/geis...
Gesture (geis) support is optional in nux.
Nux gesture support is mandatory in unity (unity2d uses geis directly) so we can't disable that :/

I've added a 'debug' USE flag for nux, so enabling this and re-emerging nux may (or may not) give some more info.

It seems geis might be having some problem accessing your input device.
In an X terminal as your desktop user, try running 'geistest' and 'geisview' to see if it finds a valid input device.

If that fails, check you have the following:
Enabled CONFIG_INPUT_EVDEV support in your kernel under 'Device Drivers' > 'Input device support' > 'Event interface'.
Ensure you have x11-drivers/xf86-input-evdev installed (I'm using 2.7.0), and x11-proto/inputproto installed (I'm using 2.2).
Ensure Xorg is using the evdev input driver, a check of /var/log/Xorg.0.log should show this.

If the 'geistest' and 'geisview' programs show a valid input device, then we can probably safely assume that it is nux that is the culprit here.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Thu Aug 30, 2012 10:41 pm    Post subject: Reply with quote

shiznix wrote:

If the 'geistest' and 'geisview' programs show a valid input device, then we can probably safely assume that it is nux that is the culprit here.


Yes, geistest and geisview show a valid device, and now? I will try to recompile nux with debug flag, results soon...
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Fri Aug 31, 2012 2:50 am    Post subject: Reply with quote

I rebuild nux and unity with debug use flag, but i still without any relevant information...

edit: is there some special way to start unity to get the debug info?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Aug 31, 2012 9:19 am    Post subject: Reply with quote

ahgblopes wrote:
I rebuild nux and unity with debug use flag, but i still without any relevant information...

edit: is there some special way to start unity to get the debug info?

I'll look into being able to get some decent debug info.
In the meantime I'll try and re-add the old unity, nux and utouch packages this evening for you.

Thanks for persevering :wink:
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 642

PostPosted: Sat Sep 01, 2012 10:11 am    Post subject: Reply with quote

Hello,

I'm trying to try out your overlay, but I've run into two issues:
  • I can't fetch qt:
    Code:
    >>> Downloading 'http://archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/qt4-x11_4.8.2-0ubuntu4.debian.tar.gz'
    --2012-09-01 11:46:26--  http://archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/qt4-x11_4.8.2-0ubuntu4.debian.tar.gz
    Herleiden van archive.ubuntu.com... 91.189.92.156, 91.189.92.182, 91.189.92.183, ...
    Verbinding maken met archive.ubuntu.com|91.189.92.156|:80... verbonden.
    HTTP-verzoek is verzonden; wachten op antwoord... 404 Not Found
    2012-09-01 11:46:26 Fout 404: Not Found.

  • there are more blockers than just qt:
    Code:
    x11-libs/gtk+:3

      (x11-libs/gtk+-99.3.4.2::unity-gentoo, ebuild scheduled for merge) pulled in by
        >=x11-libs/gtk+-99.3.4.2:3 required by (dev-libs/libdbusmenu-0.6.2::unity-gentoo, ebuild scheduled for merge)
        (and 12 more with the same problem)

      (x11-libs/gtk+-3.4.4::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

    x11-libs/gtk+:2

      (x11-libs/gtk+-99.2.24.11-r1::unity-gentoo, ebuild scheduled for merge) pulled in by
        >=x11-libs/gtk+-99.2.24.11:2 required by (x11-misc/appmenu-gtk-12.10.0::unity-gentoo, ebuild scheduled for merge)
        (and 2 more with the same problem)

      (x11-libs/gtk+-2.24.11-r1::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

    dev-libs/glib:2

      (dev-libs/glib-99.2.32.3::unity-gentoo, ebuild scheduled for merge) pulled in by
        >=dev-libs/glib-99.2.32.3 required by (unity-base/dconf-qt-0.0.0.110722::unity-gentoo, ebuild scheduled for merge)
        (and 3 more with the same problem)

      (dev-libs/glib-2.32.4::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

    app-accessibility/at-spi2-core:2

      (app-accessibility/at-spi2-core-2.2.3::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (app-accessibility/at-spi2-core-2.4.2::gentoo, ebuild scheduled for merge) pulled in by
        >=app-accessibility/at-spi2-core-2.4 required by (app-accessibility/at-spi2-atk-2.5.3::unity-gentoo, ebuild scheduled for merge)

    media-libs/mesa:0

      (media-libs/mesa-8.1_rc1_pre20120814::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (media-libs/mesa-8.0.4::gentoo, ebuild scheduled for merge) pulled in by
        <=media-libs/mesa-8.0.4 required by (unity-base/compiz-0.9.8-r2::unity-gentoo, ebuild scheduled for merge)

    gnome-base/gnome-desktop:3

      (gnome-base/gnome-desktop-3.2.1::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (gnome-base/gnome-desktop-3.4.2::gentoo, ebuild scheduled for merge) pulled in by
        >=gnome-base/gnome-desktop-3.3.92:3 required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)

Is there anything I can do to fix this? Is this a problem with my system?

Thanks for your work, I look forward to being able to try it out :)
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Sep 01, 2012 8:45 pm    Post subject: Reply with quote

Aquous wrote:
Hello,

I'm trying to try out your overlay, but I've run into two issues:
  • I can't fetch qt:
    Code:
    >>> Downloading 'http://archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/qt4-x11_4.8.2-0ubuntu4.debian.tar.gz'
    --2012-09-01 11:46:26--  http://archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/qt4-x11_4.8.2-0ubuntu4.debian.tar.gz
    Herleiden van archive.ubuntu.com... 91.189.92.156, 91.189.92.182, 91.189.92.183, ...
    Verbinding maken met archive.ubuntu.com|91.189.92.156|:80... verbonden.
    HTTP-verzoek is verzonden; wachten op antwoord... 404 Not Found
    2012-09-01 11:46:26 Fout 404: Not Found.

  • there are more blockers than just qt:
    Code:
    x11-libs/gtk+:3

      (x11-libs/gtk+-99.3.4.2::unity-gentoo, ebuild scheduled for merge) pulled in by
        >=x11-libs/gtk+-99.3.4.2:3 required by (dev-libs/libdbusmenu-0.6.2::unity-gentoo, ebuild scheduled for merge)
        (and 12 more with the same problem)

      (x11-libs/gtk+-3.4.4::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

    x11-libs/gtk+:2

      (x11-libs/gtk+-99.2.24.11-r1::unity-gentoo, ebuild scheduled for merge) pulled in by
        >=x11-libs/gtk+-99.2.24.11:2 required by (x11-misc/appmenu-gtk-12.10.0::unity-gentoo, ebuild scheduled for merge)
        (and 2 more with the same problem)

      (x11-libs/gtk+-2.24.11-r1::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

    dev-libs/glib:2

      (dev-libs/glib-99.2.32.3::unity-gentoo, ebuild scheduled for merge) pulled in by
        >=dev-libs/glib-99.2.32.3 required by (unity-base/dconf-qt-0.0.0.110722::unity-gentoo, ebuild scheduled for merge)
        (and 3 more with the same problem)

      (dev-libs/glib-2.32.4::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

    app-accessibility/at-spi2-core:2

      (app-accessibility/at-spi2-core-2.2.3::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (app-accessibility/at-spi2-core-2.4.2::gentoo, ebuild scheduled for merge) pulled in by
        >=app-accessibility/at-spi2-core-2.4 required by (app-accessibility/at-spi2-atk-2.5.3::unity-gentoo, ebuild scheduled for merge)

    media-libs/mesa:0

      (media-libs/mesa-8.1_rc1_pre20120814::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (media-libs/mesa-8.0.4::gentoo, ebuild scheduled for merge) pulled in by
        <=media-libs/mesa-8.0.4 required by (unity-base/compiz-0.9.8-r2::unity-gentoo, ebuild scheduled for merge)

    gnome-base/gnome-desktop:3

      (gnome-base/gnome-desktop-3.2.1::gentoo, installed) pulled in by
        (no parents that aren't satisfied by other packages in this slot)

      (gnome-base/gnome-desktop-3.4.2::gentoo, ebuild scheduled for merge) pulled in by
        >=gnome-base/gnome-desktop-3.3.92:3 required by (gnome-base/gnome-settings-daemon-99.3.4.2-r1::unity-gentoo, ebuild scheduled for merge)

Is there anything I can do to fix this? Is this a problem with my system?

Thanks for your work, I look forward to being able to try it out :)


Just add the packages to /etc/portage/package.accept_keywords

for example, for gtk2 and 3:


(as root): echo "=x11-libs/gtk+-99.3.4.2 ~yourarch" >> /etc/portage/package.accept_keywords
and
echo "=x11-libs/gtk+-99.2.24.11 ~yourarch" >> /etc/portage/package.accept_keywords


If for some package it doesn't work, add the package (from unity-gentoo repo) to package.unmask, and you might have to put confliting packages (from gentoo repo) in package.mask

The 404 error should be fixed soon, i guess.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Sep 02, 2012 2:04 am    Post subject: Reply with quote

Hey, Shiznix, can you explain better that method to have the overlay control automatically the keywords of their packages? I tried this:

~ # mkdir -p /etc/portage/package.keywords
~ # ln -s /var/lib/layman/unity-gentoo/PACKAGES /etc/portage/package.keywords/unity-gentoo

But it don't seems to work...

I make some modifications in my accept_keywords (changed some = to >=), and now it is:

Code:

>=unity-base/rhythmbox-ubuntuone-3.0.0::unity-gentoo ~amd64
>=unity-base/ubuntuone-client-3.0.2::unity-gentoo ~amd64
=unity-base/ubuntuone-control-panel-3.0.1::unity-gentoo ~amd64 
>=unity-base/ubuntuone-storage-protocol-3.0.0::unity-gentoo ~amd64
>=unity-base/unity-lens-applications-5.12.0::unity-gentoo ~amd64
>=unity-base/unity-lens-files-5.10.0::unity-gentoo ~amd64
>=unity-base/unity-lens-music-5.12.0::unity-gentoo ~amd64
>=unity-base/unity-lens-video-0.3.5::unity-gentoo ~amd64
>=unity-base/unity-scope-video-remote-0.3.5::unity-gentoo ~amd64
>=unity-base/unity2d-5.12.0-r3::unity-gentoo ~amd64
>=unity-base/utouch-evemu-1.0.9::unity-gentoo ~amd64
>=unity-base/utouch-frame-2.2.3::unity-gentoo ~amd64
>=unity-base/utouch-geis-2.2.9::unity-gentoo ~amd64
>=unity-base/utouch-grail-3.0.5::unity-gentoo ~amd64
>=x11-misc/appmenu-gtk-0.3.92::unity-gentoo ~amd64
>=x11-themes/ubuntu-mono-0.0.40::unity-gentoo  ~amd64
>=x11-themes/unity-asset-pool-0.8.23::unity-gentoo ~amd64
>=unity-base/nux-2.12.0::unity-gentoo ~amd64
>=unity-base/launchpad-integration-0.1.56::unity-gentoo ~amd64
>=unity-base/indicator-session-0.3.96::unity-gentoo ~amd64
>=unity-base/indicator-sound-0.8.5.0::unity-gentoo ~amd64
>=unity-base/indicator-datetime-0.3.94::unity-gentoo ~amd64
>=unity-base/indicator-appmenu-0.3.97::unity-gentoo ~amd64
>=unity-base/indicator-application-0.5.0::unity-gentoo ~amd64
>=unity-base/indicator-applet-0.5.0::unity-gentoo ~amd64
>=unity-base/ido-0.3.4::unity-gentoo  ~amd64
>=unity-base/dconf-qt-0.0.0.110722::unity-gentoo ~amd64
>=x11-libs/libvdpau-0.4.1-r1::ah-overlay ~amd64
>=unity-base/ccsm-0.9.5.92::unity-gentoo ~amd64
>=unity-base/bamf-0.2.118::unity-gentoo ~amd64
>=dev-python/lazr-restfulclient-0.12.0::unity-gentoo ~amd64
>=dev-python/dirspec-3.0.0::unity-gentoo ~amd64
>=dev-python/configglue-1.0::unity-gentoo ~amd64
>=dev-libs/libunity-misc-4.0.4::unity-gentoo ~amd64
>=dev-libs/libunity-5.12.0::unity-gentoo ~amd64
>=dev-libs/libtimezonemap-0.3.2::unity-gentoo ~amd64
>=dev-libs/libqtdee-0.2.4::unity-gentoo ~amd64
>=dev-libs/libqtgconf-0.1::unity-gentoo ~amd64
>=dev-libs/libubuntuone-3.0.1::unity-gentoo  ~amd64
>=x11-libs/qt-test-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-svg-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-qt3support-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-sql-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-gui-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-script-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-dbus-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-phonon-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-opengl-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-core-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-xmlpatterns-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-svg-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-declarative-99.4.8.2::unity-gentoo ~amd64
>=x11-libs/qt-webkit-99.4.8.2::unity-gentoo ~amd64
>=dev-libs/libqtbamf-0.2.4::unity-gentoo ~amd64
=x11-misc/appmenu-firefox-14.0.1 ~amd64
=www-client/firefox-14.0.1::gentoo ~amd64
=gnome-extra/gtkhtml-4.4.3 ~amd64
=dev-tcltk/tile-0.8.2 ~amd64
=unity-extra/indicator-power-2.0 ~amd64
>=unity-base/unity-meta-6.2.0
=app-accessibility/at-spi2-core-2.4.2 ~amd64
=app-accessibility/caribou-0.4.2 ~amd64
=app-admin/packagekit-0.7.4 ~amd64
=app-admin/packagekit-base-0.7.4 ~amd64
=app-admin/packagekit-gtk-0.7.4 ~amd64
=app-admin/packagekit-qt4-0.7.4  ~amd64
=app-text/evince-3.4.0 ~amd64
=dev-lang/spidermonkey-1.8.5-r1 ~amd64
=dev-libs/atk-2.4.0 ~amd64
=dev-libs/boost-1.49.0-r1 ~amd64
=dev-libs/dee-1.0.10 ~amd64
=dev-libs/folks-0.6.6 ~amd64
=dev-libs/gjs-1.32.0 ~amd64
=dev-libs/gobject-introspection-1.32.1 ~amd64
=dev-libs/gobject-introspection-common-1.32.1 ~amd64
=dev-libs/libgdata-0.10.2 ~amd64
=dev-libs/libgweather-3.4.1 ~amd64
=dev-libs/libwacom-0.5 ~amd64
=dev-python/isodate-0.4.8 ~amd64
=dev-python/pyatspi-2.2.1 ~amd64
=dev-python/python-distutils-extra-2.33 ~amd64
=dev-python/python-geoclue-0.1.0  ~amd64
=dev-python/rdflib-3.2.1 ~amd64
=dev-util/boost-build-1.49.0 ~amd64
=dev-util/gdbus-codegen-2.32.4 ~amd64
=gnome-base/gdm-3.4.1 **
=gnome-base/gnome-desktop-3.4.2 ~amd64
=gnome-base/gnome-menus-3.0.1-r1 ~amd64
=gnome-base/gnome-panel-3.4.1  ~amd64
=gnome-base/gnome-shell-3.2.2.1 ~amd64
=gnome-base/libgdu-3.0.2 ~amd64
=gnome-base/libgnomekbd-3.2.0-r1 ~amd64
=gnome-extra/evolution-data-server-3.2.3-r2 ~amd64
=gnome-extra/gnome-color-manager-3.2.4 ~amd64
=gnome-extra/sushi-0.2.1 ~amd64
=gnome-extra/zeitgeist-0.9.0.1 ~amd64
=gnome-extra/zeitgeist-datasources-0.8.0.1 ~amd64
=gnome-extra/zeitgeist-extensions-0.0.13-r1 ~amd64
=media-libs/webrtc-audio-processing-0.1 ~amd64
=media-sound/pulseaudio-2.1 ~amd64
=media-video/cheese-3.4.2  ~amd64
=net-libs/gnome-online-accounts-3.2.1 ~amd64
=net-libs/liboauth-0.9.7 ~amd64
=net-misc/networkmanager-0.9.4.0-r5 ~amd64
=net-print/cups-pk-helper-0.2.2 ~amd64
=net-wireless/blueman-1.23-r2 ~amd64
=sys-devel/gcc-4.6.3 ~amd64
=sys-libs/db-5.1.29 ~amd64
=x11-libs/gdk-pixbuf-2.26.1 ~amd64
=x11-libs/mx-1.4.2 ~amd64
=x11-libs/pango-1.30.1 ~amd64
=x11-libs/vte-9999 **
=x11-misc/appmenu-qt-0.2.6 ~amd64
=x11-themes/gnome-icon-theme-3.4.0 ~amd64
=x11-wm/mutter-3.2.2-r1 ~amd64
=gnome-extra/nm-applet-99.0.9.4.1 ~amd64
=x11-wm/metacity-99.2.34.1 ~amd64
=gnome-extra/gconf-editor-3.0.1 ~amd64
=x11-libs/gtk+-99.3.4.2 ~amd64
=x11-base/xorg-server-1.12.3-r9999 ~amd64
=x11-libs/libXfixes-5.0-r9999::unity-gentoo ~amd64
=x11-proto/fixesproto-5.0-r9999::unity-gentoo ~amd64
=gnome-base/gsettings-desktop-schemas-99.3.4.1::unity-gentoo ~amd64
=gnome-base/gconf-99.3.2.5 ~amd64
=unity-base/ubuntu-sso-client-3.0.2 ~amd64
>=unity-base/unity-6.2.0-r1 ~amd64
=unity-base/compiz-0.9.8-r2 ~amd64


Is it right? I missed something important? Are there some unecessary lines? I stick with ubuntuone-control-panel 3.0.1 because i cannot compile 3.99.90.

I'm upgrading my system now, and i will make a clean, revdep-rebuild, etc... I hope it will work now, if not, i will downgrade to 5.14.

edit: 6.2 doesn't work... Where is 5.14???

edit2: ok, i found it, downgrading... Thank you!!
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 642

PostPosted: Sun Sep 02, 2012 7:24 pm    Post subject: Reply with quote

ahgblopes wrote:
The 404 error should be fixed soon, i guess.
You were right, it's fixed now.
However, I can't emerge qt-gui now:
Code:
 * Failed Patch: qt-gui-4.7.3-cups.patch !
 *  ( /var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/x11-libs/qt-gui-99.4.8.2/temp/qt-gui-4.7.3-cups.patch.out

The mentioned file reads:
Code:
***** qt-gui-4.7.3-cups.patch *****
PWD: /var/tmp/portage/x11-libs/qt-gui-99.4.8.2/work/qt-everywhere-opensource-src-4.8.2

===================================

PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p1 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
patching file src/gui/dialogs/qprintdialog_unix.cpp
Hunk #1 FAILED at 569.
1 out of 1 hunk FAILED -- saving rejects to file src/gui/dialogs/qprintdialog_unix.cpp.rej
patching file src/gui/painting/qprinter.cpp
Hunk #1 succeeded at 229 with fuzz 2 (offset -398 lines).

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p2 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p3 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1
===================================

PATCH COMMAND:  patch -p4 -g0 -E --no-backup-if-mismatch  < '/var/lib/layman/unity-gentoo/x11-libs/qt-gui/files/qt-gui-4.7.3-cups.patch'

===================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/dialogs/qprintdialog_unix.cpp   2010-02-28 04:34:16.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 40
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp
|--- qt-everywhere-opensource-src-4.6.2/src/gui/painting/qprinter.cpp   2010-02-11 16:55:22.000000000 +0100
|+++ qt-everywhere-opensource-src-4.6.2-cups/src/gui/painting/qprinter.cpp   2010-02-28 04:55:15.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored

patch program exited with status 1
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Sep 02, 2012 7:38 pm    Post subject: Reply with quote

Sorry for the late reply, adding 5.14 back in took some testing and I had done some breaking with testing python-3.2 that needed some fixing also.
Having mulitple python ABIs is still not there but it's improving at least, stick with using python-2.7 for now.


@ahgblopes
Added unity-5.14.0 back into the tree and created a unity-meta-5.14.0.
Missing keyword masked the unstable unity-6.2 and it's deps, so should work doing
Code:
emerge -a unity-meta
I've also backported the dbus-1.6 stuff from Quantal to work with unity-5.14 so that should be seamless.

Decided to mask the latest version because I was also experiencing some problems with it.
Graphics glitches in the lens overlay that would strangely clean itself once the screen was toggled to 'Show Desktop' and back again.
Unity-5.14 is able to successfully respawn itself from a crash whereas 6.2 would sort of try but the result was a missing top indicator and side launcher panels with some odd graphics glitches.

Anyway sync up and try, hopefully it's a better experience for you :wink:


@Aquous
Hi, thanks for the QT report, this has been fixed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 24, 25, 26  Next
Page 4 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum