Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No fonts in Steam.exe after updating Wine? [workaround]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2403
Location: UK

PostPosted: Tue Aug 21, 2012 8:08 pm    Post subject: No fonts in Steam.exe after updating Wine? [workaround] Reply with quote

I did an emerge -u two days ago and Steam's become almost unusable since then. The in-client webkit stuff works though, as does every other Wine app I've tested. But the main GUI just has no text at all, as if it's rendering everything at 0px size. Nobody else seems to have reported bugs about this so I'm posting here in case it's a configuration error.

In the terminal I see hundreds of lines like these when I mouseover stuff, with new ones being added every 1-2 seconds when I'm not doing anything:
Code:
fixme:dwrite:dwritefactory_CreateTextLayout (L"Friends" 7 (nil) 10000.000000 10000.000000 0x33bca8): stub
fixme:dwrite:dwritefactory_CreateTextLayout (L"Games" 5 (nil) 10000.000000 10000.000000 0x33bc8c): stub
fixme:dwrite:dwritefactory_CreateMonitorRenderingParams (0x1 0x33bcb8): stub
fixme:dwrite:dwritefactory_CreateRenderingParams (0x33bcb8): stub
fixme:dwrite:dwritefactory_CreateTextLayout (L"Games" 5 (nil) 10000.000000 10000.000000 0x33bca8): stub
fixme:dwrite:dwritefactory_CreateTextLayout (L"Help" 4 (nil) 10000.000000 10000.000000 0x33bc8c): stub
fixme:dwrite:dwritefactory_CreateMonitorRenderingParams (0x1 0x33bcb8): stub
fixme:dwrite:dwritefactory_CreateRenderingParams (0x33bcb8): stub


Last edited by Ant P. on Thu Sep 13, 2012 10:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
whig
l33t
l33t


Joined: 27 Nov 2004
Posts: 970
Location: New Zealand

PostPosted: Tue Aug 21, 2012 9:01 pm    Post subject: Reply with quote

Just checked, same problem here. WIne 1.5.11 although mine's in a 32 bit chroot.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2403
Location: UK

PostPosted: Tue Aug 21, 2012 9:09 pm    Post subject: Reply with quote

Yeah, that's how I run mine too. I just noticed text is broken in a few games, but still readable.

Edit: Same problem in 1.5.10 too, but 1.5.9 works fine.
Back to top
View user's profile Send private message
Mistwolf
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2007
Posts: 108
Location: Edmonton, AB

PostPosted: Wed Aug 22, 2012 3:32 am    Post subject: Reply with quote

it is a regression they introduced in 1.5.10. If you start the program/steam/game with "-no-dwrite", it works like 1.5.9.

Hope this helps.

Edit: Bug report at Wine HQ http://bugs.winehq.org/show_bug.cgi?id=31374
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 778
Location: Germany

PostPosted: Tue Sep 04, 2012 8:34 am    Post subject: Reply with quote

If you use winetricks to install steam, it works.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum