Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo Updaten schlägt fehl
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mathos93
n00b
n00b


Joined: 15 Aug 2012
Posts: 6

PostPosted: Wed Aug 15, 2012 9:02 am    Post subject: Gentoo Updaten schlägt fehl Reply with quote

Hallo. wenn ich mein Gentoo System updaten will kommt folgende meldung?!
Kann mir vll jemand helfen?
Danke :lol:

Code:
[...]

localhost chris # emerge --update --ask world

 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for app-misc/mc from @selected
... done!

!!! The ebuild selected to satisfy "app-misc/mc" has unmet requirements.
- app-misc/mc-4.8.1-r1 USE="X edit gpm ncurses nls samba slang xdg -mclib -test"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( ncurses slang )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

localhost chris #


Last edited by mathos93 on Wed Aug 15, 2012 9:08 am; edited 1 time in total
Back to top
View user's profile Send private message
astaecker
Guru
Guru


Joined: 28 Apr 2003
Posts: 403
Location: Hamburg / Germany

PostPosted: Wed Aug 15, 2012 9:08 am    Post subject: Reply with quote

mc kann nur mit dem "ncurses" oder dem "slang" USE Flag installiert werden. Du hast aber beide aktiviert. Empfohlen wird nur "ncurses".

Wenn du also jetzt "slang" deaktivieren willst, musst es entweder aus der /etc/portage/package.use aus der "app-misc/mc" Zeile entfernen oder aus der /etc/make.conf bzw. /etc/portage/make.conf aus der "USE" Zeile.
Back to top
View user's profile Send private message
mathos93
n00b
n00b


Joined: 15 Aug 2012
Posts: 6

PostPosted: Thu Aug 16, 2012 7:59 am    Post subject: Reply with quote

Hey hab ich gemacht und es kommt trotzdem folgendes:

Code:
[...]
localhost chris # emerge --update --ask world

 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for app-misc/mc from @selected
... done!

!!! The ebuild selected to satisfy "app-misc/mc" has unmet requirements.
- app-misc/mc-4.8.1-r1 USE="X edit gpm ncurses nls samba slang xdg -mclib -test"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( ncurses slang )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

localhost chris #




In meiner /etc/portage/package.use steht folgendes drinnen:

Code:
[...]
et-im/skype qt-static


Die wichtigsten sachen aus meiner /etc/make.conf
Code:
[...]
USE="X alsa autotrace bash-completion caps cdda cddb cdparanoia cdr cdrdao
     cdrom consolekit contrast cups dbus dell devfs-compat dhcp djvu dts dv
     dvd dvdr emf emovix expat extra-tools extras ffmpeg fontconfig foomaticdb
     fpx gif glibc-omitfp gnutls graphviz gs gstreamer hal hdri hotpixels i18n
     icu imagemagick java jpeg jpeg2k kde lame laptop lasi lensfun lqr lzo
     mjpeg mmx mng mp3 msn musepack musicbrainz mysql network-cron nls nuv
     openexr opengl optimization optimized-qmake parse-clocks pch plasma png
     policykit postproc ppds qt3support qt4 quicktime rar raw rdesktop
     rdesktop-vrdp rdp real samba schroedinger semantic-desktop slang slp
     sndfile sox sql sse sse2 sse3 ssl static-libs stream strong-optimization
     svg taglib theora threads thumbnail thumbnails thunderbird tiff timezone
     truetype twolame type3 udev unicode utils v4l v4l2 vcd vim-syntax vnc
     webkit win32codecs wmf xmp xpm -debug ncurses"

ACCEPT_LICENSE="skype-eula AdobeFlash-10.3 PUEL"
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4116

PostPosted: Thu Aug 16, 2012 8:39 am    Post subject: Reply with quote

mathos93 wrote:
Hey hab ich gemacht und es kommt trotzdem folgendes:

Code:

!!! The ebuild selected to satisfy "app-misc/mc" has unmet requirements.
- app-misc/mc-4.8.1-r1 USE="X edit gpm ncurses nls samba slang xdg -mclib -test"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( ncurses slang )
 

Nein hast du anscheinen nicht oder es wird wieder überschrieben. Für mc sind immer nocht beide useflags (ncurses und slang) aktiv.
EDIT: in deiner USE= Zeile sind beide useflags noch enthalten.

Am besten du gehst den weg mit /etc/portage/package.use. Und fügst dort die zeile
Code:
app-misc/mc -slang
hinzu
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Schorchgrinder
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2006
Posts: 81
Location: Lower Uncton

PostPosted: Thu Aug 16, 2012 8:48 am    Post subject: Reply with quote

schau doch mal nach ob slang als systemweite USE-Flag gesetzt ist

Code:
emerge --info | grep slang


auch ist ufed nicht zu verachten

Code:
app-portage/ufed
     Available versions:  0.40-r6 0.40-r10 (~)0.40-r11 0.40.1
     Installed versions:  0.40.1(04:51:22 23.12.2009)
     Homepage:            http://www.gentoo.org/
     Description:         Gentoo Linux USE flags editor

_________________
AMD Athlon 1000 Mhz, RIVA TNT2/TNT2 Pro, Creative Labs SB Live, 1500 MB Arbeitsspeicher
damit läuft der Rechner unter Gentoo immer noch recht gut

AMD Athlon II X4 600e 2200 Mhz, Nvidia G210, 4GB RAM
Back to top
View user's profile Send private message
mathos93
n00b
n00b


Joined: 15 Aug 2012
Posts: 6

PostPosted: Thu Aug 16, 2012 8:54 am    Post subject: Reply with quote

Danke jetzt gehts aber ich bekomme eine andere meldung?!

Code:
[...]
localhost chris # emerge --update --ask world

 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "media-plugins/gst-plugins-meta[alsa?,ogg,vorbis]".                                                                                                           
!!! One of the following packages is required to complete your request:
- media-plugins/gst-plugins-meta-0.10-r7 (Change USE: +ogg +vorbis)
(dependency required by "media-libs/phonon-gstreamer-4.5.0" [ebuild])
(dependency required by "media-libs/phonon-4.5.1-r1[gstreamer]" [ebuild])
(dependency required by "kde-base/kdelibs-4.8.3" [ebuild])
(dependency required by "sys-auth/polkit-kde-agent-0.99.0" [ebuild])
(dependency required by "kde-misc/polkit-kde-kcmodules-0.98_pre20101127" [ebuild])
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1015

PostPosted: Thu Aug 16, 2012 9:08 am    Post subject: Reply with quote

das heißt, dass du für "gst-plugins-meta" die Useflags ogg und vorbis aktivieren musst.

Gut zu sehen an dieser Ausgabe:
Code:
- media-plugins/gst-plugins-meta-0.10-r7 (Change USE: +ogg +vorbis)
Back to top
View user's profile Send private message
mathos93
n00b
n00b


Joined: 15 Aug 2012
Posts: 6

PostPosted: Thu Aug 16, 2012 9:36 am    Post subject: Reply with quote

Dankeschön an alle :)

Ich hab jetzt alle use flags die er haben wollte aktiviert bis er jetzt zu diesen Punkt angekommen ist

Code:
[...]
[blocks B     ] sys-apps/module-init-tools ("virtual/modutils" is blocking sys-apps/module-init-tools-3.5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/modutils-0, ebuild scheduled for merge) pulled in by
    =virtual/modutils-0 required by (app-emulation/virtualbox-modules-4.1.18, ebuild scheduled for merge)
    virtual/modutils required by (app-emulation/virtualbox-modules-4.1.18, ebuild scheduled for merge)
    =virtual/modutils-0 required by (sys-apps/rescan-scsi-bus-1.29, ebuild scheduled for merge)
    (and 4 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1015

PostPosted: Thu Aug 16, 2012 9:46 am    Post subject: Reply with quote

da hat mal ein wechsel von module-init-tools zu kmod stattgefunden. Steht aber sicherlich auch in deinen News:
Code:
 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Wahrscheinlich hilft aber, das manuelle deinstallieren von module-init-tools. (emerge -C module-init-tools) beim darauffolgenden update sollte dann kmod installiert werden.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2295
Location: Germany

PostPosted: Thu Aug 16, 2012 9:54 am    Post subject: Reply with quote

Hm, vermutlich wird ein unpassendes Profil genutzt?!
Schau doch mal was
Code:
eselect profile list
bereitstellt.
Back to top
View user's profile Send private message
mathos93
n00b
n00b


Joined: 15 Aug 2012
Posts: 6

PostPosted: Thu Aug 16, 2012 10:00 am    Post subject: Reply with quote

Code:
[...]
localhost chris # eselect profile list
Available profile symlink targets:
  [1]   default/linux/x86/10.0 *
  [2]   default/linux/x86/10.0/selinux
  [3]   default/linux/x86/10.0/desktop
  [4]   default/linux/x86/10.0/desktop/gnome
  [5]   default/linux/x86/10.0/desktop/kde
  [6]   default/linux/x86/10.0/developer
  [7]   default/linux/x86/10.0/server
  [8]   hardened/linux/x86
  [9]   hardened/linux/x86/selinux
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2295
Location: Germany

PostPosted: Thu Aug 16, 2012 10:16 am    Post subject: Reply with quote

Falls du KDE nutzt ist es wahrscheinlich besser das desktop/kde Subprofil zu nutzen, dort sind u.a. schon die meisten benötigten USE-Flags passend vom Profil her gesetzt.

mathos93 wrote:
Code:
localhost chris # emerge --update --ask world
Zudem ist es beim world Update idR auch besser --deep und --newuse mit hinzuzunehmen - das löst Abhängigkeiten meist besser und passender auf.
Back to top
View user's profile Send private message
DirtyHairy
l33t
l33t


Joined: 03 Jul 2006
Posts: 608
Location: Würzburg, Deutschland

PostPosted: Tue Aug 21, 2012 7:50 am    Post subject: Reply with quote

Ich würde Dir dringend raten, die ungelesenen News zu lesen, insbesondere wenn es harte Blocker gibt --- meistens ist es harmlos, den Blocker einfach zu entfernen, aber manchmal kann man damit eine mittlere Katastrophe heraufbeschwören :) Auch habe ich mir angewöhnt, bei Blockern, die ich nicht zweifelsfrei als harmlos (nicht lebenswichtig) identifizieren kann, zuerst ein binpackage (mit quickpkg) zu machen, bevor ich sie entferne, und anschließend sofort den Ersatz zu installieren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum