Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mount option pludev is not allowed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Fri Aug 17, 2012 5:20 am    Post subject: Mount option pludev is not allowed Reply with quote

When mounting a removable usb device the following way as root:
Code:
udisks --mount /dev/sdb1 --mount-options rw,noatime,pludev

I am getting this error:

Code:
Mount failed: Mount option pludev is not allowed


thoughts?
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1072
Location: Buchholz/GER

PostPosted: Fri Aug 17, 2012 5:37 am    Post subject: Reply with quote

Hi,
sorry, I never played with udisks mount-options, but pludev? Maybe it should be called 'plugdev'?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Fri Aug 17, 2012 5:46 am    Post subject: Reply with quote

Hi thanks. A typeO
Staring at screen too long.

Unfortunately
Code:
udisks --mount /dev/sdb1 --mount-options rw,noatime,plugdev
Mount failed: Mount option plugdev is not allowed

Still errors
I am debugging my udisks-glue which basically just runs that command.
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1072
Location: Buchholz/GER

PostPosted: Fri Aug 17, 2012 5:57 am    Post subject: Reply with quote

Hi,
I think there is no mount-option like 'plugdev'.

Code:
[root@shangrila:~]# udisks --mount /dev/sdb1 --mount-options sadfkjsfd
Mount failed: Mount option sadfkjsfd is not allowed

Mount-options are listed in 'man mount' ... also no plugdev there.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Fri Aug 17, 2012 6:17 am    Post subject: Reply with quote

Hmm I was wondering if the options for udisks --mount
were the same as mount

What about this from mounts man page:
mount wrote:
group Allow an ordinary (i.e., non-root) user to mount the filesystem if one of his groups
matches the group of the device. This option implies the options nosuid and nodev (unless
overridden by subsequent options, as in the option line group,dev,suid).

_________________
Donate to Gentoo
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1072
Location: Buchholz/GER

PostPosted: Fri Aug 17, 2012 6:24 am    Post subject: Reply with quote

Hi,
plugdev is the name of a group of your system? You are running your udisks command as root. Why do you want to use something as plugdev there? What should be the effect?

I do not understand the real probleme here, sorry. You are running udisks with a wrong option and wonder that you get an error? ;)

Edit: This maybe helps to configure udisks for mounting devices as a user -> http://forums.gentoo.org/viewtopic-t-922708-start-0.html
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Fri Aug 17, 2012 6:32 am    Post subject: Reply with quote

I am debugging /etc/udisks-glue.conf
to automount usb devices
It seems to call that command

Clarification of problem:
udisks-glue is started by local and running as root, when I plug in a usb device it should mount it and allow members of plugdev to access the media.

Running udisks-glue gives the same error:
Code:
udisks-glue --config /etc/udisks-glue.conf -f

_________________
Donate to Gentoo
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Fri Aug 17, 2012 6:54 am    Post subject: Reply with quote

Tested making a .pkla file
/etc/polkit-1/localauthority/50-local.d/10-udisks.pkla

Here is what I have tried:
Code:
# [Local Users]
# Identity=unix-group:plugdev
# Action=org.freedesktop.udisks.*
# ResultAny=yes
# ResultInactive=no
# ResultActive=yes

# Action=org.freedesktop.udisks.*
[Allow to mount and unmount disks]
Identity=unix-group:plugdev
Action=org.freedesktop.udisks.filesystem-mount,org.freedesktop.udisks.drive-eject
ResultAny=yes
ResultInactive=yes
ResultActive=yes

#[Storage Permissions]
#Identity=unix-group:plugdev
#Action=org.freedesktop.udisks.filesystem-mount;org.freedesktop.udisks.drive-eject;org.freedesktop.udisks.drive-deta$
#ResultAny=yes
#ResultActive=yes
#ResultInactive=no


No luck yet
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Mon Aug 20, 2012 8:40 pm    Post subject: Reply with quote

It seems to have something to do with the file system on the drive being NTFS or VFAT or whatever these thinggys come formatted as.

just mounting it with mount and trying to change the permissions was impossible until I modprobed ntfs.
So looking into how to automagicly modprobe filesystem module.
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum