Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mpd + icecast + dynamic ip
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 318
Location: Sweden

PostPosted: Mon Aug 20, 2012 2:54 pm    Post subject: mpd + icecast + dynamic ip Reply with quote

Been using mpd + ncmpcpp locally for some time, but now wanted to access the music remotely, via icecast.

Everything seems to be setup properly in both the config of mpd and icecast, and indeed, if source is set to localhost everything works. But as soon as I set hostname (icecast) and host (mpd) to another address (myaddress.hopto.org), it fails.

But all I have to do to get it working, albeit only locally, is set the host to "localhost", so passwords and what have you work.

I've tried turning off the firewall, but that did not have an effect. I've tried some different ports (8000, 8007, 3007), but that didn't matter either.

I can't find anything relevant in the logs. ncmpcpp continually tries to reconnect, and doesn't start playing.

I can access "myaddress.hopto.org" remotely, and from the computer locally. SSH, apache and what have you.

Any ideas on how to fix / troubleshoot?
Thanks.
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 318
Location: Sweden

PostPosted: Mon Aug 20, 2012 3:14 pm    Post subject: Reply with quote

I now tried mpd:s internal stream-to-http output, and found myself having the very same issues. :-/ So I guess it's not a icecast thing, but a pure network-issue. (I hear some readers exclamation of *doh!*)

With output bound to 0.0.0.0 I could access it through localhost, 127.0.0.1, and internal LAN address 192.168.1.123 --- but not through myaddress.hopto.org, nor direct (remote) IP.
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 318
Location: Sweden

PostPosted: Mon Aug 20, 2012 3:27 pm    Post subject: Reply with quote

I can port forward it successfully to the remote machine.
...
But why doesn't it work directly with the remote IP?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum