Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Webkit-gtk-1.8.1-r201 fails to compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
neopablo2000
n00b
n00b


Joined: 21 Jun 2005
Posts: 65

PostPosted: Fri Aug 10, 2012 8:27 pm    Post subject: [Solved] Webkit-gtk-1.8.1-r201 fails to compile Reply with quote

Well, basically, thats the problem :). First, of course, data of my powerpc:

lspci:
Quote:
0000:00:0b.0 Host bridge: Apple Inc. UniNorth 1.5 AGP
0000:00:10.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV100 LY [Mobility Radeon 7000]

0001:10:0b.0 Host bridge: Apple Inc. UniNorth 1.5 PCI

0001:10:17.0 Unassigned class [ff00]: Apple Inc. KeyLargo Mac I/O (rev 03)

0001:10:18.0 USB controller: Apple Inc. KeyLargo USB

0001:10:19.0 USB controller: Apple Inc. KeyLargo USB

0001:10:1a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)

0002:24:0b.0 Host bridge: Apple Inc. UniNorth 1.5 Internal PCI

0002:24:0e.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev ff)
0002:24:0f.0 Ethernet controller: Apple Inc. UniNorth GMAC (Sun GEM) (rev 01)


emerge --info

Quote:
Portage 2.1.11.9 (default/linux/powerpc/ppc32/10.0, gcc-4.5.3, unavailable, 3.5.0-gentoo ppc)

=================================================================


System uname: Linux-3.5.0-gentoo-ppc-7450,_altivec_supported-with-gentoo-2.1

Timestamp of tree: Sat, 28 Jul 2012 00:45:01 +0000

app-shells/bash: 4.2_p37

dev-lang/python: 2.7.3-r2, 3.2.3-r1

dev-util/cmake: 2.8.8-r3

dev-util/pkgconfig: 0.27

sys-apps/baselayout: 2.1-r1

sys-apps/openrc: 0.10.5

sys-apps/sandbox: 2.6

sys-devel/autoconf: 2.13, 2.69

sys-devel/automake: 1.11.1, 1.12.2

sys-devel/binutils: 2.22.90

sys-devel/gcc: 4.5.3-r2, 4.6.3

sys-devel/gcc-config: 1.6

sys-devel/libtool: 2.4.2

sys-devel/make: 3.82-r1

sys-kernel/linux-headers: 3.5 (virtual/os-headers)

sys-libs/glibc: 2.14.1-r3

Repositories: gentoo


ACCEPT_KEYWORDS="ppc ~ppc"


ACCEPT_LICENSE="* -@EULA"


CBUILD="powerpc-unknown-linux-gnu"


CFLAGS="-O2 -mcpu=powerpc -mtune=powerpc -fno-strict-aliasing -pipe"


CHOST="powerpc-unknown-linux-gnu"


CONFIG_PROTECT="/etc"


CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"


CXXFLAGS="-O2 -mcpu=powerpc -mtune=powerpc -fno-strict-aliasing -pipe"


DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"


FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"


FFLAGS="-O2 -pipe"


GENTOO_MIRRORS="http://gentoo.localhost.net.ar/ ftp://mirrors.localhost.net.ar/pub/mirrors/gentoo/"


LANG="es_AR.UTF-8"


LDFLAGS="-Wl,-O1 -Wl,--as-needed"


MAKEOPTS="-j2"


PKGDIR="/usr/portage/packages"


PORTAGE_CONFIGROOT="/"


PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"


PORTAGE_TMPDIR="/var/tmp"


PORTDIR="/usr/portage"


PORTDIR_OVERLAY=""


SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"


USE="X acl berkdb bzip2 cli cracklib crypt cups cxx dbus dri fortran gdbm gpm iconv ipv6 jpeg lock modules mudflap ncurses nls nptl openmp pam pcre ppc pppd readline session ssl startup-notification tcpd thunar udev unicode zlib"

ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx"

ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"

APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"

CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump"

CAMERAS="ptp2"

COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc"

GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx"

INPUT_DEVICES="evdev synaptics" KERNEL="linux"

LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"

LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer"

PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7"

RUBY_TARGETS="ruby18 ruby19"

USERLAND="GNU"

VIDEO_CARDS="radeon"

XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


I was trying to install Midori, but webkit-gtk refuses to compile. Here, the build.log:

http://pastebin.com/8veteqz8

I really have no idea about the error. Hope somebody can help me, I need a webkit based broswer, not too much resources for firefox :) (I tried installing firefox, but as my hard drive hasnt had the 4 gb free required, it refuses to install, sorry my english!)


Last edited by neopablo2000 on Mon Aug 13, 2012 11:25 am; edited 1 time in total
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2070

PostPosted: Fri Aug 10, 2012 9:36 pm    Post subject: Reply with quote

If I'm not mistaken, it's a problem with >=bison-2.6
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
neopablo2000
n00b
n00b


Joined: 21 Jun 2005
Posts: 65

PostPosted: Fri Aug 10, 2012 11:51 pm    Post subject: Reply with quote

Yep, it looks like webkit refuses to compile with bison 2.4 (wich i have). Now, updating to 2.6.2, after that, will try to recompile webkit and post if succesfull (or not, hahaha). Thanks for the help avx!! :)
Back to top
View user's profile Send private message
neopablo2000
n00b
n00b


Joined: 21 Jun 2005
Posts: 65

PostPosted: Mon Aug 13, 2012 11:28 am    Post subject: Reply with quote

Well, upgrading to Bison 2.6.2 still gave compilation errors, so i downgraded to 2.5.1, wich let me emerge webkit perfectly. I believe there is already a bug submitted about this, so, i`m not thinking to duplicate it :). Thank you avx for your help! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum