Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
digikam, kipi-plugins, gdal - kein emerge möglich
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sun Aug 05, 2012 8:42 pm    Post subject: digikam, kipi-plugins, gdal - kein emerge möglich Reply with quote

Hallo zusammen,

bin schon wieder ratlos:

Nach einem emerge -puD world ist bei mir digikam nicht mehr lauffähig. Digikam vermisst die kipi-plugins. Leider bekomme ich beim "emerge kipi-plugins" nur einen Fehler:

Code:
cd /var/tmp/portage/media-plugins/kipi-plugins-2.5.0/work/kipi-plugins-2.5.0_build/dngconverter && /usr/bin/cmake -E cmake_link_script CMakeFiles/libxmp.dir/link.txt --verbose=1
/usr/bin/ar cr ../lib/liblibxmp.a  CMakeFiles/libxmp.dir/libxmp_automoc.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/common/XML_Node.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/common/UnicodeConversions.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPCore_Impl.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/WXMPIterator.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/WXMPMeta.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/WXMPUtils.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPIterator.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPMeta-GetSet.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPMeta-Parse.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPMeta-Serialize.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPMeta.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPUtils-FileInfo.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/XMPUtils.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/ExpatAdapter.o CMakeFiles/libxmp.dir/dngwriter/extra/xmp_sdk/XMPCore/ParseRDF.o
/usr/bin/ranlib ../lib/liblibxmp.a
make[2]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-2.5.0/work/kipi-plugins-2.5.0_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/media-plugins/kipi-plugins-2.5.0/work/kipi-plugins-2.5.0_build/CMakeFiles  90 91 92
[ 13%] Built target libxmp
make[1]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-2.5.0/work/kipi-plugins-2.5.0_build'
make: *** [all] Fehler 2
 * ERROR: media-plugins/kipi-plugins-2.5.0 failed (compile phase):
 *   emake failed


Ohne die kipi-plugins ist digikam etwas "mager"...

Bei meiner Fehlersuche bin ich jetzt auf gdal und zlib gestossen - vgl. auch hier. gdal lässt sich ebenfalls nicht emergen mit dieser Fehlermeldung:

Code:
make[2]: Entering directory `/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/frmts/pdf'
x86_64-pc-linux-gnu-g++ -march=native -O2 -pipe -ggdb -fPIC  -Wall  -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/port -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/gcore -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/alg -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/ogr -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/ogr/ogrsf_frmts -DOGR_ENABLED -I/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/port -Iexternal/include -I/usr/ -I/usr//include  -DPOPPLER_HAS_OPTCONTENT -DPOPPLER_BASE_STREAM_HAS_TWO_ARGS -I/usr/include -I/usr/include/poppler -c -o ../o/pdfdataset.o pdfdataset.cpp
pdfdataset.cpp: In Elementfunktion »virtual CPLErr PDFRasterBand::IReadBlock(int, int, void*)«:
pdfdataset.cpp:351:47: Fehler: keine passende Funktion für Aufruf von »SplashOutputDev::startDoc(XRef*)«
/usr/include/poppler/SplashOutputDev.h:309:8: Anmerkung: candidate is: void SplashOutputDev::startDoc(PDFDoc*)
pdfdataset.cpp: In static member function »static GDALDataset* PDFDataset::Open(GDALOpenInfo*)«:
pdfdataset.cpp:539:45: Fehler: »setErrorFunction« wurde in diesem Gültigkeitsbereich nicht definiert
pdfdataset.cpp:565:67: Warnung: ignoring return value of »char* fgets(char*, int, FILE*)«, declared with attribute warn_unused_result
make[2]: *** [../o/pdfdataset.o] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/frmts/pdf'
make[1]: *** [pdf-install-obj] Fehler 2
make[1]: Leaving directory `/var/tmp/portage/sci-libs/gdal-1.8.1-r1/work/gdal-1.8.1/frmts'
make: *** [frmts-target] Fehler 2
emake failed
 * ERROR: sci-libs/gdal-1.8.1-r1 failed (compile phase):
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 7962:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 *
 * If you need support, post the output of `emerge --info '=sci-libs/gdal-1.8.1-r1'`,
 * the complete build log and the output of `emerge -pqv '=sci-libs/gdal-1.8.1-r1'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""


Folgende Versionen sind hier beteiligt:
sys-lib/zlib-1.2.7
sci-libs/gdal-1.8.1-r1
media-plugins/kipi-plugins-2.5.0
media-gfx/digikam-2.7.0

revdep-rebuild scheitert ebenfalls. Wo kann ich denn jetzt noch ansetzen? Leider sagen mir die Fehlermeldungen gar nichts...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4116

PostPosted: Mon Aug 06, 2012 6:16 am    Post subject: Reply with quote

scheinbar ist gdal-1.8.1-r1 nicht kompatible mit der poppler version, welche du installiert hast.

Und beim gezeigten build ausschnitt für kipi-plugins fehlt der eigentliche fehler *g*
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
deranonyme
Apprentice
Apprentice


Joined: 09 Jul 2005
Posts: 268

PostPosted: Mon Aug 06, 2012 7:22 am    Post subject: Reply with quote

Hallo

Ich hatte das selbe Problem. Ich bin der Sache nicht auf den Grund gegangen, aber bei mir eine Freigabe der 2.6.0 von digikam und den kipi-plugins geholfen.

deranonyme
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Aug 06, 2012 9:20 pm    Post subject: Reply with quote

@deranonyme:
Eigentlich habe ich hier schon digikam 2.7.0 mit kipi-pugins-2.5.0 am laufen gehabt.
digikam-2.6.0 wäre ein downgrade - das will ich eigentlich nicht.

@firefly:
für gdal-1.8.1-r1 ist poppler-0.20.2-r1 im ebuild eingetragen. Also exakt meine Kombi. Ich habe heute Abend poppler neu emerged und dann ein revdep-rebuild laufen lassen. Leider habe ich wieder den gleichen Fehler bei gdal bekommen. Vielleicht sollte ich gdal ohne USE=pdf bauen? USE=-pdf emerge --oneshot gdal hat jedenfalls geklappt.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2290
Location: Germany

PostPosted: Mon Aug 06, 2012 10:40 pm    Post subject: Reply with quote

uhai wrote:
für gdal-1.8.1-r1 ist poppler-0.20.2-r1 im ebuild eingetragen. Also exakt meine Kombi. ...

Hm nein, im gdal-1.8.1-r1.ebuild ist nur schlicht "pdf? ( app-text/poppler )" definiert, also ohne Versionsangabe.
Für stable gdal-1.8.1-r1 wird normal die stable poppler-0.18.4-r1 Version "erwartet" (damit sollte es auch problemlos bauen)

Wenn es wirklich testing poppler-0.20 sein muss siehe auch im Bug 426584
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Aug 07, 2012 8:00 pm    Post subject: Reply with quote

Hallo Josef.95

Du hast recht (wie meist). Ich war bequem und habe in porthole die Abhängigkeiten angesehen. Dort wird poppler-0.20.2-r1 angeegeben. Im ebuild steht poppler ohne Versionsnummer.

Man sollte wohl immer direkt nachsehen.

Ich habe gdal ohne USE = pdf installieren können. Jetzt muss ich mal sehen, warum bei mir die Version poppler-0.20.2.1-r1 installiert ist.

uhai
PS:
Ich habe mit eix-test-obsolete mal begonnen, mein /package.keywords/ aufzuräumen. Jetzt hat emerge kipi-plugins geklappt...

Ich werde den Konfigurationsmüll jetzt mal vorsichtig ausmisten...
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum