Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Jul 30, 2012 2:20 am    Post subject: Reply with quote

Thanks for helping track this down guys.

I wasn't able to reproduce at this end because even when dev-libs/glib was uninstalled it leaves the following files as orphans:
Code:
/usr/lib64/libglib-2.0.so.0
/usr/lib64/libglib-2.0.so.0.3200.3
Which meant they were still available for pkg-config to work.

The circular dependency between dev-util/pkgconfig and dev-libs/glib is not a new thing for Gentoo and pops it's head up in bugs like 426302 and 417741.
Gentoo tries to get around a lack or breakage of pkg-config by exporting the LIBFFI stuff within the dev-libs/glib ebuild.

My fault that I was using an old dev-libs/glib ebuild from Gentoo's portage tree that would only export the needed LIBFFI when virtual/pkgconfig wasn't present.
Instead of the more direct approach of exporting LIBFFI if pkg-config is not working.
Seen here from /usr/portage/dev-libs/glib/ChangeLog:
Code:
  07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> glib-2.32.3.ebuild:
  Check if pkg-config binary is working instead of checking if
  virtual/pkgconfig is installed.

So I've ported the needed check into the overlay's version of dev-libs/glib.
I probably should still file a bug about the orphaned files though, thanks again :)

EDIT: Actually they were probably not orphans after all but being kept around as part of a @preserved-rebuild set.
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Mon Jul 30, 2012 7:34 am    Post subject: Reply with quote

All right, it's working :o Excellent job! Thanks

I just have some trouble with window decorations, and themes in general.
I tried to install Ambiance Colors pack from gnome-look.org (http://www.ravefinity.com/p/download-ambiance-radiance-colors.html) which suppose to have unity support but Appearance applet in System settings does not recognize them (or any other installed theme, but Adwaita)

Any clues how to install it?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Jul 30, 2012 10:37 am    Post subject: Reply with quote

Hooray!! Congratulations on being the first to have it working :D

Not sure on the custom colour pack but we should have a look at the window/gtk+/icon theming and see if it can be improved.

I'm using the Ambiance theme as provided by 'emerge x11-themes/light-themes' and it shows up for Appearance in System Settings as does the Radiance theme provided by same, but that's about all I've tried so far.
Choosing any of these themes also sets the window decoration to that theme, which may or may not be desireable.

Previously to Unity I was using Gnome3 desktop and had set a custom window theme (adwaita_white_netbook) using the 'gnome-tweak-tool' provided by gnome-extra/gnome-tweak-tool.
This was inherited once using Unity and looked nice but was blown away once I set the theme via Unity's gnome-control-center System Settings > Apperance > Theme

Currently the way I change the icon theme is to fire up 'gnome-tweak-tool' provided by gnome-extra/gnome-tweak-tool.
I'm using ubunto-mono icon theme (emerge ubuntu-mono).

There's probably some dconf setting that can be changed via the command line to achieve it or some other Unity function/app we're missing that frontends to that.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Jul 31, 2012 7:17 pm    Post subject: Reply with quote

When attempting to install ubuntuone-storage-protocol (is there some way to disable this dep.?) i get:

Code:

>>> Emerging (1 of 162) unity-base/ubuntuone-storage-protocol-3.0.0 from unity-gentoo
 * ubuntuone-storage-protocol_3.0.0.orig.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                             [ ok ]
 * ubuntuone-storage-protocol_3.0.0-0ubuntu1.1.debian.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking ubuntuone-storage-protocol_3.0.0.orig.tar.gz to /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work
>>> Unpacking ubuntuone-storage-protocol_3.0.0-0ubuntu1.1.debian.tar.gz to /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work
>>> Source unpacked in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work
>>> Preparing source in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0 ...
 * Applying CVE-2011-4409.patch ...                                                                                                                                                                                         [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0 ...
python3.2 setup.py build
Traceback (most recent call last):
  File "setup.py", line 29, in <module>
    from ubuntuone.storageprotocol.context import ssl_cert_location
  File "/var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0/ubuntuone/storageprotocol/context.py", line 36, in <module>
    from twisted.internet import ssl
ImportError: No module named twisted.internet
 * ERROR: unity-base/ubuntuone-storage-protocol-3.0.0 failed (compile phase):


maybe some missed dep...

i will try to install the twisted-web python packages, i guess it will work...

edit: i guess these packages are already installed:

Code:

sudo emerge --search twisted
Senha:
Searching...   
[ Results for search key : twisted ]
[ Applications found : 11 ]

*  dev-python/twisted
      Latest version available: 11.0.0
      Latest version installed: 11.0.0

*  dev-python/twisted-conch
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-lore
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-mail
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-names
      Latest version available: 11.0.0
      Latest version installed: 11.0.0

*  dev-python/twisted-news
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-pair [ Masked ]
      Latest version available: 12.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-runner
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-web
      Latest version available: 11.0.0
      Latest version installed: 11.0.0

*  dev-python/twisted-words
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twistedsnmp [ Masked ]
      Latest version available: 0.3.13
 Latest version installed: [ Not Installed ]



Please help me!!
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Wed Aug 01, 2012 6:25 am    Post subject: Reply with quote

ahgblopes wrote:
When attempting to install ubuntuone-storage-protocol (is there some way to disable this dep.?) i get:

Code:

>>> Emerging (1 of 162) unity-base/ubuntuone-storage-protocol-3.0.0 from unity-gentoo
 * ubuntuone-storage-protocol_3.0.0.orig.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                             [ ok ]
 * ubuntuone-storage-protocol_3.0.0-0ubuntu1.1.debian.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking ubuntuone-storage-protocol_3.0.0.orig.tar.gz to /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work
>>> Unpacking ubuntuone-storage-protocol_3.0.0-0ubuntu1.1.debian.tar.gz to /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work
>>> Source unpacked in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work
>>> Preparing source in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0 ...
 * Applying CVE-2011-4409.patch ...                                                                                                                                                                                         [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0 ...
python3.2 setup.py build
Traceback (most recent call last):
  File "setup.py", line 29, in <module>
    from ubuntuone.storageprotocol.context import ssl_cert_location
  File "/var/tmp/portage/unity-base/ubuntuone-storage-protocol-3.0.0/work/ubuntuone-storage-protocol-3.0.0/ubuntuone/storageprotocol/context.py", line 36, in <module>
    from twisted.internet import ssl
ImportError: No module named twisted.internet
 * ERROR: unity-base/ubuntuone-storage-protocol-3.0.0 failed (compile phase):


maybe some missed dep...

i will try to install the twisted-web python packages, i guess it will work...

edit: i guess these packages are already installed:

Code:

sudo emerge --search twisted
Senha:
Searching...   
[ Results for search key : twisted ]
[ Applications found : 11 ]

*  dev-python/twisted
      Latest version available: 11.0.0
      Latest version installed: 11.0.0

*  dev-python/twisted-conch
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-lore
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-mail
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-names
      Latest version available: 11.0.0
      Latest version installed: 11.0.0

*  dev-python/twisted-news
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-pair [ Masked ]
      Latest version available: 12.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-runner
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twisted-web
      Latest version available: 11.0.0
      Latest version installed: 11.0.0

*  dev-python/twisted-words
      Latest version available: 11.0.0
      Latest version installed: [ Not Installed ]

*  dev-python/twistedsnmp [ Masked ]
      Latest version available: 0.3.13
 Latest version installed: [ Not Installed ]



Please help me!!


I found myself a "workaround" :

I use eselect to change my python version from 3.2 to 2.7... but i guess this is no good, or am i wrong? i'm afraid that i will have more problems because this...
The twisted module from gentoo only installs the 2.7 module, the correct, i guess, is a 3.2 version of the twisted-internet, or am i wrong?? Now i will sleep, and let it compile more 151 deps from unity-meta...

ps: i tryed the version 12 (not stable) of twisted, but it also installs the 2.7 module. maybe the solution is to use an even more recent or a patched version? Can you patch it? I really like yours patcheds 99-* packages :)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Aug 01, 2012 12:16 pm    Post subject: Reply with quote

Yes we should use python2.7 and not python3.2.

I've adjusted the python ebuilds to restrict trying to install for python3.2, that should get the packages installed.

Not sure yet how to restrict that at runtime, but we need to because many of the lens applications will silently fail when python3.2 is set active.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Wed Aug 01, 2012 3:28 pm    Post subject: Reply with quote

shiznix wrote:
Yes we should use python2.7 and not python3.2.

I've adjusted the python ebuilds to restrict trying to install for python3.2, that should get the packages installed.

Not sure yet how to restrict that at runtime, but we need to because many of the lens applications will silently fail when python3.2 is set active.


Is python 3.2 really important?? If not, so i will unmerge them...


Now the bad guy is unity-base/indicator-sound-0.8.5.0:

Code:

>>> Emerging (1 of 40) unity-base/indicator-sound-0.8.5.0 from unity-gentoo
 * indicator-sound_0.8.5.0.orig.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                 [ ok ]
>>> Unpacking source...
>>> Unpacking indicator-sound_0.8.5.0.orig.tar.gz to /var/tmp/portage/unity-base/indicator-sound-0.8.5.0/work
>>> Source unpacked in /var/tmp/portage/unity-base/indicator-sound-0.8.5.0/work
>>> Preparing source in /var/tmp/portage/unity-base/indicator-sound-0.8.5.0/work/indicator-sound-0.8.5.0 ...


(...)


checking pkg-config is at least version 0.9.0... yes
checking for PULSEAUDIO... no
configure: error: Package requirements (libpulse-mainloop-glib >= 0.9.19
                              gio-unix-2.0) were not met:

No package 'libpulse-mainloop-glib' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PULSEAUDIO_CFLAGS
and PULSEAUDIO_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


And i have two questions:

Do i need the "pulseaudio" global useflag in make.conf?

Do i need the "gnome" global useflag in make.conf and select the "gnome" profile? (i was using the "desktop" profile and -gnome to get a more light config)
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Aug 01, 2012 7:45 pm    Post subject: Reply with quote

Provided you have another version of python (such as 2.7), you could unmerge python3.2 and still have a fully functional system.

I've added the media-sound/pulseaudio dep. to unity-base/indicator-sound so that should be fixed now.

You don't absolutely need the 'pulseaudio' and 'gnome' USE flags but it is certainly highly recommended.
Unity runs in a gnome-session so uses a lot of Gnome stuff, and pulseaudio is also used.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Thu Aug 02, 2012 3:05 am    Post subject: Reply with quote

shiznix wrote:
Provided you have another version of python (such as 2.7), you could unmerge python3.2 and still have a fully functional system.

I've added the media-sound/pulseaudio dep. to unity-base/indicator-sound so that should be fixed now.

You don't absolutely need the 'pulseaudio' and 'gnome' USE flags but it is certainly highly recommended.
Unity runs in a gnome-session so uses a lot of Gnome stuff, and pulseaudio is also used.


you are a genious! i successfully installed the unity-meta package.

I'm very happy to see unity running on my gentoo box, but there are some things that are not working :( :

a) the firefox appmenu

b) appmenu for applications launched by gksu (strangely it also happens in ubuntu 12.04!)

c) The windows don't fit in the panel when i press the maximize button...

d) The maximize button of the panel doesn´t work...

e) when i launch an application, it is positioned under the panel...

I'm using pulseaudio and gonme use flags, as well the gnome profile. i updated world, made the depclean and revdep-rebuild, sync again the unity-gentoo repository thousand of times, and i also installed the gnome-light (gnome3) package. I guess i missed some important package. There is an overlay called "stuff", and it has the appmenu-firefox package, but i really wont enable it...

I also want to be able to change the vertical panel size (the appearence menu doesn't work)

Thank you for the help!
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Aug 03, 2012 12:39 am    Post subject: Reply with quote

Great!! good to see you've got it working :)

a) I've noticed that Firefox doesn't use the appmenu too. The package needed for that is called firefox-globalmenu as located here
http://packages.ubuntu.com/precise-updates/firefox-globalmenu
I haven't looked into it any further than that yet.

b) I haven't come across this yet as I don't really use gksu in any intentional way. Only guessing but it might need some user variable that is lost once su'ed.
The trick is finding which variable and adding it to 'env_keep=...' in /etc/sudoers.

c) You mean they maximise to be under the launcher ?
Could be related to https://bugs.launchpad.net/ubuntu/+source/unity/+bug/928849
I get it too but like the reporter of that bug, a minimise/maximise of one window seems to make Unity aware of it's screen boundaries and it works as it should after that.
A fix was commited upstream for that some months ago in revision 1930 but there may have been some regression since then.

d) The close/minimise/maximise buttons on the panel work OK here so I'm not sure what might have happened.
They only become visible when the window is maximised and should disappear once the panel's maximise button is pressed to restore the window to it's custom size.

e) Probably related to c) but I have my launcher set to autohide anyway so it doesn't really impact.

Quote:
I also want to be able to change the vertical panel size (the appearence menu doesn't work)
Oops didn't notice that before.
You can change the vertical panel (launcher) size by firing up CompizConfig Settings Manager.
Type 'ccsm' in a terminal as your desktop user or by searching for 'compiz' in the launcher's 'Dash Home'.
Then in ccsm navigate to 'Desktop' > 'Ubuntu Unity Plugin' > 'Experimental' and change the value for 'Launcher icon size'.

The reason for the setting not working properly in gnome-control-center's Appearance is probably for the same reason the autohide settings also don't work (use ccsm for this too).
We don't yet use gconf to set or change compiz settings. There is a file called 'NOTES' in the overlay's top directory that talks about this, thanks.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sat Aug 04, 2012 12:50 am    Post subject: Reply with quote

Good news:

I installed the appmenu-firefox from the stuff overlay. I just made a local overlay for it and changed the ebuild to accept the appmenu-gtk from ::unity-gentoo, so i can install only the appmenu-firefox, without that buggy gtk...

It works like a charm for me in 14.0.1....


Bad news:

Seems that compiz is the bad guy... If i change any of the plugins, EXCEPT the "UNITY" plugin, compiz crashes and if i reboot i get a strange behavior (the panel disappears, etc)...(then i need to remove the compiz-1 folder inside the .config folder to be able to use it again).

Is there a way to install a more stable version of compiz?

I will try to fully upgrade to gnome 3 (i suspect i missed some important package), and do some revdep-rebuild, update, depclean, resync layman, etc (thousands of times...) and i hope i will fix it!
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sat Aug 04, 2012 6:58 am    Post subject: Reply with quote

This is great I just tried and it works really well, thanks a bunch :)

Was dreading adding it to the overlay because I was looking at compiling it from source which afaict would have required building firefox to then build the extension.
But using the pre-compiled .deb is much more sane and maintainable so have added it with almost no changes.

I hate to say it but different compiz plugins are more stable than others and I've always been able to crash it or have it misbehave in some way with every version I've had.
So I hope that compiz-0.9.8 smoothes a lot more of that over but I'm not holding my breath.

You'll just have to experiment with enabling/disabling different plugins and see what works for you.
But I'd guess there is probably something more critical wrong if changing ANY plugin causes a crash.

Compizconfig settings manager uses a lot of python to do it's thing so maybe there is some missing python modules from when you were installing stuff while switching back and forth between python 3.2 and 2.7.
Now you have 2.7 as your active python version, running 'python-updater' couldn't hurt to try and catch any breakage there.
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Sat Aug 04, 2012 7:24 am    Post subject: Reply with quote

My unity was crashing bcos of compiz too, I had to remove all compiz setting i had form previous installation (many month ago) and that did the trick.
To confirm that compiz settings are faulty, You can create new temporary user and try to run unity on it.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Aug 05, 2012 12:19 am    Post subject: Reply with quote

I successfully upgraded to gnome3, upgrade world, made the depclean, revdep-rebuild and nothing... I also changed the theme, but didn't help. Is there a way to "debug" unity/compiz??
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Aug 05, 2012 6:09 am    Post subject: Reply with quote

ahgblopes wrote:
I successfully upgraded to gnome3, upgrade world, made the depclean, revdep-rebuild and nothing... I also changed the theme, but didn't help. Is there a way to "debug" unity/compiz??
Is this about trying to stop compiz crashing when you change the settings in 'ccsm' ?

Have you tried running 'python-updater' yet ?

For debugging your syslog should show any segfaults while ~/.xsession-errors will show runtime problems.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Aug 05, 2012 7:20 am    Post subject: Reply with quote

shiznix wrote:
ahgblopes wrote:
I successfully upgraded to gnome3, upgrade world, made the depclean, revdep-rebuild and nothing... I also changed the theme, but didn't help. Is there a way to "debug" unity/compiz??
Is this about trying to stop compiz crashing when you change the settings in 'ccsm' ?

Have you tried running 'python-updater' yet ?

For debugging your syslog should show any segfaults while ~/.xsession-errors will show runtime problems.


python-updater? ..... I always do it:

emerge --sync
layman -S
emerge --update --with-bdeps=y --deep --newuse -avt world
emerge -avt --depclean
revdep-rebuild
python-updater
emerge --sync
layman -S
(etc)

I do it a lot of times, but nothing...

I created another user, but compiz still buggy.

But Unity-2d also has this weird behavior, and it doesn't uses compiz, i guess...

I take some screenshots:

1) When i launch an application, normally it starts fine (maximized):
http://img26.imageshack.us/img26/5860/ps1e.png


2) But, when i hit the maximize (unmaximize) button, i get the window wrong positioned:
http://img826.imageshack.us/img826/7651/ps2y.png

3) And without borders:

http://img593.imageshack.us/img593/4690/ps3sr.png

4) And if i open it again and maximize, normally it doesn't fit anymore in the panel:

http://img207.imageshack.us/img207/5143/ps4b.png

5) And sometimes the buttons disappear:

http://img207.imageshack.us/img207/8247/ps5.png

6) In Unity-2d, normally, the windows don't fit in the panel, but i see (and they work) the window buttons on the panel:

http://img707.imageshack.us/img707/6844/ps6.png


I also get this gtk waring, when i launch gtk apps:

Gtk-WARNING **: Theme parsing error: gnome-applications-gray.css:164:19: Not using units is deprecated. Assuming 'px'.
(with any theme)



When i run startx with gnome-terminal in xinitrc, then run "unity" command, i get this:

Code:

WARN  2012-08-05 04:00:32 unity <unknown>:0 Failed to fetch xid: Nenhuma
interface "org.ayatana.bamf.window" no objeto no caminho
/org/ayatana/bamf/window10485765
WARN  2012-08-05 04:00:32 unity <unknown>:0 Failed to fetch path:
Nenhuma interface "org.ayatana.bamf.application" no objeto no caminho
/org/ayatana/bamf/application0x1202060

Trying to translate to english: "Nenhuma interface no objeto caminho" = "None interface in object path"

but i guess that this is because to run the "unity" command from a terminal isn't the correct way to launch the unity-session...

And, please, tell me wich are the compiz plugins that i have to enable to get a working unity (i suspect some important plugin is disabled, but until now i tryied to change various of them(but not all) and compiz crashes). thank you for the help.

I will take a look, with attention, to my xsession-errors...
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Aug 05, 2012 10:58 pm    Post subject: Reply with quote

Looking at your screenshots:

1) Looks good.

2) 3) 4) and 5) Yes I can semi-reliabily reproduce this.
It looks to be a bug in either Unity or compiz where appmenu is not properly letting go of the window and handing it back off to compiz-decorator.
Coupled with problems of Unity not consistently being able to recognise screen boundaries as they relate to the launcher (a known bug).
Again this is largely improved if the launcher is set to auto-hide.

6) I guess this kind of confirms suspicions of how compiz-decorator and appmenu are communicating.

Your ~/.xsessions looks OK. These are non-fatal warnings and perfectly normal.

So a few ideas.
We might be enabling or disabling a setting in compiz in relation to window management.
It could all just be upstream bugs that might be fixed in the latest releases of compiz and unity (which could in turn open it's own can of worms).

I'll take a look at sorting it as soon as I can, thanks :)
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Aug 06, 2012 6:30 am    Post subject: Reply with quote

shiznix wrote:
Looking at your screenshots:

1) Looks good.

2) 3) 4) and 5) Yes I can semi-reliabily reproduce this.
It looks to be a bug in either Unity or compiz where appmenu is not properly letting go of the window and handing it back off to compiz-decorator.
Coupled with problems of Unity not consistently being able to recognise screen boundaries as they relate to the launcher (a known bug).
Again this is largely improved if the launcher is set to auto-hide.

6) I guess this kind of confirms suspicions of how compiz-decorator and appmenu are communicating.

Your ~/.xsessions looks OK. These are non-fatal warnings and perfectly normal.

So a few ideas.
We might be enabling or disabling a setting in compiz in relation to window management.
It could all just be upstream bugs that might be fixed in the latest releases of compiz and unity (which could in turn open it's own can of worms).

I'll take a look at sorting it as soon as I can, thanks :)


Ok, i'm waiting, using gnome-classic (it sucks...)... Even in my ubuntu 12.04 unity is very buggy, but i hope that these bugs be corrected soon...
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Mon Aug 06, 2012 8:45 pm    Post subject: Reply with quote

When i open ccsm (and change some plugin) i get this:

Code:

Initializing place options...done
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/ccm/Widgets.py", line 1481, in enable_plugin
    plugin.Context.UpdateExtensiblePlugins ()
  File "compizconfig.pyx", line 1140, in compizconfig.Context.UpdateExtensiblePlugins (src/compizconfig.c:10432)
  File "compizconfig.pyx", line 783, in compizconfig.Plugin.Update (src/compizconfig.c:6127)
  File "compizconfig.pyx", line 870, in compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:7239)
KeyError: '@\x88\x99\x02'


Is it normal a normal waring?
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Tue Aug 07, 2012 1:20 am    Post subject: Reply with quote

a bit off-topic, but when i try to install musescore, i get this:

Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

  (x11-libs/qt-script-99.4.8.2::unity-gentoo, installed) pulled in by
    ~x11-libs/qt-script-99.4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-99.4.8.2::unity-gentoo, installed)

  (x11-libs/qt-script-4.8.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-script-4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-4.8.2::gentoo, ebuild scheduled for merge)

x11-libs/qt-core:4

  (x11-libs/qt-core-99.4.8.2::unity-gentoo, installed) pulled in by
    ~x11-libs/qt-core-99.4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support=] required by (x11-libs/qt-opengl-99.4.8.2::unity-gentoo, installed)
    (and 7 more with the same problem)

  (x11-libs/qt-core-4.8.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-core-4.8.2[aqua=,c++0x=,qpa=,debug=,glib=,qt3support=] required by (x11-libs/qt-gui-4.8.2::gentoo, ebuild scheduled for merge)
    (and 6 more with the same problem)

x11-libs/qt-xmlpatterns:4

  (x11-libs/qt-xmlpatterns-99.4.8.2::unity-gentoo, installed) pulled in by
    ~x11-libs/qt-xmlpatterns-99.4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-99.4.8.2::unity-gentoo, installed)

  (x11-libs/qt-xmlpatterns-4.8.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-xmlpatterns-4.8.2[aqua=,debug=,qpa=] required by (x11-libs/qt-webkit-4.8.2::gentoo, ebuild scheduled for merge)

x11-libs/qt-sql:4

  (x11-libs/qt-sql-99.4.8.2::unity-gentoo, installed) pulled in by
    ~x11-libs/qt-sql-99.4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-99.4.8.2::unity-gentoo, installed)
    (and 1 more with the same problem)

  (x11-libs/qt-sql-4.8.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-sql-4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support] required by (x11-libs/qt-qt3support-4.8.2::gentoo, ebuild scheduled for merge)

x11-libs/qt-dbus:4

  (x11-libs/qt-dbus-4.8.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-dbus-4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-4.8.2::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (x11-libs/qt-dbus-99.4.8.2::unity-gentoo, installed) pulled in by
    ~x11-libs/qt-dbus-99.4.8.2[aqua=,c++0x=,qpa=,debug=] required by (x11-libs/qt-gui-99.4.8.2::unity-gentoo, installed)

x11-libs/qt-gui:4

  (x11-libs/qt-gui-4.8.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-gui-4.8.2[accessibility=,aqua=,c++0x=,debug=,qpa=,qt3support] required by (x11-libs/qt-qt3support-4.8.2::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

  (x11-libs/qt-gui-99.4.8.2::unity-gentoo, installed) pulled in by
    ~x11-libs/qt-gui-99.4.8.2[aqua=,c++0x=,debug=,glib=,qpa=,qt3support] required by (x11-libs/qt-core-99.4.8.2::unity-gentoo, installed)
    (and 3 more with the same problem)

x11-libs/qt-qt3support:4

  (x11-libs/qt-qt3support-99.4.8.2::unity-gentoo, installed) pulled in by
    ~x11-libs/qt-qt3support-99.4.8.2[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-gui-99.4.8.2::unity-gentoo, installed)

  (x11-libs/qt-qt3support-4.8.2::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/qt-qt3support-4.8.2[aqua=,c++0x=,debug=,qpa=] required by (x11-libs/qt-gui-4.8.2::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages  (...)



Is there a easy way to fix it or i will need to create an local overlay and modify the ebuild to accept the 99* packages??
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Aug 08, 2012 4:16 am    Post subject: Reply with quote

Check you've keyword unmasked all the x11-libs/qt packages in /usr/portage/x11-libs/qt*

I get your ccsm KeyError too, not sure if it's a bad thing yet.

I've added some updated ebuilds for unity-6.0.0 and compiz-0.9.8 in the hope it improves the window decoration bug we're experiencing.
If you want to try them, they've been added masked with missing keywords so you'll have to add the following to your package.keywords:
Code:
unity-base/compiz **
unity-base/unity **
unity-base/nux **
unity-base/unity2d **
unity-base/geis **
unity-base/grail **
unity-base/evemu **
unity-base/frame **

You can use compiz-0.9.8 with either unity-5.12 or unity-6.0.0 but on testing, the window decoration bug is still present in the latest versions of Unity/Compiz unfortunately.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Wed Aug 08, 2012 5:13 am    Post subject: Reply with quote

shiznix wrote:
Check you've keyword unmasked all the x11-libs/qt packages in /usr/portage/x11-libs/qt*

I get your ccsm KeyError too, not sure if it's a bad thing yet.

I've added some updated ebuilds for unity-6.0.0 and compiz-0.9.8 in the hope it improves the window decoration bug we're experiencing.
If you want to try them, they've been added masked with missing keywords so you'll have to add the following to your package.keywords:
Code:
unity-base/compiz **
unity-base/unity **
unity-base/nux **
unity-base/unity2d **
unity-base/geis **
unity-base/grail **
unity-base/evemu **
unity-base/frame **

You can use compiz-0.9.8 with either unity-5.12 or unity-6.0.0 but on testing, the window decoration bug is still present in the latest versions of Unity/Compiz unfortunately.


Code:


configure: error: Package requirements (evemu >= 1.0.5) were not met:

No package 'evemu' found



Missed dep?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Aug 08, 2012 7:56 am    Post subject: Reply with quote

ahgblopes wrote:
configure: error: Package requirements (evemu >= 1.0.5) were not met:

No package 'evemu' found

[/code]

Missed dep?

Yep, that one should be fixed now and the blockers as well for all the utouch stuff.

It's slowly evolving to a stable set of ebuilds now (I hope).
There's still a heap of QA to be done but the basic bulk should be pretty much complete.
Would be nice to get compiz settings going through gconf too.

This latest updated set for unity-6.0.0 and compiz-0.9.8 took some work as Ubuntu have renamed the utouch packages, and compiz CMake system now provides all the compzconfig and ccsm packages.
And I have an uneasy feeling that once Quantal is released they might yet split the packages back out :roll:

I'm not yet sure what the benefits are for upgrading to unity-6.0.0 and compiz-0.9.8 performance wise, but they're in overlay now and should make adding bugfix patches quickly when they become available.
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Wed Aug 08, 2012 8:33 pm    Post subject: Reply with quote

shiznix wrote:
ahgblopes wrote:
configure: error: Package requirements (evemu >= 1.0.5) were not met:

No package 'evemu' found

[/code]

Missed dep?

Yep, that one should be fixed now and the blockers as well for all the utouch stuff.

It's slowly evolving to a stable set of ebuilds now (I hope).
There's still a heap of QA to be done but the basic bulk should be pretty much complete.
Would be nice to get compiz settings going through gconf too.

This latest updated set for unity-6.0.0 and compiz-0.9.8 took some work as Ubuntu have renamed the utouch packages, and compiz CMake system now provides all the compzconfig and ccsm packages.
And I have an uneasy feeling that once Quantal is released they might yet split the packages back out :roll:

I'm not yet sure what the benefits are for upgrading to unity-6.0.0 and compiz-0.9.8 performance wise, but they're in overlay now and should make adding bugfix patches quickly when they become available.


Are you working alone in this project? And about that history that GNU wants that Canonical donate Unity? Is there some hope that some day Unity will be a bit more independent of Ubuntu?

I will try to recompile now, thanks.
Back to top
View user's profile Send private message
Rukiri
n00b
n00b


Joined: 28 Oct 2011
Posts: 56

PostPosted: Thu Aug 09, 2012 3:33 am    Post subject: Reply with quote

Unity is really shaping up, actually played with the current state in 12.10 and I like it.
Just wish the bar could be moved around :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, ... 24, 25, 26  Next
Page 2 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum